Introduzione a SSMA per DB2 (DB2ToSQL)Getting Started with SSMA for DB2 (DB2ToSQL)

SQL ServerSQL ServerMigration Assistant (SSMA) per DB2 consente rapidamente gli schemi di database DB2 per convertire SQL ServerSQL Server schemi, caricare degli schemi risultanti in SQL ServerSQL Server e la migrazione dei dati da DB2 a SQL ServerSQL Server. Migration Assistant (SSMA) for DB2 lets you quickly convert DB2 database schemas to SQL ServerSQL Server schemas, upload the resulting schemas into SQL ServerSQL Server and migrate data from DB2 to SQL ServerSQL Server.

In questo argomento introduce il processo di installazione e quindi consente di acquisire familiarità con l'interfaccia utente SSMA.This topic introduces the installation process, and then helps familiarize you with the SSMA user interface.

L'installazione di SSMAInstalling SSMA

Per l'utilizzo di SSMA, è innanzitutto necessario installare il programma client SSMA in un computer che può accedere al database di origine DB2 sia l'istanza di destinazione SQL ServerSQL Server.To use SSMA, you first must install the SSMA client program on a computer that can access both the source DB2 database and the target instance of SQL ServerSQL Server. I provider OLE DB di DB2 nel computer in cui è in esecuzione SQL ServerSQL Server.DB2 OLEDB providers on the computer that is running SQL ServerSQL Server. Questi componenti supportano la migrazione dei dati e l'emulazione delle funzioni di sistema DB2.These components support data migration and the emulation of DB2 system functions. Per istruzioni sull'installazione, vedere l'installazione di SSMA per DB2ToSQL DB2 ( ).For installation instructions, see Installing SSMA for DB2 (DB2ToSQL).

Per avviare SSMA, fare clic su avviare, scegliere tutti i programmi, scegliere SQL ServerSQL Server Migration Assistant per DB2, quindi fare clic su SQL ServerSQL Server Migration Assistant per DB2.To start SSMA, click Start, point to All Programs, point to SQL ServerSQL Server Migration Assistant for DB2, and then click SQL ServerSQL Server Migration Assistant for DB2.

SSMA per l'interfaccia utente di DB2SSMA for DB2 User Interface

Dopo l'installazione di SSMA, è possibile utilizzare SSMA per la migrazione dei database di DB2 per SQL ServerSQL Server.After SSMA is installed, you can use SSMA to migrate DB2 databases to SQL ServerSQL Server. È utile per acquisire familiarità con l'interfaccia utente SSMA prima di iniziare.It helps to become familiar with the SSMA user interface before you start. Il diagramma seguente mostra l'interfaccia utente per SSMA, incluse le finestre di esplorazione dei metadati, metadati, le barre degli strumenti, riquadro di output e riquadro elenco errori:The following diagram shows the user interface for SSMA, including the metadata explorers, metadata, toolbars, output pane, and error list pane:

Interfaccia utente di SSMASSMA User Interface

Per avviare una migrazione, è innanzitutto necessario creare un nuovo progetto.To start a migration, you must first create a new project. Quindi, connettersi a un database DB2.Then, you connect to an DB2 database. Dopo la connessione ha esito positivo, gli schemi di DB2 verranno visualizzato in Visualizzatore metadati DB2.After a successful connection, DB2 schemas will appear in DB2 Metadata Explorer. È possibile quindi oggetti pulsante destro del mouse in Visualizzatore metadati DB2 per eseguire attività quali la creano di report che valutano le conversioni in SQL ServerSQL Server.You can then right-click objects in DB2 Metadata Explorer to perform tasks such as create reports that assess conversions to SQL ServerSQL Server. È anche possibile eseguire queste attività tramite i menu e barre degli strumenti.You can also perform these tasks by using the toolbars and menus.

È inoltre necessario connettersi a un'istanza di SQL ServerSQL Server.You must also connect to an instance of SQL ServerSQL Server. Dopo la connessione ha esito positivo, una gerarchia di SQL ServerSQL Server database verranno visualizzati nella SQL ServerSQL Server Visualizzatore metadati.After a successful connection, a hierarchy of SQL ServerSQL Server databases will appear in SQL ServerSQL Server Metadata Explorer. Dopo la conversione degli schemi DB2 SQL ServerSQL Server schemi, selezionare tali schemi convertiti in SQL ServerSQL Server Visualizzatore metadati e quindi sincronizzare gli schemi con SQL ServerSQL Server.After you convert DB2 schemas to SQL ServerSQL Server schemas, select those converted schemas in SQL ServerSQL Server Metadata Explorer, and then synchronize the schemas with SQL ServerSQL Server.

Dopo la sincronizzazione di convertire gli schemi con SQL ServerSQL Server, è possibile tornare a Visualizzatore metadati DB2 e la migrazione dei dati da schemi di DB2 in SQL ServerSQL Server database.After you synchronize converted schemas with SQL ServerSQL Server, you can return to DB2 Metadata Explorer and migrate data from DB2 schemas into SQL ServerSQL Server databases.

Per ulteriori informazioni su queste attività e su come eseguire tali operazioni, vedere la migrazione di database DB2 a SQL Server ( DB2ToSQL ).For more information about these tasks and how to perform them, see Migrating DB2 Databases to SQL Server (DB2ToSQL).

Nelle sezioni seguenti vengono descritte le funzionalità dell'interfaccia utente SSMA.The following sections describe the features of the SSMA user interface.

Finestre di esplorazione dei metadatiMetadata Explorers

SSMA contiene due finestre di esplorazione dei metadati per individuare ed eseguire azioni su DB2 e SQL ServerSQL Server database.SSMA contains two metadata explorers to browse and perform actions on DB2 and SQL ServerSQL Server databases.

DB2 Visualizzatore metadatiDB2 Metadata Explorer

Visualizzatore metadati DB2 Mostra informazioni sugli schemi di DB2.DB2 Metadata Explorer shows information about DB2 schemas. Tramite Visualizzatore metadati DB2, è possibile eseguire le attività seguenti:By using DB2 Metadata Explorer, you can perform the following tasks:

Visualizzatore metadati SQL ServerSQL Server Metadata Explorer

SQL ServerSQL ServerVisualizzatore metadati Mostra le informazioni su un'istanza di SQL ServerSQL Server. Metadata Explorer shows information about an instance of SQL ServerSQL Server. Quando ci si connette a un'istanza di SQL ServerSQL Server, recupera i metadati relativi a tale istanza e la archivia nel file di progetto SSMA.When you connect to an instance of SQL ServerSQL Server, SSMA retrieves metadata about that instance and stores it in the project file.

È possibile utilizzare SQL ServerSQL Server Visualizzatore metadati per selezionare gli oggetti di database DB2 convertiti e quindi sincronizzare gli oggetti con l'istanza di SQL ServerSQL Server.You can use SQL ServerSQL Server Metadata Explorer to select converted DB2 database objects, and then synchronize those objects with the instance of SQL ServerSQL Server.

MetadatiMetadata

A destra di ogni Visualizzatore metadati sono schede che descrivono l'oggetto selezionato.To the right of each metadata explorer are tabs that describe the selected object. Ad esempio, se si seleziona una tabella in Visualizzatore metadati DB2, verranno visualizzate sei schede: tabella, SQL, del mapping dei tipi, Report, proprietà, e dati.For example, if you select a table in DB2 Metadata Explorer, six tabs will appear: Table, SQL, Type Mapping,Report, Properties, and Data. Il Report scheda contiene informazioni solo dopo aver creato un report che contiene l'oggetto selezionato.The Report tab contains information only after you create a report that contains the selected object. Se si seleziona una tabella in SQL ServerSQL Server Visualizzatore metadati, verranno visualizzate tre schede: tabella, SQL, e dati.If you select a table in SQL ServerSQL Server Metadata Explorer, three tabs will appear: Table, SQL, and Data.

La maggior parte delle impostazioni dei metadati sono di sola lettura.Most metadata settings are read-only. Tuttavia, è possibile modificare i metadati seguenti:However, you can alter the following metadata:

  • In Visualizzatore metadati DB2, è possibile alter procedure e i mapping dei tipi.In DB2 Metadata Explorer, you can alter procedures and type mappings. Per convertire le procedure modificate e i mapping dei tipi, è possibile apportare modifiche prima di convertire gli schemi.To convert the altered procedures and type mappings, make changes before you convert schemas.

  • In SQL ServerSQL Server Visualizzatore metadati, è possibile modificare il Transact-SQLTransact-SQL per le stored procedure.In SQL ServerSQL Server Metadata Explorer, you can alter the Transact-SQLTransact-SQL for stored procedures. Per visualizzare le modifiche in SQL ServerSQL Server, apportare queste modifiche prima di caricare gli schemi in SQL ServerSQL Server.To see these changes in SQL ServerSQL Server, make these changes before you load the schemas into SQL ServerSQL Server.

Le modifiche apportate in un Visualizzatore metadati vengono riflesse nei metadati del progetto, non nei database di origine o di destinazione.Changes made in a metadata explorer are reflected in the project metadata, not in the source or target databases.

Barre degli strumentiToolbars

SSMA è due barre degli strumenti: una barra degli strumenti del progetto e una barra degli strumenti di migrazione.SSMA has two toolbars: a project toolbar and a migration toolbar.

La barra degli strumenti del progettoThe Project Toolbar

La barra degli strumenti del progetto contiene pulsanti per l'utilizzo di progetti, la connessione a DB2 e connessione a SQL ServerSQL Server.The project toolbar contains buttons for working with projects, connecting to DB2, and connecting to SQL ServerSQL Server. Questi pulsanti sono simili a quelli nel File menu.These buttons resemble the commands on the File menu.

Barra degli strumenti di migrazioneMigration Toolbar

La tabella seguente illustra la migrazione di comandi della barra degli strumenti:The following table shows the migration toolbar commands:

PulsanteButton FunzioneFunction
Creazione di ReportCreate Report Converte gli oggetti selezionati di DB2 in SQL ServerSQL Server sintassi, quindi viene creato un report che mostra come esito positivo della conversione.Converts the selected DB2 objects to SQL ServerSQL Server syntax, and then creates a report that shows how successful the conversion was.

Questo comando è disabilitato a meno che non vengono selezionati gli oggetti in Visualizzatore metadati DB2.This command is disabled unless objects are selected in DB2 Metadata Explorer.
Converti SchemaConvert Schema Converte gli oggetti selezionati di DB2 in SQL ServerSQL Server oggetti.Converts the selected DB2 objects to SQL ServerSQL Server objects.

Questo comando è disabilitato a meno che non vengono selezionati gli oggetti in Visualizzatore metadati DB2.This command is disabled unless objects are selected in DB2 Metadata Explorer.
La migrazione dei datiMigrate Data Esegue la migrazione di dati dal database di DB2 in SQL ServerSQL Server.Migrates data from the DB2 database to SQL ServerSQL Server. Prima di eseguire questo comando, è necessario convertire gli schemi di DB2 SQL ServerSQL Server schemi, quindi caricare gli oggetti in SQL ServerSQL Server.Before you run this command, you must convert the DB2 schemas to SQL ServerSQL Server schemas, and then load the objects into SQL ServerSQL Server.

Questo comando è disabilitato a meno che non vengono selezionati gli oggetti in Visualizzatore metadati DB2.This command is disabled unless objects are selected in DB2 Metadata Explorer.
ArrestaStop Arresta il processo corrente.Stops the current process.

Nella tabella seguente viene illustrato i menu SSMA.The following table shows the SSMA menus.

MenuMenu DescriptionDescription
FileFile Contiene i comandi per l'utilizzo di progetti, la connessione a DB2 e connessione a SQL ServerSQL Server.Contains commands for working with projects, connecting to DB2, and connecting to SQL ServerSQL Server.
ModificaEdit Contiene i comandi per la ricerca e l'utilizzo del testo nelle pagine di dettagli, ad esempio la copia Transact-SQLTransact-SQL dal riquadro dei dettagli SQL.Contains commands for finding and working with text in the details pages, such as copying Transact-SQLTransact-SQL from the SQL details pane. Contiene inoltre il gestire segnalibri opzione, in cui sarà in grado di visualizzare un elenco di segnalibri.Also contains the Manage Bookmarks option, where you will be able to see a list of existing bookmarks. È possibile utilizzare i pulsanti sul lato destro della finestra di dialogo per gestire i segnalibri.You can use the buttons on the right side of the dialog to manage the bookmarks.
VisualizzaView Contiene il sincronizzare i metadati Explorers comando.Contains the Synchronize Metadata Explorers command. Che consente di sincronizzare gli oggetti tra Visualizzatore metadati DB2 e SQL ServerSQL Server Visualizzatore metadati.That synchronizes the objects between DB2 Metadata Explorer and SQL ServerSQL Server Metadata Explorer. Contiene inoltre i comandi per visualizzare e nascondere il Output e elenco errori riquadri e un'opzione layout per gestire il layout.Also contains commands to show and hide the Output and Error List panes and an option Layouts to manage the Layouts.
StrumentiTools Contiene i comandi per creare report ed eseguire la migrazione di oggetti e dati.Contains commands to create reports, and migrate objects and data. Fornisce inoltre l'accesso per il impostazioni globali e impostazioni progetto finestre di dialogo.Also provides access to the Global Settings and Project Settings dialog boxes.
?Help Fornisce l'accesso di SSMA Guida in linea e di ottenere il su la finestra di dialogo.Provides access to SSMA Help and to the About dialog box.

Riquadro di output e il riquadro elenco erroriOutput Pane and Error List Pane

Il vista menu sono disponibili comandi per attivare o disattivare la visibilità del riquadro di Output e il riquadro elenco errori:The View menu provides commands to toggle the visibility of the Output pane and the Error List pane:

  • Il riquadro di output mostra i messaggi di stato da SSMA durante la conversione degli oggetti di sincronizzazione dell'oggetto e migrazione dei dati.The output pane shows status messages from SSMA during object conversion, object synchronization, and data migration.

  • Nel riquadro elenco errori Mostra messaggi di errore, avviso e informativi in un elenco ordinabile.The Error List pane shows error, warning, and informational messages in a sortable list.

Vedere ancheSee Also

La migrazione dei dati di DB2 in SQL Server ( DB2ToSQL )Migrating DB2 Data into SQL Server (DB2ToSQL)
Riferimento all'interfaccia utente ( DB2ToSQL )User Interface Reference (DB2ToSQL)