Lavorare con progetti SSMA (DB2ToSQL)Working with SSMA Projects (DB2ToSQL)

Per eseguire la migrazione di database DB2 SQL ServerSQL Server, creare innanzitutto un progetto SSMA.To migrate DB2 databases to SQL ServerSQL Server, you first create an SSMA project. Il progetto è un file che contiene le informazioni seguenti:The project is a file that contains the following information:

  • I metadati sui database DB2 si desidera eseguire la migrazione a SQL ServerSQL Server.Metadata about the DB2 databases you want to migrate to SQL ServerSQL Server.

  • I metadati sull'istanza di destinazione di SQL ServerSQL Server che riceverà la migrazione di oggetti e i dati.Metadata about the target instance of SQL ServerSQL Server that will receive the migrated objects and data.

  • SQL ServerSQL Serverinformazioni di connessione. connection information.

  • Le impostazioni del progetto.Project settings.

Quando si apre un progetto, si viene disconnessi da DB2 e SQL ServerSQL Server.When you open a project, it is disconnected from DB2 and SQL ServerSQL Server. Che consente di lavorare offline.That lets you work offline. Per informazioni sulla riconnessione SQL ServerSQL Server, vedere connessione a SQL Server ( DB2eToSQL ).For information about reconnecting to SQL ServerSQL Server, see Connecting to SQL Server (DB2eToSQL).

Verificare le impostazioni di progetto predefinitoReviewing Default Project Settings

SSMA contiene diverse impostazioni per la conversione e il caricamento di oggetti di database, la migrazione dei dati e la sincronizzazione di SSMA con DB2 e SQL ServerSQL Server.SSMA contains several settings for converting and loading database objects, migrating data, and synchronizing SSMA with DB2 and SQL ServerSQL Server. Le impostazioni predefinite sono appropriate per molti utenti.The default settings are appropriate for many users. Tuttavia, prima di creare un nuovo progetto SSMA, è consigliabile verificare le impostazioni.However, before you create a new SSMA project, you should review the settings. Se si desidera, è possibile modificare le impostazioni predefinite che verranno utilizzate per tutti i nuovi progetti.If you want to, you can change the default settings that will be used for all your new projects.

Per controllare le impostazioni di progetto predefinitoTo review default project settings

  1. Nel strumenti menu, fare clic su impostazioni di progetto predefinite.On the Tools menu, click Default Project Settings.

  2. Selezionare il tipo di progetto in versione di destinazione della migrazione elenco a discesa sono necessarie da visualizzare o modificare le impostazioni e quindi fare clic su generale scheda.Select the project type in Migration Target Version drop down for which settings are required to be viewed or changed and then Click General tab.

  3. Nel riquadro a sinistra, fare clic su conversione.In the left pane, click Conversion.

  4. Nel riquadro di destra, esaminare e modificare le impostazioni in base alle esigenze.In the right pane, review and change the settings as necessary. Per ulteriori informazioni su queste impostazioni, vedere impostazioni progetto ( Conversione ) ( DB2ToSQL ) .For more information about these settings, see Project Settings (Conversion) (DB2ToSQL).

  5. Ripetere i passaggi da 1 a 3 per le pagine di migrazione, la sincronizzazione, gli oggetti di sistema durante il caricamento, GUI e Mapping dei tipi.Repeat Steps 1-3 for the Migration, Synchronization, Loading System Objects, GUI, and Type Mapping pages.

Creazione di nuovi progettiCreating New Projects

La migrazione dei dati dai database di DB2 per SQL ServerSQL Server, è innanzitutto necessario creare un progetto.To migrate data from DB2 databases to SQL ServerSQL Server, you must first create a project.

Per creare un progettoTo create a project

  1. Nel File menu, fare clic su nuovo progetto.On the File menu, click New Project.

    Verrà visualizzata la finestra di dialogo Nuovo progetto .The New Project dialog box appears.

  2. Nel nome , immettere un nome per il progetto.In the Name box, enter a name for your project.

  3. Nel percorso casella, immettere o selezionare una cartella per il progetto e quindi fare clic su OK.In the Location box, enter or select a folder for the project, and then click OK.

  4. Nel migrazione a elenco a discesa, selezionare la versione di destinazione SQL ServerSQL Server usato per la migrazione.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. Le opzioni disponibili sono:The options available are:

    • SQL ServerSQL Server 2012 2012

    • SQL ServerSQL Server 2014 2014

    • SQL ServerSQL Server 2016 2016

    • Database SQL di AzureAzure SQL DB

Personalizzazione delle impostazioni di progettoCustomizing Project Settings

Inoltre, per definire impostazioni predefinite del progetto che si applicano a tutti i nuovi progetti SSMA, è possibile personalizzare le impostazioni per ogni progetto.In addition to defining default project settings that apply to all new SSMA projects, you can customize the settings for each project. Per ulteriori informazioni, vedere OracleToSQL impostazione delle opzioni progetto ( ) e le relative sezioni.For more information, see Setting Project Options (OracleToSQL) and related sections.

Quando si personalizza il mapping di tipi di dati tra database di origine e di destinazione, è possibile definire i mapping per il progetto, un database o un livello di oggetto.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. Per ulteriori informazioni, vedere DB2ToSQL Mapping DB2 e tipi di dati di SQL Server ( ).For more information, see Mapping DB2 and SQL Server Data Types (DB2ToSQL).

Il salvataggio dei progettiSaving Projects

Quando si salva un progetto, SSMA mantiene le impostazioni di progetto e, facoltativamente, i metadati del database, al file di progetto.When you save a project, SSMA retains the project settings, and optionally the database metadata, to the project file.

Per salvare un progettoTo save a project

  • Nel File menu, fare clic su Salva progetto.On the File menu, click Save Project.

    Se gli schemi nel progetto sono state modificate o non sono stati convertiti, SSMA verrà richiesto di caricare e salvare i metadati.If schemas in the project have changed or have not been converted, SSMA will prompt you to load and save metadata. Caricare e salvare i metadati consentono di lavorare offline.Loading and saving metadata will let you work offline. È anche possibile inviare un file di progetto completo ad altri utenti, come il personale di supporto tecnico.It also lets you send a complete project file to other people, such as technical support personnel. Se viene chiesto di salvare i metadati, eseguire le operazioni seguenti:If you are prompted to save metadata, do the following:

    1. Per ogni schema che viene visualizzato lo stato metadati mancanti, selezionare la casella di controllo accanto al nome del database.For each schema that shows a status of Metadata missing, select the check box next to the database name.

      Salvataggio di metadati potrebbe richiedere alcuni minuti.Saving metadata might take several minutes. Se non si desidera salvare i metadati, non selezionare le caselle di controllo.If you do not want to save metadata yet, do not select any check boxes.

    2. Fare clic su di salvare pulsante.Click the Save button.

      SSMA analizzerà gli schemi di DB2 e salvare i metadati del file di progetto.SSMA will parse the DB2 schemas and save the metadata to the project file.

Apertura di progettiOpening Projects

Quando si apre un progetto, la disconnessione da DB2 e da SQL ServerSQL Server.When you open a project, it is disconnected from DB2 and from SQL ServerSQL Server. Che consente di lavorare offline.That lets you work offline. Per aggiornare i metadati, caricare gli oggetti di database in SQL ServerSQL Server.To update metadata, load database objects into SQL ServerSQL Server. Per eseguire la migrazione dei dati, è necessario riconnettersi a DB2 e SQL ServerSQL Server.To migrate data, you must reconnect to DB2 and SQL ServerSQL Server.

Per aprire un progettoTo open a project

  1. Utilizzare una delle procedure riportate di seguito:Use one of the following procedures:

    • Nel File dal menu progetti recenti, quindi scegliere il progetto che si desidera aprire.On the File menu, point to Recent Projects, and then click the project you want to open.

    • Nel File dal menu Apri progetto, individuare il file di progetto .o2ssproj, selezionare il file e quindi fare clic su aprire.On the File menu, select Open Project, locate the .o2ssproj project file, select the file, and then click Open.

  2. Per ristabilire la connessione a DB2, sul File menu, fare clic su Riconnetti a DB2.To reconnect to DB2, on the File menu, click Reconnect to DB2.

  3. Per riconnettersi SQL ServerSQL Servervia il File menu, fare clic su Riconnetti a SQL Server.To reconnect to SQL ServerSQL Server, on the File menu, click Reconnect to SQL Server.

Passaggio successivoNext Step

Il passaggio successivo del processo di migrazione consiste nel la connessione al Database DB2.The next step in the migration process is to Connecting to DB2 Database.

Vedere ancheSee Also

Migrazione di database DB2 a SQL Server ( DB2ToSQL )Migrating DB2 Databases to SQL Server (DB2ToSQL)
Connessione al Database DB2 ( DB2ToSQL )Connecting to DB2 Database (DB2ToSQL)
Connessione a SQL Server ( DB2eToSQL )Connecting to SQL Server (DB2eToSQL)