Uso dei progetti SSMA (OracleToSQL)Working with SSMA Projects (OracleToSQL)

Eseguire la migrazione di database Oracle a SQL ServerSQL Server, creare innanzitutto un progetto SSMA.To migrate Oracle databases to SQL ServerSQL Server, you first create an SSMA project. Il progetto è un file che contiene le informazioni seguenti:The project is a file that contains the following information:

  • I metadati relativi a database Oracle si vuole eseguire la migrazione a SQL ServerSQL Server.Metadata about the Oracle databases you want to migrate to SQL ServerSQL Server.

  • I metadati sull'istanza di destinazione di SQL ServerSQL Server che riceverà i dati e oggetti migrati.Metadata about the target instance of SQL ServerSQL Server that will receive the migrated objects and data.

  • SQL ServerSQL Server informazioni di connessione. connection information.

  • Impostazioni del progetto.Project settings.

Quando si apre un progetto, si viene disconnessi da Oracle e SQL ServerSQL Server.When you open a project, it is disconnected from Oracle and SQL ServerSQL Server. Che consente di lavorare offline.That lets you work offline. Per informazioni su riconnessione SQL ServerSQL Server, vedere ci si connette a SQL Server (OracleToSQL).For information about reconnecting to SQL ServerSQL Server, see Connecting to SQL Server (OracleToSQL).

Esame impostazioni predefinite del progettoReviewing Default Project Settings

SSMA contiene diverse impostazioni per la conversione e il caricamento di oggetti di database, la migrazione dei dati e sincronizzazione di SSMA con Oracle e SQL ServerSQL Server.SSMA contains several settings for converting and loading database objects, migrating data, and synchronizing SSMA with Oracle and SQL ServerSQL Server. Le impostazioni predefinite sono appropriate per molti utenti.The default settings are appropriate for many users. Tuttavia, prima di creare un nuovo progetto SSMA, è consigliabile verificare le impostazioni.However, before you create a new SSMA project, you should review the settings. Se si desidera, è possibile modificare le impostazioni predefinite che verranno usate per tutti i nuovi progetti.If you want to, you can change the default settings that will be used for all your new projects.

Per controllare le impostazioni di progetto predefinitoTo review default project settings

  1. Nel degli strumenti dal menu fare clic su impostazioni di progetto predefinite.On the Tools menu, click Default Project Settings.

  2. Selezionare il tipo di progetto in versione di destinazione della migrazione elenco a discesa per le impostazioni che deve essere visualizzati o modificati e quindi fare clic su generali scheda.Select the project type in Migration Target Version drop down for which settings are required to be viewed or changed and then Click General tab.

  3. Nel riquadro sinistro, fare clic su conversione.In the left pane, click Conversion.

  4. Nel riquadro di destra, esaminare e modificare le impostazioni in base alle esigenze.In the right pane, review and change the settings as necessary. Per altre informazioni su queste impostazioni, vedere impostazioni del progetto (conversione) (OracleToSQL).For more information about these settings, see Project Settings (Conversion) (OracleToSQL).

  5. Ripetere i passaggi da 1 a 3 per le pagine di migrazione, la sincronizzazione, il caricamento di oggetti di sistema, interfaccia utente grafica e del mapping dei tipi.Repeat Steps 1-3 for the Migration, Synchronization, Loading System Objects, GUI, and Type Mapping pages.

Creazione di nuovi progettiCreating New Projects

Eseguire la migrazione dei dati da database Oracle a SQL ServerSQL Server, è innanzitutto necessario creare un progetto.To migrate data from Oracle databases to SQL ServerSQL Server, you must first create a project.

Per creare un progettoTo create a project

  1. Nel File menu, fare clic su nuovo progetto.On the File menu, click New Project.

    Verrà visualizzata la finestra di dialogo Nuovo progetto .The New Project dialog box appears.

  2. Nel nome immettere un nome per il progetto.In the Name box, enter a name for your project.

  3. Nel ubicazione casella, immettere o selezionare una cartella per il progetto e quindi fare clic su OK.In the Location box, enter or select a folder for the project, and then click OK.

  4. Nel migrazione a elenco a discesa, selezionare la versione del server di destinazione SQL ServerSQL Server usato per la migrazione.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. Le opzioni disponibili sono:The options available are:

    • SQL ServerSQL Server 2005 2005

    • SQL ServerSQL Server 2008 2008

    • SQL ServerSQL Server 2014 2014

    • SQL ServerSQL Server 2016 2016

    • Azure SQL databaseAzure SQL DB

Personalizzazione delle impostazioni di progettoCustomizing Project Settings

Oltre a definire impostazioni predefinite del progetto che si applicano a tutti i nuovi progetti SSMA, è possibile personalizzare le impostazioni per ogni progetto.In addition to defining default project settings that apply to all new SSMA projects, you can customize the settings for each project. Per altre informazioni, vedere impostazione delle opzioni progetto (OracleToSQL).For more information, see Setting Project Options (OracleToSQL).

Quando si personalizzano i mapping tra i database di origine e di destinazione, è possibile definire i mapping per il progetto, database o a livello di oggetto.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. Per altre informazioni, vedere Mapping di Oracle e SQL Server Data Types (OracleToSQL).For more information, see Mapping Oracle and SQL Server Data Types (OracleToSQL).

Il salvataggio dei progettiSaving Projects

Quando si salva un progetto, SSMA consente di mantenere le impostazioni del progetto e, facoltativamente, i metadati del database, al file di progetto.When you save a project, SSMA retains the project settings, and optionally the database metadata, to the project file.

Per salvare un progettoTo save a project

  • Nel File menu, fare clic su Salva progetto.On the File menu, click Save Project.

    Se gli schemi nel progetto sono stati modificati o non sono stati convertiti, SSMA richiederà di caricare e salvare i metadati.If schemas in the project have changed or have not been converted, SSMA will prompt you to load and save metadata. Il caricamento e salvataggio dei metadati consente di lavorare offline.Loading and saving metadata will let you work offline. Consente inoltre di inviare un file di progetto completo ad altre persone, ad esempio il personale di supporto tecnico.It also lets you send a complete project file to other people, such as technical support personnel. Se viene chiesto di salvare i metadati, eseguire le operazioni seguenti:If you are prompted to save metadata, do the following:

    1. Per ogni schema che mostra lo stato i metadati mancanti, selezionare la casella di controllo accanto al nome del database.For each schema that shows a status of Metadata missing, select the check box next to the database name.

      Salvataggio di metadati potrebbe richiedere alcuni minuti.Saving metadata might take several minutes. Se non si desidera salvare i metadati, non selezionare le caselle di controllo.If you do not want to save metadata yet, do not select any check boxes.

    2. Scegliere il salvare pulsante.Click the Save button.

      Analizza gli schemi di Oracle e salvare i metadati del file di progetto SSMA.SSMA will parse the Oracle schemas and save the metadata to the project file.

Apertura di progettiOpening Projects

Quando si apre un progetto, questo viene disconnesso da Oracle e da SQL ServerSQL Server.When you open a project, it is disconnected from Oracle and from SQL ServerSQL Server. Che consente di lavorare offline.That lets you work offline. Per aggiornare i metadati, caricare gli oggetti di database in SQL ServerSQL Server.To update metadata, load database objects into SQL ServerSQL Server. Per eseguire la migrazione dei dati, è necessario riconnettersi a Oracle e SQL ServerSQL Server.To migrate data, you must reconnect to Oracle and SQL ServerSQL Server.

Per aprire un progettoTo open a project

  1. Usare una delle procedure riportate di seguito:Use one of the following procedures:

    • Nel File dal menu progetti recentie quindi fare clic con il progetto da aprire.On the File menu, point to Recent Projects, and then click the project you want to open.

    • Nel File dal menu aprire il progetto, individuare il file di progetto .o2ssproj, selezionare il file e quindi fare clic su Open.On the File menu, select Open Project, locate the .o2ssproj project file, select the file, and then click Open.

  2. Per ristabilire la connessione a Oracle, nelle File menu, fare clic su Riconnetti a Oracle.To reconnect to Oracle, on the File menu, click Reconnect to Oracle.

  3. Per riconnettersi SQL ServerSQL Servervia il File dal menu fare clic su Riconnetti a SQL Server.To reconnect to SQL ServerSQL Server, on the File menu, click Reconnect to SQL Server.

Passaggio successivoNext Step

Il passaggio successivo del processo di migrazione consiste la connessione al Database Oracle (OracleToSQL).The next step in the migration process is to Connecting to Oracle Database (OracleToSQL).

Vedere ancheSee Also

La migrazione da Oracle database in SQL Server (OracleToSQL)Migrating Oracle Databases to SQL Server (OracleToSQL)
La connessione al Database Oracle (OracleToSQL)Connecting to Oracle Database (OracleToSQL)
La connessione a SQL Server (OracleToSQL)Connecting to SQL Server (OracleToSQL)