Lavorare con progetti SSMA (SybaseToSQL)Working with SSMA Projects (SybaseToSQL)

Per eseguire la migrazione dei database Sybase Adaptive Server Enterprise (ASE) SQL ServerSQL Server o SQL Azure, creare innanzitutto un progetto SSMA.To migrate Sybase Adaptive Server Enterprise (ASE) databases to SQL ServerSQL Server or SQL Azure, you first create an SSMA project. Il progetto è un file che contiene metadati sui database che si desidera eseguire la migrazione a ASE SQL ServerSQL Server o SQL Azure, i metadati sull'istanza di destinazione di SQL ServerSQL Server o SQL Azure che riceverà la migrazione di oggetti e i dati SQL ServerSQL Server o informazioni di connessione di SQL Azure e le impostazioni del progetto.The project is a file that contains metadata about the ASE databases that you want to migrate to SQL ServerSQL Server or SQL Azure, metadata about the target instance of SQL ServerSQL Server or SQL Azure that will receive the migrated objects and data, SQL ServerSQL Server or SQL Azure connection information, and project settings.

Quando si apre un progetto, si viene disconnessi da SQL ServerSQL Server o SQL Azure.When you open a project, it is disconnected from SQL ServerSQL Server or SQL Azure. Ciò consente di lavorare offline.This lets you work offline. È possibile riconnettersi alla SQL ServerSQL Server o SQL Azure.You can reconnect to SQL ServerSQL Server or SQL Azure. Per ulteriori informazioni, vedere connessione a SQL Server ( SybaseToSQL ) / La connessione al database SQL di Azure ( SybaseToSQL ) .For more information, see Connecting to SQL Server (SybaseToSQL) / Connecting to Azure SQL DB (SybaseToSQL).

Verificare le impostazioni di progetto predefinitoReviewing Default Project Settings

SSMA contiene varie opzioni per la conversione e il caricamento di oggetti di database, la migrazione dei dati e la sincronizzazione di SSMA con ASE e SQL ServerSQL Server o SQL Azure.SSMA contains several options for converting and loading database objects, migrating data, and synchronizing SSMA with ASE and SQL ServerSQL Server or SQL Azure. Le impostazioni predefinite per queste opzioni sono appropriate per molti utenti.The default settings for these options are appropriate for many users. Tuttavia, prima di creare un nuovo progetto SSMA, si deve rivedere le opzioni e, se si desidera, modificare le impostazioni predefinite che verranno utilizzate per tutti i nuovi progetti.However, before you create a new SSMA project, you should review the options and, if you want to, change the defaults that will be used for all your new projects.

Per controllare le impostazioni di progetto predefinitoTo review default project settings

  1. Nel strumenti dal menu impostazioni di progetto predefinite.On the Tools menu, select Default Project Settings.

  2. Selezionare il tipo di progetto in versione di destinazione della migrazione elenco a discesa sono necessarie da visualizzare o modificare le impostazioni e quindi fare clic su generale scheda.Select the project type in Migration Target Version drop down for which settings are required to be viewed or changed and then Click General tab.

  3. Nel riquadro a sinistra, fare clic su conversione.In the left pane, click Conversion.

  4. Nel riquadro di destra, rivedere le opzioni, modifica delle opzioni in base alle esigenze.In the right pane, review the options, changing options as necessary. Per ulteriori informazioni su queste opzioni, vedere impostazioni progetto ( Conversione ) ( SybaseToSQL ) .For more information about these options, see Project Settings (Conversion) (SybaseToSQL).

  5. Ripetere i passaggi da 1 a 3 per le pagine di migrazione, SQL Azure, il caricamento di oggetti, interfaccia utente grafica e Mapping dei tipi.Repeat steps 1-3 for the Migration, SQL Azure, Loading Objects, GUI, and Type Mapping pages.

    Nota

    Le impostazioni di SQL Azure verranno visualizzate solo quando si seleziona migrazione a SQL Azure durante la creazione di un progetto.The SQL Azure settings will be displayed only when you select Migration to SQL Azure while creating a project.

Creazione di nuovi progettiCreating New Projects

La migrazione dei dati dai database ASE per SQL ServerSQL Server o SQL Azure, è necessario creare innanzitutto un progetto.To migrate data from ASE databases to SQL ServerSQL Server or SQL Azure, you must first create a project.

Per creare un progettoTo create a project

  1. Scegliere Nuovo progetto dal menu File.On the File menu, select New Project.

    Verrà visualizzata la finestra di dialogo Nuovo progetto .The New Project dialog box appears.

  2. Nel nome , immettere un nome per il progetto.In the Name box, enter a name for your project.

  3. Nel percorso immettere o selezionare una cartella per il progetto.In the Location box, enter or select a folder for the project.

  4. Nel migrazione a elenco a discesa, selezionare la versione di destinazione SQL ServerSQL Server usato per la migrazione.In the Migration To drop down, select the version of target SQL ServerSQL Server used for migration. Le opzioni disponibili sono:The options available are:

    • SQL ServerSQL Server 2005 2005

    • SQL ServerSQL Server 2008 2008

    • SQL ServerSQL Server 2012 2012

    • SQL ServerSQL Server 2014 2014

    • SQL ServerSQL Server 2016 2016

    • Database SQL di AzureAzure SQL DB

E quindi fare clic su OK.And then Click OK.

Personalizzazione delle impostazioni di progettoCustomizing Project Settings

Inoltre, per definire impostazioni predefinite del progetto che si applicano a tutti i nuovi progetti SSMA, è possibile personalizzare le impostazioni per ogni progetto.In addition to defining default project settings that apply to all new SSMA projects, you can customize the settings for each project. Per ulteriori informazioni, vedere impostazione delle opzioni progetto ( SybaseToSQL ) .For more information, see Setting Project Options (SybaseToSQL).

Quando si personalizza il mapping di tipi di dati tra database di origine e di destinazione, è possibile definire i mapping per il progetto, un database o un livello di oggetto.When you customize data type mappings between source and target databases, you can define mappings at the project, database, or object level. Per ulteriori informazioni sui mapping dei tipi, vedere Mapping Sybase ASE e tipi di dati di SQL Server ( SybaseToSQL ) .For more information about type mapping, see Mapping Sybase ASE and SQL Server Data Types (SybaseToSQL).

Il salvataggio dei progettiSaving Projects

Quando si salva un progetto, SSMA mantiene le impostazioni di progetto e, facoltativamente, i metadati del database, al file di progetto.When you save a project, SSMA retains the project settings, and optionally the database metadata, to the project file.

Per salvare un progettoTo save a project

  • Nel File dal menu Salva progetto.On the File menu, select Save Project.

    Se i database all'interno del progetto sono state modificate o non sono stati convertiti, SSMA verrà chiesto di salvare i metadati nel progetto.If databases within the project have changed or have not been converted, SSMA will prompt you to save metadata into the project. Salvare i metadati consentono di lavorare offline e l'invio di un file di progetto completo ad altre persone, tra cui il personale di supporto tecnico.Saving metadata will let you work offline and to send a complete project file to other people, including technical support personnel. Se viene chiesto di salvare i metadati, eseguire le operazioni seguenti:If you are prompted to save metadata, do the following:

    1. Per ogni database che viene visualizzato lo stato metadati mancanti, selezionare la casella di controllo accanto al nome del database.For each database that shows a status of Metadata missing, select the check box next to the database name.

      Salvataggio di metadati potrebbe richiedere alcuni minuti.Saving metadata might take several minutes. Se non si desidera salvare i metadati a questo punto, non selezionare le caselle di controllo.If you do not want to save metadata at this point, do not select any check boxes.

    2. Fare clic su di salvare pulsante.Click the Save button.

      SSMA analizzerà gli schemi di Sybase ASE e salvare i metadati del file di progetto.SSMA will parse the Sybase ASE schemas and save the metadata to the project file.

Apertura di progettiOpening Projects

Quando si apre un progetto, la disconnessione da ASE e da SQL ServerSQL Server o SQL Azure.When you open a project, it is disconnected from ASE and from SQL ServerSQL Server or SQL Azure. Ciò consente di lavorare offline.This lets you work offline. Per aggiornare i metadati, caricare gli oggetti di database in SQL ServerSQL Server o SQL Azure.To update metadata, load database objects into SQL ServerSQL Server or SQL Azure. Per eseguire la migrazione dei dati, è necessario riconnettersi all'ASE e SQL ServerSQL Server o SQL Azure.To migrate data, you must reconnect to ASE and SQL ServerSQL Server or SQL Azure.

Per aprire un progettoTo open a project

  1. Utilizzare una delle procedure riportate di seguito:Use one of the following procedures:

    • Nel File dal menu progetti recentie quindi selezionare il progetto che si desidera aprire.On the File menu, point to Recent Projects, and then select the project you want to open.

    • Nel File dal menu Apri progetto, individuare il file di progetto .s2ssproj, selezionare il file e quindi fare clic su aprire.On the File menu, select Open Project, locate the .s2ssproj project file, select the file, and then click Open.

  2. Per riconnettersi ASE, sul File dal menu riconnessione per Sybase.To reconnect to ASE, on the File menu, select Reconnect to Sybase.

  3. Per riconnettersi SQL ServerSQL Server o SQL Azure, sul File dal menu Riconnetti a SQL Server / Riconnetti a SQL Azure.To reconnect to SQL ServerSQL Server or SQL Azure, on the File menu, select Reconnect to SQL Server / Reconnect to SQL Azure.

Passaggio successivoNext Step

Il passaggio successivo del processo di migrazione consiste nel Connetti per Sybase ASE.The next step in the migration process is to Connect to Sybase ASE.

Vedere ancheSee Also

Migrazione di database di Sybase ASE a SQL Server: database SQL di Azure ( SybaseToSQL )Migrating Sybase ASE Databases to SQL Server - Azure SQL DB (SybaseToSQL)
Connessione a Sybase ASE ( SybaseToSQL )Connecting to Sybase ASE (SybaseToSQL)
Connessione a SQL Server ( SybaseToSQL )Connecting to SQL Server (SybaseToSQL)
Connessione a database SQL di Azure ( SybaseToSQL )Connecting to Azure SQL DB (SybaseToSQL)