Personalizzare i menu e i tasti di scelta rapidaCustomize Menus and Shortcut Keys

Un tasto di scelta rapida consente di scegliere un comando di menu o un pulsante premendo ALT+.A keyboard accelerator allows you to select a menu command or button by pressing ALT+. Per aprire ad esempio il menu Modifica , premere ALT+M.For example, to open the Edit menu, press ALT+E. È possibile modificare la disposizione di pulsanti della barra degli strumenti, di menu e di comandi di menu nella finestra di dialogo Personalizza .You can rearrange and modify toolbar buttons, menus, and menu commands by using the Customize dialog box. Vengono fornite istruzioni per modificare le impostazioni utilizzando il mouse o solo la tastiera.Instructions are provided for changing the settings using the mouse and using only the keyboard.

È possibile creare tasti di scelta rapida per stored procedure tramite CTRL dalla pagina Tastiera della finestra di dialogo Strumenti/Opzioni .Keyboard accelerators for stored procedures using the Ctrl key can be created from the Keyboard page of the Tools/Options dialog box.

Nota

Fare clic su Comprimi tutto nella parte superiore della pagina per visualizzare solo le intestazioni.Click Collapse All at the top of this page to show only the headings.

Apertura della finestra di dialogo per l'impostazione dei tasti di scelta rapida utilizzando il mouseOpening the Keyboard Accelerator Dialog Box Using the Mouse

Per accedere alla finestra di dialogo nella quale è possibile assegnare o modificare un tasto di scelta rapida utilizzando il mouseTo access the dialog box for assigning or changing a keyboard accelerator (using the mouse)

  1. Scegliere Personalizza dal menu Strumenti.On the Tools menu, click Customize.

  2. Verificare che la barra degli strumenti alla quale si desidera apportare modifiche sia visualizzata.Make sure the toolbar you want to change is visible.

    1. Nella finestra di dialogo Personalizza fare clic sulla scheda Barre degli strumenti .In the Customize dialog box, click the Toolbars tab.

    2. Selezionare la casella di controllo relativa alla barra degli strumenti che si desidera visualizzare.Select the check box for the toolbar you want to display.

  3. Nella finestra di dialogo Personalizza fare clic sulla scheda Comandi .In the Customize dialog box, click the Commands tab.

Modifica dei tasti di scelta rapida relativi ai pulsanti della barra degli strumenti utilizzando il mouseChanging a Toolbar Buttons Accelerator Key Using the Mouse

Per assegnare o modificare un tasto di scelta rapida per un pulsante della barra degli strumenti utilizzando il mouseTo assign or change a toolbar button's keyboard accelerator (using the mouse)

  1. Fare clic sul pulsante desiderato sulla barra degli strumenti.Click the button on the toolbar.

  2. Nella scheda Comandi della finestra di dialogo Personalizza fare clic su Modifica selezione.In the Customize dialog box, on the Commands tab, click Modify Selection.

  3. Nella casella Nome del menu di scelta rapida digitare un nome da assegnare al pulsante sulla barra degli strumenti, anteponendo una e commerciale (&) alla lettera che si vuole usare come tasto di scelta rapida.In the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  4. Premere INVIO.Press ENTER.

  5. Nella finestra di dialogo Personalizza fare clic su Chiudi.In the Customize dialog box, click Close.

Modifica dei tasti di scelta rapida relativi ai comandi di menu utilizzando il mouseChanging a Menu Commands Accelerator Key Using the Mouse

Per assegnare o modificare un tasto di scelta rapida per un comando di menu utilizzando il mouseTo assign or change a menu command's keyboard accelerator (using the mouse)

  1. Fare clic sul nome del menu desiderato sulla barra dei menu o sulla barra degli strumenti.Click the menu name on the menu bar or toolbar.

  2. Fare clic sul comando di menu.Click the menu command.

  3. Nella finestra di dialogo Personalizza fare clic su Modifica selezione.In the Customize dialog box, click Modify Selection.

  4. Nella casella Nome del menu di scelta rapida digitare un nome da assegnare al comando di menu, anteponendo una e commerciale (&) alla lettera che si vuole usare come tasto di scelta rapida.In the Name box on the shortcut menu, type a name for the menu command with an ampersand (&) before the letter that you want as the keyboard accelerator.

  5. Premere INVIO.Press ENTER.

  6. Nella finestra di dialogo Personalizza fare clic su Chiudi.In the Customize dialog box, click Close.

Apertura della finestra di dialogo per l'impostazione dei tasti di scelta rapida utilizzando la tastieraOpening the Keyboard Accelerator Dialog Box Using the Keyboard

Per accedere alla finestra di dialogo nella quale è possibile assegnare o modificare un tasto di scelta rapida utilizzando la tastieraTo access the dialog box for assigning or changing a keyboard accelerator (using the keyboard)

  1. Per aprire la finestra di dialogo Personalizza , premere ALT+S e digitare R.Press ALT+T, then type C, to open the Customize dialog box.

  2. Verificare che la barra degli strumenti alla quale si desidera apportare modifiche sia visualizzata.Make sure the toolbar you want to change is visible.

    1. Nella finestra di dialogo Personalizza premere ALT+B per visualizzare la scheda Barre degli strumenti .In the Customize dialog box, press ALT+B to show the Toolbars tab.

    2. Usare i tasti di direzione per selezionare la barra degli strumenti che si vuole visualizzare e premere la BARRA SPAZIATRICE per selezionare la casella di controllo.Use the arrow keys to select the toolbar you want to display, then SPACE to select the check box.

  3. Nella finestra di dialogo Personalizza premere ALT+C per visualizzare la scheda Comandi .In the Customize dialog box, press ALT+C to display the Commands tab.

Modifica dei tasti di scelta rapida relativi ai pulsanti della barra degli strumenti utilizzando la tastieraChanging a Toolbar Buttons Accelerator Key Using the Keyboard

Per assegnare o modificare un tasto di scelta rapida per un pulsante della barra degli strumenti utilizzando la tastieraTo assign or change a toolbar button's keyboard accelerator (using the keyboard)

  1. Per visualizzare la finestra di dialogo Ridisponi comandi , premere ALT+D.Press ALT+R to display the Rearrange Commands dialog box.

  2. Nella finestra di dialogo Ridisponi comandi usare i tasti di direzione per selezionare Barra degli strumenti.In the Rearrange Commands dialog box, use the arrow keys to select Toolbar.

  3. Premere TAB per passare all'elenco Barra degli strumenti , usare i tasti di direzione per selezionare la barra degli strumenti che contiene il pulsante da modificare e premere INVIO.Tab to the Toolbar list, and use the arrow keys to select the toolbar that contains the button you want to change, and then press ENTER.

  4. Premere TAB per passare all'elenco Controlli e usare i tasti di direzione per selezionare il pulsante che si vuole modificare.Tab to the Controls list, and use the arrow keys to select the button you want to change.

  5. Premere ALT+M per selezionare Modifica selezione.Press ALT+M, to select Modify Selection.

  6. Premere TAB per passare alla casella Name del menu di scelta rapida e digitare un nome da assegnare al pulsante sulla barra degli strumenti, anteponendo una e commerciale (&) alla lettera che si vuole usare come tasto di scelta rapida.Tab to the Name box on the shortcut menu, type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  7. Premere INVIO.Press ENTER.

  8. Premere TAB per passare al pulsante Chiudi e premere INVIO.Tab to the Close button, and then press ENTER.

Modifica dei tasti di scelta rapida relativi ai comandi di menu utilizzando la tastieraChanging a Menu Commands Accelerator Key Using the Keyboard

Per assegnare o modificare un tasto di scelta rapida per un comando di menu utilizzando la tastieraTo assign or change a menu command's keyboard accelerator (using the keyboard)

  1. Per visualizzare la finestra di dialogo Ridisponi comandi , premere ALT+D.Press ALT+R to display the Rearrange Commands dialog box.

  2. Premere TAB per passare a Barra dei menu , usare i tasti di direzione per fare clic sul menu appropriato nell'elenco Barra dei menu e premere INVIO.Tab to Menu Bar and then use the arrow keys to click the menu you want in the Menu Bar list, and then press ENTER.

  3. Premere TAB per passare all'elenco Controlli e usare i tasti di direzione per selezionare il pulsante che si vuole modificare.Tab to the Controls list, and use the arrow keys to select the button you want to change.

  4. Premere ALT+M per selezionare Modifica selezione.Press ALT+M, to select Modify Selection.

  5. Premere TAB per passare alla casella Nome del menu di scelta rapida e digitare un nome da assegnare al pulsante sulla barra degli strumenti, anteponendo una e commerciale (&) alla lettera che si vuole usare come tasto di scelta rapida.Tab to the Name box on the shortcut menu, and type a name for the toolbar button with an ampersand (&) before the letter that you want as the keyboard accelerator.

  6. Premere INVIO.Press ENTER.

  7. Nella finestra di dialogo Personalizza fare clic su Chiudi.In the Customize dialog box, click Close.

Creazione di un tasto di scelta rapida per una stored procedureCreating a Keyboard Accelerator for a Stored Procedure

Per creare un tasto di scelta rapida per una stored procedureTo create a keyboard accelerator for a stored procedure

  1. Scegliere Opzioni dal menu Strumenti.On the Tools menu, click Options.

  2. Nella pagina Tastiera selezionare una combinazione di tasti non usata nell'elenco Scelte rapide .On the Keyboard page, select an unused keyboard combination in the Shortcut list.

  3. Nella casella Stored Procedure digitare il nome della stored procedure e fare clic su OK.In the Stored Procedure box, type the stored procedure name, and then click OK.

Aggiunta di un nuovo elemento al menuAdding a New Item to the Menu

Per aggiungere un nuovo elemento al menuTo add a new item to the menu

  1. Scegliere Opzioni dal menu Strumenti.On the Tools menu, click Options.

  2. Nella finestra di dialogo Personalizza fare clic su Nuovo menu nella scheda Comandi.In the Customize dialog box, on the Commands tab, click New Menu.

  3. Nella casella Comandi trascinare Nuovo menu sulla barra dei menu e rilasciarlo nel punto in cui si vuole visualizzare il nuovo menu.On the Commands box, drag New Menu to the menu bar and drop it where you want the new menu to appear.

  4. Fare clic con il pulsante destro del mouse su Nuovo menue digitare un nome per il menu nella casella Nome .On the menu, right-click New Menu, and in the Name box, type a name for the new menu.

  5. Nella finestra di dialogo Personalizza selezionare una categoria, ad esempio File, e selezionare un comando, ad esempio Apri file.In the Customize dialog box, select category such as File, and select a command such as Open File. Trascinare il comando nel nuovo menu.Drag the command to the new menu. Nel momento in cui si passa il mouse sul menu, quest'ultimo si espanderà.As you point to the new menu, the menu will expand. Trascinare il comando nel menu espanso.Drop the command onto the expanded menu.

  6. Nella finestra di dialogo Personalizza fare clic su Chiudi.In the Customize dialog box, click Close.

Nota

Alcuni comandi sono disponibili solo quando in SQL Server Management StudioSQL Server Management Studio viene visualizzato contenuto rilevante.Some commands are available only when SQL Server Management StudioSQL Server Management Studio is displaying relevant content. Se nel menu non è disponibile alcun comando, la voce di menu non sarà disponibile.If no commands on the menu are available, the menu item will not be available.

Vedere ancheSee Also

Caratteristiche in SQL Server Management StudioFeatures in SQL Server Management Studio