Opzioni (Ambiente - Generale)Options (Environment - General Page)

Usare la finestra di dialogo Opzioni per configurare le azioni di avvio di MicrosoftMicrosoft SQL Server Management StudioSQL Server Management Studio, le opzioni generali di gestione della finestra e altre impostazioni generali.Use the Options dialog box to configure MicrosoftMicrosoft SQL Server Management StudioSQL Server Management Studio startup actions, general window management options, and other general settings. Scegliere Opzioni dal menu Strumenti, espandere la cartella Ambiente e quindi fare clic su Generale.On the Tools menu, click Options, expand the Environment folder, and then click General.

Elenco degli elementi di interfacciaUIElement List

All'avvioAt startup
Consente di selezionare l'azione che deve essere eseguita da SQL Server Management StudioSQL Server Management Studio all'avvio.Select the action for SQL Server Management StudioSQL Server Management Studio to perform when it is started. Le opzioni disponibili sono le seguenti:The options are:

  • Apri Esplora oggetti richiede di stabilire una connessione e quindi apre Esplora oggetti.Open Object Explorer prompts for a connection and then opens Object Explorer.

  • Apri nuova finestra Query richiede di stabilire una connessione e quindi apre Editor di query SQL.Open new query window prompts for a connection and then opens SQL Query Editor.

  • Apri Esplora oggetti e nuova finestra Query richiede di stabilire una connessione e quindi la usa per aprire sia Esplora oggetti sia Editor di query SQL.Open Object Explorer and new query prompts for a connection, then opens both Object Explorer and SQL Query Editor with that connection.

  • Apri ambiente vuoto apre SQL Server Management StudioSQL Server Management Studio senza visualizzare una finestra dell'editor di query SQL né connettere Esplora oggetti a un server.Open empty environment opens SQL Server Management StudioSQL Server Management Studio without a SQL Query editor window and without connecting Object Explorer to a server.

Nascondi oggetti di sistema in Esplora oggettiHide system objects in Object Explorer
Selezionare questa casella di controllo per rimuovere database, tabelle, viste e stored procedure di sistema dalla visualizzazione dell'albero in Esplora oggetti.Select this check box to remove the system databases, system tables, system views, and system stored procedures from tree view in Object Explorer. Le funzioni e i tipi di dati di sistema non vengono nascosti.System functions and system data types are not hidden. Questa opzione si applica solo alle istanze di SQL ServerSQL Server e non ha alcun effetto sui server già connessi in Esplora oggetti.This option only applies to instances of SQL ServerSQL Server and does not affect servers already connected in Object Explorer.

Layout ambienteEnvironment Layout

Per passare dalla modalità di ambiente a documenti a schede a quella a interfaccia per documenti multipli (MDI, Multiple-Document Interface) è necessario chiudere e riaprire SQL Server Management StudioSQL Server Management Studio .You must close and reopen SQL Server Management StudioSQL Server Management Studio to change between tabbed document and multiple-document interface (MDI) environment mode.

Documenti a schedeTabbed documents
Selezionare questa opzione per visualizzare le finestre di documento a schede raggruppate all'interno degli editor.Select this option to display document windows that are tabbed together within editors. Le finestre di documento a schede sono utili per organizzare i documenti aperti e passare da un documento all'altro.Tabbed document windows are useful for organizing and switching between multiple open documents.

Ambiente MDIMDI environment
Selezionare questa opzione per aprire i documenti in un ambiente MDI.Select this option to open documents in a MDI environment. Le finestre di documento MDI sono utili per risparmiare lo spazio sullo schermo che in un ambiente a documenti a schede è occupato dalle schede.MDI document windows are useful for gaining the screen space that is otherwise taken up by the tabs in the tabbed documents environment. Quando è abilitata la modalità MDI, è possibile spostarsi tra i documenti premendo CTRL+TAB oppure usando le opzioni di affiancamento nel menu Finestra .When working in MDI mode, you can switch between documents by pressing CTRL+TAB, or you can use the tile options located on the Window menu.

Comportamento finestra degli strumenti ancorataDocked Tool Window Behavior

Pulsante Chiudi valido solo per la scheda attivaClose button affects active tab only
Quando questa casella di controllo è selezionata, viene chiusa solo la finestra degli strumenti attiva e non tutte le finestre degli strumenti presenti nel set ancorato.Specifies that when this check box is selected, only the tool window that has focus currently is closed and not all of the tool windows in the docked set. Questa casella di controllo è selezionata per impostazione predefinita.By default, this check box is selected.

Pulsante Nascondi automaticamente valido solo per la scheda attivaAuto Hide button affects active tab only
Quando questa casella di controllo è selezionata, viene nascosta automaticamente solo la finestra degli strumenti attiva e non tutte le finestre degli strumenti presenti nel set ancorato.Specifies that when this check box is selected, only the tool window that has focus currently is hidden automatically, not all of the tool windows in the docked set. Per impostazione predefinita, tale casella di controllo è deselezionata.By default, this check box is cleared.

VisualizzazioneDisplay

Visualizza n file nell'elenco degli ultimi file usatiDisplay n files in recently used list
Consente di scegliere il numero di progetti e file recenti da visualizzare nel menu File .Customizes the number of recent projects and recent files that appear on the File menu. Digitare un numero compreso tra 1 e 24.Type a number between 1 and 24. Il valore predefinito è 4.The default is 4. Questa opzione consente di recuperare con facilità i file e i progetti script utilizzati più di recente.This is an easy way to retrieve recently used script projects and files and script projects.