Lezione 1-3 - Modificare il layout ambienteLesson 1-3 - Change the Environment Layout

I componenti di SQL Server Management StudioSQL Server Management Studio si contendono lo spazio sullo schermo.The components of SQL Server Management StudioSQL Server Management Studio compete for screen space. Per creare spazio, è possibile chiudere, nascondere o spostare i componenti di Management StudioManagement Studio .To make more room, you can close, hide, or move Management StudioManagement Studio components. Le procedure descritte in questa pagina consentono di spostare i componenti in posizioni diverse.The practices on this page move the components to different locations.

Come chiudere e nascondere i componentiClosing and Hiding Components

Per chiudere, nascondere e riaprire le finestre dei componentiTo practice closing, hiding, and reopening component windows

  1. Per nascondere i server registrati, fare clic sulla x nell'angolo superiore destro di Server registrati.Hide Registered Servers by clicking the x in the upper right corner of Registered Servers. La finestra Server registrati verrà chiusa.Registered Servers closes.

  2. In Esplora oggetti fare clic sul pulsante con la puntina con la descrizione comando Nascondi automaticamente .In Object Explorer, click the push-pin button with the Auto Hide ToolTip. Esplora oggetti viene ridotto a icona sul lato sinistro dello schermo.Object Explorer is minimized to the left side of the screen.

  3. Posizionare il mouse sulla barra del titolo di Esplora oggetti.Move your mouse over the Object Explorer title bar. L'applicazione verrà riaperta.It reopens.

  4. Fare clic nuovamente sul pulsante con la puntina per tenere aperto Esplora oggetti.Click the push-pin again to pin Object Explorer in the open position.

  5. Scegliere Server registrati dal menu Visualizza per ripristinare Server registrati.On the View menu, click Registered Servers to restore Registered Servers.

Spostamento dei componentiMoving Components

L'ambiente che ospita Management StudioManagement Studio consente di spostare i componenti e ancorarli in diversi tipi di configurazioni.The environment that hosts Management StudioManagement Studio allows you to move components and dock them in a variety of configurations.

Per spostare i componentiTo practice moving components

  1. Trascinare la barra del titolo di Server registrati all'interno della finestra del documento.Click and drag the title bar of Registered Servers into the middle of the document window. Il componente verrà disancorato e rimarrà mobile finché non sarà rilasciato.The component undocks and remains floating until you drop it.

  2. Trascinare Server registrati in una posizione diversa sullo schermo.Drag Registered Servers around to different locations on the screen. In numerose aree dello schermo verranno visualizzate informazioni di ancoraggio in blu.In several areas of the screen, you receive blue docking information. Le frecce indicano che il componente rilasciato in una determinata posizione comporta l'ancoraggio della finestra nella parte superiore, inferiore o laterale del frame.The arrows indicate that dropping the component in that location causes the window to dock to the top, bottom, or side of the frame. Quando si spostano i componenti nella freccia la posizione di destinazione dello schermo sottostante viene resa più scura.Moving the component into the arrow causes the underlying screen to darken in the target location. Il cerchio centrale indica che il componente condivide lo spazio con altri componenti.The center circle indicates that the component shares the space with other components. Quando vengono rilasciati nel centro, i componenti disponibili vengono visualizzati come schede all'interno del frame.When dropped in the center, the available components appear as tabs within the frame.

Annullamento dell'ancoraggio dei componentiUndocking Components

È possibile personalizzare la presentazione dei componenti di Management StudioManagement Studio .You can customize the presentation of the Management StudioManagement Studio components.

Per ancorare e annullare l'ancoraggio dei componentiTo dock and undock components

  1. Fare clic con il pulsante destro del mouse sulla barra del titolo di Esplora oggetti ed esaminare le opzioni di menu seguenti:Right-click the title bar of Object Explorer and note the following menu options:

    • FloatFloat

    • AncoraDock

    • Ancora come Documento a schedeDock as Tabbed Document

    • Nascondi automaticamenteAuto Hide

    • NascondiHide

    Queste opzioni sono disponibili anche nel menu Finestra o facendo clic sulla freccia giù sulla barra degli strumenti.These options are also available from the Window menu, or from the down arrow on the toolbar.

  2. Fare doppio clic sulla barra del titolo di Esplora oggetti per annullare l'ancoraggio.Double-click the title bar of Object Explorer to undock it.

  3. Tenere premuto CTRL e fare nuovamente doppio clic sulla barra del titolo per ancorare Esplora oggetti.CTRL + double-click the title bar again to dock Object Explorer.

  4. Fare clic sulla barra del titolo di Esplora oggetti e trascinarla sul bordo destro di Management StudioManagement Studio.Click and drag the title bar of Object Explorer to the right border of Management StudioManagement Studio. Quando si trascina Esplora oggetti, tramite le guide a forma di rombo viene indicato il punto in cui è possibile ancorare la finestra.As you drag Object Explorer, guide diamonds are displayed that indicate where you can dock the window. Trascinare Esplora oggetti su una guida a forma di rombo per visualizzare il posizionamento della finestra.Drag Object Explorer over a guide diamond to see how the window would be positioned. Trascinare Esplora oggetti sulla guida a forma di rombo all'estrema destra di Management StudioManagement Studio.Drop Object Explorer on the guide diamond to the far right of Management StudioManagement Studio. Quando si trascina una finestra degli strumenti, il cursore deve essere posizionato su una guida a forma di rombo per visualizzarne l'effetto di ancoraggio o per ancorare la finestra.When dragging a tool window, the cursor must be positioned over a guide diamond to either see the docking effect or to doc the window.

  5. È inoltre possibile spostare Esplora oggetti nella parte superiore o inferiore di Management Studio.Object Explorer can also be moved to the top or bottom of Management Studio. Trascinare di nuovo Esplora oggetti sulla guida a forma di rombo nella posizione originale della finestra a sinistra.Drag and drop Object Explorer back to the guide diamond in the original position of the window on the left side.

  6. Fare clic con il pulsante destro del mouse sulla barra del titolo di Esplora oggetti e quindi scegliere Nascondi.Right-click the title bar of Object Explorer, and then click Hide.

  7. Scegliere Esplora oggetti dal menu Visualizza per ripristinare la finestra.On the View menu, click Object Explorer to restore the window.

  8. Fare clic con il pulsante destro del mouse sulla barra del titolo di Esplora oggetti, quindi fare clic su Mobile per annullare l'ancoraggio di Esplora oggetti.Right-click the title bar of Object Explorer, and then click Float to undock Object Explorer.

  9. Per ripristinare la configurazione predefinita, scegliere Reimposta layout finestra dal menu Finestra.To restore the default configuration, on the Window menu, click Reset Window Layout.

Attività successiva della lezioneNext Task in Lesson

Visualizzare la finestra QueryDisplay the Query Window