Scenario: Aggiunta e modifica di un diagramma di databaseWalkthrough: Adding and Changing a Database Diagram

In questo scenario viene illustrato come creare e modificare un diagramma di database e apportare modifiche al database tramite il componente per i diagrammi di database.This walkthrough illustrates how to create and modify a database diagram and make changes to the database through the database diagrams component. Verrà descritto come aggiungere tabelle ai diagrammi, creare relazioni tra le tabelle, creare vincoli e indici su colonne e modificare il livello delle informazioni visualizzate per ogni tabella.You will see how to add tables to diagrams, create relationships between tables, create constraints and indexes on columns, and change the level of information you see for each table.

PrerequisitiPrerequisites

Per completare questo scenario, saranno necessari gli elementi seguenti:In order to complete this walkthrough, you will need:

  • Accedere a SQL ServerSQL Server con il database di esempio AdventureWorks2012AdventureWorks2012 .Access to SQL ServerSQL Server with the AdventureWorks2012AdventureWorks2012 sample database

  • Un account con privilegi di proprietario del database DBO, Database OwnerAn account with database owner dbo privileges

Nota

Se si tenta di apportare modifiche quando si utilizza un account senza privilegi sufficienti ad apportare modifiche alle tabelle, verrà visualizzato un messaggio di errore.If you attempt to make changes when using an account without sufficient privileges to make changes to tables, then an error message appears.

Creazione di un diagrammaCreating a Diagram

Per creare un nuovo diagramma di databaseTo create a new database diagram

  1. Dal menu Visualizza fare clic su Esplora oggetti.On the View menu, click Object Explorer.

  2. Aprire il nodo Database e quindi il nodo AdventureWorks2012AdventureWorks2012 .Open the Databases node and then open the AdventureWorks2012AdventureWorks2012 node.

  3. Fare clic con il pulsante destro del mouse sul nodo Diagrammi database e scegliere Nuovo diagramma database.Right-click the Database Diagrams node and choose New Database Diagram.

    Se il database non include gli oggetti necessari alla creazione dei diagrammi, verrà visualizzato il messaggio seguente: Per il database non sono disponibili uno o più oggetti di supporto necessari per l'utilizzo dei diagrammi. Creare tali oggetti?If the database does not have objects necessary to create diagrams, the following message appears: This database does not have one or more of the support objects required to use database diagramming. Do you wish to create them? Scegliere .Choose Yes.

    Verrà visualizzata la finestra di dialogo Aggiungi tabella .The Add Table dialog box appears.

  4. Selezionare AddressType (Person) (Tipo indirizzo (Persona) e Address (Person) (Indirizzo (Persona) e fare clic su Aggiungi.Select AddressType (Person) and Address (Person) and click Add.

    Al diagramma verranno aggiunte due tabelle.Two tables are added to the diagram.

  5. Chiudere la finestra di dialogo Aggiungi tabella .Close the Add Table dialog box.

Per visualizzare dati di colonne diverseTo view different column data

  1. Fare clic con il pulsante destro del mouse sulla tabella Address .Right-click the Address table. Nel menu di scelta rapida scegliere Vista tabellae fare clic su Standard.On the shortcut menu, point to Table View, and then click Standard.

    Nella griglia della tabella sono visualizzate tre colonne: Nome colonna, Tipo di datie Consenti valori Null.The table grid shows three columns: Column Name, Data Type, and Allow Nulls.

  2. Fare clic con il pulsante destro del mouse sulla tabella Address , fare clic su Vista tabella e scegliere Chiavi.Right-click the Address table, click Table View and select Keys.

    Nella griglia della tabella è visualizzata una colonna, con i nomi delle colonne della tabella.The table grid shows one column, with the table-column names. Sono visualizzate solo le colonne incluse negli indici.Only those columns participating in indexes appear.

Creazione di nuove tabelleCreating New Tables

Per creare tabelle all'interno di Progettazione diagrammiTo create tables within Diagram Designer

  1. Fare clic con il pulsante destro del mouse su Progettazione diagrammi all'esterno delle tabelle esistenti e scegliere Nuova tabella.Right-click the Diagram Designer outside the existing tables and choose New Table.

  2. Nella finestra di dialogo Scegli nome selezionare OK per accettare il nome predefinito Table1.In the Choose Name dialog box, click OK to accept the default name Table1.

    Verrà visualizzata una nuova griglia della tabella con tre colonne: Nome colonna, Tipo di datie Consenti valori Null.A new table grid appears with three columns: Column Name, Data Type, and Allow Nulls.

  3. Aggiungere le informazioni seguenti a Table1:Add the following information to Table1:

    Nome colonnaColumn Name Tipo di datiData Type Consenti valori NullAllow Nulls
    T1col1T1col1 intint selezionatachecked
    T1col2T1col2 varchar(50)varchar(50) selezionatachecked
    T1col3T1col3 floatfloat selezionatachecked
  4. Fare clic con il pulsante destro del mouse su T1col1 e selezionare Imposta chiave primaria.Right-click T1col1 and select Set Primary Key.

    Accanto al nome della colonna verrà visualizzata un'icona a forma di chiave.A key icon will appear beside the column name.

  5. Scegliere Salva Diagram1 dal menu File.From the File menu, click Save Diagram1.

  6. Nella finestra di dialogo Scegli nome selezionare OK per accettare il nome predefinito Diagram1.In the Choose Name dialog box, click OK to accept the default name Diagram1.

  7. Verrà visualizzata la finestra di dialogo Salva con un messaggio che indica che Table1 verrà salvata nel database.The Save dialog box appears with a message that Table1 will be saved to the database. Scegliere .Click Yes.

Modifica della struttura della tabellaModifying Table Structure

È possibile aggiungere vincoli CHECK e creare relazioni tra le tabelle in Progettazione diagrammi.You can add check constraints and make relationships between tables in Diagram Designer.

Per creare vincoli CHECKTo create check constraints

  1. In Table1fare clic con il pulsante destro del mouse sulla riga T1col3 e scegliere Vincoli CHECK.In Table1, right-click the T1col3 row and choose Check Constraints.

    Verrà visualizzata la finestra di dialogo Vincoli CHECK .The Check Constraints dialog box appears.

  2. Scegliere Aggiungi.Click Add.

    Verrà visualizzato un nuovo vincolo nell'elenco Selected Check Constraint (Vincolo CHECK selezionato), con il nome predefinito CK_Table1.A new constraint appears in the Selected Check Constraint list, with the default name CK_Table1.

  3. Selezionare la riga Espressione nella griglia e fare clic sul pulsante con i puntini di sospensione.Select the Expression row in the grid and click the ellipsis button.

    Verrà visualizzata la finestra di dialogo Espressione vincolo CHECK.The Check Constraint Expression dialog box appears.

  4. Digitare T1col3 > 5 e selezionare OK.Type T1col3 > 5 and click OK.

    Table1 include ora un vincolo in base al quale tutti i valori immessi in T1col3 devono essere maggiori di 5.Table1 now has a constraint that all values entered into T1col3 must be greater than 5.

  5. Scegliere Chiudi.Click Close.

Per creare relazioni tra le tabelleTo create relationships between tables

  1. Creare una nuova tabella in Progettazione diagrammi denominata Table2 con le colonne seguenti:Create a new table in Diagram designer named Table2 with the following columns:

    Nome colonnaColumn Name Tipo di datiData Type Consenti valori NullAllow Nulls
    T2col1T2col1 intint non selezionatanot checked
    T2col2T2col2 varchar(50)varchar(50) selezionatachecked
    T2col3T2col3 xmlxml selezionatachecked

    Nota

    Le colonne della chiave primaria di una relazione di chiave esterna devono far parte di un vincolo UNIQUE o PRIMARY KEY.The columns on the primary key side of a foreign key relationship must participate in either a Primary Key or a Unique Constraint.

  2. Trascinare T2col1 in T1col1.Drag T2col1 to T1col1.

    Verranno visualizzate due finestre di dialogo: Relazione chiavi esterne sullo sfondo e Tabelle e colonne in primo piano.Two dialog boxes appear: Foreign Key Relationship in the background and Tables and Columns in the foreground.

  3. Fare clic su OK per salvare la nuova relazione.Click OK to save the new relationship.

  4. Fare di nuovo clic su OK .Click OK again.

Creazione di indiciCreating Indexes

È possibile creare indici per la maggioranza dei tipi di dati, inclusi i dati XML.You can create indexes on most types of data, including XML.

Per creare un indice standardTo create a standard index

  1. Fare clic con il pulsante destro del mouse su Table1 e scegliere Indici/chiavi.Right-click Table1 and choose Indexes/Keys.

    Verrà visualizzata la finestra di dialogo Indici/chiavi .The Indexes/Keys dialog box appears.

  2. Scegliere Aggiungi.Click Add.

    Verrà visualizzato un nuovo indice nell'elenco Chiave o indice primario/univoco selezionato , con un nome predefinito simile a IX_Table1.A new index appears in the Selected Primary/Unique Key or Index list, with a default name similar to IX_Table1.

  3. Selezionare la riga Colonne e fare clic sul pulsante con i puntini di sospensione.Select the Columns row and click the ellipsis button.

    Verrà visualizzata la finestra di dialogo Colonne indice .The Index Columns dialog box appears.

  4. Fare clic sulla freccia a discesa in Nome colonna e selezionare T1col2.Click the drop-down arrow under Column Name and select T1col2.

    Nota

    È possibile aggiungere colonne aggiuntive all'indice selezionando la cella sotto T1col2 e scegliendo un altro nome di colonna.You may add additional columns to this index by selecting the cell below T1col2 and choosing another column name.

  5. Fare clic su OK per salvare l'indice.Click OK to save this index.

  6. Fare clic su Chiudi nella finestra di dialogo Indici/chiavi .Click Close in the Indexes/Keys dialog box.

Per creare un indice XMLTo create an XML index

  1. Fare clic con il pulsante destro del mouse su T2col1 e selezionare Imposta chiave primaria.Right-click T2col1 and choose Set Primary Key.

    Nota

    Per l'aggiunta di un indice XML è necessario che un'altra colonna nella tabella sia impostata come chiave primaria cluster.Adding an XML index requires that another column in the table be set as a clustered primary key.

  2. Fare clic con il pulsante destro del mouse sulla riga T2col3 in Table2 e scegliere Indici XML.Right-click the T2col3 row in Table2 and select XML Indexes.

    Verrà visualizzata la finestra di dialogo Indici XML .The XML Indexes dialog box appears.

  3. Scegliere Aggiungi.Click Add.

    Un indice XML con valori predefiniti verrà aggiunto all'elenco Selected XML Index (Indice XML selezionato).An XML index with default values will be added to the Selected XML Index list.

  4. Scegliere Chiudi.Click Close.

    Nota

    Gli indici XML vengono creati per colonna.XML indexes are created per-column. Il primo indice XML è primario, eventuali indici aggiuntivi sono secondari.The first XML index is primary; any additional indexes are secondary.

Salvataggio del diagrammaSaving the Diagram

Tutte le modifiche apportate a un diagramma non vengono inviate al database fino al salvataggio.All of the changes you make to a diagram are not posted to the database until you save it. Nel caso in cui siano presenti problemi o conflitti, verrà visualizzata una finestra di dialogo con ulteriori informazioni.If there are problems or conflicts, a dialog box appears with more information.

Per salvare un diagramma di databaseTo save a database diagram

  1. Dal menu File selezionare Salva Diagram1.On the File menu, select Save Diagram1.

    Verrà visualizzata la finestra di dialogo Salva .The Save dialog box appears. Se l'opzione Avvisa in caso le tabelle siano modificate è selezionata, vengono indicate informazioni sulle tabelle nuove o modificate.If Warn about Tables Affected is selected, information about new or changed tables is listed.

  2. Scegliere OK.Click OK.

  3. Se si sono verificati errori, verrà visualizzata la finestra di dialogo Notifiche postsalvataggio con gli errori e le relative cause.If any errors occurred, the Post-Save Notifications dialog box appears with the errors and their causes. Correggere gli errori e salvare nuovamente il diagramma.Fix the errors and save the diagram again.

Passaggi successiviNext Steps

Si tratta di un diagramma di base con due tabelle esistenti e due tabelle nuove, che illustra comunque le potenzialità della creazione di diagrammi per un database esistente o di creazione di un nuovo schema in modo visivo.This is a basic diagram with just two existing and two new tables, but it illustrates the potential for diagramming an existing database or creating a new schema visually. Alcuni suggerimenti per un'analisi più ampia dell'argomento includono:Suggestions for more exploration include:

  • Creazione di nuovi diagrammi che contengono gruppi di tabelle correlateCreate new diagrams containing groups of related tables

  • Personalizzazione della quantità di informazioni visualizzate per ogni tabellaCustomize the amount of information shown for each table

  • Modifica del layout e aggiunta di annotazioniChange the layout and add annotations

  • Copia del diagramma in una bitmapCopy the diagram to a bitmap

Vedere ancheSee Also

Personalizzazione della quantità di informazioni visualizzate nei diagrammi (Visual Database Tools)Customize the Amount of Information Displayed in Diagrams (Visual Database Tools)
Impostazione di Progettazione diagrammi di database (Visual Database Tools)Set Up Database Diagram Designer (Visual Database Tools)
Aggiunta di tabelle a diagrammi (Visual Database Tools)Add Tables to Diagrams (Visual Database Tools)
Creazione di relazioni tra tabelle in un diagramma (Visual Database Tools)Create Relationships Between Tables on a Diagram (Visual Database Tools)
Creazione di indici XMLCreate XML Indexes
Copia negli Appunti di un'immagine di un diagramma di database (Visual Database Tools)Copy an Image of a Database Diagram to the Clipboard (Visual Database Tools)
Utilizzare il layout di un diagramma (Visual Database Tools)Work with Diagram Layout (Visual Database Tools)