Filtrare gli ID del processo server (SPID) in una traccia (SQL Server Profiler)Filter Server Process IDs (SPIDs) in a Trace (SQL Server Profiler)

QUESTO ARGOMENTO SI APPLICA A: SìSQL ServernonDatabase SQL di AzurenonAzure SQL Data Warehouse non Parallel Data WarehouseTHIS TOPIC APPLIES TO: yesSQL ServernoAzure SQL DatabasenoAzure SQL Data Warehouse noParallel Data Warehouse

In questo argomento viene descritta la procedura per il filtraggio degli identificatori del processo server (SPID) in una traccia mediante SQL Server ProfilerSQL Server Profiler.This topic describes how to filter server process identifiers (SPIDs) in a trace by using SQL Server ProfilerSQL Server Profiler.

Per filtrare gli ID di sistema in una tracciaTo filter system IDs in a trace

  1. Scegliere Nuova traccia dal menu Filee quindi connettersi a un'istanza di SQL Server.On the File menu, click New Trace, and then connect to an instance of SQL Server.

    Verrà visualizzata la finestra di dialogo Proprietà traccia .The Trace Properties dialog box appears.

    Nota

    Se l'opzione Avvia traccia non appena viene stabilita una connessione è selezionata, la finestra di dialogo Proprietà traccia non viene visualizzata e viene invece avviata la traccia.if Start tracing immediately after making connection is selected, the Trace Properties dialog box fails to appear, and the trace begins instead. Per disattivare questa impostazione, scegliere Opzioni dal menu Strumenti e deselezionare la casella di controllo Avvia traccia non appena viene stabilita una connessione.To turn off this setting, on the Tools menu, click Options, and clear the Start tracing immediately after making connection check box.

  2. Nella casella Nome traccia digitare un nome per la traccia.In the Trace name box, type a name for the trace.

  3. Nell'elenco di nomi Modello selezionare un modello di traccia.In the Use the template name list, select a trace template.

  4. Facoltativamente, è possibile specificare un file o una tabella di destinazione in cui salvare i risultati della traccia.Optionally, specify a destination file or table in which to save the trace results.

  5. Nella scheda Selezione eventi fare clic sull'intestazione di colonna SPID per visualizzare la finestra di dialogo Modifica filtro.On the Events Selection tab, click the SPID column heading to launch the Edit Filter dialog box. È anche possibile fare clic con il pulsante destro del mouse sull'intestazione di colonna e scegliere Modifica filtro colonne.You can also right-click the column heading and choose Edit Column Filter. Se non viene visualizzata la colonna SPID , selezionare la casella Mostra tutte le colonne .If the SPID column does not appear, check the Show all columns box.

  6. Nella finestra di dialogo Modifica filtro espandere l'operatore di confronto appropriato e immettere uno SPID come valore di confronto.In the Edit Filter dialog box, expand the appropriate comparison operator, and enter a SPID as a value for the comparison.

Vedere ancheSee Also

SQL Server ProfilerSQL Server Profiler