"Non è possibile visualizzare Dynamics 365'app per Outlook perché il ruolo utente corrente non dispone delle autorizzazioni necessarie" si verifica in Microsoft Dynamics 365 App per Outlook

Questo articolo consente di risolvere un problema in cui non è possibile aprire Microsoft Dynamics 365 App per Outlook se il ruolo di sicurezza Dynamics 365 non ha accesso al modulo dell'app.

Si applica a: Microsoft Dynamics CRM Online
Numero KB originale: 4229661

Sintomi

Quando si apre Microsoft Dynamics 365 App per Outlook, viene visualizzato l'errore seguente:

Ci dispiace
Non è possibile visualizzare Dynamics 365'app per Outlook perché il ruolo utente corrente non dispone delle autorizzazioni necessarie. Contattare l'amministratore per avere assegnato il ruolo di sicurezza necessario alla soluzione Dynamics 365 App per Outlook.

Se si fa clic su Mostra altro, i dettagli aggiuntivi includono le informazioni seguenti:

Errore: non disporre delle autorizzazioni per recuperare l'ID AppforOutlookModule
Traccia: Errore: non dispone delle autorizzazioni per recuperare l'ID AppforOutlookModule nel nuovo ...

Causa

Questo errore viene visualizzato se il ruolo di sicurezza Dynamics 365 non ha accesso al modulo dell'app usato dall'app Dynamics 365 per Outlook.

Risoluzione

Verificare che il ruolo di sicurezza Dynamics 365 abbia accesso sufficiente per caricare il modulo dell'app usato dall'app Dynamics 365 per Outlook.

  1. Verificare che il ruolo di sicurezza abbia accesso al modulo dell'app Dynamics 365 App per Outlook:

    Fornire l'accesso al ruolo di sicurezza

    Importante

    Per impostazione predefinita, i ruoli di sicurezza personalizzati non hanno accesso al modulo dell'app Dynamics 365. Sono necessari i passaggi descritti nell'articolo a cui si fa riferimento in precedenza.

  2. Per i privilegi necessari per l'uso dell'app per Outlook, vedere la documentazione seguente:

    Si verifica un errore di privilegio quando si tenta di usare Dynamics 365'app per Outlook

  3. Dopo aver verificato tutti i privilegi necessari, chiudere e riaprire Outlook.