L'installazione di Microsoft Dynamics CRM Reporting Extensions non riesce a individuare l'istanza di SSRS

Questo articolo fornisce una soluzione per assicurarsi di poter installare correttamente le estensioni per la creazione di report Microsoft Dynamics CRM nel server di report SQL Services.

Si applica a: Microsoft Dynamics CRM Online, Microsoft Dynamics CRM 2013
Numero KB originale: 2628017

Sintomi

Quando si installa il Microsoft Dynamics CRM Reporting Extensions in report SQL Services Server, l'installazione guidata non riesce a individuare il nome dell'istanza di SSRS e l'elenco a discesa è vuoto.

Esaminando il file di log di installazione delle estensioni di report, viene registrato un avviso:

Impossibile trovare un'istanza RS locale corrispondente all'URL https:///reportserver di report per organization <orgname>

Nota

Per impostazione predefinita, il file di log di installazione delle estensioni di report è disponibile in %appdata%\Microsoft\MSCRM\Logs\SrsDataConnectorSetup.log.

Causa

Il motivo è che SSRS non si trova in una versione supportata di SQL per Microsoft Dynamics CRM.

Risoluzione

Verificare che sia installata la versione minima di SSRS.

Microsoft Dynamics CRM 2011:

  • Microsoft SQL Server 2008 x64 SP1
  • Microsoft SQL Server 2008 R2
  • Microsoft SQL Server 2012 x64

Microsoft Dynamics CRM 2013:

  • Microsoft SQL Server 2008 x64 SP3
  • Microsoft SQL Server 2008 x64 R2 SP2
  • Microsoft SQL Server 2012 x64 SP1