Spostarsi all'interno del codiceNavigate code

Visual Studio offre diversi modi per spostarsi all'interno del codice nell'editor.Visual Studio provides numerous ways to navigate code in the editor. Questo argomento contiene un riepilogo dei vari metodi di passaggio da una parte all'altra del codice e indica i collegamenti ad argomenti che scendono più in dettaglio.This topic summarizes the different ways you can navigate your code, and provides links to topics that go into more detail.

È possibile utilizzare i pulsanti Sposta indietro (CTRL + - ) e sposta Avanti (CTRL + MAIUSC + - ) sulla barra degli strumenti per spostare il punto di inserimento in posizioni precedenti oppure per tornare a una posizione più recente da una posizione precedente.You can use the Navigate Backward (Ctrl+-) and Navigate Forward (Ctrl+Shift+-) buttons on the toolbar to move the insertion point to previous locations, or to return to a more recent location from a previous location. Questi pulsanti conservano le ultime 20 posizioni del punto di inserimento.These buttons retain the last 20 locations of the insertion point. Questi comandi sono disponibili anche nel menu Visualizza, in Posizione precedente e Posizione successiva.These commands are also available on the View menu, under Navigate Backward and Navigate Forward.

Pulsanti di spostamento per spostarsi avanti e indietro

Per spostarsi all'interno di una codebase, è anche possibile usare la barra di spostamento, ovvero le caselle a discesa nella parte superiore della finestra del codiceYou can use the navigation bar (the drop-down boxes at the top of the code window) to navigate to code in a codebase. e scegliere un tipo o un membro per accedervi direttamente.You can choose a type or member to go directly to it. La barra di spostamento viene visualizzata quando si modifica il codice in una codebase Visual Basic, C# o C++.The navigation bar appears when you edit code in a Visual Basic, C#, or C++ code base. In una classe parziale i membri definiti all'esterno del file di codice corrente potrebbero essere disabilitati (visualizzati in grigio).In a partial class, members defined outside the current code file may be disabled (they appear in gray).

Barra di spostamento per il codice

È possibile spostarsi tra le caselle a discesa come segue:You can navigate around the drop-down boxes as follows:

  • Per passare a un altro progetto a cui appartiene il file corrente, selezionarlo nell'elenco a discesa a sinistra.To navigate to another project that the current file belongs to, choose it in the left drop-down.

  • Per spostarsi in una classe o un tipo, scegliere la classe o il tipo nell'elenco a discesa a sinistra.To navigate to a class or type, choose it in the middle drop-down.

  • Per passare direttamente a una routine o a un altro membro di una classe, scegliere l'elemento nell'elenco a discesa a destra.To navigate directly to a procedure or other member of a class, choose it in the right drop-down.

  • Per spostare lo stato attivo dalla finestra del codice alla barra di spostamento, premere la combinazione di tasti di scelta rapida CTRL + F2.To shift focus from the code window to the navigation bar, press the shortcut key combination Ctrl+F2.

  • Per spostare lo stato attivo da una casella all'altra nella barra di spostamento, premere TAB.To shift focus from box to box on the navigation bar, press the Tab key.

  • Per selezionare l'elemento della barra di spostamento con stato attivo e tornare alla finestra del codice, premere INVIO.To select the navigation bar item that has focus and return to the code window, press the Enter key.

  • Per ripristinare lo stato attivo dalla barra di spostamento alla finestra del codice senza effettuare selezioni, premere ESC.To return focus from the navigation bar to the code without selecting anything, press the Esc key.

Per nascondere la barra di navigazione, modificare l'opzione barra di spostamento nelle impostazioni tutti i linguaggi dell' editor di testo (strumenti > Opzioni > editor di testo > tutti i linguaggi) oppure è possibile modificare le impostazioni per i singoli linguaggi.To hide the navigation bar, change the Navigation bar option in the Text Editor All Languages settings (Tools > Options > Text Editor > All Languages), or you can change the settings for individual languages.

Trova tutti i riferimentiFind all references

Trova tutti i riferimenti all'elemento selezionato nella soluzione.Finds all the references to the selected element in the solution. Con questa opzione è possibile verificare i possibili effetti collaterali di un refactoring esteso o la presenza di codice non usato.You can use this to check possible side-effects of a large refactoring, or to verify "dead" code. Premere F8 per passare ai risultati.Press F8 to jump between results. Per altre informazioni, vedere Ricerca di riferimenti nel codice.For more information, see Find references in your code.

InputInput FunzioneFunction
TastieraKeyboard Posizionare il cursore di testo in un punto qualsiasi all'interno del nome del tipo e premere MAIUSC + F12Place your text cursor somewhere inside the type name, and press Shift+F12
MouseMouse Scegliere Trova tutti i riferimenti dal menu di scelta rapidaSelect Find All References from the right-click menu

Evidenziazione dei riferimentiReference highlighting

Quando si fa clic su un simbolo nel codice sorgente, tutte le istanze del simbolo vengono evidenziate nel documento.When you click a symbol in the source code, all instances of that symbol are highlighted in the document. I simboli evidenziati possono includere dichiarazioni e riferimenti e molti altri simboli restituiti da Trova tutti i riferimenti.The highlighted symbols may include declarations and references, and many other symbols that Find All References would return. Sono inclusi i nomi di classi, oggetti, variabili, metodi e proprietà.These include the names of classes, objects, variables, methods, and properties. Nel codice Visual Basic vengono evidenziate anche le parole chiave per molte strutture di controlli.In Visual Basic code, keywords for many control structures are also highlighted. Per passare al simbolo evidenziato successivo o precedente, premere CTRL + MAIUSC + freccia giù o CTRL + MAIUSC + freccia su.To move to the next or the previous highlighted symbol, press Ctrl+Shift+Down Arrow or Ctrl+Shift+Up Arrow. È possibile modificare il colore di evidenziazione in strumenti > Opzioni > ambiente > tipi di carattere e colori > riferimento evidenziato.You can change the highlighting color in Tools > Options > Environment > Fonts and Colors > Highlighted Reference.

Comandi Vai aGo To commands

Per Vai a sono disponibili i comandi seguenti, a cui si accede dal menu Modifica sotto Vai a:Go To has the following commands, which are available in the Edit menu under Go To:

  • Vai alla riga (CTRL+G): consente di passare al numero di riga specificato nel documento attivo.Go To Line (Ctrl+G): Move to the specified line number in the active document.

  • Vai a tutti (CTRL + T o CTRL + ,): consente di passare alla riga, al tipo, al file, al membro o al simbolo specificato.Go To All (Ctrl+T or Ctrl+,): Move to the specified line, type, file, member, or symbol.

  • Vai al file (CTRL + 1, CTRL + F): consente di passare al file specificato nella soluzione.Go To File (Ctrl+1, Ctrl+F): Move to the specified file in the solution.

  • Vai a file recente (CTRL + 1, CTRL + R): consente di passare al file specificato, visitato di recente nella soluzione.Go To Recent File (Ctrl+1, Ctrl+R): Move to the specified, recently visited file in the solution.

  • Vai al tipo (CTRL + 1, CTRL + T): consente di passare al tipo specificato nella soluzione.Go To Type (Ctrl+1, Ctrl+T): Move to the specified type in the solution.

  • Vai al membro (CTRL + 1, CTRL + M): consente di passare al membro specificato nella soluzione.Go To Member (Ctrl+1, Ctrl+M): Move to the specified member in the solution.

  • Vai al simbolo (CTRL + 1, CTRL + S): consente di passare al simbolo specificato nella soluzione.Go To Symbol (Ctrl+1, Ctrl+S): Move to the specified symbol in the solution.

In Visual Studio 2017 versione 15.8 e versioni successive, sono disponibili anche i comandi di spostamento Vai a seguenti:In Visual Studio 2017 version 15.8 and later, the following Go To navigation commands are also available:

  • Go To Next Issue in File (Vai al problema successivo nel file) o ALT+PGGIÙ e Go To Previous Issue in File (Vai al problema precedente nel file) o ALT+PGSUGo To Next Issue in File (Alt+PgDn) and Go To Previous Issue in File (Alt+PgUp)

  • Vai alla posizione dell'ultima modifica o CTRL+MAIUSC+BACKSPACEGo To Last Edit Location (Ctrl+Shift+Backspace)

Per altre informazioni su questi comandi, vedere l'argomento relativo alla ricerca di codice con i comandi Vai a.See more about these commands in the Find code using Go To commands topic.

Vai a definizioneGo To Definition

Vai a definizione consente di accedere alla definizione dell'elemento selezionato.Go To Definition takes you to the definition of the selected element. Per altre informazioni, vedere Vai a definizione e Visualizza definizione.For more information, see Go To Definition and Peek Definition.

InputInput FunzioneFunction
TastieraKeyboard Posizionare il cursore di testo in un punto qualsiasi all'interno del nome del tipo e premere F12Place your text cursor somewhere inside the type name, and press F12
MouseMouse Fare clic con il pulsante destro del mouse sul nome del tipo e selezionare Vai a definizione OPPURE premere CTRL e fare clic sul nome del tipoRight-click on the type name and select Go To Definition OR press Ctrl and click on the type name

Visualizza definizionePeek Definition

Consente di visualizzare la definizione dell'elemento selezionato in una finestra senza spostarsi dalla posizione corrente nell'editor di codice.Peek Definition displays the definition of the selected element in a window without navigating away from your current location in the code editor. Per altre informazioni, vedere procedura: visualizzare e modificare il codice usando Visualizza definizione e Vai a definizione e Visualizza definizione.For more information, see How to: View and edit code by using Peek Definition and Go To Definition and Peek Definition.

InputInput FunzioneFunction
TastieraKeyboard Posizionare il cursore di testo in un punto qualsiasi all'interno del nome del tipo e premere ALT + F12Place your text cursor somewhere inside the type name, and press Alt+F12
MouseMouse Fare clic con il pulsante destro del mouse sul nome del tipo e selezionare Visualizza definizione o premere CTRL e fare clic sul nome del tipo (se l'opzione Apri definizione in visualizzazione rapida è selezionata)Right-click on the type name and select Peek Definition OR press Ctrl and click on the type name (if you have the Open definition in peek view option checked)

Vai all'implementazioneGo To Implementation

Vai all'implementazione consente di passare da una classe o un tipo di base alle relative implementazioni.Using Go To Implementation, you can navigate from a base class or type to its implementations. Se esistono più implementazioni, vengono elencate nella finestra Risultati ricerca simbolo:If there are multiple implementations, you will see them listed in the Find Symbol Results window:

InputInput FunzioneFunction
TastieraKeyboard Posizionare il cursore di testo in un punto qualsiasi all'interno del nome del tipo e premere CTRL + F12Place your text cursor somewhere inside the type name, and press Ctrl+F12
MouseMouse Fare clic con il pulsante destro del mouse sul nome del tipo e selezionare Vai all'implementazioneRight-click on the type name and select Go To Implementation

Vai a baseGo To Base

Utilizzando Vai a base, è possibile spostarsi verso l'alto nella catena di ereditarietà dell'elemento selezionato.Using Go To Base, you can navigate up the inheritance chain of the selected element. Se sono presenti più risultati, verranno visualizzati nell'elenco Vai alla finestra di base:If there are multiple results, you will see them listed in the Go To Base window:

InputInput FunzioneFunction
TastieraKeyboard Posizionare il cursore di testo in un punto qualsiasi all'interno del nome del tipo e premere ALT + HomePlace your text cursor somewhere inside the type name, and press Alt+Home
MouseMouse Fare clic con il pulsante destro del mouse sul nome del tipo e selezionare Vai a baseRight-click on the type name and select Go To Base

Gerarchia delle chiamateCall Hierarchy

È possibile visualizzare le chiamate da e verso un metodo nella finestra Gerarchia di chiamata:You can view calls to and from a method in the Call Hierarchy window:

InputInput FunzioneFunction
TastieraKeyboard Posizionare il cursore di testo in un punto qualsiasi all'interno del nome del tipo e premere CTRL + K, CTRL + TPlace your text cursor somewhere inside the type name, and press Ctrl+K, Ctrl+T
MouseMouse Fare clic con il pulsante destro sul nome del membro e selezionare Visualizza gerarchia delle chiamateRight-click on the member name and select View Call Hierarchy

Comandi Metodo successivo e Metodo precedente (Visual Basic)Next Method and Previous Method commands (Visual Basic)

Nei file di codice di Visual Basic usare questi comandi per spostare il punto di inserimento in metodi diversi.In Visual Basic code files, use these commands to move the insertion point to different methods. Scegliere modifica > metodo successivo o modifica > metodo precedente.Choose Edit > Next Method or Edit > Previous Method.

Visualizzatore di strutturaStructure Visualizer

Nella funzionalità Visualizzatore di struttura dell'editor del codice sono visualizzate le guide per strutture, ovvero linee verticali tratteggiate che indicano la presenza di parentesi graffe corrispondenti nella codebase.The Structure Visualizer feature in the code editor shows structure guide lines - vertical dashed lines that indicate matching curly braces in your codebase. In questo modo risulta più agevole visualizzare l'inizio e la fine dei blocchi logici.This makes it easier to see where logical blocks begin and end.

Visualizzatore di struttura

Per disabilitare le linee guida per le strutture, passare a strumenti > Opzioni > editor di testo > generale e deselezionare la casella Mostra linee guida struttura .To disable structure guide lines, go to Tools > Options > Text Editor > General and clear the Show structure guide lines box.

Barra di scorrimento ottimizzataEnhanced scroll bar

Per una panoramica del codice, è possibile usare la barra di scorrimento avanzata in una finestra del codice.You can use the enhanced scroll bar in a code window to get a bird's-eye view of your code. In modalità di mapping è possibile visualizzare l'anteprima del codice quando si sposta il cursore verso l'alto e verso il basso nella barra di scorrimento.In map mode, you can see previews of the code when you move the cursor up and down the scroll bar. Per altre informazioni, vedere procedura: tenere traccia del codice personalizzando la barra di scorrimento.For more information, see How to: Track your code by customizing the scroll bar.

Informazioni CodeLensCodeLens information

È possibile trovare informazioni relative a codice specifico, ad esempio modifiche, autori delle modifiche, riferimenti, bug, elementi di lavoro, revisioni del codice e stato dello unit test quando si usa CodeLens nell'editor del codice.You can find info about specific code, like changes and who made those changes, references, bugs, work items, code reviews, and unit test status when you use CodeLens in the code editor. CodeLens funziona come una visualizzazione preliminare quando si usa Visual Studio Enterprise con Team Foundation Server.CodeLens works like a heads-up display when you use Visual Studio Enterprise with Team Foundation Server. Vedere Trovare le modifiche apportate al codice e altri elementi della cronologia.See Find code changes and other history.

Vedere ancheSee also