Personalizzare l'IDE di Visual StudioPersonalize the Visual Studio IDE

È possibile personalizzare Visual Studio in vari modi per supportare in modo ottimale stili e requisiti specifici per lo sviluppo.You can personalize Visual Studio in various ways to best support your own development style and requirements. Molte impostazioni consentono di effettuare il roaming tra più istanze di Visual Studio—vedere Impostazioni sincronizzate.Many of your settings roam with you across Visual Studio instances—see Synchronized settings. Questo articolo descrive brevemente alcune personalizzazioni e indica dove è possibile trovare altre informazioni.This article briefly describes different personalizations and where you can find more information.

Note

Questo argomento si applica a Visual Studio in Windows.This topic applies to Visual Studio on Windows. Per Visual Studio per Mac, vedere Personalizzare l'IDE di Visual Studio per Mac.For Visual Studio for Mac, see Customize the Visual Studio for Mac IDE.

Impostazioni predefiniteDefault settings

È possibile scegliere una raccolta predefinita di impostazioni che consenta di ottimizzare Visual Studio per il tipo di sviluppo che si svolge abitualmente.You can choose a default collection of settings that optimizes Visual Studio for your type of development. Per altre informazioni, vedere Impostazioni dell'ambiente.For more information, see Environment settings.

Opzioni generali dell'ambienteGeneral environment options

Molte opzioni di personalizzazione sono esposte tramite la finestra di dialogo Opzioni ambiente.Many personalization options are exposed through the Environment Options dialog box. È possibile accedere a questa finestra di dialogo in due modi:There are two ways to access this dialog box:

  • Sulla barra dei menu scegliere Strumenti > Opzionie, se non è già stato fatto, espandere il nodo Ambiente.On the menu bar, choose Tools > Options, and if it's not already expanded, expand the Environment node.

  • Premere CTRL+Q, digitare ambiente nella casella di ricerca e quindi scegliere Ambiente--> Generale nei risultati.Press Ctrl+Q, type environment in the search box, and then choose Environment --> General from the results.

Tip

Quando viene visualizzata la finestra di dialogo Opzioni, è possibile premere F1 per le informazioni della Guida sulle diverse impostazioni nella pagina.When the Options dialog box appears, you can press F1 for help on the various settings on that page.

Temi colore dell'ambienteEnvironment color themes

Per modificare il tema colori tra chiaro, scuro e blu, digitare ambiente nella casella di ricerca e quindi scegliere Ambiente--> Generale.To change the color theme between light, dark and blue, type environment in the search box, and then choose Environment --> General. Nella finestra di dialogo Opzioni modificare l'opzione Tema colori.In the Options dialog box, change the Color theme option.

Per modificare le opzioni di colorazione nell'editor, digitare ambiente nella casella di ricerca e quindi scegliere Ambiente --> Tipi di carattere e colori.To change colorization options in the editor, type environment in the search box, and then choose Environment --> Fonts and Colors. Vedere How to: Modificare tipi di carattere e colori.See How to: Change fonts and colors.

È possibile modificare la combinazione di maiuscole e minuscole per il menu principale scegliendo tra le opzioni Tutte Iniziali Maiuscole ("File") e Tutto maiuscole ("FILE").You can change the main menu casing between Title Case ("File") and All Caps ("FILE"). Digitare ambiente nella casella di ricerca, selezionare Ambiente > Generale e quindi modificare l'opzione Applica lo stile Tutte Iniziali Maiuscole alla barra dei menu.Type environment in the search box, select Environment --> General, and then change the Apply title case styling to menu bar option.

Personalizzare menu e barre degli strumentiCustomize menus and toolbars

Per aggiungere o rimuovere voci di menu o elementi della barra degli strumenti, vedere Procedura: Personalizzare menu e barre degli strumenti.To add or remove menu or toolbar items, see How to: Customize menus and toolbars.

Pagina inizialeStart page

Per creare una pagina iniziale personalizzata per l'utente e il team, vedere Personalizzare la pagina iniziale.To create a custom start page for you and your team, see Customize the Start page.

Layout delle finestreWindow layouts

È possibile definire e salvare più layout di finestra e passare da un layout all'altro.You can define and save multiple window layouts and switch between them. Ad esempio, è possibile definire un layout per la scrittura del codice e uno per il debug.For example, you can define one layout for coding and one for debugging. Per definire le posizioni e il comportamento delle finestre e salvare i layout personalizzati, vedere Personalizzare il layout delle finestre in Visual Studio.To arrange window positions and behavior and save custom layouts, see Customize window layouts.

Strumenti esterniExternal tools

È possibile personalizzare il menu Strumenti per avviare gli strumenti esterni.You can customize the Tools menu to launch external tools. Per altre informazioni, vedere Gestire gli strumenti esterni.For more information, see Manage external tools.

Vedere ancheSee also