Soluzioni e progetti in Visual StudioSolutions and projects in Visual Studio

Questa pagina descrive il concetto di progetto e una soluzione in Visual Studio.This page describes the concept of a project and a solution in Visual Studio. Vengono inoltre illustrati brevemente la finestra degli strumenti Esplora soluzioni e la modalità di creazione di un nuovo progetto.It also briefly covers the Solution Explorer tool window and how to create a new project.

Note

Questo argomento si applica a Visual Studio in Windows.This topic applies to Visual Studio on Windows. Per Visual Studio per Mac, vedere Progetti e soluzioni in Visual Studio per Mac.For Visual Studio for Mac, see Projects and solutions in Visual Studio for Mac.

ProjectsProjects

Quando si crea un'app o un sito Web in Visual Studio, si inizia con un progetto.When you create an app or website in Visual Studio, you start with a project. In senso logico, un progetto contiene tutti i file compilati in un file eseguibile, in una libreria o in un sito Web.In a logical sense, a project contains all files that are compiled into an executable, library, or website. Tali file possono includere codice sorgente, icone, immagini, file di dati e così via.Those files can include source code, icons, images, data files, and so on. Un progetto contiene anche le impostazioni del compilatore e altri file di configurazione che potrebbero essere necessari per i vari servizi o componenti con cui il programma comunica.A project also contains compiler settings and other configuration files that might be needed by various services or components that your program communicates with.

File di progettoProject file

Visual Studio USA MSBuild per compilare ogni progetto in una soluzione e ogni progetto contiene un file di progetto MSBuild.Visual Studio uses MSBuild to build each project in a solution, and each project contains an MSBuild project file. L'estensione di file riflette il tipo di progetto, ad esempio un C# progetto (con estensione csproj), un progetto di Visual Basic (vbproj) o un progetto di database (. dbproj).The file extension reflects the type of project, for example, a C# project (.csproj), a Visual Basic project (.vbproj), or a database project (.dbproj). Il file di progetto è un documento XML contenente tutte le informazioni e le istruzioni necessarie a MSBuild per compilare il progetto, inclusi il contenuto, i requisiti della piattaforma, le informazioni sul controllo delle versioni, le impostazioni del server Web o del server di database e le attività per eseguire.The project file is an XML document that contains all the information and instructions that MSBuild needs in order to build your project, including the content, platform requirements, versioning information, web server or database server settings, and the tasks to perform.

I file di progetto sono basati sulla XML schema MSBuild.Project files are based on the MSBuild XML schema. Per esaminare il contenuto dei file di progetto in stile SDK più recenti in Visual Studio, fare clic con il pulsante destro del mouse sul nodo del progetto in Esplora soluzioni e scegliere modifica <NomeProgetto> .To look at the contents of newer, sdk-style project files in Visual Studio, right-click on the project node in Solution Explorer and select Edit <projectname>. Per esaminare il contenuto di .NET Framework e di altri progetti dello stile, scaricare prima il progetto (fare clic con il pulsante destro del mouse sul nodo del progetto in Esplora soluzioni e selezionare Scarica progetto).To look at the contents of .NET Framework and other projects of that style, first unload the project (right-click on the project node in Solution Explorer and select Unload Project). Quindi, fare clic con il pulsante destro del mouse sul progetto e scegliere modifica <nomeprogetto> .Then, right-click on the project and choose Edit <projectname>.

Note

Non è necessario usare soluzioni o progetti in Visual Studio per modificare, compilare ed eseguire il debug del codice.You don't have to use solutions or projects in Visual Studio to edit, build, and debug code. È sufficiente aprire la cartella che contiene i file di origine in Visual Studio e iniziare ad apportare le modifiche.You can simply open the folder that contains your source files in Visual Studio and start editing. Per altre informazioni, vedere Sviluppare codice in Visual Studio senza progetti o soluzioni.For more information, see Develop code in Visual Studio without projects or solutions.

SoluzioniSolutions

Un progetto è contenuto all'interno di una soluzione.A project is contained within a solution. Nonostante il nome, una soluzione non è una "risposta".Despite its name, a solution is not an "answer". È semplicemente un contenitore che include uno o più progetti correlati, insieme a informazioni di compilazione, impostazioni della finestra di Visual Studio e a vari file non associati a un progetto particolare.It's simply a container for one or more related projects, along with build information, Visual Studio window settings, and any miscellaneous files that aren't associated with a particular project. Una soluzione è descritta da un file di testo (con estensione sln) con un formato univoco specifico, per il quale non è prevista la modifica manuale.A solution is described by a text file (extension .sln) with its own unique format; it's not intended to be edited by hand.

Per archiviare le impostazioni delle soluzioni, Visual Studio usa due tipi di file, uno con estensione sln e uno con estensione suo.Visual Studio uses two file types (.sln and .suo) to store settings for solutions:

EstensioneExtension NameName DescrizioneDescription
sln.sln Soluzione Visual StudioVisual Studio Solution Organizza progetti, elementi del progetto ed elementi della soluzione nella soluzione.Organizes projects, project items, and solution items in the solution.
suo.suo Opzioni utente della soluzioneSolution User Options Archivia le impostazioni a livello di utente e le personalizzazioni, ad esempio i punti di interruzione.Stores user-level settings and customizations, such as breakpoints.

Crea nuovi progettiCreate new projects

Il modo più semplice per creare un nuovo progetto è iniziare da un modello di progetto per un tipo particolare di applicazione o sito Web.The easiest way to create a new project is to start from a project template for a particular type of application or website. Un modello di progetto è costituito da un set di base di file di codice, file di configurazione, risorse e impostazioni già generati.A project template consists of a basic set of pre-generated code files, config files, assets, and settings. Questi modelli sono disponibili nella finestra di dialogo in cui si crea un nuovo progetto (File > Nuovo > Progetto).These templates are available in the dialog box where you create a new project (File > New > Project). Per altre informazioni, vedere Creare un nuovo progetto in Visual Studio e Creare soluzioni e progetti.For more information, see Create a new project in Visual Studio and Create solutions and projects.

Se si personalizzano spesso i progetti in un certo modo, è possibile creare un modello di progetto personalizzato che è possibile utilizzare per creare nuovi progetti da.If you often customize your projects in a certain way, you can create a custom project template that you can then use to create new projects from. Per altre informazioni, vedere Creare modelli di progetti e di elementi.For more information, see Create project and item templates.

Quando si crea un nuovo progetto, per impostazione predefinita viene salvato in %USERPROFILE%\source\repos.When you create a new project, it is saved by default at %USERPROFILE%\source\repos. È possibile modificare questo percorso tramite l'impostazione Percorso progetti in Strumenti > Opzioni > Progetti e soluzioni > Percorsi.You can change this location in the Projects location setting under Tools > Options > Projects and Solutions > Locations. Per altre informazioni, vedere Pagina Progetti e soluzioni, finestra di dialogo Opzioni.For more information, see Projects and Solutions page, Options dialog box.

Esplora soluzioniSolution Explorer

Dopo aver creato un nuovo progetto, è possibile usare Esplora soluzioni per visualizzare e gestire il progetto e la soluzione, nonché gli elementi associati.After you create a new project, you can use Solution Explorer to view and manage the project and solution and their associated items. La figura seguente illustra Esplora soluzioni con una soluzione C# contenente due progetti:The following illustration shows Solution Explorer with a C# solution that contains two projects:

Esplora soluzioni

Sono disponibili molti comandi di menu dal menu di scelta rapida per vari elementi in Esplora soluzioni.Many menu commands are available from the right-click menu on various items in Solution Explorer. Questi comandi includono la compilazione di un progetto, la gestione dei pacchetti NuGet, l'aggiunta di un riferimento, la ridenominazione di un file e l'esecuzione di test, solo per citarne alcuni.These commands include building a project, managing NuGet packages, adding a reference, renaming a file, and running tests, just to name a few. La barra degli strumenti nella parte superiore di Esplora soluzioni include pulsanti per passare dalla visualizzazione della soluzione alla visualizzazione delle cartelle, visualizzare i file nascosti, comprimere tutti i nodi e altro ancora.The toolbar across the top of Solution Explorer has buttons to switch from a solution view to a folder view, show hidden files, collapse all nodes, and more.

Per i progetti ASP.NET Core, è possibile personalizzare la modalità di annidamento dei file in Esplora soluzioni.For ASP.NET Core projects, you can customize how files are nested in Solution Explorer. Per altre informazioni, vedere Personalizzare l'annidamento file in Esplora soluzioni.For more information, see Customize file nesting in Solution Explorer.

Vedere ancheSee also