Visual Studio Icon Note sulla versione di Visual Studio 2019 versione 16.3Visual Studio 2019 version 16.3 Release Notes



Developer Community | Requisiti di sistema | Compatibilità | Codice distribuibile | Condizioni di licenza | Blog | Novità di Visual Studio DocsDeveloper Community | System Requirements | Compatibility | Distributable Code | License Terms | Blogs | Whats New in Visual Studio Docs


Fare clic su un pulsante per scaricare la versione più recente di Visual Studio 2019.Click a button to download the latest version of Visual Studio 2019. Per istruzioni sull'installazione e sull'aggiornamento di Visual Studio 2019, vedere Aggiornare Visual Studio 2019 alla versione più recente.For instructions on installing and updating Visual Studio 2019, see the Update Visual Studio 2019 to the most recent release. Vedere anche le istruzioni su come eseguire l'installazione offline.Also, see instructions on how to install offline.

Community Download Button Professional Download Button Enterprise Download Button


Novità in Visual Studio 2019 versione 16.3What's New in Visual Studio 2019 version 16.3

Rilasci di Visual Studio 2019 versione 16.3Visual Studio 2019 version 16.3 Releases

Note sulla versione archiviateArchived Release Notes

Blog di Visual Studio 2019Visual Studio 2019 Blog

Il blog di Visual Studio 2019 è la fonte ufficiale di informazioni dettagliate sul prodotto da parte del team Visual Studio Engineering.The Visual Studio 2019 Blog is the official source of product insight from the Visual Studio Engineering Team. È possibile trovare informazioni approfondite sulle versioni di Visual Studio 2019 nei post seguenti:You can find in-depth information about the Visual Studio 2019 releases in the following posts:


Release Notes Icon Visual Studio 2019 versione 16.3.10Visual Studio 2019 version 16.3.10 New release icon

Data di rilascio: 20 novembre 2019released November 20, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.10Top Issues Fixed in Visual Studio 2019 version 16.3.10


Release Notes Icon Visual Studio 2019 versione 16.3.9Visual Studio 2019 version 16.3.9

Data di rilascio: 12 novembre 2019released November 12, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.9Top Issues Fixed in Visual Studio 2019 version 16.3.9


Release Notes Icon Visual Studio 2019 versione 16.3.8Visual Studio 2019 version 16.3.8

Data di rilascio: 5 novembre 2019released November 5, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.8Top Issues Fixed in Visual Studio 2019 version 16.3.8


Release Notes Icon Visual Studio 2019 versione 16.3.7Visual Studio 2019 version 16.3.7

Data di rilascio: 29 ottobre 2019released October 29, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.7Top Issues Fixed in Visual Studio 2019 version 16.3.7


Release Notes Icon Visual Studio 2019 versione 16.3.6Visual Studio 2019 version 16.3.6

Data di rilascio: 22 ottobre 2019released October 22, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.6Top Issues Fixed in Visual Studio 2019 version 16.3.6


Release Notes Icon Visual Studio 2019 versione 16.3.5Visual Studio 2019 version 16.3.5

Data di rilascio: 15 ottobre 2019released October 15, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.5Top Issues Fixed in Visual Studio 2019 version 16.3.5


Release Notes Icon Visual Studio 2019 versione 16.3.4Visual Studio 2019 version 16.3.4

Data di rilascio: 10 ottobre 2019released October 10, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.4Top Issues Fixed in Visual Studio 2019 version 16.3.4


Release Notes Icon Visual Studio 2019 versione 16.3.3Visual Studio 2019 version 16.3.3

Data di rilascio: 8 ottobre 2019released October 8, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.3Top Issues Fixed in Visual Studio 2019 version 16.3.3


Release Notes Icon Visual Studio 2019 versione 16.3.2Visual Studio 2019 version 16.3.2

Data di rilascio: 1 ottobre 2019released October 1, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.2Top Issues Fixed in Visual Studio 2019 version 16.3.2

  • Correzione di un problema relativo al supporto di Xcode 11.Corrected an issue with Xcode 11 support.

Release Notes Icon Visual Studio 2019 versione 16.3.1Visual Studio 2019 version 16.3.1

Data di rilascio: 25 settembre 2019released September 25, 2019

Principali problemi risolti in Visual Studio 2019 versione 16.3.1Top Issues Fixed in Visual Studio 2019 version 16.3.1


Release Notes Icon Visual Studio 2019 versione 16.3.0Visual Studio 2019 version 16.3.0

Data di rilascio: 23 settembre 2019released September 23, 2019

Riepilogo delle novità in Visual Studio 2019 versione 16.3Summary of What's New in Visual Studio 2019 version 16.3

Principali problemi risolti in Visual Studio 2019 versione 16.3.0Top Issues Fixed in Visual Studio 2019 version 16.3.0


Dettagli delle novità di Visual Studio 2019 versione 16.3.0Details of What's new in Visual Studio 2019 version 16.3.0

.NET Framework 4.8.NET Framework 4.8

Sono stati aggiunti gli strumenti di sviluppo .NET Framework 4.8 per supportare le destinazioni .NET Framework 4.8.The .NET Framework 4.8 development tools have been added to support targeting .NET Framework 4.8. .NET Framework 4.8 include diverse nuove funzionalità e miglioramenti, oltre a numerose correzioni relative ad affidabilità, stabilità, sicurezza e prestazioni.The .NET Framework 4.8 offers several new features and improvements as well as numerous reliability, stability, security, and performance fixes. Per altre informazioni su .NET Framework 4.8, vedere l'annuncio nel blog di .NET Framework 4.8Find more details about the .NET Framework 4.8 in the .NET Framework 4.8 blog announcement

Produttività .NET.NET productivity

  • Gli sviluppatori possono ora rinominare un file quando si rinominano un'interfaccia, un'enumerazione o una classe.Developers can now rename a file when renaming an interface, enum, or class. Posizionare il cursore nel nome della classe e digitare (CTRL+R, R) per aprire la finestra di dialogo Rinomina e selezionare la casella ' Rinomina file'.Place the cursor in the class name and type (Ctrl + R,R) to open the Rename dialogue and check the ‘Rename file’ box.
Rename containing file when renaming a class
Rinominare il file contenitore durante la ridenominazione di una classeRename containing file when renaming a class
  • È ora disponibile il supporto di Modifica e continuazione per progetti con più destinazioni, che include moduli caricati più volte nello stesso processo in domini o contesti di caricamento diversi.You can now Edit and Continue support for multi-targeted projects which includes modules loaded multiple times in the same process on different domains or load contexts. Inoltre, gli sviluppatori possono modificare i file di origine anche quando il progetto contenitore non è caricato o l'applicazione è in esecuzione.In addition, developers can edit source files even when the containing project is not loaded or the application is running.
  • È ora possibile eseguire il wrapping di catene di chiamate Fluent con un refactoring.You can now wrap chains of fluent calls with a refactoring. Posizionare il cursore su una catena di chiamate e premere (CTRL+. ) per attivare il menu Azioni rapide e refactoring.Place your cursor on a call chain and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selezionare Esegui il wrapping della catena di chiamate o Esegui il wrapping e allinea la catena di chiamate.Select either Wrap call chain or Wrap and align call chain.
Wrap call chain
Eseguire il wrapping della catena di chiamateWrap Call Chain
  • Gli utenti possono ora introdurre una variabile locale subito dopo averne scritto l'inizializzatore.Users can now introduce a local variable immediately after writing its initializer. Prima di tutto, scrivere un'espressione,First, write an expression. quindi posizionare il cursore sul nome dell'espressione e premere (CTRL+. ) per attivare il menu Azioni rapide e refactoring.Then place the cursor in the expression name and press (Ctrl+.) to trigger the Quick Actions and Refactorings menu. Selezionare l'opzione per introdurre una variabile locale.Select the option to introduce a local variable.
Introduce a local variable
Introdurre una variabile locale dopo aver scritto l'inizializzatoreIntroduce Local Variable After Writing Initializer
  • È ora disponibile il supporto degli strumenti per .NET Core per gli analizzatori.There is now .NET Core tooling support for analyzers. Gli utenti possono aggiungere il pacchetto dell'analizzatore più consigliato facendo clic con il pulsante destro del mouse sul nome del progetto in Esplora soluzioni e scegliendo Proprietà.Users can add the most recommended analyzer package by right clicking on the project name within the solution explorer and select properties. Selezionare Analisi codice per installare il pacchetto dell'analizzatore e configurare quando eseguire l'analisi codice.Select Code Analysis to install the analyzer package and to configure when to run code analysis.
.NET Core Tooling Analyzer Support
Supporto per gli analizzatori degli strumenti per .NET Core.NET Core Tooling Analyzer Support
  • In precedenza, è stato aggiunto il completamento di IntelliSense per tipi non importati.Previously, we added IntelliSense completion for unimported types. Questa funzionalità poteva essere disattivata dagli utenti che non volevano che i tipi non importati popolassero sempre IntelliSense.This feature came with the option to turn it off for users who did not want unimported types always populating their IntelliSense. Ora, per gli utenti che disattivano il completamento dei tipi non importati, è molto più semplice tornare all'elenco di completamento con il nuovo filtro dei tipi importati aggiunto agli interruttori di IntelliSense.Now, for users who turn off the completion for unimported types, it's much easier to get it back in the completion list with the new imported type filter added to the IntelliSense toggles.
IntelliSense completion list expander
Espansione dell'elenco di completamento di IntelliSenseIntelliSense completion list expander
IntelliSense completion list expander triggered
Espansione dell'elenco di completamento di IntelliSense attivataIntelliSense Completion List Expander Triggered
  • È ora disponibile il supporto degli stili in Informazioni rapide per i commenti XML.There is now Quick Info style support for XML comments. Posizionare il cursore sul nome del metodo.Place the cursor over the method name. Le Informazioni rapide visualizzeranno quindi gli stili supportati dai commenti XML sopra il codice.Quick Info will then display the supported styles from the XML comments above the code.
Quick info style support for XML comments
Supporto degli stili in Informazioni rapide per i commenti XMLQuick Info style support for XML comments

Strumenti WPF/UWPWPF/UWP Tooling

I clienti che creano applicazioni WPF/UWP noteranno i miglioramenti seguenti per gli strumenti XAML di Visual Studio:Customers building WPF/UWP applications will see the following improvements in Visual Studio XAML tooling:

Finestra di progettazione:Designer:

  • WPF Designer è ora completamente disponibile (GA) per i progetti .NET Core WPF: La finestra di progettazione XAML per le applicazioni .NET Core WPF è ora disponibile a livello generale per tutti i clienti senza la necessità di un flag di funzionalità in anteprima.WPF Designer now fully available (GA) for WPF .NET Core Projects: The XAML Designer for WPF .NET Core applications is now generally available (GA) to all customers without the need for preview feature flag. La finestra di progettazione XAML per le applicazioni .NET Core WPF è leggermente diversa per alcuni comportamenti e funzionalità rispetto a WPF .NET Framework Designer. Si noti che si tratta di differenze previste dalla progettazione.The XAML Designer for WPF .NET Core applications is slightly different in some behaviors and functionality then WPF .NET Framework Designer, please note this is by design. Considerate le differenze, i clienti sono invitati a segnalare eventuali problemi o limitazioni che potrebbero riscontrare tramite la funzionalità per l'invio di commenti e suggerimenti di Visual Studio.Given the difference we’d like to encourage customers to report any problems or limitations that you might be running into using Visual Studio feedback feature.
WPF .NET Core XAML Designer
Finestra di progettazione XAML .NET Core WPFWPF .NET Core XAML Designer

Strumenti di debug XAML:XAML Debugging Tools:

  • Aggiunta del supporto di Ricaricamento rapido XAML per i dizionari risorse WPF: La funzionalità Ricaricamento rapido XAML supporta ora l'aggiornamento dei dizionari risorse WPF per gli aggiornamenti in tempo reale nell'applicazione.XAML Hot Reload support added for WPF resource dictionaries changes: XAML Hot Reload now supports updating WPF Resource Dictionaries for real-time updates in the application. In precedenza questa funzionalità era disponibile solo per la piattaforma UWP (Universal Windows Platform), ma ora è supportata per le app WPF .NET Framework, WPF .NET Core e UWP.Previously this feature was only available to Universal Windows Platform (UWP), but is now supported for WPF .NET Framework, WPF .NET Core and UWP apps. Le azioni supportate includono l'aggiunta di una nuova definizione di sezione delle risorse e l'aggiunta, l'eliminazione e l'aggiornamento delle sezioni nuove/esistenti delle risorse.Supported actions include adding a new Resources section definition and adding, deleting and updating resources new/existing sections.
  • La barra degli strumenti in-app è ora mobile: La barra degli strumenti in-app è stata migliorata in modo da poter essere spostata all'interno dell'applicazione WPF/UWP in esecuzione, consentendo agli sviluppatori di trascinarla a sinistra o a destra nell'app per rendere visibile l'interfaccia utente dell'app.In-app toolbar now movable: The in-app toolbar has been enhanced so that it is movable within the running WPF/UWP application, enabling developers to drag it left or right within the app to unblock app UI. Si noti che la posizione in cui viene spostata la barra degli strumenti non viene archiviata tra le sessioni e viene ripristinata la posizione predefinita al riavvio dell'app.Note that position to which the toolbar is moved is not stored between sessions and will go back to the default position when your app is restarted.
In-app toolbar movable
Barra degli strumenti in-app mobileIn-app toolbar movable

Firma dei pacchetti UWP.UWP Package Signing.

  • È stata reintrodotta la possibilità di creare e importare i file dei certificati di firma (con estensione pfx) tramite Progettazione manifesto.Brought back the ability to create and import signing certificate files (.pfx) through the Manifest Designer.
UWP signing
  • È stata introdotta la possibilità di creare e importare i certificati di firma tramite la creazione guidata pacchetto per semplificare il processo di firma.Introduced the ability to create and import signing certificates through the Packaging Wizard to streamline the signing process.
UWP signing packaging wizard

Strumenti .NET.NET tools

  • Supporto per l'aggiunta di nuovi riferimenti a Open API e al servizio GRPC ai progetti .NET Core 3.0.Support for adding new Open API & GRPC service references to .NET Core 3.0 projects.
  • Pubblicare progetti di lavoro .NET Core 3.0 in Registro Azure Container, DockerHub e così via.Publish .NET Core 3.0 worker projects Azure Container Registry, DockerHub, etc.
  • I modelli .NET Core 3.0 per Worker, gRPC, la libreria di classi Razor e Blazor vengono visualizzati nella finestra di dialogo Nuovo progetto..NET Core 3.0 templates for Worker, gRPC, Razor Class library & Blazor are surfaced in the New Project Dialog.
  • Tutti gli aggiornamenti apportati ai modelli .NET Core 3.0 tramite l'interfaccia della riga di comando di .NET vengono esposti anche in Visual Studio.Any updates made to the .NET Core 3.0 templates via the .NET CLI are also surfaced in Visual Studio.

C++C++

  • Gli sviluppatori C++ possono ora attivare/disattivare i commenti per la riga usando i tasti di scelta rapida CTRL+K, CTRL +/ .C++ developers can now toggle line comments using the keyboard shortcut Ctrl + K, Ctrl + /.
  • Gli elenchi di membri IntelliSense vengono ora filtrati in base ai qualificatori di tipo, ad esempio, con const std::vector verranno ora filtrati metodi come push_back.IntelliSense member lists are now filtered based on type qualifiers, e.g. const std::vector will now filter out methods such as push_back.
  • Aggiunta delle funzionalità di anteprima della libreria standard C++ 20 seguenti (con /std:c++latest):Added the following C++20 Standard Library preview features (with /std:c++latest):
    • P0487R1: correzione di operator>>(basic_istream&, CharT*)P0487R1: Fixing operator>>(basic_istream&, CharT*)
    • P0616R0: uso di move() in <numeric>P0616R0: Using move() In <numeric>
    • P0758R1: is_nothrow_convertibleP0758R1: is_nothrow_convertible
    • P0734R0: estensioni C++ per i concettiP0734R0: C++ extensions for Concepts
    • P0898R3: concetti della libreria standardP0898R3: Standard Library Concepts
    • P0919R3: ricerca eterogenea di contenitori non ordinatiP0919R3: Heterogeneous Lookup For Unordered Containers
  • Nuovi controlli delle Linee guida di base di C++, inclusi il nuovo set di regole "Regole per enumerazioni" e le regole aggiuntive per costanti, enumerazioni e tipi.New C++ Core Guideline checks, including the new "Enum Rules" rule set, and additional const, enum, and type rules.
  • Un nuovo schema di colorazione semantica predefinito consente agli utenti di comprendere meglio il codice a colpo d'occhio, la finestra dello stack di chiamate può essere configurata per nascondere gli argomenti dei modelli e IntelliCode per C++ è attivo per impostazione predefinita.A new default semantic colorization scheme allows users to better understand their code at a glance, the call-stack window can be configured to hide template arguments, and C++ IntelliCode is on-by-default.
  • Configurare le destinazioni di debug e le attività personalizzate con le variabili di ambiente tramite CMakeSettings.json o CppProperties.json oppure il nuovo tag "env" nelle singole destinazioni e attività in launch.vs.json e tasks.vs.json.Configure debug targets and custom tasks with environment variables using CMakeSettings.json or CppProperties.json or the new "env" tag on individual targets and tasks in launch.vs.json and tasks.vs.json.
  • Gli utenti possono ora usare un'azione rapida per i pacchetti vcpkg mancanti per aprire automaticamente una console ed eseguire l'installazione predefinita di vcpkg.Users can now use a quick action on missing vcpkg packages to automatically open a console and install to the default vcpkg installation.
  • La copia remota dell'intestazione eseguita dai progetti Linux (CMake e MSBuild) è stata ottimizzata e ora viene eseguita in parallelo.The remote header copy done by Linux projects (CMake and MSBuild) has been optimized and now runs in parallel.
  • Il supporto nativo per WSL di Visual Studio ora supporta le compilazioni parallele per i progetti Linux basati su MSBuild.Visual Studio's native support for WSL now supports parallel builds for MSBuild-based Linux projects.
  • Gli utenti possono ora specificare un elenco di output di compilazione locale da distribuire in un sistema remoto con progetti makefile di Linux.Users can now specify a list of local build outputs to deploy to a remote system with Linux Makefile projects.
  • Le descrizioni delle impostazioni nell'Editor impostazioni CMake ora contengono più contesto e collegamenti alla documentazione utile.Setting descriptions in the CMake Settings Editor now contain more context and links to helpful documentation.

Strumenti per contenitoriContainer Tools

  • Gli sviluppatori che compilano Funzioni di Azure (v2) ora possono aggiungere il supporto per contenitori Docker (solo Linux) ai progetti C#.Developers building Azure Functions (v2) can now add Docker container support (Linux only) to their C# projects. Questa operazione può essere eseguita facendo clic con il pulsante destro del mouse sul nome del progetto in Esplora soluzioni e scegliendo "Aggiungi" --> "Supporto Docker".This can be done by right clicking the project name in Solution Explorer and selecting "Add" --> "Docker Support". Oltre ad aggiungere un Dockerfile al progetto, la destinazione di debug verrà impostata su "Docker".In addition to adding a Dockerfile to your project the debug target will be set to "Docker". Ciò significa che il debug del codice di Funzioni verrà eseguito all'interno del contenitore in esecuzione.What this means is debugging of Functions code will happen inside of the running container. Gli utenti potranno raggiungere i punti di interruzione, controllare le variabili e usare tutte le potenti funzionalità di debug di Visual Studio.Users will be able to hit breakpoints, inspect variables, and use all the powerful debugging features Visual Studio provides.
Debug Azure Functions running in Linux containers.
Eseguire il debug di Funzioni di Azure in esecuzione in contenitori LinuxDebug Azure Functions running in Linux containers

Profilatura del database per i progetti .NET CoreDatabase Profiling for .Net Core projects

Questa versione include un nuovo strumento nella famiglia di strumenti per le prestazioni e la diagnostica disponibili tramite il Profiler prestazioni (ALT-F2).This release includes a new tool in the suite of performance and diagnostics tools available via the Performance Profiler (ALT-F2). Il nuovo strumento per database offrirà dettagli sulle query da progetti .NET Core che utilizzano ADO.NET o Entity Framework.The new database tool will provide details about queries from .Net Core projects which utilize ADO.Net or Entity Framework. Lo strumento include un'opzione "vai all'origine" per collegarsi al codice sorgente e fornisce informazioni dettagliate sui tempi per ogni query eseguita durante una sessione di profilatura.The tool provides a "go to source" option for linking to source code and provides timing details for each query executed during a profiling session. Questo strumento può essere eseguito in contemporanea con altri strumenti nel Profiler prestazioni.This tool can work simultaneously with other tools in the Performance Profiler. Quando viene usato in combinazione con lo strumento Utilizzo CPU, si ottengono informazioni dettagliate sulle caratteristiche a livello di prestazioni del codice .NET Core che usa un database.When used in conjunction with the CPU Usage tool, one gains detailed information about the performance characteristics of .Net Core code which uses a database.

DebuggerDebugger

  • La finestra Stack in parallelo ha migliorato la visualizzazione delle attività e delle dipendenze in un processo per facilitare la diagnosi dei problemi nel codice asincrono.The Parallel Stacks Window has improved the visualization of tasks and their dependencies in a process to make it easier to diagnose problems in asynchronous code.
Tasks visualization in parallel stacks window
Visualizzazione delle attività migliorata nella finestra Stack in paralleloImproved task visualization in the Parallel Stacks Window

F# e strumenti F#F# and F# tools

Questa versione include il supporto per F# 4.7, la versione più recente del linguaggio F#.This release includes support for F# 4.7, the newest version of the F# language!

Gran parte di F# 4.7 è dedicata a modifiche infrastrutturali sottostanti che consentono di fornire in modo più efficace le funzionalità del linguaggio F# in anteprima.Much of F# 4.7 was dedicated to underlying infrastructural changes that allow us to deliver preview of F# language functionality more effectively. Detto questo, sono incluse anche alcune nuove funzionalità interessanti.That said, there are still some nice new features delivered as well.

Linguaggio e libreria di base F#F# language and core library

È stato aggiunto il supporto per F# 4.7, una versione del linguaggio secondaria fornita con l'infrastruttura del compilatore necessaria per abilitare le funzionalità di anteprima, in modo da poter ottenere commenti e suggerimenti sulla progettazione delle funzionalità in una fase più precoce del processo di sviluppo.We added support for F# 4.7, a minor language release that comes with compiler infrastructure to enable preview features so that we can get feedback on feature designs earlier in the development process.

L'intero set di funzionalità di F# 4.7 comprende:The full F# 4.7 feature set is:

Oltre al set di funzionalità di F# 4.7, questa versione include il supporto per le funzionalità del linguaggio F# di anteprima seguenti:In addition to the F# 4.7 feature set, this release includes support for the following preview F# language features:

  • Supporto per le espressioni nameofSupport for nameof expressions
  • Supporto per l'apertura delle classi staticheSupport for opening of static classes

È possibile abilitare questo supporto impostando <LangVersion>preview</LangVersion> nel file di progetto.You can enable this by seeting <LangVersion>preview</LangVersion> in your project file.

Questa versione contiene anche le correzioni di bug e i miglioramenti al compilatore F# seguenti:This release also contains the following bug fixes and improvements to the F# compiler:

  • È stato risolto un problema presente da tempo per cui il compilare F# poteva causare un overflow dello stack con record, struct o altri tipi di grandi dimensioni (#7070)A longstanding issue where the F# compiler could stack overflow with massive records, structs, or other types has been resolved (#7070)
  • È stato risolto un problema per cui specificare un'istruzione IL inline non valida poteva causare l'arresto anomalo di Visual Studio (#7164An issue where specifying invalid inline IL could crash Visual Studio has been resolved (#7164
  • È stato risolto un problema per cui la copia di uno struct non veniva eseguita se definito in C# e modificato in una chiamata a membro (#7406)Resolution of an issue where copying of a struct would not occur if it was defined in C# and mutated in a member call (#7406)
  • Una funzione crittografica di hash del contenuto PDB portatile creato dal compilatore non è inclusa nella directory di debug PE, con un hash configurabile impostato su SHA-256 per impostazione predefinita (#4259, #1223)A crypto hash of the portable PDB content created by the compiler is not included in the PE debug directory, with a configurable hash set to SHA-256 by default (#4259, #1223)
  • È stato corretto un bug per cui LeafExpressionConverter ignorava ValueType e presupponeva System.Tuple (#6515), contributo di Kevin MalenfantA bug where LeafExpressionConverter ignored ValueType and assumed System.Tuple has been fixed (#6515) by Kevin Malenfant
  • È stato corretto un bug per cui List.transpose rimuoveva dati anziché generare un'eccezione (#6908), contributo di Patrick McDonaldA bug where List.transpose discaded data instead of throwing an exception has been resolved (#6908) by Patrick McDonald
  • È stato corretto un bug per cui List.map3 generava un errore fuorviante se usato su elenchi di lunghezze diverse (#6897), contributo di reacheightA bug where List.map3 gave a misleading error when used on lists of different lengths has been resolved (#6897) by reacheight

Strumenti F#F# tools

Questa versione include anche alcuni miglioramenti agli strumenti F# di Visual Studio:This release also includes a few improvements to the F# tools for Visual Studio:

  • I record sono formattati per avere un aspetto più simile alle dichiarazioni e ai valori canonici nelle descrizioni comandi e in F# Interactive (#7163)Records are formatted more to look more like canonical declarations and values in tooltips and F# interactive (#7163)
  • Le proprietà nelle descrizioni comandi ora specificano se sono o meno solo get, solo set oppure get e set (#7007)Properties in tooltips now specify whether or not that are get-only, set-only, or get and set (#7007)
  • È stato risolto un problema per cui Vai alla definizione... e altre funzionalità non sempre funzionavano in progetti diversi quando i file contengono barre (#4446, #5521, #4016), contributo di chadunitAn issue where Go to Definition and other features could not always work across projects when files use forward slashes (#4446, #5521, #4016) has been fixed, with help from chadunit
  • Sono stati risolti i problemi relativi a record anonimi e debug (#6728, #6512)Issues with anonymous records and debugging have been resolved (#6728, #6512)
  • È stato corretto un bug per cui la presenza di direttive hash vuote nel codice sorgente generava una colorazione casuale del testo (#6400, #7000)A bug where empty hash directives in source could make source text coloring seem random has been resolved (#6400, #7000)

IDEIDE

  • Una casella di ricerca nella finestra di avvio consente di individuare rapidamente i progetti, le soluzioni e le cartelle usati di recente.A search box in the start window allows you quick location of recently used projects, solutions, and folders. Inoltre, questi contenitori di codice MRU si integrano con la ricerca globale di Visual Studio in modo che gli sviluppatori possano trovarli tramite la casella di ricerca di Visual Studio.In addition, these MRU code containers integrate with Visual Studio global search so developers can find them through the Visual Studio search box.
Start window MRU search
Ricerca nell'elenco dei progetti recenti nella finestra di avvioSearch in recent projects list on start window
  • I miglioramenti apportati all'interfaccia della finestra di dialogo Programma di installazione nell'IDE di Visual Studio facilitano l'identificazione di carichi di lavoro specifici che vengono aggiunti a Visual Studio.Improvements to the Installer dialog interface within the Visual Studio IDE makes it easier to identify specific workloads being added to Visual Studio.
  • Ricerca di Visual Studio consentirà di cercare tipi e membri con C# e VB, oltre a supportare la ricerca di file per tutti i linguaggi.VS Search will support the ability to search for types and members with C# and VB, as well as file search for all languages. I risultati vengono visualizzati mentre gli utenti digitano la query di ricerca, oltre che in un gruppo "Codice" dedicato accessibile tramite tasti di scelta rapida o clic del mouse.Results will show up as users type their search query, as well as in a dedicated ‘Code’ group accessible via keyboard shortcut or mouse click.
  • I modelli di progetto appena installati sono indicati con un'etichetta "Nuovo" che consente di identificarli rapidamente e i filtri mostrano i valori selezionati nella finestra di dialogo Nuovo progetto.Newly installed project templates are indicated with a "New" label to allow quick identification, and filters show selected values in the New Project Dialog. Gli sviluppatori possono anche organizzare i modelli usati di recente aggiungendoli, rimuovendoli ed eliminandoli dall'elenco.In addition, developers can organize recently used templates by pinning, unpinning, and removing them from the list.
New Project Dialog
Visualizzare i progetti appena installati e i filtri selezionati e aggiungere i modelli nella finestra di dialogo Nuovo progettoSee newly installed projects and selected filters, and pin templates in the New Project Dialog
  • Cercare modelli nella finestra di dialogo Nuovo progetto tramite una ricerca fuzzy più affidabile che si adatta a errori di digitazione e plurali per evidenziare la parola chiave corrispondente e classificare i risultati in base alla pertinenza della ricerca e dei filtri.Search for templates in the New Project Dialog through a more robust fuzzy search which adapts with typos and plurals to highlighting matching keyword and rank results based on search and filter relevance.
New Project Dialog template search
Miglioramento della precisione della ricerca ed evidenziazione per la ricerca di modelli di progettoImproved search accuracy and highlighting in project templates search

Programma di installazioneInstaller

  • Visual Studio ora aggiorna sia l'IDE che il Programma di installazione di Visual Studio con un solo clic per una maggiore produttività.Visual Studio now updates both the Visual Studio IDE and the Installer with a single click for increased productivity.
  • I componenti del Programma di installazione di Visual Studio per .NET Core 2.1 e 2.2 in precedenza eseguivano solo il runtime.The Visual Studio installer components for .NET Core 2.1 and 2.2 used to only carry the runtime. A partire da questa anteprima, oltre al runtime, i componenti eseguiranno anche i modelli.From this preview onwards the components will also carry the templates as well as the runtime.
  • Una casella di ricerca nella scheda Singoli componenti del Programma di installazione di Visual Studio consente di individuare rapidamente tutti i componenti disponibili per l'installazione.A search box in the Visual Studio Installer's Individual components tab allows for quick location of all available components for installation.
Installer components search
Cercare i singoli componenti nel Programma di installazione di Visual StudioSearch individual components in the Visual Studio Installer

IntelliCodeIntelliCode

  • Il modello di base C++ è stato attivato per impostazione predefinita.The C++ base model has been turned on by default.
    • Per modificare questa impostazione, passare a Strumenti > Opzioni > IntelliCode.You can change this setting by going to Tools > Options > IntelliCode.
  • È stata inclusa la funzionalità delle modifiche ripetute per C#, che analizza le modifiche locali in cerca di modifiche ripetibili e individua gli altri punti nello stesso file in cui potrebbe essere necessaria la stessa modifica.We've included Repeated Edits for C#, which analyzes local edits for repeatable changes and determines other places you may need this change within the same file.
    • Le modifiche ripetute suggerite compariranno nell'Elenco errori e come avvisi all'interno del file di codice.Suggested repeated edits will appear in the Error List and as warnings within the code file.

JavaScript/TypeScriptJavaScript/TypeScript

  • La classificazione JavaScript e TypeScript (comunemente denominata "colorazione della sintassi") viene applicata più rapidamente ai file di grandi dimensioni.JavaScript and TypeScript classification (commonly called “syntax coloring”) will be applied to large files more quickly. Anche l'elenco di refactoring e correzioni del codice JavaScript e TypeScript (l'icona di lampadina) verrà visualizzato più rapidamente.The list of JavaScript and TypeScript code fixes and refactorings (i.e. the lightbulb) will also be displayed more quickly.
  • È ora disponibile il supporto dell'editor per TypeScript 3.6.There is now editor support for TypeScript 3.6.
  • Quando si modifica un file tsconfig.json, ora Visual Studio aggiorna il progetto in maniera più reattiva.When a tsconfig.json file is edited or changed, Visual Studio will now refresh the project more responsively.

Test PythonPython Tests

  • Gli sviluppatori Python ora possono eseguire i test usando il noto framework di Python pytest sia nei progetti Python che negli scenari delle aree di lavoro Apri cartella.Python Developers can now run tests using the popular Python framework pytest in both Python projects and Open Folder workspace scenarios.
  • Per abilitare pytest e unittest per i progetti Python, fare clic con il pulsante destro del mouse sul nome della soluzione del progetto e scegliere Proprietà.To enable pytest and unittest for Python projects, right-click on the project solution name and select Properties. Selezionare la scheda Test per selezionare le opzioni di test.From there, select the Test tab to select testing options. Si noti che per unittest, è necessario specificare la directory per i test (la directory radice è quella predefinita) e il modello per i nomi dei file di test.Note that for unittest, you must specify the directory for the tests (root directory is the default) as well as the pattern for the test filenames. L'individuazione dei test viene avviata non appena le modifiche vengono salvate nella scheda Test. Test Discovery is intitiated as soon as changes are saved in the Test tab.
pythontest_project
Configurazione di un progetto Python per individuare i pytest o i test scritti con unittest. Si noti che selezionando "Mostra output di: Test" nella finestra di output, gli utenti possono visualizzare le informazioni di registrazione associate alle esecuzioni dei test, sia per i test non superati che per quelli superati.Configuring a Python project to discover pytests or tests written with unittest. Notice that by selecting 'Show output from: Tests' in the Output Window, users are able to see logging information associated with test runs, for both failed and passed tests.
  • Una delle novità dell'esperienza di test con unittest consiste nel fatto che ora un utente deve configurare manualmente i test sia per i progetti Python che per le aree di lavoro Apri cartella perché questi test non vengono più individuati automaticamente:The unittest testing experience has been reworked such that a user now needs to manually configure tests for both Python projects and Open Folder workspaces as these tests are no longer automatically discovered:
  • Per abilitare i test per le cartelle Python, fare clic sull'iconaTo enable tests for Python folders, click on the Show All Files per visualizzare tutti i file in Esplora soluzioni.icon to Show All Files in the Solution Explorer. Fare clic sul file PythonSettings.json presente nella cartella "Impostazioni locali". Se il file non è presente nella cartella, crearlo.From there, click on the PythonSettings.json file located within your 'Local Settings' folder (if there isn't a file there, create one). In questo file è possibile specificare quale "TestFramework" usare, oltre ai modelli di nome file di test e la directory contenente i test (entrambe le opzioni si applicano a unittest): Within this file, you can specify the 'TestFramework' you wish to use as well as the test filename patterns and the directory that contains your tests (both options apply to unittest):
pythontest_folder
  • Il debug dei test è stato aggiornato per usare PTVSD 4, ma, se gli utenti vogliono continuare a usare il "debugger legacy" o riscontrano problemi con l'uso del nuovo debugger, potranno abilitarlo passando a Strumenti > Opzioni > Python > Debug > Usa debugger legacy e selezionando la casella per abilitarlo.Test debugging is updated to use PTVSD 4, but if users wish to continue using the 'Legacy Debugger' or run into any issues with using the new debugger, they can enable it by going to Tools > Options > Python > Debugging > Use Legacy Debugger and check the box to enable it.
  • Gli utenti con progetti preesistenti e nelle area di lavoro Apri cartella contenenti file di test ora possono continuare a usare facilmente e rapidamente il codice in Visual Studio 2019.We have also made it simple for users with pre-existing projects and in open folder workspaces that contain test files to quickly continue working with their code in Visual Studio 2019. Quando gli utenti aprono un progetto che contiene file di configurazione di test (ad esempio, un file INI per pytest), ma non hanno installato o abilitato pytest, verrà loro chiesto di installare i pacchetti necessari e di configurarli per l'ambiente Python in uso: When users open a project that contains testing configuration files (e.g. a .ini file for pytest), but they have not installed or enabled pytest, they will be prompted to install the necessary packages and configure them for the Python environment they are working:
pytest infobar
Ogni volta che viene aperto un progetto Python o una cartella contenente file di test non configurati, viene chiesto agli utenti di configurarli e di installare il pacchetto di test necessario, che in questo esempio è pytest.Whenever a Python project or folder is opened that contains test files that aren't configured, users are prompted to do so as well as install the necessary test package, which in this example, is pytest.
  • Analogamente, per i file di test unittest in un progetto o in un'area di lavoro Apri cartella, verrà chiesto agli utenti di installare e/o abilitare il framework di test.Similarly for unittest test files within a project or open folder workspace, users will be prompted to install and/or enable the testing framework. In entrambi gli scenari gli sviluppatori hanno la possibilità di ignorare il messaggio e di configurare manualmente il framework.For both scenarios, developers have the option to ignore the message and to manually configure the framework.

Profiler prestazioni di Visual StudioVisual Studio Performance Profiler

  • Lo strumento Utilizzo CPU in Profiler prestazioni visualizza automaticamente l'indicatore di "percorso critico" con un'icona a forma di fiamma rossa durante la visualizzazione dell'albero delle chiamate.The CPU Usage tool in the Performance Profiler automatically displays the "hot path" indicator with a red flame icon when displaying the Call Tree. Questo consente di evitare un clic per le indagini comuni relative alle prestazioni di utilizzo della CPU.This saves a click on common CPU Usage performance investigations. Gli strumenti Utilizzo CPU sono accessibili tramite ALT+F2 o dal menu Debug.The CPU Usage tools is accessible by using Alt-F2 or from the Debug menu.
  • Profiler prestazioni partecipa ora agli spostamenti in avanti/indietro nell'IDE di Visual Studio.The Performance Profiler now participates in forward/backward navigation in the Visual Studio IDE. Man mano che gli sviluppatori si spostano nelle varie visualizzazioni degli strumenti in Profiler prestazioni, vengono salvati i punti di spostamento insieme agli altri elementi di spostamento.As developers navigate to various views of tools in the Performance Profiler, navigation points are saved along with other navigation items. Possono essere utilizzati facendo clic sui pulsanti di spostamento o usando i comandi di spostamento in Visual Studio.They can be employed by clicking the navigation buttons or using navigation commands in Visual Studio.
Forward/Backward Navigation Image
Spostamento in avanti/indietro nel profilerForward/Backward Navigation in the Profiler

Web ToolsWeb Tools

  • Configurare facilmente le dipendenze delle applicazioni nei profili di pubblicazione usando la nuova procedura guidata Aggiungi dipendenza.Easily configure applications' dependencies in publish profiles using the new Add Dependency wizard. Attualmente supporta l'aggiunta di dipendenze al servizio Azure SignalR, al server di Azure SQL, ad Archiviazione di Azure, consentendo agli utenti di effettuare il provisioning di nuove istanze o di selezionare quelle esistenti senza uscire dall'IDE.It currently supports adding dependencies to Azure SignalR Service, Azure SQL Server, Azure Storage allowing users to either provision new instances or select existing ones without leaving the IDE.
  • Data la grande richiesta, il team del runtime ASP.NET ha abilitato il supporto per gestire il contenuto statico dalle librerie di classi Razor.The ASP.NET runtime team has enabled support for serving static content from within Razor class libraries due to popular demand. In questa versione di anteprima di Visual Studio il team ha aggiunto il supporto degli strumenti per questo scenario.In this preview of Visual Studio, the team has added tooling support for this scenario.

XamarinXamarin

Questa versione include gli aggiornamenti Xamarin SDK seguenti:This release includes the following Xamarin SDK updates:

  • Xamarin.iOS 13Xamarin.iOS 13
    • Aggiunge il supporto per Xcode 11 per compilare ed eseguire il debug di app per iOS 13, tvOS 13 e watchOS 6.Adds support for Xcode 11 to build and debug apps for iOS 13, tvOS 13, and watchOS 6. Per altri dettagli sulle nuove funzionalità disponibili, vedere Introduzione a iOS 13.See our Introduction to iOS 13 for more details on the new features available.
  • Xamarin.Android 10Xamarin.Android 10
    • Le app Android possono ora usare Android 10 come destinazione impostando Versione di Android per la compilazione: (framework di destinazione) su Android 10.0 (Q) nella scheda Applicazione delle pagine delle proprietà del progetto.Android apps can now target Android 10 by setting Compile using Android version: (Target Framework) to Android 10.0 (Q) under the Application tab of the project property page. Android 10 introduce funzionalità quali tema scuro, navigazione basata sui gesti e ottimizzazioni per i dispositivi pieghevoli.Android 10 introduces features such as dark theme, gestural navigation, and optimizations for foldable devices. Per altre informazioni su queste nuove funzionalità, vedere la pagina Android 10 con Xamarin.See our Android 10 with Xamarin page for more information on these new features.
android q
Impostare Versione di Android per la compilazione: (framework di destinazione) su Android 10.0 (Q).Set the Compile using Android version: (Target Framework) to Android 10.0 (Q).

Questa versione include anche vari nuovi miglioramenti e funzionalità per gli strumenti:This release also includes several new tooling features and enhancements:

  • In questa versione è disponibile un'anteprima pubblica del ricaricamento rapido XAML per Xamarin.Forms.A public preview of XAML Hot Reload for Xamarin.Forms is available in this release. Il ricaricamento rapido XAML consente di eseguire rapidamente l'iterazione dell'interfaccia utente durante il debug dell'app in un emulatore, un simulatore o un dispositivo fisico.XAML Hot Reload lets you rapidly iterate on your UI while debugging your app on an emulator, simulator, or physical device. È sufficiente modificare il codice XAML e quindi salvare il file per visualizzare le modifiche immediatamente riflesse nell'app in esecuzione.Simply edit your XAML then save the file to see the changes immediately reflected on the running app. Per abilitare il ricaricamento rapido XAML, passare a Strumenti > Opzioni > Xamarin > Ricaricamento rapido.To enable XAML Hot Reload, go to Tools > Options > Xamarin > Hot Reload.
xaml hot reload
Ricaricamento a caldo di XAML per Xamarin.Forms.XAML Hot Reload for Xamarin.Forms.
  • Il Visualizzatore anteprima XAML per Xamarin.Forms esegue ora il rendering di Material Design sia per iOS che per Android quando si usa l'oggetto visivo Xamarin.Forms.The XAML Previewer for Xamarin.Forms now renders Material design for both iOS and Android when using Xamarin.Forms Visual.
  • Xamarin Designer per iOS include un nuovo modo per usare i vincoli.The Xamarin Designer for iOS has a new way to work with constraints. Quando si seleziona una visualizzazione vincolabile, ora compaiono dei puntini di sospensione nella barra degli strumenti accanto al selettore della modalità di blocco dei vincoli.When you select a constrainable view, an ellipsis will now appear in the toolbar next to the Constraints Pinning Mode selector. Fare clic sui puntini di sospensione per visualizzare un popover per la modifica dei vincoli nella visualizzazione selezionata.Click the ellipsis to display a popover for editing constraints on the selected view.
new ios constraints editor
Nuovo popover per l'editor di vincoli iOS.New iOS constraints editor popover.
  • È ora possibile archiviare e pubblicare app iOS da Visual Studio in Windows.You can now archive and publish iOS apps from Visual Studio on Windows. Creare un archivio mentre si è collegati a un computer Mac impostando la configurazione su Versione|iPhone, quindi fare clic con il pulsante destro del mouse sul progetto iOS in Esplora soluzioni e scegliere l'opzione di menu Archivia.Create an archive while paired to a Mac machine by setting the configuration to Release|iPhone, right-clicking your iOS project in the Solution Explorer, and selecting the Archive... menu option. Da Gestione archivi è possibile salvare un file con estensione ipa su disco per la distribuzione ad hoc o caricarlo in App Store Connect per pubblicare l'app in App Store.From the archive manager you can save an .ipa to disk for ad-hoc distribution or upload to App Store Connect to publish your app to the App Store.
  • Quando si fa clic con il pulsante destro del mouse su un file con estensione plist in Esplora soluzioni, sono disponibili nuove opzioni per aprirlo rapidamente tramite la finestra di progettazione plist generica o l'editor XML.When you right-click a .plist file in the Solution Explorer, there are new options to quickly open it using the generic plist designer or the XML editor.
new plist options
Nuove opzioni per aprire i file con estensione plist.New options to open .plist files.

Problemi notiKnown Issues

Vedere tutti i problemi e le soluzioni alternative disponibili in Visual Studio 2019 versione 16.3 facendo clic sul collegamento seguente.See all issues and available workarounds in Visual Studio 2019 version 16.3 by following the below link.

Visual Studio 2019 Known Issues Visual Studio 2019 Known Issues


Feedback e suggerimentiFeedback and suggestions

Le opinioni dei nostri clienti sono molto importanti per noi.We would love to hear from you! È possibile segnalare un problema tramite l'opzione Segnala un problema disponibile nell'angolo superiore destro del programma di installazione o dell'IDE di Visual Studio.For issues, let us know through the Report a Problem option in the upper right-hand corner of either the installer or the Visual Studio IDE itself. Alla classeThe Feedback Icon L'icona si trova nell'angolo superiore destro.icon is located in the upper right-hand corner. È possibile inviare un suggerimento sul prodotto o monitorare lo stato dei problemi nella community degli sviluppatori di Visual Studio, dove è possibile porre domande, trovare risposte e proporre nuove funzionalità.You can make a product suggestion or track your issues in the Visual Studio Developer Community, where you can ask questions, find answers, and propose new features. È anche possibile usufruire gratuitamente del supporto per l'installazione con Assistenza live chat.You can also get free installation help through our Live Chat support.


BlogBlogs

Sfruttare i vantaggi delle informazioni dettagliate e delle raccomandazioni disponibili nel sito dei blog sugli strumenti di sviluppo per mantenersi aggiornati su tutte le nuove versioni con post di approfondimento su una vasta gamma di funzionalità.Take advantage of the insights and recommendations available in the Developer Tools Blogs site to keep you up-to-date on all new releases and include deep dive posts on a broad range of features.


Cronologia delle note sulla versione di Visual Studio 2019Visual Studio 2019 Release Notes History

Per altre informazioni relative a versioni precedenti di Visual Studio 2019, vedere la pagina Cronologia delle note sulla versione di Visual Studio 2019.For more information relating to past versions of Visual Studio 2019, see the Visual Studio 2019 Release Notes History page.


Inizio pagina

Top of Page