2. Inizializzazione del progetto e distribuzione della prima applicazione2. Initializing your project and deploying your first application

In questa esercitazione apprenderai come creare un nuovo progetto Unity, come configurarlo per lo sviluppo Mixed Reality Toolkit (MRTK) e come importare MRTK.In this tutorial, you'll learn how to create a new Unity project, configure it for Mixed Reality Toolkit (MRTK) development, and import MRTK. Verranno inoltre esaminati i processi di configurazione, compilazione e distribuzione di una scena Unity di base da Visual Studio a HoloLens 2.You'll also walk through configuring, building, and deploying a basic Unity scene from Visual Studio to your HoloLens 2. Dopo la distribuzione in HoloLens 2, dovrebbe essere visualizzata una mesh di mapping spaziale che copre le superfici percepite da HoloLens.Once you have deployed it to your HoloLens 2, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Dovresti anche vedere indicatori sulle mani e sulle dita per il tracciamento delle mani e un contatore della frequenza dei fotogrammi per tenere sotto controllo le prestazioni dell'app.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance.

ObiettiviObjectives

  • Apprendere come configurare Unity per lo sviluppo per HoloLens.Learn how to configure Unity for HoloLens development.
  • Apprendere come compilare e distribuire l'app in HoloLens.Learn how to build and deploy your app to HoloLens.
  • Sperimentare la mesh di mapping spaziale, le mesh mano il contatore della frequenza dei fotogrammi sul dispositivo HoloLens 2.Experience the spatial mapping mesh, hand meshes, and framerate counter on your HoloLens 2 device.

Creazione del progetto UnityCreating the Unity project

  1. Avviare Unity Hub, selezionare la scheda Projects (Progetti) e quindi fare clic sulla freccia giù accanto al pulsante New (Nuovo):Launch Unity Hub, select the Projects tab, and then click the down arrow next to the New button:

Unity Hub in cui è evidenziata la freccia giù del pulsante "New" (Nuovo)

  1. Dal menu a discesa scegliere la versione di Unity specificata nella sezione Prerequisiti:In the dropdown menu, select the Unity version specified in the Prerequisites:

Selezionare la versione di Unity

Suggerimento

Se la versione specifica di Unity non è disponibile in Unity Hub, puoi avviare l'installazione da Download Archive (Archivio download) di Unity.If the particular Unity version is not available in Unity Hub, you can initiate the installation from Unity's Download Archive.

  1. Nella finestra Create a new project (Crea un nuovo progetto) eseguire queste operazioni:In the Create a new project window, do the following:

    • Assicurarsi che in Templates (Modelli) sia impostata l'opzione 3D.Ensure Templates is set to 3D.
    • Nella casella Project Name (Nome progetto) immettere un nome appropriato per il progetto, ad esempio "Esercitazioni di MRTK".In the Project Name box, enter a suitable name for your project (for example, "MRTK Tutorials").
    • Fare clic sul pulsante con tre punti accanto a Location (Percorso) e quindi passare alla cartella in cui si intende salvare il progetto.Click the three-dot button next to Location, and then navigate to the folder where you want to save your project.

Attenzione

Se lavori in Windows, tieni presente che è previsto un limite (MAX_PATH) di 255 caratteri per il percorso.When working on Windows, there is a MAX_PATH limit of 255 characters. È pertanto consigliabile salvare il progetto Unity in prossimità della radice dell'unità.Because of this, you should save the Unity project close to the root of the drive.

* <span data-ttu-id="c3b95-125">Fare clic sul pulsante **Create** (Crea).</span><span class="sxs-lookup"><span data-stu-id="c3b95-125">Click the **Create** button.</span></span> <span data-ttu-id="c3b95-126">Il nuovo progetto Unity viene creato e avviato.</span><span class="sxs-lookup"><span data-stu-id="c3b95-126">This creates and launches your new Unity project.</span></span>

Unity Hub con la finestra "Create a new project" (Crea un nuovo progetto) completata

La barra di stato consente di restare aggiornati sullo stato di avanzamento.The status bar keeps you updated on your progress.

L'indicatore di stato di Unity consente di restare aggiornati sullo stato di "creazione del progetto"

Passaggio a un'altra piattaforma di compilazioneSwitching the build platform

  1. Sulla barra dei menu scegliere File > Build Settings (Impostazioni di compilazione).On the menu bar, select File > Build Settings...

Percorso del menu Build Settings... di Unity

  1. Nella finestra Build Settings (Impostazioni di compilazione) selezionare Universal Windows Platform (Piattaforma UWP) e quindi fare clic sul pulsante Switch Platform (Cambia piattaforma):In the Build Settings window, select Universal Windows Platform and then click the Switch Platform button:

Finestra Build Settings di Unity con la piattaforma UWP selezionata in sostituzione della piattaforma Standalone

  1. Attendere che venga completato il cambiamento di piattaforma e quindi chiudere la finestra Build Settings (Impostazioni di compilazione).Wait for Unity to finish switching the platform, and then close the Build Settings window.

Importazione delle risorse essenziali TextMeshProImporting the TextMeshPro Essential Resources

Le risorse essenziali TextMeshPro sono richieste dagli elementi dell'interfaccia utente di MRTK.The TextMeshPro Essential Resources are required by MRTK's UI elements. Se non si prevede di usare gli elementi dell'interfaccia utente di MRTK nel progetto, è possibile ignorare questo passaggio.If you are not planning to use MRTK's UI elements in your project, you can skip this step.

  1. Sulla barra dei menu scegliere Window (Finestra) > TextMeshPro > Import TMP Essential Resources (Importa le risorse essenziali TMP).On the menu bar, select Window > TextMeshPro > Import TMP Essential Resources.

Percorso del menu Import TMP Essential Resources di Unity

  1. Nella finestra Import Unity Package (Importa il pacchetto Unity) fare clic sul pulsante All (Tutti) per assicurarsi che vengano selezionati tutti gli asset e quindi fare clic sul pulsante Import (Importa) per importare gli asset:In the Import Unity Package window, click the All button to ensure that all the assets are selected, and then click the Import button to import the assets:

Finestra di importazione TMP Essential Resources di Unity

Importazione di Mixed Reality ToolkitImporting the Mixed Reality Toolkit

  1. Scarica il pacchetto personalizzato di Unity:Download the Unity custom package:

    Microsoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackageMicrosoft.MixedReality.Toolkit.Unity.Foundation.2.4.0.unitypackage

  2. Sulla barra dei menu scegliere Assets (Asset) > Import Package (Importa pacchetto) > Custom Package (Pacchetto personalizzato).On the menu bar, select Assets > Import Package > Custom Package....

  3. Nella finestra di dialogo Import package (Importa pacchetto) passare al percorso del pacchetto appena scaricato, selezionare il pacchetto e quindi fare clic sul pulsante Open (Apri).In the Import package... dialog, navigate to the location of the package you just downloaded, then select it, and then click the Open button.

  4. Nella finestra Import Unity Package (Importa il pacchetto Unity) fare clic sul pulsante All (Tutti) per assicurarsi che vengano selezionati tutti gli asset e quindi fare clic sul pulsante Import (Importa) per importare gli asset.In the Import Unity Package window, click the All button to ensure that all the assets are selected, and then click the Import button to import the assets.

Selezione delle impostazioni di MRTK e del progettoSelecting MRTK and project settings

Al termine dell'importazione del pacchetto dalla sezione precedente, viene visualizzata la finestra MRTK Project Configurator (Configuratore del progetto MRTK).After Unity has finished importing the package from the previous section, the MRTK Project Configurator window should appear. In caso contrario, è possibile aprirlo manualmente passando a Mixed Reality Toolkit > Utilities (Utilità) > Configure Unity Project (Configura il progetto Unity):If it doesn't, you can manually open it by going to Mixed Reality Toolkit > Utilities > Configure Unity Project:

Percorso del menu Configure Unity Project di Unity

  1. Nella finestra MRTK Project Configurator (Configuratore del progetto MRTK) espandere la sezione Modify Configurations (Modifica configurazioni), se necessario, e quindi verificare che tutte le opzioni siano selezionate.In the MRTK Project Configurator window, expand the Modify Configurations section, if necessary, and then ensure that all options are selected.

Finestra MRTK Project Configurator (Configuratore del progetto MRTK) di Unity in cui è visualizzata la sezione Modify Configurations (Modifica configurazioni)

  1. Per applicare le impostazioni, fare clic sul pulsante Apply (Applica).To apply the settings, click the Apply button.

Pulsante Apply (Applica) in MRTK

Nota

Viene usata la versione legacy di XR incorporata in Unity, invece del nuovo sistema di plug-in XR, perché il nuovo sistema non è completamente compatibile con le versioni consigliate di Unity e MRTK per questa serie di esercitazioni.You are using Unity's built-in legacy XR instead of the new XR Plugin System because the new system is not fully compatible with the recommended Unity and MRTK versions for this tutorial series. Se vengono visualizzati avvisi relativi alla deprecazione di XR incorporata, è possibile ignorarli.If you see any warnings about built-in XR being deprecated, you can ignore them.

Suggerimento

L'applicazione delle impostazioni predefinite di MRTK è facoltativa ma fortemente consigliata, poiché consente di configurare alcune impostazioni consigliate di Unity:Applying the MRTK Default Settings is optional but strongly recommended as it will help configure some recommended Unity settings:

  • Enable legacy XR (Abilita XR legacy): abilita VR per il progetto.Enable legacy XR: Enables VR for the project.
  • Set Single Pass Instanced rendering path (Imposta il percorso di rendering con istanze a singolo passaggio): migliora le prestazioni grafiche eseguendo la pipeline di rendering per entrambi gli occhi nella stessa chiamata di disegno.Set Single Pass Instanced rendering path: Improves graphics performance by executing the render pipeline for both eyes in the same draw call. Per altre informazioni su questo argomento, è possibile fare riferimento alla sezione sul rendering con istanze a singolo passaggio della documentazione di MRTK relativa alle prestazioni.To learn more about this topic, you can refer to the Single-Pass Instanced rendering section of MRTK's Performance documentation.
  • Set default Spatial Awareness layer (Imposta livello di consapevolezza spaziale predefinito): crea un livello di Unity denominato Spatial Awareness e configura MRTK per l'uso di questo livello per la mesh di consapevolezza spaziale.Set default Spatial Awareness layer: Creates a Unity Layer named Spatial Awareness and configures MRTK to use this layer for the spatial awareness mesh. Per altre informazioni sui livelli di Unity, vedere la documentazione relativa alla personalizzazione dell'area di lavoro di Unity.To learn more about Unity Layers, you can refer to Unity's Customizing Your Workspace documentation.
  1. Sulla barra dei menu scegliere Edit (Modifica) > Project Settings (Impostazioni progetto).On the menu bar, select Edit > Project Settings... .

  2. Nella finestra Project Settings (Impostazioni progetto) selezionare Player (Lettore), fare clic sull'elenco a discesa XR Settings (Impostazioni XR) e quindi selezionare la casella accanto a Virtual Reality Supported (Realtà virtuale supportata):In the Project Settings window, select Player, then click the XR Settings dropdown, and then select the box next to Virtual Reality Supported:

Finestra XR Settings(Impostazioni XR) di Unity in cui è visualizzata la casella Virtual Reality Supported (Realtà virtuale supportata)

Viene importato Windows Mixed Reality SDK:This imports the Windows Mixed Reality SDK:

Finestra XR Settings(Impostazioni XR) di Unity in cui è visualizzata la sezione Virtual Reality SDKs (Virtual Reality SDK)

Al termine dell'importazione di Windows Mixed Reality SDK, viene visualizzata di nuovo la finestra MRTK Project Configurator (Configuratore del progetto MRTK).After Unity has finished importing the Windows Mixed Reality SDK, the MRTK Project Configurator window should appear again. In caso contrario, selezionare Mixed Reality Toolkit > Utilities (Utilità) > Configure Unity Project (Configura il progetto Unity) per aprirla.If it doesn't, select Mixed Reality Toolkit > Utilities > Configure Unity Project to open it.

  1. Nella finestra MRTK Project Configurator (Configuratore del progetto MRTK) fare clic sull'elenco a discesa Audio spatializer (Spazializzatore audio) e quindi selezionare MS HRTF Spatializer (Spazializzatore MS HRTF).In the MRTK Project Configurator window, click the Audio spatializer dropdown, and then select MS HRTF Spatializer.

Finestra Project Settings (Impostazioni progetto) in cui sono visualizzate le opzioni Audio spatializer (Spazializzatore audio)

  1. Fare clic sul pulsante Applica.Click the Apply button. La finestra MRTK Project Configurator (Configuratore del progetto MRTK) viene chiusa.This closes the MRTK Project Configurator window.

    Suggerimento

    L'impostazione della proprietà Audio spatializer (Spazializzatore audio) è facoltativa, ma può migliorare l'esperienza audio nel progetto.Setting the Audio spatializer property is optional but may improve the audio experience in your project. Se si imposta questa proprietà su MS HRTF Spatializer, questo plug-in di spazializzatore verrà usato quando la proprietà AudioSource.spatialize di Unity è abilitata.If you set it to MS HRTF Spatializer, this spatializer plugin will be used when Unity's AudioSource.spatialize property is enabled. Per altre informazioni su questo argomento, è possibile fare riferimento alle esercitazioni sull'audio spaziale.To learn more about this topic, you can refer to the Spatial audio tutorials.

  2. Nella finestra Project Settings (Impostazioni progetto) fare clic sull'elenco a discesa Depth Format (Formato profondità) e quindi selezionare 16-bit depth (Profondità a 16 bit):In the Project Settings window, click the Depth Format dropdown, and then select 16-bit depth:

    Area XR Settings (Impostazioni XR) di Unity in cui è selezionata l'opzione 16-bit depth (Profondità a 16 bit).

    Suggerimento

    La riduzione del formato profondità a 16 bit è facoltativa, ma consente di migliorare le prestazioni grafiche nel progetto.Reducing the Depth Format to 16-bit is optional but may help improve graphics performance in your project. Per altre informazioni su questo argomento, è possibile fare riferimento alla sezione sulla condivisione del buffer di intensità (HoloLens) della documentazione di MRTK relativa alle prestazioni.To learn more about this topic, you can refer to the Depth buffer sharing (HoloLens) section of MRTK's Performance documentation.

  3. Fare clic sull'elenco a discesa Publishing Settings (Impostazioni di pubblicazione) e quindi nella casella Package name (Nome pacchetto) immettere un nome appropriato, ad esempio "MRTK-Tutorials-Getting-Started".Click the Publishing Settings drop-down, and then in the Package name box, enter a suitable name (for example, "MRTK-Tutorials-Getting-Started").

    Finestra Publishing Settings (Impostazioni di pubblicazione) di Unity con il nome pacchetto configurato.

    Nome pacchetto e nome prodottoPackage Name and Product Name

    • Il valore di 'Package name' (Nome del pacchetto) è l'identificatore univoco dell'app.The 'Package name' is the unique identifier for the app. Creare questo identificatore prima di distribuire l'app per evitare di sovrascrivere app installate in precedenza.You should create this identifier before deploying the app to avoid overwriting previously installed apps.
    • Il valore di 'Product Name' (Nome del prodotto) è il nome visualizzato nel menu di avvio di HoloLens.The 'Product Name' is the name displayed in the HoloLens Start menu. Per semplificare l'individuazione dell'app durante lo sviluppo, è possibile anteporre un carattere di sottolineatura al nome in modo che compaia all'inizio dell'elenco.To make the app easier to locate during development, you can add an underscore in front of the name to sort it to the top.

    Finestra Project Settings (Impostazioni progetto) di Unity con il nome prodotto configurato.

  4. Chiudere la finestra Project Settings (Impostazioni progetto).Close the Project Settings window.

Creazione e configurazione della scenaCreating and configuring the scene

  1. Sulla barra dei menu scegliere File > New Scene (Nuova scena).On the menu bar, select File > New Scene.

  2. Per aggiungere MRTK alla scena, sulla barra dei menu scegliere Mixed Reality Toolkit > Add to Scene and Configure (Aggiungi alla scena e configura).To add the MRTK to the scene, on the menu bar, select Mixed Reality Toolkit > Add to Scene and Configure....

    Percorso del menu Add to Scene and Configure (Aggiungi alla scena e configura) di Unity.

  3. Nella finestra Hierarchy (Gerarchia) assicurarsi che sia selezionato l'oggetto MixedRealityToolkit.In the Hierarchy window, ensure that MixedRealityToolkit is selected.

    Assicurarsi che l'oggetto MixedRealityTookit sia selezionato.

  4. Nella sezione MixedRealityToolkit della finestra Inspector (Controllo) verificare che il profilo di configurazione sia impostato su DefaultMixedRealityToolkitConfigurationProfile:In the Inspector window's MixedRealityToolkit section, verify that the configuration profile is set to DefaultMixedRealityToolkitConfigurationProfile:

    Componente MixedRealityToolkit di Unity con DefaultMixedRealityTookitConfigurationProfile selezionato.

    Importante

    Durante le attività di sviluppo per HoloLens viene usato in genere DefaultHoloLens2ConfigurationProfile.Typically, you will use the DefaultHoloLens2ConfigurationProfile when developing for HoloLens. Tuttavia, per questa esercitazione si userà DefaultMixedRealityToolkitConfigurationProfile.However, for this tutorial, you will use the DefaultMixedRealityToolkitConfigurationProfile. Nell'esercitazione successiva, riguardante la configurazione dei profili MRTK, si passerà a DefaultHoloLens2ConfigurationProfile.In the next tutorial, Configuring the MRTK profiles, you will change to the DefaultHoloLens2ConfigurationProfile.

  5. Sulla barra dei menu scegliere File > Save As (Salva con nome).On the menu bar, select File > Save As...

  6. Nella finestra di dialogo Save scene (Salva scena) passare alla cartella Scenes (Scene) del progetto.In the Save Scene dialog, navigate to your project's Scenes folder. Nella casella File name (Nome file) assegnare alla scena un nome appropriato, ad esempio "_GettingStarted_", e quindi fare clic sul pulsante Save (Salva).In the File name box, give your scene a suitable name (for example, "_GettingStarted_"), and then click the Save button.

    Finestra del prompt di salvataggio della scena di Unity.

Compilazione e distribuzione in HoloLens 2Building and deploying to your HoloLens 2

Prima di compilare sul dispositivo, verificare quanto segue:Before building to your device, confirm the following:

  • Il dispositivo è in modalità sviluppatore.Your device is in Developer Mode.
  • Il dispositivo è associato al computer di sviluppo.Your device is paired with your development computer. In caso contrario, verrà visualizzata la finestra di dialogo seguente in Visual Studio durante il processo di compilazione:If it's not, you will see the following dialog box in Visual Studio during the build process:

Immissione del PIN per l'associazione dei dispositivi

Per altre informazioni su entrambi questi passaggi, vedere Uso di Visual Studio per la distribuzione e il debug.To learn more about both of these steps, see Using Visual Studio to deploy and debug.

  1. Sulla barra dei menu scegliere File > Build Settings (Impostazioni di compilazione).On the menu bar, select File > Build Settings....
  2. Nella finestra Build Settings (Impostazioni di compilazione) fare clic sul pulsante Add Open Scenes (Aggiungi scene aperte) per aggiungere la scena corrente all'elenco Scenes In Build (Scene in compilazione).In the Build Settings window, click the Add Open Scenes button to add your current scene to the Scenes In Build list.

Aggiungere la scena corrente all'elenco "Scenes in Build" (Scene in compilazione)

  1. Fare clic sul pulsante Build.Click the Build button.

    Fare clic sul pulsante Build.

  2. Nella finestra di dialogo Build Universal Windows Platform (Compila piattaforma UWP) scegliere un percorso appropriato per memorizzare la build, ad esempio è possibile creare una cartella "Build" nella cartella "Esercitazioni di MRTK".In the Build Universal Windows Platform dialog, choose a suitable location to store your build (for example, you may want to create a "Builds" folder in your "MRTK Tutorials" folder). Creare una nuova cartella e assegnarle un nome appropriato, ad esempio "GettingStarted", selezionare la cartella e quindi fare clic sul pulsante Select Folder (Seleziona cartella) per avviare il processo di compilazione.Create a new folder and give it a suitable name (for example, "GettingStarted"), then select the folder, and then click the Select Folder button to start the build process.

    Finestra di compilazione di Unity in cui è visualizzata la cartella della build.

    Viene visualizzata una barra di stato che consente di restare aggiornati sullo stato di avanzamento della compilazione.A status bar appears and keeps you updated on your build progress.

    Processo di compilazione di Unity in corso.

    Suggerimento

    Puoi anche eseguire la distribuzione nell'emulatore HoloLens o creare un Pacchetto applicazione per il sideload.You can also deploy to the HoloLens Emulator or create an App Package for sideloading.

  3. Al termine del processo di compilazione, in Esplora file passare al percorso in cui è stata memorizzata la build e quindi fare doppio clic sul file della soluzione per aprirlo in Visual Studio:When the build process has completed, in File Explorer, navigate to the location where you stored the build, and then double-click the solution file to open it in Visual Studio:

    Esplora risorse in cui è selezionato il file appena creato per la soluzione di Visual Studio.

    Nota

    Se Visual Studio chiede di installare nuovi componenti, dedica qualche minuto a verificare di disporre di tutti i componenti indispensabili come specificato nella documentazione Installare gli strumenti .If Visual Studio asks you to install new components, take a moment to check that you have all the prerequisite components in the Install the Tools documentation.

  4. Configurare Visual Studio per HoloLens selezionando la configurazione Master o Release, l'architettura ARM64 e Dispositivo come destinazione.Configure Visual Studio for HoloLens by selecting the Master or Release configuration, the ARM64 architecture, and Device as the target.

    Suggerimento

    Se esegui la distribuzione in HoloLens (1a generazione), seleziona l'architettura x86.If you're deploying to HoloLens (1st generation), select the x86 architecture.

    Visual Studio configurato per la distribuzione in HoloLens 2.

    Nota

    Per HoloLens, in genere la compilazione viene eseguita per l'architettura ARM.For HoloLens, you will typically build for the ARM architecture. Esiste tuttavia un problema noto in Unity 2019.3 che causa errori quando viene selezionata l'architettura di compilazione ARM in Visual Studio.However, there is a known issue in Unity 2019.3 that causes errors when selecting ARM as the build architecture in Visual Studio. La soluzione consigliata consiste nel compilare per ARM64.The recommended workaround is to build for ARM64. Se questa opzione non è applicabile, passa a Modifica > Impostazioni progetto > Player (Lettore) > Altre impostazioni e disabilita Graphics Jobs (Processi grafici).If that is not an option, go to Edit > Project Settings > Player > Other Settings and disable Graphics Jobs.

    Nota

    Se non viene visualizzata l'opzione Dispositivo come destinazione, potresti dover modificare il progetto di avvio per la soluzione di Visual Studio passando dal progetto IL2CPP al progetto UWP.If you don't see Device as a target option, you may need to change the startup project for the Visual Studio solution from the IL2CPP project to the UWP project. A tale scopo, in Esplora soluzioni fare clic con il pulsante destro del mouse su NomeProgetto (Windows universale) e quindi scegliere Imposta come progetto di avvio.To do this, in the Solution Explorer, right-click on YourProjectName (Universal Windows), and then select Set as StartUp Project.

  5. Connettere HoloLens al computer e quindi eseguire una di queste operazioni:Connect your HoloLens to your computer, and then do one of the following:

  • Per compilare l'app, distribuirla in HoloLens e avviarla automaticamente senza il debugger di Visual Studio associato, pertanto sulla barra dei menu scegliere Debug > Avvia senza eseguire il debug.To build the app, deploy it to your HoloLens, and start it automatically without the Visual Studio debugger attached, on the menu bar, select Debug > Start Without Debugging.

    Percorso del menu di Visual Studio per l'avvio senza il debug.

  • Per compilare e distribuire l'app in HoloLens senza però avviarla automaticamente, sulla barra dei menu scegliere Compila > Distribuisci soluzione.To build and deploy the app to your HoloLens but not have it start automatically, on the menu bar, select Build > Deploy Solution.

    Nota

    Potrebbe essere visibile nell'app il profiler di diagnostica, che può essere attivato o disattivato tramite il comando vocale Toggle Diagnostics (Attiva/Disattiva diagnostica).You may notice the Diagnostics profiler in the app, which you can toggle on or off by using the speech command Toggle Diagnostics. È consigliabile mantenere visibile il profiler la maggior parte del tempo durante lo sviluppo per verificare quando le modifiche apportate all'app possono produrre effetti negativi sulle prestazioni.It's recommended that you keep the profiler visible most of the time during development to understand when changes to the app may impact performance. Le app HoloLens ad esempio devono essere eseguite costantemente a 60 FPS.For example, HoloLens apps should continuously run at 60 FPS.

Lezione completataCongratulations

A questo punto hai distribuito la tua prima app per HoloLens.You've now deployed your first HoloLens app. Esplorando, noterai una mesh di mapping spaziale che copre le superfici percepite da HoloLens.As you walk around, you should see a spatial mapping mesh covering the surfaces that are perceived by the HoloLens. Dovresti anche vedere indicatori sulle mani e sulle dita per il tracciamento delle mani e un contatore della frequenza dei fotogrammi per tenere sotto controllo le prestazioni dell'app.Additionally, you should see indicators on your hands and fingers for hand tracking and a frame rate counter for keeping an eye on app performance. Queste funzionalità sono solo alcune delle parti fondamentali incluse in MRTK.These features are just a few foundational pieces included with MRTK. Nelle esercitazioni successive aggiungerai contenuto alla scena per esplorare le funzionalità di HoloLens e MRTK.In the upcoming tutorials, you'll add content to your scene to explore the capabilities of HoloLens and the MRTK.