2. Creazione di un'applicazione Holographic Remoting per PC2. Creating a Holographic Remoting PC application

In questa esercitazione si apprenderà come creare un'app Holographic Remoting per PC e connettere HoloLens 2 in qualsiasi momento, offrendo un modo per visualizzare il contenuto 3D in realtà mista.In this tutorial, you will learn how to create a PC app for Holographic Remoting and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality.

ObiettiviObjectives

  • Configurare Unity per Holographic RemotingConfigure Unity for Holographic Remoting
  • Imparare a compilare e distribuire l'applicazione con Visual StudioLearn how to build and deploy the application with Visual Studio
  • Sviluppare un'applicazione Holographic Remoting e connetterla a HoloLensDeveloping Holographic Remoting application and connecting to HoloLens

Configurazione della scena per Holographic RemotingConfiguring your scene for Holographic Remoting

In questa sezione si configurerà il progetto in modo da trasmettere l'esperienza di realtà mista al dispositivo HoloLens 2 dal PC in tempo reale tramite una connessione Wi-Fi.In this section, you will configure your project to stream your Mixed Reality experience to your HoloLens 2 device from your PC in real-time over a Wi-Fi connection.

Nella finestra Project (Progetto) passare alla cartella Assets (Asset) > MRTK.Tutorials.PCHolograhicRemoting > Prefabs (Prefab) e selezionare e trascinare il prefab HolographicRemoting nella scena.In the Project window, navigate to the Assets > MRTK.Tutorials.PCHolograhicRemoting > Prefabs folder, and click and drag HolographicRemoting prefab into your scene.

Unity con il prefab HolographicRemoting appena creato ancora selezionato

Compilare l'applicazione nel PCBuild your application to PC

L'app Holographic Remoting è ora pronta per la compilazione nel PC.Your Holographic Remoting app is now ready to build on your PC. Attenersi ai passaggi seguenti e apportare queste modifiche per compilare l'applicazione nel PC.Follow the below steps and make these changes to build this application on to your PC.

1. Configurare le impostazioni del lettore1. Set the player settings

Nel menu di Unity scegliere Edit (Modifica) > Project Settings (Impostazioni del progetto) per visualizzare la finestra Player Settings (Impostazioni lettore).In the Unity menu, select Edit > Project Settings to open the Player Settings window.

Nella finestra Project Settings (Impostazioni del progetto) espandere Publishing Settings (Impostazioni di pubblicazione), scorrere verso il basso fino alla sezione Capabilities (Funzionalità) e selezionare la casella di controllo della funzionalità mostrata di seguito, in aggiunta alle funzionalità esistenti.In the Project Settings window, expand the Publishing Settings, scroll down to the Capabilities section and select the below-shown capability checkbox in addition to the existing capabilities.

  • Client e server InternetInternet Clint server
  • Client e server di rete privataPrivate Network Client Server

Nella sezione XR Settings (Impostazioni XR) selezionare la casella di controllo WSA Holographic Remoting Supported e abilitare Holographic Remoting.In the XR Settings section, select the WSA Holographic Remoting Supported checkbox and enable the Holographic Remoting.

Finestra XR Settings di Unity con l'opzione WSA Holographic Remoting Supported abilitata

2. Compilare il progetto Unity2. Build the Unity Project

Dal menu di Unity scegliere File > Build Settings (Impostazioni di compilazione) per visualizzare la finestra corrispondente.In the Unity menu, select File > Build Settings to open the Build Settings window.

Nella finestra Build Settings (Impostazioni di compilazione) fare clic sul pulsante *Add Open Scenes _ (Aggiungi scene aperte) per aggiungere la scena corrente alle scene.In the Build Settings window, click the *Add Open Scenes _ button to add your current scene to the Scenes. Nell'elenco Build (Compilazione) fare clic sul pulsante Build (Compila) per aprire la finestra Build Universal Windows Platform (Compilazione UWP):In the Build list, then click the Build button to open the Build Universal Windows Platform window:

Finestra Build Settings di Unity con la scena aggiunta

Nella finestra Build Universal Windows Platform (Compilazione UWP) scegliere un percorso adatto per archiviare la compilazione, ad esempio Documenti\MixedRealityLearning.In the Build Universal Windows Platform window, choose a suitable location to store your build, for example, Documents\MixedRealityLearning. Creare una nuova cartella e assegnarle un nome appropriato, ad esempio PCHolographicRemoting.Create a new folder and give it a suitable name, for example, PCHolographicRemoting. Fare quindi clic sul pulsante Select Folder (Seleziona cartella) per avviare il processo di compilazione:Then click the Select Folder button to start the build process:

Finestra Build Settings di Unity con la finestra di prompt Select Folder

Attendere che Unity completi il processo di compilazione.Wait for Unity to finish the build process.

Processo di compilazione di Unity in corso

3. Compilare e distribuire l'applicazione3. Build and deploy the application

Al termine del processo di compilazione, Unity richiederà a Esplora file di Windows di aprire il percorso in cui è stata archiviata la compilazione.When the build process is completed, Unity will prompt Windows File Explorer to open the location you stored the build. Spostarsi all'interno della cartella e fare doppio clic sul file con estensione sln per aprirlo in Visual Studio:Navigate inside the folder, and double-click the .sln file to open it in Visual Studio:

Esplora risorse con la soluzione di Visual Studio appena creata selezionata

Nota

Se Visual Studio chiede di installare nuovi componenti, dedicare qualche minuto a verificare che siano installati tutti i componenti indispensabili, come specificato nell'argomento Installare gli strumenti.If Visual Studio asks you to install new components, take a moment to ensure that all prerequisite components are installed as specified in the Install the Tools documentation.

Configurare Visual Studio per PC selezionando la configurazione Release, l'architettura x64 e Local Machine (Computer locale) come destinazione:Configure Visual Studio for PC by selecting the Release configuration, the x64 architecture, and Local Machine as target:

Visual Studio configurato per Computer locale

Fare clic sul pulsante Computer locale.Click the button that says Local Machine. Viene avviata la compilazione e la distribuzione dell'applicazione nel PC.It starts to build and deploy the application on to your PC. L'applicazione verrà installata nel PC per impostazione predefinita.The application will be installed in your PC by default.

Test di un'applicazione remota Holographic RemotingTesting Holographic Remoting remote application

Per connettere l'applicazione PC a HoloLens 2, seguire questa procedura:To connect your PC application to your HoloLens 2, follow the below process:

1. Installare l'applicazione Remoting Player nel dispositivo HoloLens 21. Install the Remoting Player application on HoloLens 2 device

_ In HoloLens 2 aprire l'app dello Store e cercare "Remoting Player"._ On your HoloLens 2, visit the Store app and search for "Remoting Player."

  • Selezionare l'app Remoting Player.Select the Remoting Player app.
  • Toccare Install (Installa) per scaricare e installare l'app.Tap Install to download and install the app.

2. Connettere l'app del PC Holographic Remoting a Remoting Player2. Connect the Holographic remoting PC app to the Remoting Player

  • Avviare Remoting Player in HoloLens.Start the Remoting Player on your HoloLens.
  • Prendere nota dell'indirizzo IP di HoloLens.Take note of the HoloLens IP address. Verrà visualizzato come ologramma da Remoting Player non appena viene avviato.It will be displayed as a hologram by the Remoting Player as soon as it launches.
  • Aprire l'applicazione Holographic Remoting per PC nel PC in uso.Open the Holographic Remoting PC application on your PC.
  • Una volta avviata l'applicazione, immettere l'indirizzo IP e fare clic sul pulsante Connect (Connetti) per connettersi.Once the application is launched, enter the IP address and click on the Connect button to connect.

Lezione completataCongratulations

In questa esercitazione si è appreso come creare un'app remota Holographic Remoting e connetterla a HoloLens 2 in qualsiasi momento, offrendo un modo per visualizzare il contenuto 3D in realtà mista.In this tutorial, you learned how to create a Holographic Remoting remote app and connect to HoloLens 2 at any point, providing a way to visualize 3D content in mixed reality. Dopo aver connesso HoloLens all'applicazione PC Holographic Remoting, si noterà che l'esperienza di realtà mista è in streaming nel dispositivo HoloLens 2.Once the HoloLens connected to the Holographic Remoting PC application, you should see the mixed reality experience streaming into your HoloLens 2 device.