2. Configurazione di Photon Unity Networking

In questa esercitazione si preparerà l'ambiente per la creazione di un'esperienza condivisa tramite Photon Unity Networking (PUN). Si apprenderà come creare un'app PUN, importare asset di PUN nel progetto Unity e connettere il progetto Unity all'app PUN.

Obiettivi

  • Imparare a creare un'app PUN
  • Imparare a trovare e importare gli asset di PUN
  • Imparare a connettere il progetto Unity all'app PUN

Creazione e preparazione del progetto Unity

In questa sezione creerai un nuovo progetto Unity per prepararti allo sviluppo con MRTK.

Per prima cosa, seguire le istruzioni Inizializzazionedel progetto e Distribuzione della prima applicazione, escluse le istruzioni Aggiunta dell'interazione manuale a un oggetto e Compilare l'applicazione nel dispositivo, che include i passaggi seguenti:

  1. Creazione del progetto Unity e assegnazione di un nome appropriato, ad esempio MRTK Tutorials
  2. Passaggio a un'altra piattaforma di compilazione
  3. Importazione delle risorse essenziali TextMeshPro
  4. Importazione del progetto Toolkit realtà mista e configurazione del progetto Unity
  5. Creazione della scena e configurazione di MRTK e assegnare alla scena un nome appropriato, ad esempio MultiUserCapabilities

Segui quindi le istruzioni riportate in Modifica delle opzioni di visualizzazione di consapevolezza spaziale per:

  1. Impostare MRTK configuration profile (Profilo di configurazione di MRTK) su DefaultHoloLens2ConfigurationProfile
  2. Impostare le opzioni di visualizzazione mesh di consapevolezza spaziale su Occlusion (Occlusione).

Abilitazione delle funzionalità aggiuntive

Dal menu Unity scegli Edit > Project Settings... (Modifica > Impostazioni del progetto) per aprire la finestra Project Settings (Impostazioni del progetto) e quindi individua la sezione Player > Publishing Settings (Lettore > Impostazioni di pubblicazione):

Impostazioni del lettore di Unity

In Publishing Settings (Impostazioni di pubblicazione) scorrere verso il basso fino alla sezione Capabilities (Funzionalità) e verificare che siano abilitate le funzionalità InternetClient, Microphone, SpatialPerception, e GazeInput, abilitate al passaggio Configurazione del progetto Unity precedente.

Abilitare quindi le funzionalità aggiuntive seguenti:

  • Funzionalità InternetClientServer
  • Funzionalità PrivateNetworkClientServer

Impostazione delle funzionalità di Unity

Importazione degli asset dell'esercitazione

Aggiungere AzurespatialAnchors SDK V2.7.1 al progetto Unity. Per aggiungere i pacchetti, seguire questa esercitazione

Scarica e importa i pacchetti personalizzati di Unity seguenti, nell'ordine in cui sono elencati:

Dopo l'importazione degli asset dell'esercitazione, la finestra Project (Progetto) avrà un aspetto simile al seguente:

Finestre Hierarchy, Scene e Project di Unity dopo l'importazione degli asset dell'esercitazione

Suggerimento

Per un promemoria su come importare un pacchetto personalizzato di Unity, vedere le istruzioni relative all'importazione degli asset dell'esercitazione.

Nota

Dopo aver importato il pacchetto di asset dell'esercitazione MultiUserCapabilities, nella finestra della console verranno visualizzati alcuni errori CS0246 che indicano che manca il tipo o lo spazio dei nomi. Si tratta di un comportamento previsto, che verrà risolto nella prossima sezione quando verranno importati gli asset di PUN.

Importazione degli asset di PUN

Nel menu di Unity selezionare Window > Asset Store (Finestra > Store degli asset) per aprire la finestra Asset Store (Store degli asset), cercare e selezionare PUN 2 - FREE (PUN 2 - GRATUITO) in Exit Games (Giochi in uscita) e fare clic sul pulsante Download (Scarica) per scaricare il pacchetto di asset nell'account Unity.

Al termine del download, fai clic sul pulsante Import (Importa) per aprire la finestra Import Unity Package (Importa pacchetto Unity):

Unity Asset Store con PUN 2 - Free

Nella finestra Import Unity Package (Importa il pacchetto Unity), fai clic sul pulsante All (Tutti) per assicurarti che vengano selezionati tutti gli asset e quindi fai clic sul pulsante Import (Importa) per importare gli asset:

Unity con la finestra per l'importazione di PUN 2

Dopo che Unity ha completato il processo di importazione, verrà visualizzata la finestra PUN Wizard (Creazione guidata PUN) con il menu PUN Setup (Configurazione PUN) caricato. Per il momento puoi ignorare o chiudere questa finestra:

Unity con la finestra per la configurazione di PUN 2

Creazione dell'applicazione PUN

In questa sezione si creerà un account Photon, se non esiste già, e una nuova app PUN.

Passa al dashboard di Photon ed esegui l'accesso se hai già un account che vuoi usare. In caso contrario, fai clic sul collegamento Create One (Creane uno) e segui le istruzioni per la registrazione di un nuovo account:

Pagina di accesso di Photon

Una volta eseguito l'accesso, fai clic sul pulsante Create a New App (Crea una nuova app):

Pagina di benvenuto del dashboard Photon

Nella pagina Create a New Application (Crea una nuova applicazione) immetti i valori seguenti:

  • In Photon Type (Tipo Photon) selezionare PUN
  • In Name (Nome) immetti un nome appropriato, ad esempio MRTK Tutorials
  • In Description (Descrizione) immetti facoltativamente una descrizione appropriata
  • In Url lascia il campo vuoto

Fare quindi clic sul pulsante Create (Crea) per creare la nuova app:

Pagina per la creazione dell'applicazione Photon

Al termine del processo di creazione, nel dashboard verrà visualizzata la nuova app PUN:

Pagina dell'applicazione Photon

Connessione del progetto Unity all'applicazione PUN

In questa sezione si connetterà il progetto Unity all'app PUN creata nella sezione precedente.

Nel dashboard di Photon fai clic sul campo App ID (ID app) per visualizzare l'ID dell'app e quindi copialo negli Appunti:

Pagina dell'applicazione Photon con App Id selezionato

Nel menu di Unity seleziona Window (Finestra) > Photon Unity Networking > PUN Wizard (Creazione guidata PUN) per aprire la finestra PUN Wizard (Creazione guidata PUN), fai clic sul pulsante Setup Project (Configura progetto) per aprire il menu PUN Setup (Configurazione PUN) ed esegui la configurazione nel modo seguente:

  • Nel campo AppId or Email (ID app o e-mail) incolla l'ID dell'app PUN copiato nel passaggio precedente

Fai quindi clic sul pulsante Setup Project (Configura progetto) per applicare l'ID dell'app:

Finestra PUN Setup di Unity con AppId compilato

Dopo che Unity ha terminato il processo di configurazione di PUN, nel menu PUN Setup (Configurazione PUN) verrà visualizzato il messaggio Done! (Fatto) e nella finestra Project (Progetto) verrà selezionato automaticamente l'asset PhotonServerSettings, in modo che le relative proprietà siano visualizzate nella finestra Inspector (Controllo):

Finestra PUN Setup di Unity con Setup Project applicato

Lezione completata

È stata creata un'app PUN ed è stata connessa al progetto Unity. Il passaggio successivo consiste nel consentire connessioni con altri utenti, in modo che ogni utente possa visualizzare il lavoro svolto dagli altri.