(WinRM クライアントは要求を処理できません)、リモート Windows PowerShell経由でExchange Onlineに接続するとエラーが発生します

問題

リモート Windows PowerShellを使用して Microsoft 365 のExchange Onlineに接続すると、次のエラー メッセージが表示されます。

[outlook.office365.com]リモート サーバーへの接続に失敗し、次のエラー メッセージが表示されました。
WinRM クライアントは、サーバー名を解決できないため、要求を処理できません。 詳細については、about_Remote_Troubleshootingヘルプ トピックを参照してください。

+ CategoryInfo : OpenError:
(System.Manageme....RemoteRunspace:RemoteRunspace) [].
PSRemotingTransportException

+ FullyQualifiedErrorId : PSSessionOpenedFailed

原因

この問題は、次のいずれかの状況で発生します。

  • ファイアウォールは、必要なトラフィックをブロックします。
  • Windows リモート管理サービスは開始されません。
  • プロキシ サーバーが正しく動作しません。

解決方法

  • ファイアウォールが必要なトラフィックをブロックしていないことを確認します。

  • Windows リモート管理サービスがインストールされ、開始されているかどうかを確認します。

    1. [実行] ダイアログ ボックスに 「services.msc」と入力し、Enter キーを押します。

    2. サービス MMC で、 Windows リモート管理 をダブルクリックします。

    3. スタートアップの種類を [手動] に設定し、[OK] をクリック します

    4. サービスを右クリックし、[開始] を選択 します

    5. サービスを開始します。

      注意

      サービスが既に開始されていても応答していない場合は、[ 再起動] をクリックする必要があります。

    6. もう一度Exchange Onlineに接続してみてください。

  • プロキシ サーバーの設定を確認する

    1. 管理者特権のコマンド プロンプトを開きます。

    2. 次のコマンドを実行して、現在のプロキシ構成を確認します。

      netsh winhttp show proxy
      
    3. 次のどちらかの手順を実行します。

      • WinHTTP プロキシをリセットするには、次のコマンドを実行します。

        netsh winhttp reset proxy
        
      • 新しいプロキシ サーバーを構成するには、次のコマンドを実行します。

        netsh winhttp set proxy <proxy>:<port>
        

        たとえば、.netsh winhttp set proxy 10.0.0.6:8080

詳細情報

Microsoft 365 エンドポイントの詳細については、「 Microsoft 365 URL と IP アドレス範囲」を参照してください。

リモート PowerShell を使用してExchange Onlineに接続する方法の詳細については、「リモート PowerShell を使用してExchange Onlineに接続する」を参照してください。

さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。