(WinRM クライアントは要求を処理できません) エラーは、リモート サーバーをExchange Online接続Windows PowerShell
問題
リモート サーバーを使用Windows PowerShell、Exchange Onlineに接続Microsoft Office 365、次のエラー メッセージが表示されます。
[outlook.office365.com]リモート サーバーへの接続に失敗し、次のエラー メッセージが表示されました。
サーバー名を解決できないので、WinRM クライアントは要求を処理できません。 詳細については、「ヘルプ」のトピックabout_Remote_Troubleshooting参照してください。+ CategoryInfo : OpenError:
(System.Manageme.....RemoteRunspace:RemoteRunspace) [].
PSRemotingTransportException+ FullyQualifiedErrorId : PSSessionOpenedFailed
原因
この問題は、次のいずれかの状況で発生します。
- ファイアウォールは、必要なトラフィックをブロックします。
- リモートWindowsサービスが開始されていない場合。
- プロキシ サーバーが正しく動作しません。
解決方法
ファイアウォールが必要なトラフィックをブロックしないか確認します。
リモート管理サービスWindowsインストールされ、開始されているかどうかを確認します。
[実行] ダイアログ ボックスに「services.msc」と入力し、Enter キーを押します。
Services MMC で、[リモート管理] Windows ダブルクリックします。
スタートアップの種類を [手動] に設定し、[OK] を クリックします。
サービスを右クリックし、[スタート] を 選択します。
サービスを開始します。
注意
サービスが既に開始されているが応答していない場合は、[再起動] をクリックする必要 があります。
もう一度デバイスに接続Exchange Onlineします。
プロキシ サーバーの設定を確認する
管理者特権でコマンド プロンプトを開きます。
次のコマンドを実行して、現在のプロキシ構成を確認します。
netsh winhttp show proxy
次のいずれかの操作を実行します。
WinHTTP プロキシをリセットするには、次のコマンドを実行します。
netsh winhttp reset proxy
新しいプロキシ サーバーを構成するには、次のコマンドを実行します。
netsh winhttp set proxy <proxy>:<port>
たとえば、実行します
netsh winhttp set proxy 10.0.0.6:8080
。
詳細情報
エンドポイントの詳細については、「Microsoft 365 URL と IP アドレスMicrosoft 365を参照してください。
リモート PowerShell を使用してリモート PowerShell Exchange Online接続する方法の詳細については、「リモート PowerShell を使用ConnectのExchange Online」を参照してください。
さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。