Autopilot デバイスのインポートと登録のトラブルシューティング

適用対象

  • Windows 11
  • Windows 10

Intune にデバイスをインポートおよび登録するときに発生する可能性がある問題については、以下のセクションを参照してください。

自己展開0x80180014準備モードを使用して再登録するときにエラー コードが表示される

最初の自動パイロット展開後、自動パイロットの自己展開モードまたは事前プロビジョニング モード プロファイルを持つデバイスは、自動パイロットを使用して自動的に再登録できません。 デバイスを再展開する場合は、エラー コード 0x80180014 が返されます。

[登録状態] ページには0x80180014展開モードまたはプレプロビジョニング モードを使用するデバイスのエラー コードが表示されます。

[事前プロビジョニング] ページには、0x80180014展開モードまたはプレプロビジョニング モードを使用するデバイスのエラー コードが表示されます。

ETW ログに次のエラーが表示される場合があります。

MDM Enroll: Server Returned Fault/Code/Subcode/Value=(DeviceNotSupported) Fault/Reason/Text=(Enrollment blocked for AP device by SDM One Time Limit Check)

原因 A

Microsoft エンドポイント マネージャー自動パイロットWindows展開モード (パブリック プレビュー) とプレプロビジョニング モード (以前はホワイト グローブ、パブリック プレビュー) のエクスペリエンスを変更しました。 デバイスを再利用するには、Intune によって作成されたデバイス レコードを削除する必要があります。

この変更は、自己展開モードまたは事前プロビジョニング モードを使用するすべての Autopilot 展開に影響します。 この変更は、デバイスが再利用、リセット、またはプロファイルの再展開時に影響を与えます。

解決策 A

Autopilot を使用してデバイスを再展開するには、次の操作を行います。

  1. Intune でデバイス レコードを削除します。 具体的な手順については、「デバイスを管理センターから削除するエンドポイント マネージャー参照してください
  2. 自動パイロット展開プロファイルを再展開します。

原因 B

Windowsで MDM 登録が無効になっている場合。

解決策 B

スタンドアロンの Intune 環境でこの問題を解決するには、次の手順を実行します。

  1. 管理センター Microsoft エンドポイント マネージャー DevicesEnrollment > の制限を選択し、デバイスの種類の制限を選択します。
  2. [プラットフォーム設定 ] の > 横にある [PropertiesEdit] を選択します。 次に、[許可する] Windows (MDM) を選択します
  3. [確認 ] を選択 し、[保存] を選択します

デバイスのインポートに関する問題

デバイス ハッシュ エラーを変換できません

説明

  • CSV を選択した後で [インポート] をクリックしても何も実行しない
  • 400 エラーがネットワーク トレースに表示され、"リテラル '[DEVICEHASH]' を予期される型 'Edm.Binary' に変換できません。

原因

このエラーは、誤って書式設定されているデバイス ハッシュを示しています。 収集されたハッシュを破損すると、このエラーが発生する可能性があります。 1 つの可能性は、ハッシュ自体 (有効な場合でも) がデコードに失敗する可能性があります。

説明

デバイス ハッシュは Base64 です。 デバイス レベルでは、未パッドの Base64 としてエンコードされますが、Autopilot ではパッド入りの Base64 が必要です。 通常、ペイロードはパディングを必要とし、プロセスは機能します。 ただし、ペイロードがきれいに配置され、パディングが必要な場合があります。 この場合、上記のエラーが表示されます。 PowerShell の Base64 デコーダーでは、埋め込み Base64 も必要なので、このデコーダーを使用して、ハッシュが適切に埋め込まれることを検証できます。

ハッシュの末尾にある "A" 文字は、事実上空のデータです。 Base64 の各文字は 6 ビットで、Base64 の A は 0 に等しい 6 ビットです。 最後に As を 削除または追加しても、実際のペイロード データは変更されません。

解決方法

この問題を解決するには、PowerShell がハッシュのデコードに成功するまで、ハッシュを変更し、新しい値をテストする必要があります。 結果は、ほとんどが分からなく、問題ありません。 "Base-64 char 配列または文字列に対して無効な長さ" というエラーをスローしない方法を探しています。

base64 をテストするには、次の PowerShell を使用できます。

[System.Text.Encoding]::ascii.getstring( [System.Convert]::FromBase64String("DEVICE HASH"))

したがって、例として (これはデバイス ハッシュではないが、パッドされていない Base64 が誤って設定されているので、テストに良い方法です)。

[System.Text.Encoding]::ascii.getstring( [System.Convert]::FromBase64String("Q29udG9zbwAAA"))

次に、パディング ルールについてです。 パディング文字は "=" です。 埋め込み文字はハッシュの末尾にのみ指定できます。最大 2 つのパディング文字しか使用できません。 基本的なロジックを次に示します。

  • ハッシュのデコードが失敗しますか?
  • はい: 最後の 2 文字は "="ですか?
    • はい: 両方の "=" を単一の "A" 文字に置き換え、もう一度やり直してください
    • いいえ: 最後に別の "=" 文字を追加してから、もう一度やり直してください
  • いいえ: そのハッシュは有効です

前の例のハッシュで上記のロジックをループすると、次の変換が取得されます。

  • Q29udG9zbwAAA
  • Q29udG9zbwAAA=
  • Q29udG9zbwAAA==
  • Q29udG9zbwAAAA
  • Q29udG9zbwAAAAAA=
  • Q29udG9zbwAAAA== (この 1 つは有効なパディングを持っています)

収集したハッシュをこの新しい埋め込みハッシュに置き換え、もう一度インポートを試みます。

Intune 登録の問題

Intune 登録の問題に関するサポートについては 、このサポート技術情報の記事を参照してください。 一般的な問題には、次のようなものがあります。

  • ユーザーに割り当てられているライセンスが正しくないか不足しています。
  • ユーザーに登録されているデバイスが多すぎます。

エラー コード80180018通常、"何か問題が発生しました" というタイトルのエラー ページで報告されます。 このエラーは、MDM 登録が失敗したという意味です。

Autopilot Reset がエラーですぐに失敗した場合 、問題が発生しました。管理者アカウントでサインインして、 理由を確認し、手動でリセットする方法については、「 Autopilot Reset のトラブルシューティング」を参照してください。

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