クエリ、フォーム、またはレポートを実行すると、[パラメーター値の入力] ダイアログ ボックスが表示されます。

注意

Office 365 用リソース は、 エンタープライズ向け Microsoft 365 アプリに名前変更されています。 この変更の詳細については、 このブログの投稿を参照してください。

中程度: 基本的なマクロ、コーディング、相互運用性のスキルが必要です。

この記事は、Microsoft Access データベース (.mdb) にのみ適用されます。

現象

クエリ、フォーム、またはレポートを実行しようとすると、[パラメーター値の入力] ダイアログ ボックスが予期せず表示される場合があります。

原因

この動作は、クエリ、フォーム、またはレポート内のフィールド、条件、式、またはコントロールが Access で見つけきできない名前を参照している場合に発生します。 たとえば、名前のスペルが間違っている場合や、フィールドをそのスコープ内で使用できない場合があります。

解決方法

この動作を解決するには、参照の名前を有効なフィールド名に変更します。 参照の場所が分からない場合は、[パラメーター値の入力] ダイアログ ボックスに表示されているオブジェクトのデータベース ドキュメントを実行し、その情報をテキスト ファイルに出力します。 そのために、以下の手順に従ってください。

  • Access 2002 および 2003 を使用する場合は、次の手順を実行します。
    1. [ツール]メニューの[分析] を ポイントし**、[Documenter] をクリックします**。

    2. 検索するデータベース オブジェクトの種類に対応するタブをクリックし、クエリ、フォーム、または実行しようとしたレポートのチェック ボックスをオンにします。

      メモ オブジェクトがフォームまたはレポートの場合は、すべてのソース クエリとサブフォームまたはサブレポートを選択リストに含める必要があります。

    3. [ オプション] をクリックして、印刷する選択したオブジェクトの機能を指定し 、[OK] をクリックします

    4. [OK] を クリックして、[ドキュメント作成] ダイアログ ボックス を閉じます。

    5. [ファイル] メニューの [ エクスポート] を クリックします

    6. [名前を 付けて保存] の 一覧で、[テキスト ファイル] をクリック し、必要に応じて残りの情報を入力します。

    7. エクスポートしたファイルを [パラメーターの値Microsoft Word入力] ダイアログ ボックスで、要求されたパラメーター 検索します。

  • Access 2007 以降のバージョンを使用する場合は、次の手順を実行します。
    1. [データベース ツール ] タブで 、[分析] グループの [データベース ドキュメント] をクリック します。

    2. 検索するデータベース オブジェクトの種類に対応するタブをクリックし、クエリ、フォーム、または実行しようとしたレポートのチェック ボックスをオンにします。

      メモ オブジェクトがフォームまたはレポートの場合は、すべてのソース クエリとサブフォームまたはサブレポートを選択リストに含める必要があります。

    3. [ オプション] をクリックして、印刷する選択したオブジェクトの機能を指定し 、[OK] をクリックします

    4. [OK] を クリックして、[ドキュメント作成] ダイアログ ボックス を閉じます。

    5. [ データ] グループで、[テキスト ファイル] をクリック し、必要に応じて残りの情報を入力します。

    6. エクスポートしたファイルを [パラメーターの値Microsoft Word入力] ダイアログ ボックスで、要求されたパラメーター 検索します。

データベース ドキュメント を実行できない場合は、参照が見つからないか確認してください。 この場合、最も一般的な不足している参照は Utility.mda です。 この参照を確認するには、次の手順を実行します。

  1. [データベース] ウィンドウで、[オブジェクト] の 下の [モジュール] を****クリックします

    メモ Access 2007 以降のバージョンを使用する場合は、[データベース ツール] タブで 、[データベース ツール] Visual Basicをクリック し、手順 3 に進みます。

  2. 既存のモジュールを選択し、[デザイン] をクリックするか、新しいモジュールを挿入します。 これにより、エディターのVisual Basicされます。

  3. [ツール] メニューの [参照設定] をクリックします。

  4. [使用可能な参照] リストで、名前の前に "MISSING:" が含まれる参照を探します。 チェック ボックスをオフにします。

    メモ Utility.mda への参照が必要ない場合は、手順 8 に進みます。

  5. [参照] をクリックします。

  6. [種類のファイル] ボックスの一覧で、[アドイン] (*.mda) をクリックします。

  7. Utility.mda を含むフォルダーを参照して選択し、[開く] をクリックします。 既定では、このファイルはフォルダー C:\Program Files\Microsoft Office\Office\1033 にあります。

  8. [OK] をクリックします。

  9. [デバッグ] メニューの [データベース名のコンパイル] をクリックします

  10. [ファイル] メニューの [閉じる] をクリックし、[Microsoft Access に戻る] をクリックします

詳細情報

Access 2002 または Access 2003 での動作を再現する手順

注意事項

この例の手順に従う場合は、サンプル データベース Northwind.mdb を変更します。 Northwind.mdb ファイルをバックアップし、データベースのコピーで次の手順を実行できます。

  1. サンプル データベース Northwind.mdb を開きます。
  2. デザイン ビューで Order Subtotals クエリ を開きます
  3. OrderID フィールド の名前を OrderIDNumber に変更します
  4. クエリを閉じ、[はい] をクリックして変更を保存します。
  5. Order Subtotals クエリを実行します。

[パラメーター値の入力] ダイアログ ボックスが表示されます。