"エラー 1919。 Office 用セットアップ プログラムを実行するときに ODBC データ ソースの構成中にエラーが発生しました
現象
[適用対象] セクションに記載されているプログラムのいずれかに対してセットアップ プログラムを実行すると、次のエラー メッセージが表示される場合があります。
エラー 1919。 ODBC データ ソースの構成中にエラーが発生しました: MS Access Database。 ODBC エラー 6: コンポーネントがレジストリに見つかりません。 ファイル MS Access Database が存在し、それにアクセスできることを確認します。
[無視] を選択すると、次のエラー メッセージが表示されることがあります。
エラー 1919。 ODBC データ ソースの構成中にエラーが発生しました: Excel Files。 ODBC エラー 0: ファイル Excel Files が存在し、ファイルにアクセスできることを確認します。
次のいずれかのエラー メッセージが表示される場合もあります。
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エラー 1919。 ODBC データ ソースの構成中にエラーが発生しました: MS Access Database。 ODBC エラー 0: ファイル MS Access Database が存在し、それにアクセスできることを確認します。
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エラー 1919。 ODBC データ ソースの構成中にエラーが発生しました: Visual FoxPro Database。 ODBC エラー 0: Visual FoxPro Database ファイルが存在し、それにアクセスできることを確認します。
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エラー 1919。 ODBC データ ソースの構成中にエラーが発生しました: Visual FoxPro Tables。 ODBC エラー 0: Visual FoxPro Tables ファイルが存在し、それにアクセスできることを確認します。
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エラー 1919。 ODBC データ ソースの構成中にエラーが発生しました: dBASE ファイル。 ODBC エラー 6: ファイル dBASE Files が存在し、それにアクセスできることを確認します。
原因
これらの問題は、Windows レジストリに一部のレジストリ キーがない場合に発生する可能性があります。
解決方法
この問題を解決するには、不足しているレジストリ キーを置き換えます。 それには、以下のいずれかの方法を使用します。
方法 1: MDAC 2.8 をインストールする
インストールと削除の手順など、MDAC 2.8 の詳細については、「 Microsoft Data Access Components (MDAC) インストール」を参照してください。
MDAC 2.8 をインストールしたら、コンピューターを再起動し、管理者の資格情報でログオンする必要があります。
注:
MDAC 2.8 は、Microsoft Windows XP Service Pack 2 (SP2) をインストールするときにもインストールされます。 オペレーティング システムが Windows XP の場合は、前の手順に従う代わりに Windows XP SP2 をインストールすることもできます。
方法 2: Mdac.inf ファイルを使用してレジストリ キーをリセットする
Mdac.inf を使用してレジストリ キーをリセットします。 このプログラムでは、Windows CD で新しいファイルを取得するように求められる場合があります。
お使いのオペレーティング システムと Windows CD をお持ちの場合は、次のいずれかの操作を行います。
Microsoft Windows XP および Microsoft Windows Server 2003 のリテール エディションの場合
[ スタート] をクリックし、[ 実行] をクリックし、[ 開く ] ボックスに「path\inf」と入力し、[OK] をクリック します。
この例では、path は Windows フォルダーのパスです。 たとえば、「C:\Windows\Inf」または「C:\Winnt」と入力します。 既定では、C:\Windows は Windows XP がインストールされているフォルダーです。C:\Winnt は、Windows 2000 を Windows XP にアップグレードした場合に Windows XP がインストールされているフォルダーです。
[ ツール ] メニューの [ フォルダー オプション] をクリックします。
[ 表示 ] タブの [ 詳細設定 ] ボックスで、[ 非表示のファイルとフォルダーを表示する] をクリックし、[OK] をクリック します。
Mdac.inf を右クリックし、[インストール] をクリックします。
Windows CD の入力を求められたら、CD-ROM ドライブまたは DVD-ROM ドライブに Windows CD を挿入します。
ハード ディスク上の I386 フォルダー (通常は C:\I386) をクリックし、[OK] をクリック します。
I386 フォルダーが Windows フォルダーのサブフォルダーである場合、一部のコンピューターでは選択できません。 この場合は、[ ファイルのコピー元 ] ボックスに完全なパスを入力し (たとえば、「C:\Windows\I386」または「C:\Winnt\I386」と入力)、[OK] をクリック します。
コンピューターを再起動します。
Windows XP のオリジナル機器メーカー (OEM) エディションの場合
重要
このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。
手順 1: レジストリ キーを変更する
ハード ディスク上の I386 フォルダーを見つけて、そのパスを書き留めます。
[スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。
[名前] ボックスに「regedit」と入力し、[OK] をクリックします。
[レジストリ] エディターで、次のキーを見つけてクリックします。
HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Setup
[インストール ソース] エントリを右クリックし、[変更] をクリックします。
[ 値データ ] ボックスで、ハード ディスク上の I386 フォルダーのパスに値を変更し、[OK] をクリック します。
次のエントリごとに手順 5 と 6 を繰り返します。
- SourcePath
- ServicePackSourcePath
レジストリ エディターを終了します。
手順 2: Mdac.inf をインストールする
[ スタート] をクリックし、[ 実行] をクリックし、[ 開く ] ボックスに「C:\Winnt\Inf」と入力し、[OK] をクリック します。
[ ツール ] メニューの [ フォルダー オプション] をクリックします。
[詳細設定] ボックスの [表示] タブで、[非表示のファイルとフォルダーを表示する] をクリックし、[OK] をクリックします。
Mdac.inf を右クリックし、[インストール] をクリックします。
Windows CD の入力を求められたら、CD-ROM ドライブまたは DVD-ROM ドライブに Windows CD を挿入します。
ハード ディスク上の I386 フォルダー (通常は C:\I386) をクリックし、[OK] をクリック します。
注:
- 現在の Windows インストール用の CD がない場合は、[ 参照] をクリックし、 I386 フォルダーを見つけて選択します。
- I386 フォルダーが Windows フォルダーのサブフォルダーである場合、一部のコンピューターでは選択できません。 この場合は、[ ファイルのコピー元 ] ボックスに完全なパスを入力し (たとえば、「C:\Windows\I386」または「C:\Winnt\I386」と入力)、[OK] をクリック します。
コンピューターを再起動します。
方法 3: ネットワーク上の別のコンピューターからレジストリ キーをインポートする
メモ 別のコンピューターからレジストリ キーをインポートする場合は、ソース コンピューターと移行先コンピューターで同じオペレーティング システムが実行されていることを確認します。 たとえば、Windows XP を実行しているコンピューターでこのメソッドを使用している場合は、レジストリ キーのエクスポートに使用できる Windows XP を実行するコンピューターを見つけます。
重要
このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 レジストリを変更する際には十分に注意してください。 保護を強化するため、レジストリを変更する前にレジストリをバックアップします。 こうしておけば、問題が発生した場合にレジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。
パート 1: "ソース" コンピューターのレジストリからキーをエクスポートする
キーが見つからないコンピューター ("ソース" コンピューター) で、[ スタート] をクリックし、[ 実行] をクリックし、[ 開く ] ボックスに「regedit」と入力し、[OK] をクリック します。
次のレジストリ キーを見つけてクリックします。
HKEY_CURRENT_USER\Software\ODBC
[ ファイル ] メニューの [ エクスポート] をクリックします。
[保存場所] ボックス で 、登録ファイル (.reg ファイル) を一時的に保存する場所を指定します。
[ ファイル名 ] ボックスにファイル名を入力し、[ 保存] をクリックします。
次のキーを見つけてクリックします。
HKEY_LOCAL_MACHINE\Software\ODBC
手順 4 と 5 を繰り返して、このキーをエクスポートします。
パート 2: "移行先" コンピューターのレジストリにキーをインポートする
- エクスポートした.reg ファイルをソース コンピューターから、キー ("宛先" コンピューター) が見つからないコンピューター上の一時的な場所にコピーします。
- [スタート] をクリックし、[実行] をクリックし、[開く] ボックスに「」と入力
regedit
し、[OK] をクリックします。 - [レジストリ] メニュー の [ レジストリ ファイルのインポート] をクリックします。
- 手順 1 でコピーした.reg ファイルのいずれかを見つけてクリックし、[ 開く] をクリックします。
- もう一方の.reg ファイルに対して手順 4 と 5 を繰り返します。
回避策
この問題を回避するには、これらのエラー メッセージを受け取ったときに [再試行 ] を数回クリックします。 ただし、この回避策は長期的には機能しない可能性があります。
フィードバック
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