PowerPoint で破損したプレゼンテーションのトラブルシューティングを行う方法

注意

Office 365 用リソース は、 エンタープライズ向け Microsoft 365 アプリに名前変更されています。 この変更の詳細については、 このブログの投稿を参照してください。

概要

Microsoft PowerPoint プレゼンテーションで作業をする場合、予期しない動作が発生することがあります。 この動作はプレゼンテーションが破損している場合に発生することがあります。 この資料では、プレゼンテーションを一部または完全に復元するのに役立つ方法について、手順を追って説明します。

この資料は初級レベルから中級レベルのコンピューター ユーザーを対象にしています。 この資料を最初に印刷しておくと、手順を実行しやすい場合があります。

現象

破損したプレゼンテーションを開くか変更しようとすると、次の現象が発生することがあります。

  • プレゼンテーションを開くときに、次のいずれかのエラー メッセージが表示される。

    This is not a PowerPoint Presentation (これは PowerPoint プレゼンテーションではありません)

    PowerPoint cannot open the type of file represented by <file_name>.ppt (PowerPoint は、.ppt で表示されるファイルの種類を開けません)

    Part of the file is missing. (ファイルの一部が失われています。)

  • 次のようなエラー メッセージが表示されます。

    一般保護エラー

    無効な命令

    ページ違反

    システム リソースが不足しています

    メモリ不足です

詳細情報

プレゼンテーションが破損されているかどうかを確認する方法

プレゼンテーションが破損されているかどうかを確認するには、いつかの方法があります。 PowerPoint がインストールされた別のコンピューターでファイルを開き、他のコンピューターで予期しない動作が発生するかどうか確認します。 PowerPoint で新しいファイルを作成して、新しいファイルで予期しない動作が発生するかどうかを確認します。 このセクションでは、既存のプレゼンテーションを使用する方法、および PowerPoint で新しいファイルを作成して、プレゼンテーションで同様の動作が発生するかどうかを確認します。

方法 1: 既存のプレゼンテーションを開きます

  1. [ファイル] メニューの [開く] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択します。
  2. 別のプレゼンテーションを選択してから、[開く] を選択します。

このプレゼンテーションが表示され、破損されていないようであれば、このセクションの方法 3 に進みます。 それ以外の場合は、方法 2 に進み、新しいプレゼンテーションを作成します。

方法 2: 新しいプレゼンテーションを作成する

手順 1: プレゼンテーションを作成する
  1. [ファイル] メニューの [新規] を選択してから、[PowerPoint へようこそ] (または PowerPoint 2010 のご紹介) を選択します。
    • PowerPoint 2007 では、[インストールされているテンプレート] を選択してから、[PowerPoint 2007 のご紹介] を選択します。
  2. [作成] を選択します。 このプロセスでは、テンプレートに基づいてプレゼンテーションを作成します。
  3. [ファイル] メニューの [名前を付けて保存] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択してから、[名前を付けて保存] を選択します。
  4. プレゼンテーションの名前を入力し、[保存] を選択します。
  5. PowerPoint を終了します。
手順 2: 新しいプレゼンテーションを開きます。
  1. [ファイル] メニューの [開く] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択してから、[開く] を選択します。
  2. 新しいプレゼンテーションを選択してから、[開く] を選択します。

新しいプレゼンテーションを開くか保存できない場合は、方法 3 に進みます。

新しいプレゼンテーションを作成できない場合は、PowerPoint が破損している可能性があるため、修復を開始する必要があります。 (以下の方法 3、パート 2 を参照してください。)

方法 3: 一般的なトラブルシューティング

Windows 10、Windows 8.1、Windows 8、および Windows 7

パート 1

この手順を実行すると、スタートアップ アドオンを使用せずにコンピューターを再起動できます。 クリーン リスタートを実行するには、次の手順を実行します。

  1. 管理者権限を持つアカウントを使用して、コンピューターにログオンします。

  2. [スタート] ボタンを選択し、[検索の開始] ボックスに「msconfig.exe」と入力してから、Enter キーを押して、システム構成ユーティリティを起動します。

    注意

    管理者のパスワードを要求するダイアログ ボックスが表示された場合はパスワードを入力して [OK] をクリックし、確認を要求するダイアログ ボックスが表示された場合は [続行] をクリックします。

  3. [全般] タブで、[スタートアップのオプションを選択] を選択してから、[スタートアップの項目を読み込む] チェック ボックスをオフにします。 ([元の BOOT.INI を使う] チェック ボックスは使用できません)。

  4. [サービス] タブで、[Microsoft のサービスをすべて隠す] チェック ボックスをオンにしてから、[すべて無効] を選択します。

    注意

    この手順では、マイクロソフトのサービスを引き続き実行できます。 クリーン リスタートを実行後、Office パフォーマンスを確認して、通常のスタートアップを再開します。

パート 2

この手順を実行すると、Office プログラムで問題がチェックされ、修復されます。

  1. [スタート] ボタンを選択し、「コントロール パネル」と入力します。

  2. コントロール パネルを開き、[プログラムのアンインストールまたは変更] (または [プログラムの追加と削除]) に移動します。

  3. プログラムの一覧をスクロールして、Microsoft Office のバージョンを確認します。 右クリックしてから、[変更] を選択します。

    注意

    オンライン修復オプションを実行することをお勧めします。

プレゼンテーションを開けない場合に試す方法

方法 1: プレゼンテーションを PowerPoint プログラム ファイル アイコンにドラッグする

Windows 10、Windows 8.1、および Windows 8
  1. タスクバーで Windows アイコンを右クリックしてから、[実行] を選択します。

  2. PowerPoint のバージョンに応じて、次のいずれかを入力します。

    %ProgramFiles%\Microsoft Office
    %ProgramFiles(x86)%\Microsoft Office
    
  3. Enter キーを選択します。

  4. エクスプローラーで、 Powerpnt.exe アイコンを探します。

  5. 破損したプレゼンテーション アイコンを、別のウィンドウの Powerpnt.exe アイコンに移動します。

PowerPoint で対象のプレゼンテーションを開いてみます。 PowerPoint でプレゼンテーションが開かない合は、方法 2 に進みます。

Windows 7
  1. [スタート] を選択してから、[ドキュメント] を選択します。 または、[スタート] を選択してから、[エクスプローラー] を検索します。

  2. PowerPoint 2013 の MSI バージョンをインストールしている場合は、「%ProgramFiles%\Microsoft Office\office15」(PowerPoint 2013 64 ビット版) または「%ProgramFiles(x86)%\Microsoft Office\office15」(PowerPoint 2013 32 ビット版) と入力してから、Enter キーを押します。

    PowerPoint 2013 の Select-to-Run をインストールしている場合は、「C:\Program Files\Microsoft Office 15\root\office15」(PowerPoint 2013 64 ビット版) または「C:\Program Files(x86)\Microsoft Office 15\root\office15」(PowerPoint 2013 32 ビット版) と入力してから、Enter キーを押します。

    PowerPoint 2016 の MSI バージョンをインストールしている場合は、「%ProgramFiles(x86)%\Microsoft Office\office16」と入力してから、Enter キーを押します。

    PowerPoint 2016 の Select-to-Run をインストールしている場合は、「%ProgramFiles%\Microsoft Office\root\Office16」(PowerPoint 2016 64 ビット版) または「%ProgramFiles(x86)%\Microsoft Office\root\Office16」(PowerPoint 2016 32 ビット版) と入力してから、Enter キーを押します。

  3. エクスプローラーで、 Powerpnt.exe アイコンを探します。

  4. 破損したプレゼンテーション アイコンを、別のウィンドウの Powerpnt.exe アイコンに移動します。

方法 2: 新しいプレゼンテーションにスライドを挿入する

手順 1: 新しいプレゼンテーションを作成する
  1. [ファイル] メニューで、[新規] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] をクリックしてから、[新規作成] をクリックします。
  2. [新しいプレゼンテーション] を選択してから、[作成] を選択します。

このプロセスでは、空白タイトルのスライドを作成します。 プレゼンテーションを再作成したら、このスライドは削除できます。

手順 2: 破損したプレゼンテーションをスライドとして挿入する
  1. [ホーム] タブで、[スライド] グループ内の [新しいスライド] の横にある矢印を選択してから、[スライドの再利用] を選択します。
  2. [スライドの再利用] 作業ウィンドウで、[参照] を選択します。 破損したプレゼンテーションを選択してから、[開く] を選択します。
  3. 破損したプレゼンテーションの各スライドに対して、[スライドの挿入] を選択します。
  4. [ファイル] メニューの [名前を付けて保存] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] をクリックしてから、[名前を付けて保存] をクリックします。
  5. プレゼンテーションの新しい名前を入力してから、[保存] を選択します。
手順 3: 破損したプレゼンテーションをテンプレートとして適用する

これらの手順を試した後、プレゼンテーションが期待どおりに表示されない場合は、破損したプレゼンテーションをテンプレートとして適用してみます。 これを行うには、次の手順を実行します。

  1. [ファイル] メニューの [名前を付けて保存] を選択します。

    • PowerPoint 2007 では、[Microsoft Office ボタン] をクリックしてから、[名前を付けて保存] をクリックします。
  2. プレゼンテーションの新しい名前を入力してから、[保存] を選択します。

    注意

    この操作により、復元されたプレゼンテーションのバックアップ コピーが作成されるので、破損したプレゼンテーションが新しいプレゼンテーションを破損した場合でも、このコピーを使えます。。

  3. [デザイン] タブで、[テーマ] グループにある [詳細] を選択してから、[テーマの参照] を選択します。

  4. 破損したプレゼンテーションを選択してから、[適用] を選択します。 破損したプレゼンテーションのスライド マスタが新規のスライド マスタと置き換わります。

注意

この手順を実行した後で予期しない動作が発生した場合は、テンプレートがプレゼンテーションを破損した可能性があります。 この場合、バックアップ コピーを使用して、マスター スライドを再作成します。

新しいプレゼンテーションのバックアップ コピーが、元のプレゼンテーションと同じ破損または正常ではない動作を示す場合は、方法 3 に進みます。

方法 3: プレゼンテーションの一時ファイルを開く

プレゼンテーションを編集する場合、PowerPoint はファイルの一時コピーを作成します。 この一時ファイルには、PPT ####.tmp という名前が付きます。

注意

プレースホルダー #### には、無作為な数字 4 桁が指定されます。

この一時ファイルは、プレゼンテーションが保存されている同じフォルダー内に保存される可能性があります。 または、一時ファイル フォルダーに保存されます。

ファイルの名前を変更してから、そのファイルを PowerPoint で開きます。
  1. ファイルを右クリックし、[名前の変更] を選択します。

  2. 元のファイル名の拡張子を .tmp から .pptx に変更します。これにより、ファイル名は次のようになります。

    PPT ####.pptx

  3. PowerPoint を起動します。

  4. [ファイル] メニューの [開く] を選択します。

  5. 名前を変更したファイルが保存されているフォルダーを開きます。

  6. このファイルを PowerPoint で開きます。

注意

プレゼンテーションを最後に保存したときに作成された一時ファイルに、2 つ以上のファイルが該当する場合があります。 この場合、各ファイルを開き、一時コピーのプレゼンテーションかどうかの確認が必要となる場合があります。

一時ファイルがない場合、または一時ファイルが同じ種類の破損または正常ではない動作を示す場合は、方法 4 に進みます。

方法 4: 破損したプレゼンテーションのコピーを作成する

  1. プレゼンテーションを右クリックし、[コピー] を選択します。
  2. エクスプローラー ウィンドウで、空白のスペースを右クリックしてから、[貼り付け] を選択します。

ファイルをコピーできない場合、ファイルが破損しているか、コンピューターのハードディスクの破損している箇所に保存されている可能性があります。 この場合は、方法 5 に進みます。

ファイルをコピーできる場合、PowerPoint で、破損したプレゼンテーションのコピーを開きます。 破損したプレゼンテーションのコピーを開けない場合は、破損したプレゼンテーションのコピーを使用して、「プレゼンテーションを開けない場合に試す方法」セクションの、方法 1 から方法 5 まで繰り返します。

方法 5: ハード ディスク ドライブでエラー チェックを実行する

Windows 10、Windows 8.1、および Windows 8
  1. 起動しているすべてのプログラムを終了します。
  2. [スタート] メニューを右クリックし、[エクスプローラー] を選択します。
  3. 破損しているプレゼンテーションが含まれるハード ディスク ドライブを右クリックします。
  4. [プロパティ] を選択してから、[ツール] タブを選択します。
  5. [エラー チェック] で、 [今すぐチェック] を選択します。
  6. [ファイル システム エラーを自動的に修復する] チェック ボックスをオンにします。
  7. [不良セクターをスキャンし、回復する] チェック ボックスをオンにします。
  8. [開始] を選択します。
Windows 7
  1. 起動しているすべてのプログラムを終了します。
  2. [スタート] を選択してから、[コンピューター] を選択します。
  3. 破損しているプレゼンテーションが含まれるハード ディスク ドライブを右クリックします。
  4. [プロパティ] を選択してから、[ツール] タブを選択します。
  5. [エラー チェック] で、 [今すぐチェック] を選択します。
  6. [ファイル システム エラーを自動的に修復する] チェック ボックスをオンにします。
  7. [不良セクターをスキャンし、回復する] チェック ボックスをオンにします。
  8. [開始] を選択します。

注意

エラー チェックは、プレゼンテーションが相互リンクされていることを確認して、修復することができます。 ただし、プレゼンテーションは PowerPoint で読み取れることを保証するものではありません。

破損したプレゼンテーションが開けるか確認する方法

方法 1: 破損したプレゼンテーションをテンプレートとして適用する

手順 1: 新しいプレゼンテーションを作成する
  1. [ファイル] メニューの [新規] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択してから、[新規作成] を選択します。
  2. [新しいプレゼンテーション] を選択してから、[作成] を選択します。 このプロセスでは、空白タイトルのスライドを作成します。 (プレゼンテーションを再作成したら、このスライドは削除できます)。
手順 2: 新しいプレゼンテーションに破損したプレゼンテーションを挿入する
  1. [ホーム] タブで、[スライド] グループ内の [新しいスライド] の横にある矢印を選択してから、[スライドの再利用] を選択します。
  2. [スライドの再利用] 作業ウィンドウで、[参照] を選択します。
  3. 破損したプレゼンテーションを選択してから、[開く] を選択します。
  4. 破損したプレゼンテーションの各スライドに対して、[スライドの挿入] を選択します。
  5. [Microsoft Office] ボタンを選択してから、[名前を付けて保存] を選択します。
  6. プレゼンテーションの新しい名前を入力してから、[保存] を選択します。
手順 3: 破損したプレゼンテーションをテンプレートとして適用する

これらの手順に沿って実行した後、プレゼンテーションが期待どおりに表示されない場合は、破損したプレゼンテーションをテンプレートとして適用してみます。 これを行うには、次の手順を実行します。

  1. [ファイル] メニューの [名前を付けて保存] を選択します。
  • PowerPoint 2007 では、[Microsoft Office ボタン] を選択してから、[名前を付けて保存] を選択します。
  1. プレゼンテーションの新しい名前を入力し、[保存] をクリックします。

    注意

    この操作により、復元されたプレゼンテーションのバックアップ コピーが作成されるので、破損したプレゼンテーションが新しいプレゼンテーションを破損した場合でも、このコピーを使えます。。

  2. [デザイン] タブで、[テーマ] グループにある [詳細] を選択してから、[テーマの参照] を選択します。

  3. 破損したプレゼンテーションを選択してから、[適用] を選択します。 破損したプレゼンテーションのスライド マスタが新規のスライド マスタと置き換わります。

注意

この手順を実行した後で予期しない動作が発生した場合は、テンプレートがプレゼンテーションを破損した可能性があります。 この場合、バックアップ コピーを使用して、マスター スライドを再作成します。

新しいプレゼンテーションのバックアップ コピーが、引き続き破損または正常ではない動作を示す場合は、方法 2 に進みます。

方法 2: 破損したプレゼンテーションを空白のプレゼンテーションにスライドをコピーする

手順 1: 新しいプレゼンテーションを作成する
  1. PowerPoint の [ファイル] メニューで、[開く] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択してから、[開く] を選択します。
  2. 破損したプレゼンテーションを探してから、[開く] を選択します。
  3. PowerPoint の [ファイル] メニューで、[開く] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択してから、[新規作成] を選択します。
  4. [新しいプレゼンテーション] を選択してから、[作成] を選択します。 このプロセスでは、空白タイトルのスライドを作成します。
手順 2: 破損したプレゼンテーションから空白のプレゼンテーションにスライドをコピーする
  1. [表示] タブで、[スライド一覧] を選択します。 表示を切り替えるときにエラー メッセージが表示される場合は、アウトライン表示を使います。

  2. コピーするスライドを選択します。 [ホーム] タブで、[コピー] を選択します。

    注意

    複数のスライドをまとめてコピーする場合は、Shift キーを押したままコピーする各スライドを選択します。

  3. 新規のプレゼンテーションに切り替えます。 これを行うには、[表示] グループの [ウィンドウ] タブで、 [ウィンドウの切り替え] を選択してから、手順 1 で作成した新しいプレゼンテーションを選択します。

  4. [表示] タブで、[スライド一覧] を選択します。

  5. [ホーム] タブで、[貼り付け] を選択します。

  6. 手順 2a ~ 2f を繰り返してプレゼンテーションのコピーを完了します。

注意

一部のケースでは、1 つの破損したスライドが、プレゼンテーション全体に問題を引き起こす可能性があります。 スライドをプレゼンテーションにコピーした後、新しいプレゼンテーションで予期しない動作が発生した場合は、スライドが破損している可能性があります。 スライドを再作成するか、スライドの一部分を新しいスライドにコピーしてください。

新しいプレゼンテーションが、破損または正常ではない動作を示す場合は、方法 3 に進んでください。

方法 3: プレゼンテーションを RTF (リッチ テキスト形式) ファイルで保存する

プレゼンテーション全体で破損がある場合、プレゼンテーションを回復する唯一の方法は、プレゼンテーションを RTF (リッチ テキスト形式) ファイルで保存することです。 この方法が成功すると、アウトライン表示でテキストのみが回復されます。

手順 1: プレゼンテーションを RTF ファイル形式で保存する
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [名前を付けて保存] を選択し、ファイルを保存する場所を選択してから、[その他のオプション] を選択します。
    • PowerPoint 2007 では、[Microsoft Office ボタン] を選択し、[名前を付けて保存] を選択してから、[その他の形式] を選択します。
  3. [ファイルの種類] 一覧で、[アウトライン/リッチ テキスト形式 (*.rtf)] を選択します。
  4. [ファイル名] ボックスに使用する名前を入力し、プレゼンテーションを保存する場所を選択してから、[保存] を選択します。
  5. プレゼンテーションを閉じます。

注意

元のプレゼンテーションのグラフィック、表、その他のテキストは、.rtf ファイルでは保存されません。

手順 2: PowerPoint で .rtf ファイルを開く
  1. [ファイル] メニューの [開く] を選択します。
  2. [ファイルの種類] 一覧で、[すべてのアウトライン] または [すべてのファイル] を選択します。
  3. 手順 1d で保存した .rtf ファイルを選択してから、[開く] を選択します。

この手順により、元のプレゼンテーションのアウトライン ビューに基づいてプレゼンテーションが作成されます。