Word で文書が破損している場合のトラブルシューティング方法

注意

Office 365 用リソース は、 エンタープライズ向け Microsoft 365 アプリに名前変更されています。 この変更の詳細については、 このブログの投稿を参照してください。

概要

この記事では、Word 2007 以降のバージョンで文書が破損していることを確認する方法について説明します。 また、この資料では、破損している文書を特定した後で、文書に含まれていたテキストとデータを回復する手順についても説明します。

この資料は初級レベルから中級レベルのコンピューター ユーザーを対象にしています。 この資料を最初に印刷しておくと、手順を実行しやすい場合があります。

Microsoft OfficeおよびWindowsの更新

ソフトウェアの問題の多くは、Microsoft OfficeおよびWindowsプログラムを更新することで解決できます。

Windows Update に関する FAQ

Office の更新プログラムのインストール

Microsoft Update で Office を更新する

破損した文書またはソフトウェアの問題が発生しましたか?

Word文書は、いくつかの理由により破損し開くことができなくなります。 この現象は文書または文書のベース テンプレートの破損が原因で発生する場合があります。 この現象には以下のものが含まれます。

  • 文書内の既存のページの番号が繰り返し変更される。
  • 文書で改ページが繰り返し行われる。
  • 文書レイアウトや書式設定が正しくない。
  • 画面に判読不可能な文字が表示される。
  • 処理中にエラー メッセージが表示される。
  • ファイルを開くとコンピューターが応答を停止する。
  • その他、プログラムの標準的な動作とは考えられない異常な現象が発生する。

場合によっては、文書の破損以外の要因で発生する現象もあります。 文書が破損しているか、または問題がソフトウェアの問題であるかどうかを判断することが重要です。 文書の破損以外の要因を排除するには、次の手順を実行します。

  1. 他の文書で同様の現象が発生するかどうかを調べます。 他のWord文書を開いて、同じ問題が発生するかを確認します。 正常に開いた場合は、問題がWord文書である可能性があります。
  2. 他の Microsoft Office プログラムで同様の現象が発生するかどうかを調べます。 同じ問題が発生した場合は、別のアプリケーションまたはオペレーティングシステムに問題がある可能性があります。

これらの手順のいずれかを実行して文書に問題があるわけではないことが示された場合は、Word、Office スイート、またはコンピューターで実行しているオペレーティング システムのトラブルシューティングを行う必要があります。

破損した文書を開けない場合に試すトラブルシューティング手順

指定された順番でトラブルシューティングを試してください。 1 つのトラブルシューティンを実行しても解決しない場合は、次のトラブルシューティン手順を試します。

手順 1: Word を構成する

  1. Word を起動します。
  2. [表示] タブで、[グループの表示] の [下書き] を選択します。
  3. [ファイル メニュー] を選択して、[オプション]、[詳細設定] の順にクリックします。
  4. [ドキュメント コンテンツの表示] セクションの [下書き表示およびアウトライン表示で下書きフォントを使用する] と [図をイメージ枠で表示する] を選択します。
  5. [全般 ] セクションまでスクロールダウンし、[ 起動時に自動リンクを更新する] のチェックボックスをオフにし、[OK] を選択して、Word を閉じます。

手順 2: 破損した文書を開く

  1. Word を起動します。
  2. [File]メニューを選択し、[ Open]を選択します。
  3. 破損した文書を選択し、[開く] を選択します。

文書を開くことができる場合、文書を閉じ、方法 6 に従ってもう一度開き、文書を修復します。 そうでない場合は、手順 2. に進みます。

方法 2: 文書をファイルとして新しい文書に挿入する

手順 1: 新しい白紙の文書を作成する

  1. [ファイルメニュー] を選択し、[新規] を選択します。
  2. [白紙の文書] を選択し、[作成] を選択します。

手順 2: 破損した文書を新しい文書に挿入する

  1. [挿入] タブの [オブジェクトの挿入] を選択し、[ファイルからテキストを挿入] を選択します。

  2. [ファイルの挿入] ダイアログ ボックスで破損した文書を検索して選択します。 次に、[挿入]を選択します。

    注意

    新しく作成した文書では、最後のセクションで一部の書式の再設定が必要な場合があります。

手順 1: 白紙の文書を作成する

  1. Word で、[ファイルメニュー] を選択し、[新規作成] を選択します。
  2. [白紙の文書] を選択し、[作成] を選択します。
  3. 新しい文書に「これはテストです」と入力します。
  4. [ファイルメニュー]を選択し、[保存]を選択します。
  5. 「リンク救出」と入力し、[保存] を選択します。
  1. 手順 1-3 で入力したテキストを選択します。
  2. [ホーム] タブの [クリップボード] にある [コピー] を選択します。
  3. [ファイルメニュー] を選択し、[新規] を選択します。
  4. [白紙の文書] を選択し、[作成] を選択します。
  5. [ホーム] タブの [クリップボード] グループにある [貼り付け] の矢印ボタンを選択し、[形式を選択して貼り付け] を選択します。
  6. [リンク貼り付け] を選択し、[リッチ テキスト形式 (RTF)] を選択します。
  7. [OK] を選択します。
  1. 文書内のリンクされたテキストを右クリックし、[リンクされた Word 文書オブジェクト] をポイントして、[リンクの設定] を選択します。

  2. [リンクの設定] ダイアログ ボックスで、リンクする文書のファイル名を選択し、[リンク元の変更] を選択します。

  3. [リンク元の変更] ダイアログ ボックスで、開けない文書を選択し、[開く] を選択します。

  4. [OK] を選択して [リンクの設定] ダイアログ ボックスを閉じます。

    注意

    復元可能なデータまたはテキストがある場合は、破損した文書の情報が表示されます。

  5. リンクされたテキストを右クリックし、[リンクされた Word 文書オブジェクト] をポイントして、[リンクの設定] を選択します。

  6. [リンクの設定] ダイアログ ボックスで、[リンクの解除] を選択します。

  7. 次のメッセージが表示されたら、[はい] を選択します。選択したリンクを解除してもよろしいですか?

方法 4: ファイル修復コンバーターを使用する

注意

ファイル修復コンバーターには制限があります。 たとえば、文書の書式設定は失われます。 また、グラフィックス、フィールド、描画オブジェクト、およびテキストではないその他の項目もすべて失われます。 ただし、フィールド テキスト、ヘッダー、フッター、脚注、および文末脚注は、単純なテキストとして保持されます。

  1. Word で、[ファイルメニュー] を選択し、[開く] を選択します。
  2. [ファイルの種類] ボックスの一覧の [ファイル修復コンバーター(.)] を選択します。
  3. 修復する文字列が含まれている文書を選択します。
  4. [開く]を選択します。

ファイル修復コンバーターを使用して文書を修復した場合、一部のバイナリ データのテキストが変換されずに残ります。 このテキストは、主に文書の最初と最後にあります。 ファイルを Word 文書として保存する前に、このバイナリ データのテキストを削除する必要があります。

注意

Word 2007 を使用している場合、ユーザー インターフェイスに [ファイル] ボタンはありません。必要に応じて [Office] ボタンをクリックし、指示に従ってください。

破損した文書を開ける場合に実行するトラブルシューティング手順

方法 1: 最後の段落記号を除いたすべての部分を新しい文書にコピーする

手順 1: 新しい文書を作成する

  1. Word で、リボンの [ファイル] を選択し、[新規作成] を選択します。
  2. [白紙の文書] を選択し、[作成] を選択します。

手順 2: 破損した文書を開く

  1. リボンの [ファイル] を選択し、[開く] を選択します。
  2. 破損した文書を選択し、[開く] を選択します。

手順 3: 文書の内容をコピーし、新しい文書にその内容を貼り付ける

注意

文書にセクション区切りが含まれる場合、セクション区切り間のテキストのみをコピーします。 セクション区切りをコピーすると新しい文書に破損部分がコピーされる可能性があるため、セクション区切りをコピーしないでください。 セクション区切りをコピーすることを防ぐため、文書間でコピーと貼り付けを行うときには文書の表示を下書き表示に変更します。 下書き表示に変更するには、[表示] タブで、[文書の表示] の [下書き] をクリックします。

  1. 破損している文書で Ctrl + End キーを押し、次に Ctrl + Shift + Home キーを押します。
  2. [ホーム] タブの [クリップボード] にある [コピー] を選択します。
  3. [表示] タブの [ウィンドウ] にある [ウィンドウの切り替え] を選択します。
  4. 手順 1. で作成した新しい文書を選択します。
  5. [ホーム] タブの [クリップボード] にある [貼り付け] を選択します。

異常な現象が引き続き発生する場合は、方法 8 に進みます。

方法 2: 文書で使用されているテンプレートを変更する

手順 1: 文書で使用されているテンプレートを判別する

  1. Word で破損した文書を開きます。
  2. リボンの [ファイル] を選択し、[オプション] を選択します。
  3. [アドイン] を選択します。
  4. [管理] ボックスの [Office アドインの管理を表示]にある[テンプレート]を選択します。
  5. [Go]を選択します。 [文書の作成に使用するテンプレート] ボックスに、文書で使用されるテンプレートが表示されます。 表示されているテンプレートが [Normal] の場合は、手順 2に進みます。 そうでない場合は、手順 3 に進みます。

手順 2: 全文書対象のテンプレート (Normal.dotm) の名前を変更する

  1. Word を終了します。
  2. [スタート] ボタンを選択します。
  3. オペレーティング システムで normal.dotm を検索します。 通常は、次の場所にあります。%userprofile%\appdata\roaming\microsoft\templates
  4. [Normal.dotm] を右クリックし、[名前の変更] を選択します。
  5. 「Oldword.old」と入力し、Enter キーを押します。
  6. エクスプローラのファイルを閉じます。
  7. Word を起動し、文書を開きます。

手順 3: 文書のテンプレートを変更する

  1. Word で破損した文書を開きます。
  2. リボンの [ファイル] を選択し、[オプション] を選択します。
  3. [アドイン] を選択します。
  4. [管理] で [テンプレート] を選択し、[検索] を選択します。
  5. [添付]を選択します。
  6. [Templates] フォルダーの [Normal.dotm] を選択し、[開く] を選択します。
  7. [OK] を選択して [テンプレートとアドイン] ダイアログ ボックスを閉じます。
  8. Word を終了します。

手順 4: テンプレートの変更によって問題が解決されたかを検証する

  1. Word を起動します。
  2. リボンの [ファイル] を選択し、[オプション] を選択します。
  3. 破損した文書を選択し、[開く] を選択します。

異常な現象が引き続き発生する場合は、方法 3 に進みます。

方法 3: 既定の設定で Word を起動する

/a スイッチを使用すると、Word の既定の設定のみを使用して Word を起動できます。 /a スイッチを使用した場合、アドインは読み込まれません。また、既存の Normal.dotm テンプレートも使用されません。 /a スイッチを使用して Word を再起動します。

手順 1: /a スイッチを使用して Word を起動する

  1. Word を終了します。

  2. [スタート] ボタンを選択し、[実行] を検索します。 [ファイル名を指定して実行] ダイアログ ボックスに次のように入力します。

    winword.exe /a

手順 2: 文書を開く

  1. Wordでリボンの [ファイル] を選択し、[開く] を選択します。
  2. 破損した文書を選択し、[開く] を選択します。

異常な現象が引き続き発生する場合は、方法 4 に進みます。

方法 4: プリンター ドライバーを変更する

手順 1: 異なるプリンター ドライバーを使用する

  1. オペレーティング システムで [デバイスとプリンター] を検索します。
  2. [プリンターの追加] を選択します。
  3. [プリンターの追加] ダイアログ ボックスで、[ローカル プリンターを追加] を選択します。
  4. [既存のポートを使用] を選択し、[次へ] を選択します。
  5. [製造元] 一覧の [Microsoft] を選択します。
  6. [Microsoft XPS Document Writer] を選択し、[次へ] を選択します。
  7. [現在インストールされているドライバーを使う (推奨)] を選択し、[次へ] を選択します。
  8. [通常使うプリンターに設定する] チェック ボックスを選択し、[次へ] を選択します。
  9. [完了] を選択します。

手順 2: プリンター ドライバーの変更によって問題が解決されたかを検証する

  1. Word を起動します。
  2. リボンの [ファイル] を選択し、[開く] を選択します。
  3. 破損した文書を選択し、[開く] を選択します。

異常な現象が引き続き発生する場合は、手順 3 に進みます。

手順 3: 元のプリンター ドライバーを再インストールする

Windows 10 および Windows 7

  1. オペレーティング システムで [プリンター] を検索します。

  2. もともと通常使うプリンターに設定されていたプリンターを選択し、[削除] を選択します。

    管理者パスワードまたは確認を求められたら、パスワードを入力するか、[続行] 選択します。

  3. そのプリンターに関連付けられたファイルをすべて削除するかどうかを確認するメッセージが表示されたら、[はい] を選択します。

  4. [プリンターまたはスキャナーの追加] を選択し、プリンターの追加ウィザード の指示に従って、プリンター ドライバーを再インストールします。

手順 4: プリンター ドライバーの変更によって問題が解決されたかを検証する

  1. Word を起動します。
  2. リボンの [ファイル] を選択し、[開く] を選択します。
  3. 破損した文書を選択し、[開く] を選択します。

異常な現象が引き続き発生する場合は、方法 5 に進みます。

方法 5: Word で強制的にファイルを修復する

手順 1: 文書を修復する

Wordでリボンの [ファイル] を選択し、[開く] を選択します。

  1. [開く] ダイアログ ボックスで、目的の Word 文書を1回クリックして強調表示します。
  2. [開く] ボタンの矢印を選択し、[開いて修復] を選択します。

手順 2: 文書の修復によって問題が解決されたことを確認する

異常な現象が発生しなくなったことを確認します。 異常な現象が引き続き発生する場合は、Windows を再起動してから方法 6 に進みます。

方法 6: 文書の形式を変更して、その文書を Word の形式に変換する

手順 1: 文書を開く

  1. Word を起動します。
  2. リボンの [ファイル] を選択し、[開く] を選択します。
  3. 破損した文書を選択し、[開く] を選択します。

手順 2: 文書を別のファイル形式で保存する

  1. リボンの [ファイル] を選択し、[名前を付けて保存] を選択します。
  2. その他のフォーマット を選択します。
  3. [ファイルの種類] 一覧の [リッチ テキスト形式 (RTF) (*.rtf)] を選択します。
  4. [保存] を選択します。
  5. リボンの [ファイル] を選択し、[閉じる] を選択します。

手順 3: 文書を開き、その文書を Word のファイル形式に変換し直す

  1. Wordで、[ファイル]を選択し、[オプション] を選択します。
  2. 変換した文書を選択し、[開く] を選択します。
  3. [ファイル] を選択し、[名前を付けて保存] を選択します。
  4. [名前を付けて保存] でファイルの種類として [Word 文書] を選択します。
  5. 文書のファイル名を変更し、[保存] を選択します。

手順 4: 文書のファイル形式を変換することによって問題が解決されたことを確認する

異常な現象が発生しなくなったことを確認します。 異常な現象が引き続き発生する場合は、ファイルをさらに別のファイル形式で保存します。 手順 1. から手順 4. を繰り返し、記載されている順に、以下のファイル形式でファイルを保存します。

  • Webページ (.htm、.html)
  • その他のワープロ形式
  • 書式なし

注意

ファイルを [書式なし (.txt)] の形式で保存した場合、破損した文書が修復される場合があります。 文書の書式、マクロ コード、およびグラフィックスはすべて失われます。 ファイルを [書式なし (*.txt)] の形式で保存した場合は、書式を設定し直す必要があります。 そのため、[書式なし (*.txt)] の形式での保存は、他のファイル形式で問題が解決されない場合にのみ実行してください。

異常な現象が引き続き発生する場合は、方法 7 に進みます。

方法 7: 破損している文書内の破損していない部分を新しい文書にコピーする

手順 1: 新しい文書を作成する

  1. Wordで、[ファイル]を選択し、[新規] を選択します。
  2. [白紙の文書] を選択し、[作成] を選択します。

手順 2: 破損した文書を開く

  1. [ファイル]を選択し、 [開く] を選択します。
  2. 破損した文書を選択し、[開く] を選択します。

手順 3: 文書内の破損していない部分をコピーし、新しい文書にその破損していない部分を貼り付ける

注意

文書にセクション区切りが含まれる場合、セクション区切り間のテキストのみをコピーします。 セクション区切りをコピーすると新しい文書に破損部分がコピーされる可能性があるため、セクション区切りをコピーしないでください。 セクション区切りをコピーすることを防ぐため、文書間でコピーと貼り付けを行うときには文書の表示を下書き表示に変更します。 下書き表示に変更するには、[表示] タブで、[文書の表示] の [下書き] をクリックします。

  1. 破損している文書内で、破損していない部分を見つけて選択します。
  2. [ホーム] タブの [クリップボード] にある [コピー] を選択します。
  3. [表示] タブの [ウィンドウ] にある [ウィンドウの切り替え] を選択します。
  4. 手順 1. で作成した新しい文書を選択します。
  5. [ホーム] タブの [クリップボード] にある [貼り付け] を選択します。
  6. 文書の破損していない部分ごとに、手順 3a. から 3e. を繰り返します。 文書の破損した部分は、作成し直す必要があります。

方法 8: 文書の表示を切り替えて破損した内容を取り除く

文書が切り詰められていると考えられる場合 (文書内のすべてのページが表示されていない)、文書の表示を切り替えて、破損した内容を取り除ける場合があります。

  1. 文書の切り詰めの原因となった破損した内容を含むページを特定します。

    1. Wordで、[ファイル]を選択し、[オプション] を選択します。
    2. 破損した文書を選択し、[開く] を選択します。
    3. スクロールして、切り詰められた部分の直前のページを表示します。 そのページに表示されている内容をメモします。
  2. 表示を切り替え、破損した内容を取り除きます。

    1. [表示] タブで、[文書の表示] グループの [Web レイアウト] または [下書きの表示] を選択します。
    2. スクロールして、切り詰められた部分の前に表示されていた内容を表示します。
    3. ファイル内でその内容の次にある段落、テーブル、またはオブジェクトを選択して削除します。
    4. [表示] タブで、[文書の表示]グループの [印刷レイアウト] を選択します。 引き続き文書が切り詰められて表示される場合は、[印刷レイアウト] で文書が切り詰めて表示されなくなるまで、表示を切り替えて、内容を削除します。
    5. 文書を保存します。

方法 9: メモ帳でドキュメントを開く

ドキュメントが破損していて、以前の方法のいずれも機能しない場合は、メモ帳でドキュメントを開いてコンテンツを復元します。

注意

このメソッドを使用すると、すべての書式が失われます。 目的は、コンテンツを回復することです。

  1. エクスプローラを使用して、破損したドキュメントを見つけます。
  2. メッセージを右クリックし、[プログラムから開く] を選びます。
  3. メモ帳 を選択してください:

Word 文書をメモ帳で開くスクリーンショット。

  1. ドキュメントがメモ帳で開き、コンテンツの周囲に追加のコードとテキストが表示されます。

    注意

    ファイルの種類を "テキスト ドキュメント(.txt)" から "すべてのファイル(.*)"に変更する必要がある場合があります。

  2. 余分な文字のすべてまたは大部分を削除して、テキストをきれいにします。

  3. [ファイル] を選択し、[名前を付けて保存] を選択します。 ドキュメントの名前を変更して、破損した文書を上書きしないようにします。

Word に戻り、新しい文書を開きます。 Word で一度クリーンアップし、失われた形式の再適用を試みます。