FormulaLocal プロパティ (Excel)Range.FormulaLocal property (Excel)

指定したオブジェクトの数式を A1 参照形式で、コード実行時の言語で示します。Returns or sets the formula for the object, using A1-style references in the language of the user. 値の取得と設定が可能なバリアント型 (Variant) の値です。Read/write Variant.

構文Syntax

FormulaLocalexpression.FormulaLocal

expressionRange オブジェクトを表す変数です。expression A variable that represents a Range object.

注釈Remarks

セルに定数が含まれている場合、その定数がそのまま返されます。If the cell contains a constant, this property returns that constant. セルが空のときには、空の文字列が返されます。If the cell is empty, the property returns an empty string. セルに数式が含まれるときには、数式バーの表示と同じ形式の文字列で (等号も付加されます)、その数式が返されます。If the cell contains a formula, the property returns the formula as a string, in the same format in which it would be displayed in the formula bar (including the equal sign).

セルの値や数式を日付に設定すると、そのセルが日付や時刻の書式になっているかどうかが確認されます。If you set the value or formula of a cell to a date, Microsoft Excel checks to see whether that cell is already formatted with one of the date or time number formats. 日付や時刻の書式になっていないときは、既定の日付の形式に変更されます。If not, the number format is changed to the default short date number format.

対象セル範囲が 1 次元または 2 次元のセル範囲のときは、同じ次元を持つ Visual Basic の配列から各セルの数式を設定できます。If the range is a one- or two-dimensional range, you can set the formula to a Visual Basic array of the same dimensions. 同様に、各セルの数式を Visual Basic の配列に代入することもできます。Similarly, you can put the formula into a Visual Basic array.

セル範囲に対して数式を設定すると、範囲内のすべてのセルに同じ数式が設定されます。Setting the formula of a multiple-cell range fills all cells in the range with the formula.

Example

次の使用例は、メッセージ ボックスに数式 =SUMME(A1:A10) を表示します。Assume that you enter the formula =SUM(A1:A10) in cell A11 on worksheet one, using the American English version of Microsoft Excel. 日本語版の Excel でワークシートのセル A11 に数式 =SUM(A1:A10) を入力し、ドイツ語版の Excel でブックを開いて実行するものとします。If you then open the workbook on a computer that's running the German version and run the following example, the example displays the formula =SUMME(A1:A10) in a message box.

MsgBox Worksheets(1).Range("A11").FormulaLocal

サポートとフィードバックSupport and feedback

Office VBA またはこの説明書に関するご質問やフィードバックがありますか?Have questions or feedback about Office VBA or this documentation? サポートの受け方およびフィードバックをお寄せいただく方法のガイダンスについては、Office VBA のサポートおよびフィードバックを参照してください。Please see Office VBA support and feedback for guidance about the ways you can receive support and provide feedback.