RPC 接続Outlook HTTPS 接続を使用してサーバーに接続しようとするとエラーが発生する: プロキシ サーバーのセキュリティ証明書に問題があります

元の KB 番号:  923575

現象

Microsoft Outlookリモート プロシージャ 呼び出し (RPC) 接続またはセキュリティで保護された HTTP (HTTPS) 接続を使用してサーバーに接続しようとすると、次のいずれかのエラー メッセージが表示されます。

  • エラー メッセージ 1

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 Outlookサーバーに接続できません。 (%s)

  • エラー メッセージ 2

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 セキュリティ証明書の名前が無効であるか、サイトの名前と一致しません。 Outlookサーバーに接続できません。 (%s)

  • エラー メッセージ 3

    プロキシ サーバーのセキュリティ証明書 %s に問題があります。 セキュリティ証明書は、信頼できる認証機関からの証明書ではありません。 Outlookサーバーに接続できません。(%s)"

  • エラー メッセージ 4

    プロキシ サーバーのセキュリティ証明書に問題があります。 セキュリティ証明書の名前が無効であるか、ターゲット サイトの名前と一致しない outlook.office365.com。 Outlookサーバーに接続できない場合 (エラー コード 0)

エラー メッセージに関する注意事項

  • %s プレースホルダー は、Outlookプロファイル プロパティ 001f6622 です。 これは RPC プロキシ Microsoft Exchange Server名です。

  • (%s) プレースホルダー はエラー コードです。

    エラー メッセージ 1 とエラー メッセージ 2 の場合、返されるエラー コードは、すべてのビットマスク証明書の問題コードの合計です。 ビットマスク証明書の問題コードの詳細については、「詳細」セクションを参照してください。

    エラー メッセージ 3 の場合、エラー コードは常にエラー 0x00000008。

原因

この問題は、次の条件の 1 つ以上が当てはまる場合に発生する可能性があります。

  • サーバーへの接続には、証明機関 (CA) が必要です。
  • ルートで証明機関を信頼していない。
  • 証明書が無効または失効している可能性があります。
  • 証明書がサイトの名前と一致しません。
  • サード パーティ製アドインまたはサード パーティ製ブラウザー アドインがアクセスを妨げている。

解決策 1: エラー メッセージ 1 または 2 の証明書を調べる

証明書を確認します。 次に、システム管理者に問い合わせてこの問題を解決します。

証明書を確認するには、次の手順を実行します。

  1. Microsoft Internet Explorer RPC サーバーまたはセキュリティで保護されたサーバーに接続します。 たとえば、と入力します https://www 。server_name のアドレス バーで .com/rpc をクリックし、Enter キーを押します。

    注意

    この server_name は、RPC サーバー名またはセキュリティで保護されたサーバー名を参照します。

  2. Web ブラウザーの右下隅にある南京錠アイコンをダブルクリックします。

  3. [ 詳細] タブをクリックします。

  4. 次のフィールドの情報に注意してください。

    • 有効
      [ 有効] フィールド は、証明書が有効になるまでの日付を示します。
    • 件名
      [件名] フィールド のデータ は、サイト名と一致する必要があります。

解決策 2: エラー メッセージ 3 の信頼されたルート証明書をインストールする

信頼できるルート証明書をクライアントにインストールするには、次の手順を実行します。

  1. [ 証明書] ダイアログ ボックス が表示されたら、[証明書のインストール ] を クリックします。
  2. [次へ] をクリックします。
  3. [すべての証明書を 次のストアに配置する] チェック ボックスを オンにします。
  4. [ 参照] をクリックします。
  5. [信頼 されたルート証明機関] > [OK] をクリックします
  6. [ 次へ] をクリックします。
  7. [完了] をクリックします。
  8. [OK] をクリックします。

参照については、「信頼できるルート 証明書のインストール」を参照してください

解決策 3: エラー メッセージ 4 でサード パーティ製アドインまたはサード パーティ製ブラウザー アドインを無効にする

サード パーティ製アドインを無効にする

  1. 問題Outlook分離するためにセーフ モードで開始します。 これを行うには、[実行の開始] > クリック し、「outlook.exe /safe」と入力、[OK] をクリックします

    セーフ Outlook正常に起動した場合、発生している問題は、サード パーティ製アドインによって発生する可能性があります。

  2. サードパーティの COM アドインを確認し、無効にします。 これを行うには、次の手順を実行します。

    1. [ファイル]メニューの[オプション アドイン > ] をクリックします
    2. [管理]ボックスで**、[COM アドインの移動] を** > クリックします
    3. 無効にするサード パーティ製アドインの横にあるチェック ボックスをオフにします。
    4. Outlook を再起動します。

詳細については、次のマイクロソフト サポート技術情報の記事の「手順 6: セーフ モードでOutlookを開始する」セクションを参照してください。

2632425 2010 および Outlook 2013 でのクラッシュのトラブルシューティングOutlook方法

サードパーティのブラウザー アドインを無効にする

Outlook HTTP 要求Internet Explorer設定を使用します。 サードパーティのブラウザー アドインでこの問題が発生している場合は、この問題を無効Internet Explorer。 これを行う方法の手順については、次のマイクロソフト サポート技術情報の記事の「Internet Explorer でアドオンを無効にする」セクションを参照してください。

956196 "Internet Explorer Web ページを表示できません" というエラー

詳細情報

ビットマスク証明書の問題コードを次の表に示します。

説明 エラー コード
FLAG_CERT_REV_FAILED 0x00000001
FLAG_INVALID_CERT 0x00000002
FLAG_CERT_REVOKED 0x00000004
FLAG_INVALID_CA 0x00000008
FLAG_CERT_CN_INVALID 0x00000010
FLAG_CERT_DATE_INVALID 0x00000020
FLAG_CERT_WRONG_USAGE 0x00000040
FLAG_SECURITY_CHANNEL_ERROR 0x80000000