[Microsoft Dynamics CRMで追跡] を選択すると、これらのレコード にアクセスするためのアクセス許可がありません。

この記事では、Outlook 用の Microsoft Dynamics CRM 内で [Microsoft Dynamics CRMで追跡] を選択したときに発生するこれらのレコードにアクセスするためのアクセス許可がありませんエラーの解決策について説明します。

適用対象: Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2016
元の KB 番号: 3140750

現象

Outlook 用Microsoft Dynamics CRM内の [Microsoft Dynamics CRMで追跡] を選択すると、次のエラーで失敗します。

これらのレコードにアクセスするためのアクセス許可がありません。 Microsoft Dynamics CRM管理者に問い合わせてください。

原因

Microsoft Dynamics CRMのユーザー レコードに、レコードの作成および更新ルール エンティティの読み取りアクセス権がありません。 Microsoft は、この問題を認識しており、メールを追跡するためにこの権限が必要ないように修正プログラムを提供する予定です。 それまでは、「解決策」セクションで提供されている回避策を使用できます。

解決方法

システム管理者ロールを持つユーザーとしてMicrosoft Dynamics CRMにサインインします。 ユーザーに割り当てられているセキュリティ ロールを見つけます。 セキュリティ ロールの [ サービス管理 ] タブで、[レコードの作成と更新ルール] エンティティの読み取りアクセス権を付与します。

詳細

クライアント側 CRM トレースをキャプチャすると、次の情報がログに記録されます。

プリンシパル ユーザー (Id={GUID}、type=8) に prvReadConvertRule 特権 (Id=<GUID>) がありません 2015-08-21T15:27:32.0596285Z