アップグレード時のエラー Azure AD Connect: 同期サービスをインストールできません

元の製品バージョン:  Office 365 ID 管理, Azure Active Directory
元の KB 番号:   4054462

現象

アップグレードを試みAzure Active Directory Connect、次のエラー メッセージが表示されます。

同期からアップグレード中にエラー Azure Active Directoryしました。同期サービスをアップグレードできません。 詳細については、イベント ログを参照してください。

詳細なイベント ログは、次のようになります。

Date/Time[ 12] [INFO] ServiceControllerProvider: StartService status: Running Date/Time[ 12] [ERROR] 同期エンジンのアップグレード中にエラーが発生しました。 System.Exception: 同期サービスをアップグレードできません。 詳細については、イベント ログを参照してください。 ---> Microsoft.Azure.ActiveDirectory.Client.Framework.ProcessExecutionFailedException: msi パッケージ '同期Service.msi' のインストール中にエラーが発生しました。 完全なログは 'C:\ProgramData\AADConnect\Synchronization Service_Install-DateTime.log'で利用できます。

アクションの開始時間: DetectServiceAccount。 CustomAction DetectServiceAccount は、実際のエラー コード 1603 を返しました (サンドボックス内で変換が発生した場合、これは 100% 正確ではない場合があります) Action endedTime: DetectServiceAccount。 戻り値 3。 アクションの終了時間: INSTALL。 戻り値 3。 MSI (s) (14:AC)時間: 注: 1: 1708 MSI (s) (14:AC)時間: 製品: Microsoft Azure AD Connect 同期サービス -- インストール操作に失敗しました。 MSI (s) (14:AC)時間: Windowsインストーラーが製品をインストールしました。 製品名: Microsoft Azure AD Connect同期サービス。 製品バージョン: 1.1.614.0。 製品の言語: 1033。 製造元: Microsoft Corporation. インストールの成功またはエラーの状態: 1603。 MSI (s) (14:AC)時間: パッケージ/ファイルのクリーンアップを延期する(存在する MSI (s) (14:AC)Time: MainEngineThread が 1603 MSI (s) (14:80)Time: RESTART MANAGER: Session closed.

原因

基になるサービス アカウントは、Domain\SamAccountName の代わりにユーザー プリンシパル名 (UPN) を使用して構成されています。

解決方法

この問題を解決するには、次の手順を実行します。

  1. サーバーでサービス コンソールをAzure AD Connectします。
  2. 同期サービス Microsoft Azure ADし、サービスを右クリックします。
  3. [プロパティ ] を 選択し、[ログオン] を選択します
  4. UPN を使用する代わりに Domain\SamAccountName を使用してアカウントを設定します。
  5. [適用] と [OK] を選択します