別のデバイスが切断された後、アプリケーションが新しいスキャン デバイスを見つけ出できない

この記事では、別のスキャナーが切断された後にスキャナーが接続されている場合に、アプリケーションでスキャン デバイスが見つからない場合に発生するエラーを回避するのに役立ちます。

元の製品バージョン:   Windows 10、Windows 8.1
元の KB 番号:   4537086

現象

次のような状況で問題が発生します。

  1. デバイス上の Web サービス (WSD) スキャン デバイスを Windows ベースのコンピューターに接続します。
  2. WSD スキャナーを切断します。
  3. USB スキャナーなどの別のスキャン デバイスをコンピューターに接続します。
  4. 新しいスキャナーを使用するアプリケーションを起動します。 このシナリオでは、アプリケーションが正しく動作しない可能性があります。 たとえば、アプリケーションが新しいスキャナーを見つからない場合があります。 この問題が発生すると、スキャナー ドライバーがメソッドを び出WIA_ERROR_OFFLINEエラーが発生する可能性 IStiDevice::LockDevice があります。

注意

This issue is applicable for Windows 10 versions up to 19H2 (namely Windows 10 Version 1909). この問題は 20H1 で修正されています (Windows 10 バージョン 2004)

原因

この問題は、サービスが WSD スキャナーを初期化するときに、"Windows イメージ取得 (WIA)" サービスでエラーが発生した場合に発生します。 初期化プロセスがエラーなしで成功した場合、この問題は発生しません。

回避策

この問題を回避するには、次の方法を試してください。

  • 接続されているスキャナー デバイス (たとえば、デバイス マネージャーを使用) をアンインストールし、スキャナーを再接続します。
  • "Windows イメージ取得 (WIA)" サービスを停止し、サービスを再起動します。
  • スキャナーが接続されている間にコンピューターを再起動します。

詳細

WIA スキャナー アプリケーションまたはドライバーで発生する可能性のあるエラーの詳細については、「エラー コード」を 参照してください