LmCompatibility を使用0xC000035Bターミナル サービス クライアント接続エラー

この記事では、リモート デスクトップ プロトコル (RDP) 8.0 を使用して WINDOWS SERVER 2012 RD ゲートウェイ サーバーを介して接続するターミナル サービス クライアント接続で発生するエラー 0xC000035B に対するソリューションを提供します。

適用対象:  Windows Server 2012R2
元の KB 番号:   2903333

現象

リモート デスクトップ プロトコル (RDP) 8.0 を使用して Windows Server 2012 RD ゲートウェイ サーバーを介して接続するターミナル サービス クライアント接続が失敗し、次のエラー メッセージが生成されます。

このコンピューターはリモート コンピューターに接続できません。

さらに、イベント 4625 はゲートウェイ サーバーのセキュリティ 記号に記録され、エラーが0xC000035Bされます。

ログ名: セキュリティ
ソース: Microsoft-Windows-Security-Auditing
日付: <DateTime>
イベント ID: 4625
タスク カテゴリ: ログオン
レベル: 情報
キーワード: 監査エラー
ユーザー: N/A
コンピューター: RDGW。CONTOSO.COM
説明:
アカウントがログオンに失敗しました。

件名:
セキュリティ ID: NULL SID
アカウント名: -
アカウント ドメイン: -
ログオン ID: 0x0
ログオンの種類: 3
ログオンに失敗したアカウント:
セキュリティ ID: NULL SID
アカウント名: Myuser
アカウント ドメイン: Contoso
エラー情報:
エラーの理由: ログオン中にエラーが発生しました。
状態: 0xC000035B
Sub Status: 0x0

原因

この問題は、システムに強制的に NTLMv1 を使用するように LmCompatibility レジストリ値が構成されている場合に発生します。 LmCompatibility 値が 3 未満の場合、システムは強制的に NTLMv1 を使用します。

既定では、Windows Server 2012 RDP 8.0 でチャネル バインドが適用されます。 NTLMv1 を使用してもこれらのバインドは送信されないので、認証は失敗し、0xC000035B "クライアントが提供するセキュリティ サポート プロバイダー インターフェイス (SSPI) チャネル バインドが正しくありません" というエラー メッセージが生成されます。 チャネル バインドが無効な状態を示します。

解決方法

重要

このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 場合によっては、オペレーティング システムの再インストールが必要になります。 こうした問題の修復について、マイクロソフトはいかなる保証もいたしません。 レジストリの変更はユーザー自身の責任において行ってください。 変更する前に、「問題が発生した場合に備え、レジストリをバックアップWindows復元する方法」を参照してください。

レジストリを編集する方法については、「レジストリ エディター」の「キーと値の変更」のヘルプ トピックを参照してください。

この問題を解決するには、次のいずれかの方法を使用します。

方法 1

クライアントの LmCompatibility レジストリ値を 3 以上に設定して、NTLMv1 を強制的に設定しなさる調整を行います。 LmCompatibility レジストリ値の詳細については 、「LmCompatibilityLevel」を参照してください

方法 2

EnforceChannelBinding レジストリ値 を 0 (ゼロ) に設定すると、ゲートウェイ サーバーでチャネル バインドが見つからないのは無視されます。 これを行うには、次のレジストリ サブキーを見つけて、指定した仕様を使用します。

HKLM\Software\Microsoft\Windows NT\CurrentVersion\TerminalServerGateway\Config\Core
種類: REG_DWORD
名前: EnforceChannelBinding
値: 0 (Decimal)

注意

既定では 、EnforceChannelBinding 値 はゲートウェイ サーバーに存在しません。 この値を作成する必要があります。