Azure Data Lake Tools for Visual Studio Code の使用Use Azure Data Lake Tools for Visual Studio Code

このアーティクルでは、U-SQL スクリプトを作成、テスト、実行するために Azure Data Lake Tools for Visual Studio Code (VS Code) を使用する 方法について説明します。In this article, learn how you can use Azure Data Lake Tools for Visual Studio Code (VS Code) to create, test, and run U-SQL scripts. この情報は、次のビデオにも含まれています。The information is also covered in the following video:

ビデオ プレーヤー:Azure Data Lake tools for VS CodeVideo player: Azure Data Lake tools for VS Code

前提条件Prerequisites

Azure Data Lake Tools for VS Code では、Windows、Linux、および macOS がサポートされます。Azure Data Lake Tools for VS Code supports Windows, Linux, and macOS.  U-SQL のローカル実行とローカル デバッグは Windows でのみ動作します。 U-SQL local run and local debug works only in Windows.

MacOS および Linux の場合 :For MacOS and Linux:

Azure Data Lake Tools をインストールするInstall Azure Data Lake Tools

前提条件の各項目のインストールが完了したら、Azure Data Lake Tools for VS Code をインストールできます。After you install the prerequisites, you can install Azure Data Lake Tools for VS Code.

Azure Data Lake Tools をインストールするにはTo install Azure Data Lake Tools

  1. Visual Studio Code を開きます。Open Visual Studio Code.

  2. 左側のウィンドウで、 [拡張機能] を選択します。Select Extensions in the left pane. 検索ボックスに「Azure Data Lake」と入力します。Enter Azure Data Lake Tools in the search box.

  3. [Azure Data Lake Tools] の横にある [インストール] を選択します。Select Install next to Azure Data Lake Tools.

    Data Lake Tools をインストールするための選択

    数秒後、 [インストール] ボタンが [再度読み込む] に変わります。After a few seconds, the Install button changes to Reload.

  4. [再度読み込む] を選択して、Azure Data Lake Tools 拡張機能をアクティブにします。Select Reload to activate the Azure Data Lake Tools extension.

  5. [ウィンドウの再読み込み] をクリックして確認します。Select Reload Window to confirm. [拡張機能] ウインドウにAzure Data Lake Tools が表示されます。You can see Azure Data Lake Tools in the Extensions pane.

Azure Data Lake Tools をアクティブ化するActivate Azure Data Lake Tools

新しい .usql ファイルを作成するか、既存の .usql ファイルを開いて拡張機能をアクティブにしてください。Create a .usql file or open an existing .usql file to activate the extension.

U-SQL の操作Work with U-SQL

U-SQL を操作するには、U-SQL ファイルまたはフォルダーを開く必要があります。To work with U-SQL, you need open either a U-SQL file or a folder.

サンプル スクリプトを開くにはTo open the sample script

コマンド パレットを開いて (Ctrl + Shift + P)、「ADL:Open Sample Script」と入力します。Open the command palette (Ctrl+Shift+P) and enter ADL: Open Sample Script. このサンプルの別のインスタンスが開きます。It opens another instance of this sample. このインスタンスのスクリプトは編集、構成、送信することもできます。You can also edit, configure, and submit a script on this instance.

U-SQL プロジェクトのフォルダーを開くにはTo open a folder for your U-SQL project

  1. Visual Studio Code で [ファイル] メニューを選択し、 [フォルダーを開く] を選択します。From Visual Studio Code, select the File menu, and then select Open Folder.

  2. フォルダーを指定し、 [フォルダーの選択] を選択します。Specify a folder, and then select Select Folder.

  3. [ファイル] メニューを選択し、 [New](新規作成) を選択します。Select the File menu, and then select New. Untitled-1 ファイルがプロジェクトに追加されます。An Untitled-1 file is added to the project.

  4. 次のコードを 無題-1 ファイルに入力します:Enter the following code in the Untitled-1 file:

    @departments  =
        SELECT * FROM
            (VALUES
                (31,    "Sales"),
                (33,    "Engineering"),
                (34,    "Clerical"),
                (35,    "Marketing")
            ) AS
                  D( DepID, DepName );
    

    OUTPUT @departments     TO "/Output/departments.csv" USING Outputters.Csv();OUTPUT @departments     TO "/Output/departments.csv" USING Outputters.Csv();

    このスクリプトにより、いくつかのデータを含む departments.csv ファイルが /output フォルダーに作成されます。The script creates a departments.csv file with some data included in the /output folder.

  5. 開いたフォルダーに myUSQL.usql という名前でファイルを保存します。Save the file as myUSQL.usql in the opened folder.

U-SQL スクリプトをコンパイルするにはTo compile a U-SQL script

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.
  2. ADL:Compile Script」と入力します。Enter ADL: Compile Script. [出力] ウィンドウにコンパイル結果が表示されます。The compile results appear in the Output window. スクリプト ファイルを右クリックし、 [ADL:Compile Script] を選択して U-SQL ジョブをコンパイルすることもできます。You can also right-click a script file, and then select ADL: Compile Script to compile a U-SQL job. コンパイル結果は [出力] ウィンドウに表示されます。The compilation result appears in the Output pane.

U-SQL スクリプトを送信するにはTo submit a U-SQL script

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.
  2. ADL:Submit Job を選択して、ジョブを送信します。Enter ADL: Submit Job. スクリプト ファイルを右クリックし、 [ADL:Submit Job] を選択して、ジョブを送信します。You can also right-click a script file, and then select ADL: Submit Job.

U-SQL ジョブの送信後、VS Code の [出力] ウィンドウに送信ログが表示されます。After you submit a U-SQL job, the submission logs appear in the Output window in VS Code. 右側のウィンドウで、ジョブ ビューが表示されます。The job view appears in the right pane. 送信が成功した場合は、ジョブの URL も表示されます。If the submission is successful, the job URL appears too. ジョブの URL を Web ブラウザーで開くと、リアルタイムのジョブの状態を追跡できます。You can open the job URL in a web browser to track the real-time job status.

ジョブ ビューの [概要] タブでは、ジョブの詳細を確認できます。On the job view's SUMMARY tab, you can see the job details. 主な機能には、スクリプトの再送信、スクリプトの複製、ポータルで開くなどがあります。Main functions include resubmit a script, duplicate a script, and open in the portal. ジョブ ビューの [データ] タブでは、入力ファイル、出力ファイル、リソースファイルを参照できます。On the job view's DATA tab, you can refer to the input files, output files, and resource files. ファイルはローカル コンピューターにダウンロードできます。Files can be downloaded to the local computer.

ジョブ ビューの概要タブ

ジョブ ビューのデータタブ

既定のコンテキストを設定するにはTo set the default context

ファイルのパラメーターを個々に設定していない場合、この設定をすべてのスクリプトファイルに適用する既定のコンテキストを設定することができます。You can set the default context to apply this setting to all script files if you have not set parameters for files individually.

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.

  2. ADL:Set Default Context を選択します。Enter ADL: Set Default Context. または、スクリプト エディターを右クリックし、 [ADL:Set Default Context] を選択します。Or right-click the script editor and select ADL: Set Default Context.

  3. 使用するアカウント、データベース、およびスキーマを選択します。Choose the account, database, and schema that you want. この設定は xxx_settings.json 構成ファイルに保存されます。The setting is saved to the xxx_settings.json configuration file.

    既定のコンテキストとして設定されたアカウント、データベース、およびスキーマ

スクリプト パラメーターを設定するにはTo set script parameters

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.

  2. ADL:Set Script Parameters」と入力します。Enter ADL: Set Script Parameters.

  3. xxx_settings.json ファイルが以下のプロパティでが開かれています:The xxx_settings.json file is opened with the following properties:

    • account:U-SQL ジョブをコンパイルし、実行するために必要な Azure サブスクリプションの Azure Data Lake Analytics アカウント。account: An Azure Data Lake Analytics account under your Azure subscription that's needed to compile and run U-SQL jobs. U-SQL ジョブのコンパイルと実行を行う前に、このコンピューター アカウントを構成する必要があります。You need configure the computer account before you compile and run U-SQL jobs.
    • database:自分のアカウントのデータベース。database: A database under your account. 既定値は master です。The default is master.
    • schema:自分のデータベースのスキーマ。schema: A schema under your database. 既定値は dbo です。The default is dbo.
    • optionalSettings:optionalSettings:
      • priority:優先順位の範囲は 1 から 1,000 で、1 が最も高い優先順位です。priority: The priority range is from 1 to 1000, with 1 as the highest priority. 既定値は 1,000 です。The default value is 1000.
      • degreeOfParallelism:並列処理の範囲は 1 から 150 です。degreeOfParallelism: The parallelism range is from 1 to 150. 既定値は、Azure Data Lake Analytics アカウントで許可される並列処理の最大数です。The default value is the maximum parallelism allowed in your Azure Data Lake Analytics account.

    JSON ファイルのコンテンツ

注意

構成の保存後、アカウント、データベース、スキーマ情報が、対応する .usql ファイルの左下隅にあるステータス バーに表示されます (既定のコンテキストを設定していない場合)。After you save the configuration, the account, database, and schema information appear on the status bar at the lower-left corner of the corresponding .usql file if you don’t have a default context set up.

Git Ignore を設定するにはTo set Git ignore

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.

  2. ADL:Set Git Ignore」と入力します。Enter ADL: Set Git Ignore.

    • VS Code 作業フォルダーに .gitIgnore ファイルが存在しない場合、このフォルダーに .gitIgnore という名前のファイルが作成されます。If you don’t have a .gitIgnore file in your VS Code working folder, a file named .gitIgnore is created in your folder. 4 つの項目 (usqlCodeBehindReferenceusqlCodeBehindGenerated.cacheobj) が既定でファイルに追加されます。Four items (usqlCodeBehindReference, usqlCodeBehindGenerated, .cache, obj) are added in the file by default. 必要な場合は、さらに更新することができます。You can make more updates if needed.
    • VS Code 作業フォルダーに .gitIgnore ファイルが既に存在する場合、ツールによって4項目 (usqlCodeBehindReferenceusqlCodeBehindGenerated.cacheobj) が .gitIgnore ファイルに追加されます(ファイルにこの 4 項目が含まれていない場合)。If you already have a .gitIgnore file in your VS Code working folder, the tool adds four items (usqlCodeBehindReference, usqlCodeBehindGenerated, .cache, obj) in your .gitIgnore file if the four items were not included in the file.

    .gitIgnore ファイル内の項目

分離コード ファイル(C Sharp、Python、R) を操作するWork with code-behind files: C Sharp, Python, and R

Azure Data Lake Tools は、複数のカスタム コードをサポートしています。Azure Data Lake Tools supports multiple custom codes. 手順については、VS Code で Azure Data Lake Analytics の Python、R、および C Sharp を使用した U-SQL を開発するを参照してください。For instructions, see Develop U-SQL with Python, R, and C Sharp for Azure Data Lake Analytics in VS Code.

アセンブリの操作Work with assemblies

アセンブリの開発に関する情報については、「Azure Data Lake Analytics ジョブの U-SQL アセンブリの開発」を参照してください。For information on developing assemblies, see Develop U-SQL assemblies for Azure Data Lake Analytics jobs.

Data Lake Analytics カタログには、Data Lake Tools を使用してカスタム コード アセンブリを登録できます。You can use Data Lake Tools to register custom code assemblies in the Data Lake Analytics catalog.

アセンブリを登録するにはTo register an assembly

ADL:Register Assembly または ADL:Register Assembly (Advanced) コマンドを使用して、アセンブリを登録できます。You can register the assembly through the ADL: Register Assembly or ADL: Register Assembly (Advanced) command.

ADL:Register Assembly コマンドを使用して登録するにはTo register through the ADL: Register Assembly command

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.
  2. ADL:Register Assembly」と入力します。Enter ADL: Register Assembly.
  3. ローカル アセンブリのパスを指定します。Specify the local assembly path.
  4. Data Lake Analytics アカウントを選択します。Select a Data Lake Analytics account.
  5. データベースを選択します。Select a database.

ポータルがブラウザーで開かれ、アセンブリの登録プロセスが表示されます。The portal is opened in a browser and displays the assembly registration process.

ADL:Register Assembly コマンドをトリガーする、より便利な方法として、エクスプローラーで .dll ファイルを右クリックする方法があります。A more convenient way to trigger the ADL: Register Assembly command is to right-click the .dll file in File Explorer.

ADL:Register Assembly (Advanced) コマンドを使用して登録するにはTo register through the ADL: Register Assembly (Advanced) command

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.

  2. ADL:Register Assembly (Advanced) 」と入力します。Enter ADL: Register Assembly (Advanced).

  3. ローカル アセンブリのパスを指定します。Specify the local assembly path.

  4. JSON ファイルが表示されます。The JSON file is displayed. アセンブリの依存関係とリソース パラメーターを確認して、必要な場合は編集します。Review and edit the assembly dependencies and resource parameters, if needed. 手順が [出力] ウィンドウに表示されます。Instructions are displayed in the Output window. アセンブリの登録に進むには、JSON ファイルを保存 (Ctrl + S) します。To proceed to the assembly registration, save (Ctrl+S) the JSON file.

    アセンブリの依存関係とリソース パラメーターを使用した JSON file

注意

  • Azure Data Lake Tools は、DLL がアセンブリの依存関係をもつかどうかを自動的に検出します。Azure Data Lake Tools autodetects whether the DLL has any assembly dependencies. 依存関係は、検出された後 JSON ファイルに表示されます。The dependencies are displayed in the JSON file after they're detected.
  • DLL リソース (.txt、.png、.csv など) をアセンブリの登録の一部としてアップロードできます。You can upload your DLL resources (for example, .txt, .png, and .csv) as part of the assembly registration.

ADL:Register Assembly (Advanced) コマンドをトリガーする別の方法として、エクスプローラーで .dll ファイルを右クリックする方法があります。Another way to trigger the ADL: Register Assembly (Advanced) command is to right-click the .dll file in File Explorer.

次の U-SQL コードは、アセンブリを呼び出す方法を示しています。The following U-SQL code demonstrates how to call an assembly. このサンプルでは、アセンブリ名は test です。In the sample, the assembly name is test.

REFERENCE ASSEMBLY [test];
@a =
    EXTRACT
        Iid int,
    Starts DateTime,
    Region string,
    Query string,
    DwellTime int,
    Results string,
    ClickedUrls string
    FROM @"Sample/SearchLog.txt"
    USING Extractors.Tsv();
@d =
    SELECT DISTINCT Region
    FROM @a;
@d1 =
    PROCESS @d
    PRODUCE
        Region string,
    Mkt string
    USING new USQLApplication_codebehind.MyProcessor();
OUTPUT @d1
    TO @"Sample/SearchLogtest.txt"
    USING Outputters.Tsv();

U-SQL のローカル実行とローカル デバッグをWindows ユーザーで使用するUse U-SQL local run and local debug for Windows users

U-SQL ローカル実行は、Data Lake Analytics にコードを発行する前に、ローカル データをテストし、スクリプトをローカルで検証するものです。U-SQL local run tests your local data and validates your script locally before your code is published to Data Lake Analytics. 作成したコードを Data Lake Analytics に送信する前に、ローカル デバッグ機能を使用して次のタスクを完了することができます:You can use the local debug feature to complete the following tasks before your code is submitted to Data Lake Analytics:

  • C# 分離コードをデバッグする。Debug your C# code-behind.
  • コードをステップ実行する。Step through the code.
  • スクリプトをローカルで検証する。Validate your script locally.

ローカル実行およびローカル デバッグ機能は Windows 環境でのみ動作し、macOS および Linux ベースのオペレーティング システムではサポートされていません。The local run and local debug feature only works in Windows environments, and is not supported on macOS and Linux-based operating systems.

ローカル実行とローカル デバッグの手順については、「Visual Studio Code を使用した U-SQL ローカル実行とローカル デバッグ」を参照してください。For instructions on local run and local debug, see U-SQL local run and local debug with Visual Studio Code.

Azure に接続するConnect to Azure

Data Lake Analytics で U-SQL スクリプトをコンパイルして実行するには、まず Azure アカウントに接続する必要があります。Before you can compile and run U-SQL scripts in Data Lake Analytics, you must connect to your Azure account.

コマンドを使用して Azure に接続するにはTo connect to Azure by using a command

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.

  2. ADL:Login を選択します。Enter ADL: Login. 右下にログイン情報が表示されます。The login information appears on the lower right.

    ログイン コマンドを入力しています

    サインインと認証についての通知

  3. [Copy & Open] を選択し、ログイン Web ページを開きます。Select Copy & Open to open the login webpage. ボックスにコードを貼り付け、 [続行] を選択します。Paste the code into the box, and then select Continue.

    ログイン Web ページ

  4. 手順に従って Web ページからサインインします。Follow the instructions to sign in from the webpage. 接続すると、VS Code ウィンドウの左下隅のステータス バーに Azure アカウント名が表示されます。When you're connected, your Azure account name appears on the status bar in the lower-left corner of the VS Code window.

注意

  • Data Lake Tools は、次回サインアウトしない場合、自動的にサインアウトします。Data Lake Tools automatically signs you in the next time if you don't sign out.
  • アカウントで 2 要素認証が有効になっている場合は、PIN ではなく電話認証の使用をお勧めします。If your account has two factors enabled, we recommend that you use phone authentication rather than using a PIN.

サインアウトするには、ADL:Logout コマンドを入力します。To sign out, enter the command ADL: Logout.

エクスプローラーから Azure に接続するにはTo connect to Azure from the explorer

AZURE DATALAKEを展開し、 Azure へのサインインを選択して次のコマンドを使用して Azure に接続するの手順 3 と手順 4に従ってください。Expand AZURE DATALAKE, select Sign in to Azure, and then follow step 3 and step 4 of To connect to Azure by using a command.

エクスプ ローラーで「Azure にサインインする」の選択

エクスプ ローラーからサインアウトすることはできません。You can't sign out from the explorer. サインアウトするには、コマンドを使用して Azure に接続するを参照してください。To sign out, see To connect to Azure by using a command.

抽出スクリプトの作成Create an extraction script

.csv、.tsv、および .txt ファイルの抽出スクリプトは、ADL:Create EXTRACT Script コマンドを使用するか、Azure Data Lake エクスプローラーから作成できます。You can create an extraction script for .csv, .tsv, and .txt files by using the command ADL: Create EXTRACT Script or from the Azure Data Lake explorer.

コマンドを使用して抽出スクリプトを作成するにはTo create an extraction script by using a command

  1. Ctrl + Shift + P キーを押してコマンド パレットを開き、「ADL:Create EXTRACT Script」と入力します。Select Ctrl+Shift+P to open the command palette, and enter ADL: Create EXTRACT Script.
  2. Azure Storage ファイルの完全なパスを指定し、Enter キーを押します。Specify the full path for an Azure Storage file, and select the Enter key.
  3. 1 つのアカウントを選択します。Select one account.
  4. .txt ファイルの場合は、区切り記号を選択してファイルを抽出します。For a .txt file, select a delimiter to extract the file.

抽出スクリプト作成のプロセス

入力に基づいて抽出スクリプトが生成されます。The extraction script is generated based on your entries. 列を検出できないスクリプトの場合は、次の 2 つのオプションのいずれかを選択します。For a script that cannot detect the columns, choose one from the two options. それ以外の場合は、1 つのスクリプトのみが生成されます。If not, only one script will be generated.

抽出スクリプト作成の結果

エクスプローラーから抽出スクリプトを作成するにはTo create an extraction script from the explorer

抽出スクリプトを作成する別の方法は、Azure Data Lake Store または Azure Blob Storage 内の .csv ファイル、.tsv ファイルの右クリック (ショートカット) メニューを使用することです。Another way to create the extraction script is through the right-click (shortcut) menu on the .csv, .tsv, or .txt file in Azure Data Lake Store or Azure Blob storage.

ショートカット メニューの「抽出スクリプトを作成する」コマンド

コマンドを使用して Azure Data Lake Analytics と統合するIntegrate with Azure Data Lake Analytics through a command

Azure Data Lake Analytics リソースにアクセスして、アカウントの一覧表示、メタデータへのアクセス、分析ジョブの表示を実行できます。You can access Azure Data Lake Analytics resources to list accounts, access metadata, and view analytics jobs.

Azure サブスクリプション内の Azure Data Lake Analytics アカウントを一覧表示するにはTo list the Azure Data Lake Analytics accounts under your Azure subscription

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.
  2. ADL:List Accounts」と入力します。Enter ADL: List Accounts. [出力] ウィンドウにアカウントが表示されます。The accounts appear in the Output pane.

Azure Data Lake Analytics メタデータにアクセスするにはTo access Azure Data Lake Analytics metadata

  1. Ctrl + Shift + P キーを押し、「ADL:List Tables」と入力します。Select Ctrl+Shift+P, and then enter ADL: List Tables.
  2. いずれかの Data Lake Analytics アカウントを選択します。Select one of the Data Lake Analytics accounts.
  3. いずれかの Data Lake Analytics データベースを選択します。Select one of the Data Lake Analytics databases.
  4. いずれかのスキーマを選択します。Select one of the schemas. テーブルの一覧が表示されます。You can see the list of tables.

Azure Data Lake Analytics ジョブを表示するにはTo view Azure Data Lake Analytics jobs

  1. コマンド パレットを開いて (Ctrl + Shift + P)、 [ADL:Show Job] を選択します。Open the command palette (Ctrl+Shift+P) and select ADL: Show Jobs.

  2. Data Lake Analytics アカウントまたはローカル アカウントを選択します。Select a Data Lake Analytics or local account.

  3. アカウントのジョブ一覧が表示されるまで待ちます。Wait for the job list to appear for the account.

  4. ジョブ一覧からジョブを選択します。Select a job from the job list. Data Lake Tools により右側のウィンドウにジョブ ビューが開かれ、VS Code 出力情報を表示します。Data Lake Tools opens the job view in the right pane and displays some information in the VS Code output.

    Job 一覧

コマンドを使用して Azure Data Lake Store と統合するIntegrate with Azure Data Lake Store through a command

Azure Data Lake Store 関連コマンドを使用して次のことを実行できます:You can use Azure Data Lake Store-related commands to:

ストレージ パスの一覧表示List the storage path

コマンド パレットを使用してストレージ パスを一覧表示するにはTo list the storage path through the command palette

  1. スクリプト エディターを右クリックし、 [ADL:List Path] を選択します。Right-click the script editor and select ADL: List Path.
  2. 一覧でフォルダーを選択するか、 [Enter a path] または [Browse from root path] をクリックします。Choose the folder in the list, or select Enter a path or Browse from root path. (ここでは、例として [Enter a path] を使用しています。)(We're using Enter a path as an example.)
  3. Data Lake Analytics アカウントを選択します。Select your Data Lake Analytics account.
  4. ストレージ フォルダーのパスを参照もしくは入力します (/output/ など)。Browse to or enter the storage folder path (for example, /output/).

コマンド パレットに入力に基づくパス情報の一覧が表示されます。The command palette lists the path information based on your entries.

Storage パスの結果

相対パスの一覧を表示するさらに便利な方法は、ショートカット メニューを使用することです。A more convenient way to list the relative path is through the shortcut menu.

ショートカット メニューを使用してストレージ パスを一覧表示するにはTo list the storage path through the shortcut menu

パス文字列を右クリックし、 [List Path] を選択します。Right-click the path string and select List Path.

ショートカット メニューの「パスの一覧を表示する」

ストレージ ファイルのプレビューPreview the storage file

  1. スクリプト エディターを右クリックし、 [ADL:Preview File] を選択します。Right-click the script editor and select ADL: Preview File.
  2. Data Lake Analytics アカウントを選択します。Select your Data Lake Analytics account.
  3. Azure Storage ファイルのパス (/output/SearchLog.txt など) を入力します。Enter an Azure Storage file path (for example, /output/SearchLog.txt).

このファイルは、VS Code で開きます。The file opens in VS Code.

ストレージファイルのプレビュー手順と結果

ファイルをプレビューする別の方法として、スクリプト エディターでファイルの完全なパスまたは相対パスの右クリック メニューを使用する方法があります。Another way to preview the file is through the shortcut menu on the file's full path or the file's relative path in the script editor.

ファイルまたはフォルダーをアップロードUpload a file or folder

  1. スクリプト エディターを右クリックし、 [ファイルのアップロード] または [フォルダーをアップロード] を選択します。Right-click the script editor and select Upload File or Upload Folder.
  2. 1 つ以上のファイル ( [ファイルのアップロード] を選択した場合) またはフォルダー全体 ( [フォルダーをアップロード] を選択した場合) を選択します。Choose one file or multiple files if you selected Upload File, or choose the whole folder if you selected Upload Folder. [アップロード] を選択します。Then select Upload.
  3. 一覧でストレージフォルダーを選択するか、 [Enter a path] または [Browse from root path] をクリックします。Choose the storage folder in the list, or select Enter a path or Browse from root path. (ここでは、例として [Enter a path] を使用しています。)(We're using Enter a path as an example.)
  4. Data Lake Analytics アカウントを選択します。Select your Data Lake Analytics account.
  5. ストレージ フォルダーのパスを参照もしくは入力します (/output/ など)。Browse to or enter the storage folder path (for example, /output/).
  6. [Choose Current Folder] をクリックして、アップロード先を指定します。Select Choose Current Folder to specify your upload destination.

ファイルまたはフォルダーをアップロードする手順と結果

ファイルをストレージにアップロードする別の方法として、スクリプト エディターでファイルの完全なパスまたは相対パスのショートカット メニューを使用する方法があります。Another way to upload files to storage is through the shortcut menu on the file's full path or the file's relative path in the script editor.

アップロードの状態の監視ができます。You can monitor the upload status.

ファイルをダウンロードするDownload a file

ファイルは、コマンド ADL:Download File または ADL:Download File (Advanced) を使用してダウンロードできます。You can download a file by using the command ADL: Download File or ADL: Download File (Advanced).

ADL:Download File (Advanced) コマンドを使用してファイルをダウンロードするにはTo download a file through the ADL: Download File (Advanced) command

  1. スクリプト エディターを右クリックし、 [Download File (Advanced)](ファイルのダウンロード (詳細)) を選択します。Right-click the script editor, and then select Download File (Advanced).

  2. VS Code に、JSON ファイルが表示されます。VS Code displays a JSON file. ファイルのパスを入力して、複数のファイルを同時にダウンロードできます。You can enter file paths and download multiple files at the same time. 手順が [出力] ウィンドウに表示されます。Instructions are displayed in the Output window. ファイルのダウンロードを続行するには、Ctrl + S キーを押して JSON ファイルを保存します。To proceed to download the file or files, save (Ctrl+S) the JSON file.

    ファイルのダウンロード用のパスつき JSON ファイル

[出力] ウィンドウに、ファイル ダウンロードの状態が表示されます。The Output window displays the file download status.

ダウンロードの状態が表示された出力ウィンドウ

ダウンロードの状態の監視ができます。You can monitor the download status.

ADL:Download File コマンドを使用してファイルをダウンロードするにはTo download a file through the ADL: Download File command

  1. スクリプト エディターを右クリックし、 [ファイルのダウンロード] を選択してから、 [フォルダーの選択] ダイアログ ボックスでダウンロード先フォルダーを選択します。Right-click the script editor, select Download File, and then select the destination folder from the Select Folder dialog box.

  2. 一覧でフォルダーを選択するか、 [Enter a path] または [Browse from root path] をクリックします。Choose the folder in the list, or select Enter a path or Browse from root path. (ここでは、例として [Enter a path] を使用しています。)(We're using Enter a path as an example.)

  3. Data Lake Analytics アカウントを選択します。Select your Data Lake Analytics account.

  4. ストレージ フォルダーのパス (/output/ など) を参照または入力し、 ダウンロードするファイルを選択します。Browse to or enter the storage folder path (for example, /output/), and then choose a file to download.

ファイルをダウンロードする手順と結果

ストレージファイルをダウンロードする別の方法として、スクリプト エディターでファイルの完全なパスまたは相対パスのショートカット メニューを使用する方法があります。Another way to download storage files is through the shortcut menu on the file's full path or the file's relative path in the script editor.

ダウンロードの状態の監視ができます。You can monitor the download status.

ストレージ タスクの状態の確認Check storage tasks' status

アップロードとダウンロードの状態は、ステータス バーに表示されます。The upload and download status appears on the status bar. ステータス バーを選択すると、出力タブに状態が表示されます。Select the status bar, and then the status appears on the OUTPUT tab.

ステータス バーと出力の詳細

エクスプローラーから Azure Data Lake Analytics と統合するIntegrate with Azure Data Lake Analytics from the explorer

ログインすると、 [AZURE DATALAKE] の下の左側のウインドウに、現在の Azure アカウントに含まれるサブスクリプションがすべて一覧表示されます。After you log in, all the subscriptions for your Azure account are listed in the left pane, under AZURE DATALAKE.

Data Lake エクスプローラー

Data Lake Analytics メタデータへのナビゲーションData Lake Analytics metadata navigation

Azure サブスクリプションの展開。Expand your Azure subscription. U-SQL データベースノードの下で、U SQL データベースを参照することができ、スキーマ資格情報アセンブリテーブル、およびインデックスなどのフォルダーが表示されます。Under the U-SQL Databases node, you can browse through your U-SQL database and view folders like Schemas, Credentials, Assemblies, Tables, and Index.

Azure Data Lake Analytics メタデータのエンティティData Lake Analytics metadata entity management

U-SQL データベースを展開します。Expand U-SQL Databases. データベース、スキーマ、テーブル、テーブル型、インデックス、または統計を作成するには、対応するノードを右クリックして、ショートカット メニューの作成するスクリプトを選択します。You can create a database, schema, table, table type, index, or statistic by right-clicking the corresponding node, and then selecting Script to Create on the shortcut menu. 開いているスクリプトページで、必要に応じてスクリプトを編集します。On the opened script page, edit the script according to your needs. その後、これを右クリックし、 [ADL:Submit Job] を選択して、ジョブを送信します。Then submit the job by right-clicking it and selecting ADL: Submit Job.

アイテムの作成が完了したら、ノードを右クリックし、最新の情報に更新を選択してアイテムを表示します。After you finish creating the item, right-click the node and then select Refresh to show the item. 右クリックして [削除] を選択して、アイテムを削除することもできます。You can also delete the item by right-clicking it and then selecting Delete.

Data Lake エクスプローラーのショートカットメニューの「作成するスクリプト」コマンド

新しい項目のスクリプトページ

Data Lake Analytics アセンブリの登録Data Lake Analytics assembly registration

[アセンブリ] ノードを右クリックして、 [アセンブリを登録] をクリックしてアセンブリを関連するデータベースに登録できます。You can register an assembly in the corresponding database by right-clicking the Assemblies node, and then selecting Register assembly.

アセンブリノードのショートカット メニューの「アセンブリの登録」コマンド

エクスプローラーから Azure Data Lake Store と統合するIntegrate with Azure Data Lake Store from the explorer

Data Lake Storeを参照する:Browse to Data Lake Store:

  • フォルダー ノードを右クリックし、ショートカット メニューの [更新][削除][アップロード][フォルダーをアップロード][相対パスのコピー] および [完全パスのコピー] コマンドを実行できます。You can right-click the folder node and then use the Refresh, Delete, Upload, Upload Folder, Copy Relative Path, and Copy Full Path commands on the shortcut menu.

    Data Lake エクスプ ローラーのフォルダー ノードのショートカット メニューのコマンド

  • ファイル ノードを右クリックし、ショートカット メニューのコマンド [プレビュー][ダウンロード][削除][EXTRACT スクリプトの作成] (CSV、TSV、および TXT ファイルでのみ使用可能)、 [相対パスのコピー] および [完全パスのコピー] を実行できます。You can right-click the file node and then use the Preview, Download, Delete, Create EXTRACT Script (available only for CSV, TSV, and TXT files), Copy Relative Path, and Copy Full Path commands on the shortcut menu.

    Data Lake エクスプ ローラーのファイル ノードのショートカット メニューのコマンド

エクスプローラーから Azure BLOB ストレージ と統合するIntegrate with Azure Blob storage from the explorer

BLOB ストレージの参照:Browse to Blob storage:

  • BLOB コンテナー ノードを右クリックし、ショートカット メニューのコマンド [最新の情報に更新][BLOB コンテナーの削除] 、および [BLOB のアップロード] を実行できます。You can right-click the blob container node and then use the Refresh, Delete Blob Container, and Upload Blob commands on the shortcut menu.

    Blob ストレージの blob コンテナー ノードのショートカット メニューのコマンド

  • フォルダー ノードを右クリックし、ショートカット メニューのコマンド [最新の情報に更新] および [BLOB のアップロード] を実行できます。You can right-click the folder node and then use the Refresh and Upload Blob commands on the shortcut menu.

    BLOB ストレージの フォルダー ノードのショートカット メニューのコマンド

  • ファイル ノードを右クリックし、ショートカット メニューのコマンド [プレビュー/編集][ダウンロード][削除][EXTRACT スクリプトの作成] (CSV、TSV、および TXT ファイルでのみ使用可能)、 [相対パスのコピー] および [完全パスのコピー] を実行できます。You can right-click the file node and then use the Preview/Edit, Download, Delete, Create EXTRACT Script (available only for CSV, TSV, and TXT files), Copy Relative Path, and Copy Full Path commands on the shortcut menu.

    BLOB ストレージの ファイル ノードのショートカット メニューのコマンド

ポータルで、Data Lake エクスプ ローラーを開くOpen the Data Lake explorer in the portal

  1. Ctrl + Shift + P キーを押してコマンド パレットを開きます。Select Ctrl+Shift+P to open the command palette.
  2. Open Web Azure Storage Explorer」と入力するか、スクリプト エディターで相対パスまたは完全なパスを右クリックして、 [Open Web Azure Storage Explorer] を選択します。Enter Open Web Azure Storage Explorer or right-click a relative path or the full path in the script editor, and then select Open Web Azure Storage Explorer.
  3. Data Lake Analytics アカウントを選択します。Select a Data Lake Analytics account.

Data Lake Tools によって、Azure Portal に Azure Storage パスが表示されます。Data Lake Tools opens the Azure Storage path in the Azure portal. そのパスを見つけて Web からファイルをプレビューすることができます。You can find the path and preview the file from the web.

その他の機能Additional features

Data Lake Tools for VS Code では、以下の各機能がサポートされています。Data Lake Tools for VS Code supports the following features:

  • IntelliSense オートコンプリート:キーワード、メソッド、変数などの項目の付近にポップアップ ウィンドウで修正候補が表示されます。IntelliSense autocomplete: Suggestions appear in pop-up windows around items like keywords, methods, and variables. オブジェクトの種類ごとに異なるアイコンで表されます:Different icons represent different types of objects:

    • Scala データ型Scala data type

    • 複合データ型Complex data type

    • 組み込みの UDTBuilt-in UDTs

    • .NET コレクションおよびクラス.NET collection and classes

    • C# 式C# expressions

    • 組み込みの C# UDF、UDO、UDAAGBuilt-in C# UDFs, UDOs, and UDAAGs

    • U-SQL 関数U-SQL functions

    • U-SQL ウィンドウ化関数U-SQL windowing functions

      IntelliSense オブジェクトの種類

  • Data Lake Analytics メタデータでの IntelliSense オートコンプリート:Data Lake Tools によって Data Lake Analytics メタデータ情報がローカルにダウンロードされます。IntelliSense autocomplete on Data Lake Analytics metadata: Data Lake Tools downloads the Data Lake Analytics metadata information locally. IntelliSense 機能は、Data Lake Analytics メタデータからオブジェクトを自動的に作成します。The IntelliSense feature automatically populates objects from the Data Lake Analytics metadata. これらのオブジェクトには、データベース、スキーマ、テーブル、ビュー、テーブル値関数、プロシージャ、および C# アセンブリが含まれます。These objects include the database, schema, table, view, table-valued function, procedures, and C# assemblies.

    IntelliSense のメタデータ

  • IntelliSense エラー マーカー:Data Lake Tools によって U-SQL と C# の編集エラーが下線で示されます。IntelliSense error marker: Data Lake Tools underlines editing errors for U-SQL and C#.

  • 構文の強調表示:Data Lake Tools では色を使用して、変数、キーワード、データ型、関数などの項目を区別します。Syntax highlights: Data Lake Tools uses colors to differentiate items like variables, keywords, data types, and functions.

    さまざまな色で表示された構文

注意

Azure Data Lake Tools for Visual Studio バージョン 2.3.3000.4 以降にアップグレードすることをお勧めしています。We recommend that you upgrade to Azure Data Lake Tools for Visual Studio version 2.3.3000.4 or later. 以前のバージョンはダウンロードできなくなり、非推奨になっています。The previous versions are no longer available for download and are now deprecated.

次のステップNext steps