AADRM PowerShell モジュールのインストールInstalling the AADRM PowerShell module

適用対象: Azure Information ProtectionOffice 365Applies to: Azure Information Protection, Office 365

以下の情報は、Azure Information Protection から Azure Rights Management サービス用 Windows PowerShell をインストールする場合に役立ちます。Use the following information to help you install the Windows PowerShell module for the Azure Rights Management service from Azure Information Protection. このモジュールの名前は AADRM です。The name of this module is AADRM.

この PowerShell モジュールを使用すると、インターネットに接続され、次のセクションでリストする前提条件を満たす任意のコンピューターを使って、コマンドラインから Azure Rights Management サービスを管理できます。You can use this PowerShell module to administer the Azure Rights Management service from the command line by using any computer that has an Internet connection and that meets the prerequisites listed in the next section. Azure の権限管理Azure Rights Management 用の Windows PowerShell は、自動化のためのスクリプトをサポートし、高度な構成シナリオのために必要になる場合があります。Windows PowerShell for Azure の権限管理Azure Rights Management supports scripting for automation or might be necessary for advanced configuration scenarios. 管理タスクと、モジュールがサポートする構成に関する詳細については、「Windows PowerShell を使用した Azure Rights Management の管理」を参照してください。For more information about the administration tasks and configurations that the module supports, see Administering Azure Rights Management by Using Windows PowerShell.

必要条件Prerequisites

この表には、Azure Information Protection から Azure Rights Management サービス用 AADRM PowerShell モジュールをインストールして使用するための前提条件が一覧表示されています。This table lists the prerequisites to install and use the AADRM PowerShell module for the Azure Rights Management service from Azure Information Protection.

要件Requirement 詳細情報More information
Windows PowerShell の最小バージョン: 3.0Minimum version of Windows PowerShell: 3.0 PowerShell セッションで「$PSVersionTable」と入力すると、実行中の Windows PowerShell のバージョンを確認できます。You can confirm the version of Windows PowerShell that you are running by typing $PSVersionTable in a PowerShell session.

新しいバージョンの Windows PowerShell をインストールする必要がある場合は、「既存の Windows PowerShell をアップグレードする」を参照してください。If you need to install a later version of Windows PowerShell, see Upgrading existing Windows PowerShell.
Microsoft .NET Framework の最小バージョン: 4.5Minimum version of the Microsoft .NET Framework: 4.5

注: 最近のオペレーティング システムには、このバージョンの Microsoft .NET Framework が付属しています。このため、手動でインストールする必要があるのは、クライアントのオペレーティング システムが Windows 8.0 よりも前のバージョンの場合か、サーバーのオペレーティング システムが Windows Server 2012 よりも前のバージョンの場合に限ります。Note: This version of the Microsoft .NET Framework is included with the later operating systems, so you should need to manually install it only if your client operating system is less than Windows 8.0 or your server operating system is less than Windows Server 2012.
Microsoft .NET Framework の最小バージョンがまだインストールされていない場合は、Microsoft .NET Framework 4.5 をダウンロードできます。If the minimum version of the Microsoft .NET Framework is not already installed, you can download Microsoft .NET Framework 4.5.

この最小バージョンの Microsoft .NET Framework は、AADRM モジュールで使用されるクラスの一部で必要になります。This minimum version of the Microsoft .NET Framework is required for some of the classes that the AADRM module uses.

AADRM モジュールのバージョン 2.5.0.0 以降、Microsoft Online Services サインイン アシスタントは必要なくなりました。Starting with version 2.5.0.0 of the AADRM module, the Microsoft Online Services Sign-In Assistant is no longer required.

注意

Azure Rights Management 管理ツールで AADRM モジュールのバージョンをインストールした場合、PowerShell ギャラリーから AADRM モジュールの最新バージョンをインストールする前に、[プログラムと機能] を使って Windows Azure AD Rights Management の管理をアンインストールしてください。If you installed a version of the AADRM module with the Azure Rights Management Administration Tool, use Programs and Features to uninstall Windows Azure AD Rights Management Administration before you install the latest version of the AADRM module from the PowerShell Gallery.

AADRM モジュールをインストールする方法How to install the AADRM module

AADRM モジュールは PowerShell ギャラリーに移動しており、Microsoft ダウンロード センターからは入手できません。The AADRM module has moved to the PowerShell Gallery and is no longer available from the Microsoft Download Center.

PowerShell ギャラリーを初めてお使いの場合は、「PowerShell ギャラリーの概要」を参照してください。If you're new to the PowerShell Gallery, see Get Started with the PowerShell Gallery. PowerShellGet モジュールと NuGet プロバイダーのインストールを含む、ギャラリー要件の手順に従います。Follow the instructions for the gallery requirements, which include installing the PowerShellGet module and the NuGet provider.

PowerShell ギャラリーで AADRM モジュールの詳細を確認するには、AADRM に関するページを参照してください。To see details about the AADRM module on the PowerShell Gallery, visit the AADRM page.

AADRM モジュールをインストールするには、[管理者として実行] オプションを使用して PowerShell セッションを開始し、次のように入力します。To install the AADRM module, start a PowerShell session with the Run as Administrator option, and type:

Install-Module -Name AADRM

信頼されていないリポジトリからのインストールについての警告が表示される場合は、Y キーを押して確認できます。If you are warned about installing from an untrusted repository, you can press Y to confirm. または、N キーを押し、Set-PSRepository -Name PSGallery -InstallationPolicy Trusted コマンドを使って信頼されたリポジトリとして PowerShell ギャラリーを構成した後、コマンドを再び実行して AADRM モジュールをインストールします。Or, press N and configure the PowerShell Gallery as a trusted repository by using the command Set-PSRepository -Name PSGallery -InstallationPolicy Trusted and then rerun the command to install the AADRM module.

以前のバージョンの AADRM モジュールをギャラリーからインストールした場合は、次のように入力して最新バージョンに更新します。If you have a previous version of the AADRM module installed from the Gallery, update it to the latest by typing:

Update-Module -Name AADRM

次の手順Next steps

Windows PowerShell セッションで、インストールされているモジュールのバージョンを確認します。In a Windows PowerShell session, confirm the version of the installed module. このチェックは、以前のバージョンからアップグレードした場合に特に重要です。This check is particularly important if you upgraded from an older version:

(Get-Module AADRM –ListAvailable).Version

注: このコマンドが失敗した場合は、最初に Import-module AADRM を実行します。Note: If this command fails, first run Import-Module AADRM.

使用可能なコマンドレットを確認するには、次のコマンドを入力します。To see which cmdlets are available, type the following:

Get-Command -Module AADRM

Get-Help <cmdlet_name> コマンドを使って特定のコマンドレットのヘルプをご覧ください。また、-online パラメーターを使って Microsoft のドキュメント サイトで最新のヘルプをご覧ください。Use the Get-Help <cmdlet_name> command to see the Help for a specific cmdlet, and use the -online parameter to see the latest help on the Microsoft documentation site. 次に例を示します。For example:

Get-Help Connect-AadrmService -online

詳細情報:For more information:

Azure の権限管理Azure Rights Management サービスを構成するコマンドを実行するには、Connect-AadrmService コマンドレットを使用して前もってサービスに接続しておく必要があります。Before you can run any commands that configure the Azure の権限管理Azure Rights Management service, you must connect to the service by using the Connect-AadrmService cmdlet. 構成コマンドの実行が完了したら、ベスト プラクティスとしては、Disconnect-AadrmService コマンドレットを使用してサービスとの接続を切断します。When you have finished running your configuration commands, as a best practice, disconnect from the service by using the Disconnect-AadrmService cmdlet. 切断しない場合は、非アクティブ状態の後に自動的に切断されます。If you do not disconnect, the connection is automatically disconnected after a period of inactivity. この自動切断の挙動によって、PowerShell セッションで再接続が必要になる場合があります。Because of the automatic disconnection behavior, you might find that you need to occasionally reconnect in a PowerShell session.

注意

Azure Rights Management サービスがまだアクティブ化されていない場合は、サービスに接続した後で、Enable-Aadrm コマンドレットを使用してアクティブ化することができます。If the Azure Rights Management service is not yet activated, you can do this after you have connected to the service, by using the Enable-Aadrm cmdlet.

コメントComments

コメントを投稿する前に、内部ルールを参照してください。Before commenting, we ask that you review our House rules.