Azure Toolkit for Eclipse を使用して Spring Boot アプリを Docker コンテナーとして発行するPublish a Spring Boot app as a Docker container by using the Azure Toolkit for Eclipse

Spring Framework は Java 開発者のエンタープライズ レベルのアプリケーション作成を支援するオープンソース ソリューションです。The Spring Framework is an open-source solution that helps Java developers create enterprise-level applications. このプラットフォームで構築される特に知られたプロジェクトの 1 つが Spring Boot です。これによって、スタンドアロンの Java アプリケーションの作成方法が簡略化されます。One of the more-popular projects that is built on top of that platform is Spring Boot, which provides a simplified approach for creating standalone Java applications.

Docker は、開発者が、コンテナーで実行されるアプリケーションのデプロイ、スケーリング、管理を自動化することを支援するオープン ソース ソリューションです。Docker is an open-source solution that helps developers automate the deployment, scaling, and management of their applications that are running in containers.

このチュートリアルでは、Azure Toolkit for Eclipse を使用して Spring Boot アプリケーションを Docker コンテナーとして Microsoft Azure にデプロイする手順について説明します。This tutorial walks you through the steps to deploy a Spring Boot application as a Docker container to Microsoft Azure by using the Azure Toolkit for Eclipse.

前提条件Prerequisites

この記事の手順を完了するには、Azure Toolkit for Eclipse をインストールする必要があります。これには、次のソフトウェア コンポーネントが必要です。To complete the steps in this article, you will need to install the Azure Toolkit for Eclipse, which requires the following software components:

注意

Eclipse Marketplace の Azure Toolkit for Eclipse に関するページに、このツールキットと互換性のあるビルドが一覧表示されています。The Azure Toolkit for Eclipse page at the Eclipse Marketplace lists the builds that are compatible with the toolkit.

既定の Spring Boot Docker リポジトリの複製Clone the default Spring Boot Docker repository

パブリック リポジトリのインポートImport the public repository

次の手順では、IntelliJ を使用して、ローカル コンピューターに Spring Boot Docker リポジトリを複製する方法について説明します。The following steps walk you through cloning the Spring Boot Docker repository to your local computer by using IntelliJ. コマンド ラインを使用したい場合は、Azure Container Service で Spring Boot アプリケーションを Linux にデプロイする方法に関するページを参照してください。If you want to use a command line, see Deploy a Spring Boot application on Linux in Azure Container Service.

  1. Eclipse を開きます。Open Eclipse.

  2. [ファイル] > [インポート] をクリックします。Click File > Import.

    [ファイル] の [インポート] メニュー

  3. [インポート] ダイアログ ボックスが開いたら、次の手順を実行します。When the Import dialog box opens:

    a.a. [Git] を展開します。Expand Git.

    b.b. [Projects from Git](Git のプロジェクト) を選択します。Select Projects from Git.

    c.c. [次へ] をクリックします。Click Next.

    [インポート] ダイアログ ボックス

  4. [Select Repository Source](リポジトリ ソースの選択) ページで次の手順を実行します。On the Select Repository Source page:

    a.a. [Clone URI](URI の複製) を選択します。Select Clone URI.

    b.b. [次へ] をクリックします。Click Next.

    リポジトリ ソース ページの選択

  5. [Source Git Repository](ソース Git リポジトリ) ページで次の手順を実行します。On the Source Git Repository page:

    a.a. [URI] に「https://github.com/spring-guides/gs-spring-boot-docker.git」と入力します。For URI, enter https://github.com/spring-guides/gs-spring-boot-docker.git. これで [Host](ホスト)[Repository path](リポジトリ パス) の各フィールドに正しい値が設定されます。This step should automatically populate the Host and Repository path fields with the correct values.

    b.b. Spring Boot リポジトリは公開されるため、Git のユーザー名とパスワードを入力する必要はありません。The Spring Boot repository is public, so you should not have to enter your Git username and password.

    c.c. [次へ] をクリックします。Click Next.

    [Source Git Repository](ソース Git リポジトリ) ページ

  6. [Branch Selection](ブランチの選択) ページで [Next](次へ) をクリックします。On the Branch Selection page, click Next.

    [Branch Selection](ブランチの選択) ページ

  7. [Local Destination](ローカルの保存先) ページで次の手順を実行します。On the Local Destination page:

    a.a. ローカル リポジトリを保存するローカル フォルダーを指定します。Specify the local folder where you want your local repo.

    b.b. [次へ] をクリックします。Click Next.

    [Local Destination](ローカルの保存先) ページ

  8. [Select a wizard to use for importing projects](プロジェクトのインポートに使用するウィザードの選択) ページで次の手順を実行します。On the Select a wizard to use for importing projects page:

    a.a. [Import as a general project](一般的なプロジェクトのインポート) を選択します。Select Import as a general project.

    b.b. [次へ] をクリックします。Click Next.

    [Select a wizard to use for importing projects](プロジェクトのインポートに使用するウィザードの選択) ページ

  9. [Import Projects](プロジェクトのインポート) ページで次の手順を実行します。On the Import Projects page:

    a.a. プロジェクト名を指定します。Specify your project name.

    b.b. [完了] をクリックします。Click Finish.

    [Import Projects](プロジェクトのインポート) ページ

  10. リポジトリの複製が完了すると、Eclipse にすべてのファイルが表示されます。When the repository is cloned successfully, you see all the files listed in Eclipse.

    ローカル リポジトリ

ローカル リポジトリからの Maven プロジェクトの作成Create a Maven project from your local repository

Spring Boot Docker リポジトリには、このチュートリアルで使用する完成した Maven プロジェクトが含まれています。The Spring Boot Docker repository contains a completed Maven project, which you will use for this tutorial.

  1. [ファイル] > [インポート] をクリックします。Click File > Import.

    [ファイル] メニューの [インポート] コマンド

  2. [インポート] ダイアログ ボックスが開いたら、次の手順を実行します。When the Import dialog box opens:

    a.a. [Maven] を展開します。Expand Maven.

    b.b. [Existing Maven Projects](既存の Maven プロジェクト) を選択します。Select Existing Maven Projects.

    c.c. [次へ] をクリックします。Click Next.

    [インポート] ダイアログ ボックス

  3. [Maven Projects](Maven プロジェクト) ページで次の手順を実行します。On the Maven Projects page:

    a.a. [Root Directory](ルート ディレクトリ) に、ローカル リポジトリの complete フォルダーを指定します。For Root Directory, specify the complete folder in your local repository.

    b.b. [Advanced](詳細) セクションを展開し、 [Name template](テンプレートの名前) にカスタムの名前を入力します。Expand the Advanced section, and enter a custom name for Name template.

    c.c. プロジェクトの pom.xml ファイルのボックスを選択します。Select the box for the pom.xml file in the project.

    d.d. [完了] をクリックします。Click Finish.

    [Maven Projects](Maven プロジェクト) ページ

  4. Maven プロジェクトが正常に開くと、Eclipse に 2 つ目のプロジェクトが表示されます。When the Maven project is opened successfully, you see a second project listed in Eclipse.

    ローカルの Maven プロジェクト

Maven での Spring Boot アプリのビルドBuild your Spring Boot app by using Maven

  1. Eclipse Project Explorer で、Maven プロジェクトを選択します。In the Eclipse Project Explorer, select the Maven project.

  2. [実行] > [Run As](プログラム名を指定して実行) > [Maven build](Maven ビルド) をクリックします。Click Run > Run As > Maven build.

    [Run As](プログラム名を指定して実行) の [Maven build](Maven ビルド) コマンド

  3. アプリケーションが正常にビルドされると、コンソール ウィンドウに状態が表示されます。When your application is successfully built, the console window shows the status.

    Maven ビルドの成功

Docker コンテナーを使用して Web アプリを Azure に発行するPublish your web app to Azure by using a Docker container

  1. Eclipse Project Explorer で、Maven プロジェクトを選択します。In the Eclipse Project Explorer, select the Maven project.

  2. Azure の [Publish](発行) メニューをクリックし、 [Publish as Docker container](Docker コンテナーとして発行) をクリックします。Click the Azure Publish menu, and then click Publish as Docker Container.

    [Publish as Docker Container](Docker コンテナーとして発行) コマンド

  3. [Deploy Docker Container on Azure](Azure への Docker コンテナーのデプロイ) ダイアログ ボックスが表示されたら、次の手順を実行します。When the Deploying Docker Container on Azure dialog box appears:

    a.a. カスタムの Docker イメージ名を入力します。Enter a custom Docker image name.

    b.b. [Artifact to deploy](デプロイするアーティファクト) に、ビルドした gs-spring-boot-docker-0.1.0.jar ファイルのパスを指定します。For Artifact to deploy, specify the path to the gs-spring-boot-docker-0.1.0.jar file you just built.

    Docker オプションの指定

    既存の Docker ホストがすべて表示されます。Any existing Docker hosts are displayed.

  4. 既存のホストへのデプロイを選択する場合は、スキップして手順 5 に進みます。If you choose to deploy to an existing host, you can skip to step 5. そうでない場合は、次の手順に従ってホストを作成します。Otherwise, use the following steps to create a host:

    a.a. [追加] をクリックします。Click Add.

    新しい Docker ホストの追加

    b.b. [Create Docker Host](Docker ホストの作成) ダイアログ ボックスが表示されたら、新しい Docker ホストに既定値をそのまま使用するか、カスタム設定を指定できますWhen the Create Docker Host dialog box appears, you can choose to accept the defaults, or you can specify any custom settings for your new Docker host. (さまざまな設定について詳しくは、「Azure Toolkit for IntelliJ を使用して Web アプリを Docker コンテナーとして発行する」を参照してください)。使用する設定を指定したら、 [Next](次へ) をクリックします。(For detailed descriptions of the various settings, see Publish a web app as a Docker container by using the Azure Toolkit for IntelliJ.) Click Next when you have specified which settings to use.

    Docker ホスト オプションの指定

    c.c. Azure Key Vault の既存のログイン資格情報を使用することも、新しい Docker ログイン資格情報を入力することもできます。You can choose to use existing login credentials from an Azure key vault, or you can choose to enter new Docker login credentials. オプションを指定したら、 [Finish](完了) をクリックします。Click Finish when you have specified your options.

    Docker ホストの資格情報の指定

  5. Docker ホストを選択し、 [次へ] をクリックします。Select your Docker host, and then click Next.

    使用する Docker ホストの選択

  6. [Deploying Docker Container on Azure](Azure への Docker コンテナーのデプロイ) ダイアログ ボックスの最後のページで、次のオプションを指定します。On the last page of the Deploying Docker Container on Azure dialog box, specify the following options:

    a.a. Docker コンテナーをホストするコンテナーのカスタム名を指定するか、既定値をそのまま使用することができます。You can choose to specify a custom name for the container that will host your Docker container, or you can accept the default.

    b.b. " [外部ポート] : [内部ポート] " という構文で、Docker ホストの TCP ポートを入力します。Enter the TCP ports for your docker host by using the following syntax: [external port]:[internal port]. たとえば "80:8080" では、外部ポート "80" と既定の内部 Spring Boot ポート "8080" が指定されます。For example, 80:8080 specifies an external port of 80 and the default internal Spring Boot port of 8080.

    内部ポートをカスタマイズした場合 (application.yml ファイルを編集するなどして)、Azure で正しいルーティングが実現するようポート番号を指定する必要があります。If you have customized your internal port (for example, by editing the application.yml file), you need to specify the port number for the correct routing to occur in Azure.

    c.c. これらのオプションを構成したら、 [完了] をクリックします。After you configure these options, click Finish.

    Azure への Docker コンテナーのデプロイ

  7. Azure Toolkit による発行が完了したら、Azure Activity Log の状態が発行済みになります。When the Azure Toolkit has finished publishing, the Azure Activity Log displays Published for the status.

    正常にデプロイされた Docker ホスト

次の手順Next steps

Docker の他のリソースについては、公式の Docker の Web サイトを参照してください。For additional resources for Docker, see the official Docker website.

バグを報告したり、新機能をリクエストしたりするには、当社の GitHub リポジトリで問題を作成してください。To report bugs or request new features, create issues on our GitHub repository. または、Stack Overflow でタグ azure-java-tools を使用して質問してください。Or, ask questions on Stack Overflow with tag azure-java-tools.

Azure での Java の使用方法の詳細については、以下のリンクを参照してください。For more information about using Java with Azure, see the following links: