IDE を使用する Azure Machine Learning Workbench の構成方法How to configure Azure Machine Learning Workbench to work with an IDE

Azure Machine Learning Workbench は、一般的な Python IDE (統合開発環境) と動作するように構成することができます。Azure Machine Learning Workbench can be configured to work with popular Python IDEs (Integrated Development Environment). この構成を行うことで、データの準備、コードの作成、追跡と操作化の実行などを行き来する、スムーズなデータ サイエンス開発エクスペリエンスを可能にします。It enables a smooth data science development experience moving between data preparation, code authoring, run tracking and operationalization. 現在サポートされている IDE は次のとおりです。Currently the supported IDEs are:

  • Microsoft Visual Studio CodeMicrosoft Visual Studio Code
  • JetBrain PyCharmJetBrain PyCharm

ワークベンチの構成Configure workbench

  1. アプリの左上隅にある [ファイル] メニューをクリックします。Click on the File menu in the top left corner of the app.
  2. ポップアップから [Configure Project IDE](プロジェクト IDE の構成) オプションを選択します。Select the Configure Project IDE option from the flyout
  3. [名前] フィールドに、VS Code または PyCharm で入力します (名前は任意)。Type in VS Code or PyCharm in the Name field (the name is arbitrary)
  4. [実行パス] に、IDE 実行可能ファイルの場所 (実行可能ファイル名と拡張子を含む完全パス) を入力します。Enter the location to the IDE executable (complete with the executable name and extension) in Execution Path

Visual Studio Code の既定のインストール パスDefault install path for Visual Studio Code

  • Windows 32-bit - C:\Program Files (x86)\Microsoft VS Code\Code.exeWindows 32-bit - C:\Program Files (x86)\Microsoft VS Code\Code.exe
  • Windows 64-bit - C:\Program Files\Microsoft VS Code\Code.exeWindows 64-bit - C:\Program Files\Microsoft VS Code\Code.exe
  • macOS - アプリのパス (例: /Applications/Visual Studio Code.app) を選択すると、アプリ側で残りのパスを追加します。macOS - select the .app path, for example /Applications/Visual Studio Code.app, and the app appends the rest of the path for you. 実行可能ファイルの完全パスは、既定では /Applications/Visual Studio Code.app/Contents/Resources/app/bin/code です。The full path to the executable by default is /Applications/Visual Studio Code.app/Contents/Resources/app/bin/code. VS Code で Shell Command: Install 'code' command in PATH コマンドを実行した場合、その VS Code スクリプトは /usr/local/bin/code でも参照することができます。If you have executed the Shell Command: Install 'code' command in PATH command in VS Code, then you can also reference the VS Code script at /usr/local/bin/code

PyCharm の既定のインストール パスDefault install path for PyCharm

  • Windows 32-bit - C:\Program Files (x86)\JetBrains\PyCharm Community Edition 2017.2.1\bin\pycharm.exeWindows 32-bit - C:\Program Files (x86)\JetBrains\PyCharm Community Edition 2017.2.1\bin\pycharm.exe.
  • Windows 64-bit - C:\Program Files\JetBrains\PyCharm Community Edition 2017.2.1\bin\pycharm64.exeWindows 64-bit - C:\Program Files\JetBrains\PyCharm Community Edition 2017.2.1\bin\pycharm64.exe.
  • macOS - アプリのパス (例: /Applications/PyCharm CE.app) を選択すると、アプリ側で残りのパスを追加します。macOS - select the .app path, for example “/Applications/PyCharm CE.app”, and the app appends the rest of the path for you. 実行可能ファイルの完全パスは、既定では /Applications/PyCharm CE.app/Contents/MacOS/pycharm です。The full path to the executable by default is /Applications/PyCharm CE.app/Contents/MacOS/pycharm. また、bin フォルダー /usr/local/bin/charmにも PyCharm があります。You may also find PyCharm at the bin folder, /usr/local/bin/charm

IDE でプロジェクトを開くOpen project in IDE

構成が完了したら、Azure Machine Learning Workbench の [ファイル] メニューを開いてから [プロジェクトを開く (<IDE_Name>)] をクリックして、Azure Machine Learning プロジェクトを開くことができます。Once the configuration is complete, you can open an Azure Machine Learning project by opening the File menu in Azure Machine Learning Workbench, then click Open Project (<IDE_Name>). この操作により、構成済みの IDE 内に現在のアクティブなプロジェクトが開かれます。This action opens the current active project in the configured IDE. 注: プロジェクトに参加していない場合は、[プロジェクトを開く (<IDE_Name>)] は無効になります。Note: If you are not in a project, the Open Project (<IDE_Name>) will be disabled.

Visual Studio Code での統合ターミナルの構成Configuring the integrated terminal in Visual Studio Code

WindowsWindows

既定のシェルが、PowerShell ではなく cmd になるようにオーバーライドしました。We have overridden the default shell to be cmd instead of PowerShell. [プロジェクトを開く (<IDE_Name>)] をクリックすると、プロンプトが表示されます。On clicking on Open Project (<IDE_Name>), you see a prompt:

シェル: C:\windows\System32\cmd.exe (ワークスペース設定として定義されている) をターミナルで起動することを許可しますか?Do you allow shell: C:\windows\System32\cmd.exe (defined as a workspace setting) to be launched in the terminal?

yes と応答し、シェルが Azure ML Workbench コマンドライン インターフェイスとシームレスに動作するよう構成することを許可します。Answer yes to allow configuring the shell to work seamlessly with Azure ML Workbench command-line interface.

MacMac

Mac で Visual Studio Code の統合ターミナルを使用して az コマンドを実行するには、PATH を、terminal.integrated.env.osx キーでプロジェクトの .vscode/settings.json ファイルの PATH と同じ値になるように手動で設定する必要があります。To run an az command using Visual Studio Code's integrated terminal on Mac, you need to manually set the PATH to be the same value as PATH in the project's .vscode/settings.json file under the key terminal.integrated.env.osx. ターミナルで次のコマンドを実行すると、これを行うことができます: PATH=<PATH in .vscode/settings>You can do so by running the following command in the terminal: PATH=<PATH in .vscode/settings>