C# および Visual Studio Code の使用を開始するGet Started with C# and Visual Studio Code

.NET Core は、Windows、Linux および macOS で実行されるアプリケーションを作成するための、高速でモジュール型のプラットフォームを提供します。.NET Core gives you a fast and modular platform for creating applications that run on Windows, Linux, and macOS. Visual Studio Code を C# 拡張機能とともに使用して、C# IntelliSense の完全サポート (スマート コード補完) とデバッグによる強力な編集機能をご活用ください。Use Visual Studio Code with the C# extension to get a powerful editing experience with full support for C# IntelliSense (smart code completion) and debugging.

必須コンポーネントPrerequisites

  1. Visual Studio Code のインストール。Install Visual Studio Code.
  2. .NET Core SDK のインストール。Install the .NET Core SDK.
  3. Visual Studio Code の C# 拡張機能のインストール。Install the C# extension for Visual Studio Code. Visual Studio Code に拡張機能をインストールする方法については、VS Code Extension Marketplace を参照してください。For more information about how to install extensions on Visual Studio Code, see VS Code Extension Marketplace.

Hello WorldHello World

.NET Core でシンプルな "Hello World" プログラムを作成してみましょう。Let's get started with a simple "Hello World" program on .NET Core:

  1. プロジェクトを開くOpen a project:

    • Visual Studio Code を開きます。Open Visual Studio Code.

    • 左側のメニューで [エクスプローラー] アイコンをクリックし、[フォルダーを開く] をクリックします。Click on the Explorer icon on the left menu and then click Open Folder.

    • メイン メニューから [ファイル][フォルダーを開く] の順に選択し、C# プロジェクトを保存するフォルダーを開き、[フォルダーの選択] をクリックします。Select File > Open Folder from the main menu to open the folder you want your C# project to be in and click Select Folder. ここで、Hello World という名前のプロジェクトのフォルダーを作成します。For our example, we're creating a folder for our project named HelloWorld.

      VSCodeOpenFolder

  2. C# プロジェクトを初期化するInitialize a C# project:

    • Visual Studio Code から統合ターミナルを開きます。メイン メニューで [表示][統合端末] の順に選択してください。Open the Integrated Terminal from Visual Studio Code by selecting View > Integrated Terminal from the main menu.

    • ターミナル ウィンドウで、dotnet new console と入力します。In the terminal window, type dotnet new console.

    • このコマンドで、フォルダーに HelloWorld.csproj という名前の C# プロジェクト ファイルとともに、単純な "Hello World" プログラムが既に書き込まれた Program.cs ファイルが作成されます。This command creates a Program.cs file in your folder with a simple "Hello World" program already written, along with a C# project file named HelloWorld.csproj.

      dotnet new コマンド

  3. ビルド資産を解決するResolve the build assets:

    • .NET Core 1.x の場合、「dotnet restore」と入力します。For .NET Core 1.x, type dotnet restore. dotnet restore を実行すると、プロジェクトのビルドに必要な .NET Core パッケージにアクセスします。Running dotnet restore gives you access to the required .NET Core packages that are needed to build your project.

      dotnet restore コマンド

      注意

      .NET Core 2.0 以降、dotnet restore を実行する必要がなくなりました。dotnet newdotnet builddotnet run のような、復元を必要とするあらゆるコマンドによって暗黙的に実行されるためです。Starting with .NET Core 2.0, you don't have to run dotnet restore because it's run implicitly by all commands that require a restore to occur, such as dotnet new, dotnet build and dotnet run. Azure DevOps Services の継続的インテグレーション ビルドなど、明示的な復元が合理的となる一部のシナリオや、復元の時刻を明示的に制御する必要があるビルド システムでは、引き続き有効なコマンドとなります。It's still a valid command in certain scenarios where doing an explicit restore makes sense, such as continuous integration builds in Azure DevOps Services or in build systems that need to explicitly control the time at which the restore occurs.

  4. "Hello World" プログラムを実行するRun the "Hello World" program:

    • dotnet run」と入力します。Type dotnet run.

      dotnet run コマンド

WindowsmacOS、または Linux での詳細設定については、簡単なビデオ チュートリアルを見ることができます。You can also watch a short video tutorial for further setup help on Windows, macOS, or Linux.

デバッグDebug

  1. Program.cs をクリックして開きます。Open Program.cs by clicking on it. Visual Studio Code で初めて C# ファイルを開くと、OmniSharp がエディターに読み込まれます。The first time you open a C# file in Visual Studio Code, OmniSharp loads in the editor.

    Program.cs ファイルを開く

  2. Visual Studio Code で、アプリのビルドとデバッグに必要なアセットの追加を求められます。Visual Studio Code should prompt you to add the missing assets to build and debug your app. [はい] を選択します。Select Yes.

    足りない資産の入力を求める

  3. デバッグ ビューを開くには、左側のメニューにある [デバッグ] アイコンをクリックします。To open the Debug view, click on the Debugging icon on the left side menu.

    [デバッグ] タブを開く

  4. ウィンドウの上部で緑色の矢印を探します。Locate the green arrow at the top of the pane. その横にあるドロップダウン リストで .NET Core Launch (console) が選択されていることを確認します。Make sure the drop-down next to it has .NET Core Launch (console) selected.

    .NET Core を選択する

  5. 9 行目の横にあるエディター余白 (エディター内の行番号の左側の領域) をクリックして、プロジェクトにブレークポイントを追加するか、またはエディター内でテキスト カーソルを 9 行目に移動して F9 キーを押します。Add a breakpoint to your project by clicking on the editor margin, which is the space on the left of the line numbers in the editor, next to line 9, or move the text cursor onto line 9 in the editor and press F9.

    ブレークポイントの設定

  6. デバッグを開始するには、F5 キーまたは緑色の矢印を選択します。To start debugging, select F5 or the green arrow. デバッガーは、前述の手順で設定したブレークポイントに達すると、プログラムの実行を停止します。The debugger stops execution of your program when it reaches the breakpoint you set in the previous step.

    • デバッグ中は左上のペインにローカル変数が表示され、デバッグ コンソールを使用できます。While debugging, you can view your local variables in the top left pane or use the debug console.

    実行およびデバッグ

  7. 上部にある緑色の矢印を選択してデバッグを継続するか、上部にある赤色の四角形を選択して停止します。Select the green arrow at the top to continue debugging, or select the red square at the top to stop.

ヒント

Visual Studio Code で OmniSharp を使用した .NET Core のデバッグの詳細とトラブルシューティングのヒントについては、「Instructions for setting up the .NET Core debugger」 (.NET Core デバッガーの設定に関する指示) を参照してください。For more information and troubleshooting tips on .NET Core debugging with OmniSharp in Visual Studio Code, see Instructions for setting up the .NET Core debugger.

FAQFAQ

Visual Studio Code 内で C# をビルドおよびデバッグするのに必要な資産が欠落しています。I'm missing required assets to build and debug C# in Visual Studio Code. デバッガーには、"構成がありません" と表示されます。My debugger says "No Configuration."

Visual Studio Code C# の拡張機能では、ビルドおよびデバッグする資産を自動的に作成することができます。The Visual Studio Code C# extension can generate assets to build and debug for you. C# プロジェクトを初めて開くと、これらの資産を作成するように Visual Studio Code から求められます。Visual Studio Code prompts you to generate these assets when you first open a C# project. 資産を作成しなかった場合でも、このコマンドを実行する方法はあります。コマンド パレットを開き ([表示] > [コマンド パレット])、「>.NET: Generate Assets for Build and Debug」 と入力します。If you didn't generate assets then, you can still run this command by opening the Command Palette (View > Command Palette) and typing ">.NET: Generate Assets for Build and Debug". これを選択すると、必要としている .vscode、launch.json、tasks.json の各構成ファイルが作成されます。Selecting this generates the .vscode, launch.json, and tasks.json configuration files that you need.

関連項目See also