ML.NET モデル ビルダーのインストール方法How to install ML.NET Model Builder

ML.NET モデル ビルダーをインストールして .NET アプリケーションに機械学習を追加する方法について説明します。Learn how to install ML.NET Model Builder to add machine learning to your .NET applications.

注意

モデル ビルダーは現在のところ、プレビュー段階です。Model Builder is currently in Preview.

前提条件Prerequisites

  • Visual Studio 2017 バージョン 15.9.12 以降 / Visual Studio 2019Visual Studio 2017 version 15.9.12 or later / Visual Studio 2019
  • .NET Core 2.1 SDK 以降。.NET Core 2.1 SDK or later.

注意

.NET Core 3.0 SDK は現在サポートされていません。.NET Core 3.0 SDK is not currently supported.

制限事項Limitations

  • ML.NET モデル ビルダー拡張機能は現在のところ、Windows 上の Visual Studio でのみ動作します。ML.NET Model Builder Extension currently only works on Visual Studio on Windows.
  • トレーニング データセットの制限は 1 GB までの制限がありますTraining dataset limit of 1GB
  • SQL Server のトレーニング用の行は 10 万行までの制限があります。SQL Server has a limit of 100 thousand rows for training
  • Visual Studio 2017 用の Microsoft SQL Server Data Tools はサポートされていませんMicrosoft SQL Server Data Tools for Visual Studio 2017 is not supported

インストールInstall

ML.NET モデル ビルダーは、Visual Studio Marketplace または Visual Studio からインストールできます。ML.NET Model builder can be installed either through the Visual Studio Marketplace or from within Visual Studio.

Visual Studio MarketplaceVisual Studio Marketplace

  1. Visual Studio Marketplace からダウンロードDownload from Visual Studio Marketplace
  2. 指示に従って該当する Visual Studio バージョンにインストールしますFollow prompts to install onto respective Visual Studio version

Visual Studio 2017Visual Studio 2017

  1. メニュー バーで、 [ツール] > [拡張機能と更新プログラム] の順に選択しますIn the menu bar, select Tools > Extensions and Updates

    VS2017 の拡張機能マネージャー ダイアログを開く

  2. [拡張機能と更新プログラム] プロンプト内で、 [オンライン] ノードを選択しますInside the Extension and Updates prompt, select the Online node.

  3. 検索バーで「ML.NET モデル ビルダー」を検索し、結果から「ML.NET モデル ビルダー (Preview)」を選択しますIn the search bar, search for ML.NET Model Builder and from the results, select ML.NET Model Builder (Preview)

    VS2017 の拡張機能マネージャー ダイアログでモデル ビルダー拡張機能を検索してインストールする

  4. プロンプトの指示に従って、インストールを行いますFollow the prompts to complete the installation

Visual Studio 2019Visual Studio 2019

  1. メニュー バーで [拡張機能] > [拡張機能の管理] の順に選択しますOn the menu bar, select Extensions > Manage Extensions

    VS2019 の拡張機能マネージャー ダイアログを開く

  2. [拡張機能と更新プログラム] プロンプト内で、 [オンライン] ノードを選択しますInside the Extension and Updates prompt, select the Online node.

  3. 検索バーに「ML.NET モデル ビルダー」と入力し、「ML.NET モデル ビルダー (Preview)」を選択しますType ML.NET Model Builder into the search bar select ML.NET Model Builder (Preview)

    VS2019 の拡張機能マネージャー ダイアログでモデル ビルダー拡張機能を検索してインストールする

  4. プロンプトの指示に従って、インストールを行いますFollow the prompts to complete the installation

[アンインストール]Uninstall

Visual Studio 2017Visual Studio 2017

  1. メニュー バーで、 [ツール] > [拡張機能と更新プログラム] の順に選択しますOn the menu bar, select Tools > Extensions and Updates

    VS2017 の [拡張機能の管理] ダイアログを開く

  2. [拡張機能と更新プログラム] プロンプト内で、 [インストール済み] ノードを展開し、 [ツール] を選択しますInside the Extension and Updates prompt, expand the Installed node and select Tools

  3. ツールの一覧から「ML.NET モデル ビルダー (Preview)」を選択し、 [アンインストール] を選択しますSelect ML.NET Model Builder (Preview) from the list of tools and then, select Uninstall

    VS2017 の拡張機能マネージャー ダイアログでモデル ビルダー拡張機能を検索してアンインストールする

  4. プロンプトの指示に従って、アンインストールを行いますFollow the prompts to complete the uninstallation.

Visual Studio 2019Visual Studio 2019

  1. メニュー バーで [拡張機能] > [拡張機能の管理] の順に選択しますOn the menu bar, select Extensions > Manage Extensions

    VS2019 の [拡張機能の管理] ダイアログを開く

  2. [拡張機能と更新プログラム] プロンプト内で、 [インストール済み] ノードを展開し、 [ツール] を選択しますInside the Extension and Updates prompt, expand the Installed node and select Tools

  3. ツールの一覧から「ML.NET モデル ビルダー (Preview)」を選択し、 [アンインストール] を選択しますSelect ML.NET Model Builder (Preview) from the list of tools and then, select Uninstall

    VS2019 の拡張機能マネージャー ダイアログでモデル ビルダー拡張機能を検索してアンインストールする

  4. プロンプトの指示に従って、アンインストールを行いますFollow the prompts to complete the uninstallation.

アップグレードUpgrade

アップグレード プロセスは、インストール プロセスに似ています。The upgrade process is similar to the installation process. Visual Studio Marketplace から最新バージョンをダウンロードするか、または Visual Studio で拡張機能マネージャーを使用します。Either download the latest version from Visual Studio Marketplace or use the Extensions Manager in Visual Studio.