開発ツールのチュートリアル

このチュートリアルでは、Visual Studio の フリート管理 ソリューションとその開発ツールの概要を紹介します。

このチュートリアルでは、Visual Studio のフリート管理ソリューションについて説明します。 Visual Studio 開発環境で、プロジェクトを体系化する方法が分かります。 表示されるものの多くが標準の Visual Studio 機能を使用しており、新規にカスタマイズされたいくつかの機能が追加されたことを確認できます。 途中でこれらの新機能、およびカスタマイズされた機能や開発を簡単にする方法を指摘します。 このチュートリアルでは次の点に焦点を当てます。

  • Visual Studio プロジェクトとその機能。
  • 開発で使用されるファイル。

必要条件

このチュートリアルでは、リモート デスクトップを使用して環境にアクセスし、インスタンスの管理者としてプロビジョニングする必要があります。

セットアップ

  1. 管理者として実行 を使用して Visual Studio を起動します。

  2. ファイルメニューで、開くをポイントし、プロジェクト/ソリューションをクリックします。

  3. デスクトップを参照し、次に FleetManagement フォルダーを開きます。 ソリューション ファイルがコンピュータにない場合は、作成手順が「チュートリアル: AOT のフリート管理モデルからフリート管理ソリューションを作成する」に記載されています。

  4. FleetManagement という名前のソリューション ファイルを選択します。 表示されるファイル タイプは Microsoft Visual Studio Solution (SLN file) です。

    • フリート管理ソリューション ファイルは、ダウンロード可能で利用できます。
    • VHD。
  5. 開く をクリックします。 ソリューションの読み込みには時間がかかる場合があります。

FleetManagement モデルの表示

  1. 表示メニューで、アプリケーション エクスプローラーをクリックします。 アプリケーション エクスプローラは、クラシック ビューで開きます。 このビューは、使い慣れたアプリケーション オブジェクト ツリー (AOT) ビューを提供します。これは MorphX のビューに似ています。 新しい AOT は、Microsoft Dynamics AX 2012 とは少し異なるモデル要素タイプを分類します。 例:

    • データ ディクショナリ ノードで以前見られた項目は、データ モデルまたはデータ型の下にあります。

    • クラスとマクロは Code の下にあります

    • フォーム、メニュー、およびその他の GUI 要素はユーザー インターフェイスにあります。

    • ビジネス インテリジェンス コンポーネントは分析の下にあります。

      AOT_IntroVisualStudio

  2. アプリケーション エクスプローラーで、AOT を右クリックしてからモデル ビューをクリックします。

    FilterQuery_IntroVisualStudio

    モデル ビューでは、そのモデルに従って、プログラム可能なオブジェクトを整理します。 これらのチュートリアルでは、アプリケーション スイート モデルが削除されました。 コアの基盤とプラットフォームのコンポーネントは、アプリケーション スイートから分離されています。 この分離により、アプリケーション スイート モデルの削除が可能になります。

  3. モデル ツリー ノードを展開するには Fleet Management をダブルクリックまたは矢印をクリックします。 モデル ビューは、一連のプログラム可能なオブジェクトを操作する使いやすい方法を提供します。 クラシック ビューでの表示と似ていますが、ツリーに特定のモデルの一部であるオブジェクトのみが表示されます。

  4. フォーム ノードを展開するには、ユーザー インターフェイス をダブルクリックし、次に フォーム をダブルクリックします。 フリート管理サンプルでは、フォームおよびその他のプログラム可能なオブジェクトの名前に接頭語「FM」が付くため簡単に識別できます。 各オブジェクトの名前の後にレイヤーの名前が続きます。このレイヤーの名前は "isv"で、それが属しているモデルの名前は「フリート管理」です。

  5. ツリー内のノードの展開を続行することができます。 たとえば、FM レンタルをダブルクリックして、フォームのパーツ、データ ソース、およびメソッドを表示します。

  6. アプリケーション エクスプ ローラーから、Visual Studio コード エディターを開き、フォームのソース コードを表示することができます。 たとえば、FMRental を右クリックし、コードの表示をクリックします。

  7. フォーム デザイナー を開くこともできます。 たとえば、FMRental を右クリックし、デザイナーを開くをクリックします。 フォーム デザイナー でツリー ノードを展開してフォーム メタデータを表示し編集することができます。

  8. プレビュー ウィンドウでフォームをプレビューすることもできます。 プレビューのコントロールをフォーム デザイナーでクリックします。 同様に、コントロールをフォーム デザイナーでクリックしてフォーム プレビューでハイライトします。

FleetManagement ソリューションとそのプロジェクトの表示

このチュートリアルのこのセクションでは、フリート管理プロジェクトとその解決方法について説明します。 プロジェクトを使うと、モデル要素の作成 (コンパイル、データベースを同期、RDL ファイルの生成など)、アプリケーションのテスト、およびコードのデバッグを行うことができます。 モデル要素がプロジェクトの一部でない限り、モデル要素に変更を加えないことをお勧めします。そうでない場合、モデルの完全なビルドを実行するまで変更がコンパイルされないので、処理の時間が非常に長くなります。 ソリューション エクスプローラーで、FleetManagement 割引および移行された FleetManagement という名前のサンプル プロジェクトを確認できます。 これらのプロジェクトは、FleetManagement という名前の単一の Visual Studio ソリューションに含まれています。

SolutionExplorer_IntroVisualStudio

  1. ソリューション エクスプローラーで、移行されたフリート管理を右クリックしてからプロパティをクリックします。
  2. プロパティ ページ ダイアログ ボックスで、一覧表示されたプロパティを確認します。 スタートアップ オブジェクト フィールドで、プロジェクトを実行またはデバッグするときに実行する最初のフォームの名前を表示することができます。 スタートアップ オブジェクト タイプ フィールドに フォーム がセットされていることがわかります。 モデル名およびそのレイヤーを表示することもできます。 プロジェクトは、常に 1 つのモデルに属しています。
  3. ダイアログボックスでは何も変更しないでください。 キャンセルをクリックして閉じます。

モデル要素のソース ファイルの表示

ソリューション内のコードは XML として保存されます。 次の手順は、Visual Studio でコードを表示する方法と、Internet Explorer でソース XML を表示する方法を示しています。

  1. ソリューション エクスプローラーで、移行されたフリート管理プロジェクト ノードが展開されていることを確認します。

  2. Fleet Management Migrated プロジェクトのクラス一覧を含むフォルダーを開けるには、Code をダブルクリックし、次に Classes をダブルクリックします。

  3. クラスの一覧で、FMDataHelper をダブルクリックしてコード エディターを開きます。 ここで、FMDataHelper X++ クラスの実装が表示されます。

  4. コードを下にスクロールして main メソッドを見つけます。 ヒント: また、コード エディタ ウィンドウの右上にあるメソッド ナビゲーション メニューを使用してメイン メソッドに移動することもできます。

    Main_IntroVisualStudio

    このクラスは、プロジェクトのスタートアップ オブジェクトとして設定されている場合、プロジェクトを実行またはデバッグするときに、メイン メソッドは実行のエントリ ポイントになります。

    FMDataHelper_IntroVisualStudio

  5. Windows で、ファイル エクスプローラーを開いてから、C:\Packages\FleetManagement\FleetManagement\AxClass のフォルダーを参照します。

  6. FMDataHelper.xml という名前のファイルをダブルクリックします。 ファイルを開くプログラムを選択するように求められた場合、その他のオプションをクリックし、Internet Explorer をクリックします。 それ以外の場合、メモ帳で開きます。

    Notepad_IntroVisualStudio

    このファイルでは、FMDataHelper クラスを記述するメタデータを含む XML コードを表示できます。 たとえば、FMDataHelper という名前のクラスにメソッドのセットが含まれていることを表示できます。 XML 要素に含まれる、intializeNumberSequence メソッドなどを実装するコードを表示することができます。 <![CDATA]> タグは、含まれているテキストが XML パーサーにより解釈または変更されないことを確証します。 このメタデータには、Visual Studio のコード ウィンドウで表示したソース コードが含まれています。 ソリューションを開発するときは、XML として格納されているコードを常に操作します。 つまり、コード ファイルはデータベースではなくコンピューターに保存されます。 アプリケーションの開発中は、Application Object Server (AOS) へのアクティブな接続がありません。 データの損失を避けるために、Visual Studio Team Foundation Server などのソースコード管理システムでプロジェクト ファイルを管理することをお勧めします。 ソース コード ファイルの格納方法と保管場所を知るのに役立ちますが、XML ファイルを直接変更しないでください。 常に Visual Studio を使用して、プロジェクトのソース コードを変更します。

  7. FMDataHelper.xml ファイルのウィンドウを閉じます。

  8. ソリューション エクスプローラーで、移行された FleetManagement プロジェクトのラベル ファイルをダブルクリックしてフォルダーを開き、プロジェクトのラベルを表示してから、FLM_en-US ノードをクリックしてラベル エディターを開きます。

    FLM_en-US_IntroVisualStudio

    ラベル エディターの検索ボックスに、「レンタル」と入力します。 入力すると、「レンタル」という単語が含まれているフリート管理のサンプルのラベル一覧が表示されます。 編集可能ないずれかのセルをダブルクリックしてコンテンツを変更し、ラベル ファイルを保存することができます。

    Search-rental_IntroVisualStudio

FleetManagement 移行プロジェクトの構築

  1. ソリューション エクスプローラーで、移行されたフリート管理を右クリックしてからリビルドをクリックします。

  2. 出力ウィンドウの出力元の表示リストで、ビルドをクリックします。 コンパイル エラーなしにビルドが完了したことを確認します。 ビルドの完了を待ちます。 出力 ウィンドウの最終ビルド メッセージには、「...ビルドが完了しました」と表示されます。 状態バー (Visual Studio の左下隅) 内の最終ビルド メッセージは "Ready" と表示します。

    Output_IntroVisualStudio

  3. 表示メニューで、エラー リストをクリックして、ベスト プラクティス警告のリストを表示します。 この機能を示すために、ビルドにいくつかの警告を意図的に残しました。

  4. 警告メッセージをダブルクリックして、警告の原因となったコードまたはリソースを表示します。

  5. ウィンドウ メニューで、すべてのドキュメントを閉じるをクリックして開いているすべてのドキュメントを閉じます。