代理人が Microsoft 365 ハイブリッド環境への移行後に代理人として送信できない
元の KB 番号: 4039613
現象
ユーザーが Microsoft 365 に移動し、オンプレミスの環境にメールボックスを持つ代理人を追加した場合、代理人はそのユーザーの代わりに送信することはできません。 フォルダーアクセスおよび会議の招待状の転送ルールが正常に機能します。
原因
この問題 publicDelegates
は、属性 ( GrantSendOnBehalfTo
) が現在、オンプレミスの Active Directory ドメインサービスに書き戻されていないために発生します。 これが既定の構成です。
解決方法
代理人 () 属性を自動的に書き戻すには publicDelegates
、Azure Active Directory (AZURE AD) Connect Exchange ハイブリッド展開の設定を有効にする必要があります。また、バージョン1.1.553 以降のバージョンを実行している必要があります。 詳細については、次の記事を参照してください。
回避策として、管理者はリモート PowerShell を使用して、 代理人 として送信するアクセス許可を手動で追加することができます。 これを行うには、次のコマンドレットを実行します。
Set-MailUser UserSMTPAddress -GrantSendOnBehalfTo DelegateSMTPAddress
このアクセス許可を手動で追加すると、代理人はユーザーの代理として送信できるようになります。
Microsoft 365 専任/ITAR ユーザーのみ:
従来の専用環境から Microsoft 365 に移行する場合は、 代理人 として送信するアクセス許可を手動で追加する必要があります。 この値は、メールボックスを vNext に移動した専用ユーザーに自動的に書き戻されることはありません。
次のオプションを使用できます。
オプション 1
SSA/SE/ボックス役割グループのメンバーである管理者は、次のコマンドレットを実行できます。
Set-RemoteMailbox <mailbox> -GrantSendonBehalfTo <delegate>
オプション 2
Microsoft サポートに要求を送信して、 GrantSendOnBehalfTo
リモートメールボックスにアクセス許可を追加することができます。