ラボ - Power BI Desktop でレポートをデザインする (パート 2)

完了

環境にアクセスする

(前のラボから続行する場合を除き) このラボを開始する前に、上の [ラボの起動] を選択します。

data-ai\student としてラボ環境に自動的にログインします。

これで、このラボの作業を開始できます。

ヒント

ラボ環境をドッキングしてウィンドウいっぱいに表示されるようにするには、上部中央にある画びょうのアイコンを選択します。

画びょうのアイコンが強調表示されているラボのスクリーンショット。

このラボの推定所要時間: 45 分

このラボでは、高度なデザイン機能を使用して Sales Analysis を強化します。

このラボでは、以下の方法について説明します。

  • スライサーを同期する

  • ドリルスルー ページの作成

  • 条件付き書式の適用

  • ブックマークの作成と使用

ラボのストーリー

このラボは、データの準備に始まり、レポートおよびダッシュボードとして発行するまでの完全なストーリーとして設計されたラボ シリーズの 1 つです。 ラボは任意の順序で完了できます。 しかしながら、複数のラボに取り組む場合は、最初の 10 のラボについては、次の順序で行うことをお勧めします。

  1. Power BI Desktop でデータを準備する

  2. Power BI Desktop でデータを読み込む

  3. Power BI Desktop でデータをモデル化する (パート 1)

  4. Power BI Desktop でデータをモデル化する (パート 2)

  5. Power BI Desktop で DAX 計算を作成する (パート 1)

  6. Power BI Desktop で DAX 計算を作成する (パート 2)

  7. Power BI Desktop でレポートをデザインする (パート 1)

  8. Power BI Desktop でレポートをデザインする (パート 2) << 現在はここです。 これは、現在のモジュールのラボです。

  9. Power BI ダッシュボードを作成する

  10. Power BI Desktop でデータ分析を実行する

  11. Power BI のページ分割されたレポートを作成する

注意

各ラボは、前のラボ作業がすべて完了した PBIX ファイルを使用して開始されます。 何らかの理由で作業が失われた場合は、次のラボの冒頭に示されているフォルダーから、その時点までの進行状況を含む PBIX ファイルを開くことができます。

演習 1: スライサーの同期を構成する

この演習では、レポート ページのスライサーを同期します。

タスク 1: 開始する - サインイン

このタスクでは、Power BI にサインインして、ラボの環境を設定します。

重要

既に Power BI にサインインしている場合は、次のタスクから続行します。

  1. Microsoft Edge を開くには、タスク バーにある Microsoft Edge プログラム ショートカットを選択します。

  2. Microsoft Edge ブラウザー ウィンドウで、https://powerbi.com に移動します。

    ヒント

    Microsoft Edge のお気に入りバーで、Power BI サービスのお気に入りを使用することもできます。

  3. 右上隅にある [サインイン] を選択します。

  4. 提供されたアカウントの詳細を入力します。

  5. パスワードの更新を求めるメッセージが表示されたら、提供されたパスワードを再入力し、新しいパスワードを入力して確認します。

    重要

    新しいパスワードは必ず記録しておいてください。

  6. サインイン プロセスを完了します。

  7. Microsoft Edge からサインインを維持するように求められた場合は、[はい] を選択します。

  8. Microsoft Edge ブラウザー ウィンドウの Power BI サービスの [ナビゲーション] ペインで、[マイ ワークスペース] を展開します。

    [ナビゲーション] ペインの [マイ ワークスペース] 展開ボタンが強調表示されているスクリーンショット。

  9. Microsoft Edge ブラウザー ウィンドウを開いたままにします。

タスク 2: 開始する - レポートを開く

このタスクでは、スタート レポートを開いてラボの環境を設定します。

重要

前のラボから継続している (そのラボを正常に完了した) 場合は、このタスクは行わないでください。 代わりに、次のタスクから続行してください。

  1. Power BI Desktop を開くには、タスク バーにある Microsoft Power BI Desktop ショートカットを選択します。

  2. 開始ウィンドウを閉じるには、ウィンドウの左上にある [X] を選択します。

  3. Power BI サービスにサインインするには、右上にある [サインイン] を選択します。

  4. Power BI サービスへのサインインに使用したのと同じアカウントを使用して、サインイン プロセスを完了します。

  5. スターター Power BI Desktop ファイルを開くには、[ファイル] リボン タブを選択して Backstage ビューを開きます。

  6. [レポートを開く] を選択します。

    [ファイル] メニューが展開され、[レポートを開く] オプションが強調表示されているスクリーンショット。

  7. [レポートを参照] を選択します。

  8. [開く] ウィンドウで、D:\DA100\Labs\design-report-in-power-bi-desktop-enhanced\Starter フォルダーに移動します。

  9. Sales Analysis ファイルを選択します。

  10. [Open] を選択します。

  11. 情報ウィンドウが開いている場合はすべて閉じます。

  12. ファイルのコピーを作成するには、[ファイル] リボン タブを選択して Backstage ビューを開きます。

  13. [名前を付けて保存] を選択します。

    [ファイル] メニューが展開され、[名前を付けて保存] オプションが強調表示されているスクリーンショット。

  14. 変更の適用を求めるメッセージが表示されたら、[適用] を選択します。

  15. [名前を付けて保存] ウィンドウで、D:\DA100\MySolution フォルダーに移動します。

  16. [保存] を選択します。

タスク 3: スライサーを同期する

このタスクでは、[Year][Region] のスライサーを同期します。

Power BI Desktop でレポートをデザインする (パート 1) のラボで作成したレポートの開発を継続します。

  1. Power BI Desktop の [概要] ページで、[年] スライサーを FY2018 に設定します。

  2. [My Performance] ページに移動すると、[Year] スライサーの値が異なっていることがわかります。

    スライサーが同期されていないと、データが誤って表示され、レポート ユーザーのフラストレーションにつながる可能性があります。 ここで、レポート スライサーを同期します。

  3. [概要] ページに戻り、[年] スライサーを選択します。

  4. [表示] リボン タブの [ペインを表示する] グループ内の [スライサーの同期] を選択します。

    [表示] タブの [スライサーの同期] ボタンのスクリーンショット。

  5. [スライサーの同期] ペイン ([視覚化] ペインの左側) の 2 番目の列 (同期中を表します) で、[概要] ページと [My Performance](マイ パフォーマンス) ページのチェック ボックスをオンにします。

    選択するページ名が表示された [スライサーの同期] ペインのスクリーンショット。

  6. [Overview] ページで、[Region] スライサーを選択します。

  7. スライサーを [Overview] ページおよび [Profit] ページと同期します。

    [Overview] ページと [Profit] ページが選択された [スライサーの同期] ペインのスクリーンショット。

  8. さまざまなフィルター オプションを選択してスライサーの同期をテストし、同期されたスライサーが同じ選択でフィルター処理されることを確認します。

  9. [スライサーの同期] ページを閉じるには、ペインの右上にある [X] を選択します。

演習 2: ドリルスルーを構成する

この演習では、新しいページを作成し、ドリルスルー ページとして構成します。 デザインが完了すると、ページは次のようになります。

構築するドリルスルー ページの最終的なデザインのスクリーンショット。

タスク 1: ドリルスルー ページを作成する

このタスクでは、新しいページを作成し、ドリルスルー ページとして構成します。

  1. Product Details」という名前の新しいレポート ページを追加します。

    画面の下部にある新しいレポート ページのスクリーンショット。

  2. [Product Details] ページ タブを右クリックし、[ページを非表示にする] を選択します。

    レポート ユーザーがドリルスルー ページに直接アクセスすることはできません。 他のページの視覚化からアクセスする必要があります。 このラボの最後の演習では、このページにドリルスルーする方法を学習します。

  3. [視覚化] ペインの下にある [ドリルスルー] セクションで、Product | Category フィールドを [Add Drill-Through Fields Here](ドリルスルー フィールドをここに追加します) ボックスに追加します。

    このラボでは、フィールドを参照するために簡略表記を使用します。 Product | Category のようになります。 この例では、Product はテーブル名、Category はフィールド名です。

    Category フィールドが強調表示されている [ドリルスルー] セクションのスクリーンショット。

  4. ドリルスルー ページをテストするには、ドリルスルー フィルター カードで [Bikes] を選択します。

    [Bikes] を選択したドリルスルー フィルター カードのスクリーンショット。

  5. レポート ページの左上にある矢印ボタンにお気付きでしょうか。

    左上の矢印ボタンのスクリーンショット。

    ドリルスルー ウェルにフィールドを追加すると、ボタンが自動的に追加されます。 これを使うと、レポート ユーザーがドリルスルー元のページに戻ることができます。

  6. ページに [カード] 視覚化を追加し、ボタンの右側でページの残りの幅を埋めるようにサイズと位置を変更します。

    カードの視覚化が強調表示された [視覚化] ペインのスクリーンショット。

    [カード] ビジュアルのサイズと位置の画像のスクリーンショット。

  7. カードの視覚化に Product | Category フィールドをドラッグします。

  8. 視覚化の書式オプションを構成してから、[カテゴリ ラベル] プロパティを [オフ] にします。

    [カテゴリ ラベル] がオフのスクリーンショット。

  9. [背景色] プロパティを灰色の薄い網掛けに設定します。

  10. ページに [表] の視覚化を追加し、サイズと位置を変更して、カードの視覚化の下でページの残りの領域を埋めるようにします。

    表の視覚化が強調表示された [視覚化] ペインのスクリーンショット。

    ペイン上の [表] ビジュアルのサイズと位置の画像のスクリーンショット。

  11. 視覚化に次のフィールドを追加します。

    • Product | Subcategory

    • Product | Color

    • Sales | Quantity

    • Sales | Sales

    • Sales | Profit Margin

  12. ビジュアルの書式オプションを構成し、[グリッド] セクションで、[文字のサイズ] プロパティを [20pt] に設定します。

    ドリル スルー ページのデザインはほぼ完了です。 次の演習では、条件付き書式を使用してページを拡張します。

演習 3: 条件付き書式を追加する

この演習では、条件付き書式を使用してドリル スルー ページを拡張します。 デザインが完了すると、ページは次のようになります。

構築する最終的なドリル スルー ページのスクリーンショット。

タスク 1: 条件付き書式を追加する

このタスクでは、条件付き書式を使用してドリル スルー ページを拡張します。

  1. テーブル視覚化を選択します。

  2. 視覚化フィールド ペインの [Profit Margin](利益率) フィールドで、下向き矢印を選択し、[条件付き書式] | [アイコン] を選択します。

    [利益率] フィールドの下矢印、[条件付き書式] の下矢印と [アイコン] が選択されているスクリーンショット。

  3. [Icons - Profit Margin](アイコン -- 利益率) ウィンドウの [アイコンのレイアウト] ドロップダウン リストで、[データの右側] を選択します。

    [アイコン] のスクリーンショット、[アイコンのレイアウト] が強調表示された [Profit Margin](利益率) ウィンドウ。

  4. 中央のルールを削除するには、黄色の三角形の左側にある [X] を選択します。

    中央のルールを削除する [X] のスクリーンショット。

  5. 次のように、最初のルール (赤色のひし形) を構成します。

    • 2 つ目のコントロールで値を削除します

    • 3 つ目のコントロールで [番号] を選択します

    • 5 つ目のコントロールに「0」と入力します

    • 6 つ目のコントロールで [番号] を選択します

  6. 次のように、2 つ目のルール (緑色の円) を構成します。

    • 2 つ目のコントロールに「0」と入力します

    • 3 つ目のコントロールで [番号] を選択します

    • 5 つ目のコントロールで値を削除します

    • 6 つ目のコントロールで [番号] を選択します

    2 つ目と 3 つ目のルールのスクリーンショット。

    ルールは次のようになります。

    • 利益率の値が 0 未満の場合、赤色のひし型を表示します。
    • それ以外の場合、値が 0 以上であれば、緑色の円を表示します。
  7. [OK] を選択します。

  8. テーブル視覚化で、正しいアイコンが表示されていることを確認します。

    緑色の丸と赤色のひし形のテーブル視覚化のスクリーンショット。

  9. [色] フィールドの背景色の条件付き書式を構成します。

  10. [背景色 -- 色] ウィンドウの [書式設定基準] ドロップダウン リストで、[フィールド値] を選択します。

    [背景色] ウィンドウのスクリーンショット。

  11. [フィールドに基づく] ドロップダウン リストで、[製品] | [書式設定] | [Background Color Format] を選択します。

    [フィールドに基づく] ウィンドウのスクリーンショット

  12. [OK] を選択します。

  13. 前の手順を繰り返し、[製品] | [書式設定] | [Font Color Format](フォントの色の書式) フィールドを使用して、[色] フィールドのフォント色の条件付き書式を設定します。

背景とフォントの色は Power BI Desktop でデータを準備する のラボで ColorFormats.csv ファイルから取得された後、Power BI Desktop でデータを読み込む のラボで Product クエリと統合されることを思い出されるかもしれません。

演習 4: ブックマークとボタンを追加する

この演習では、[My Performance](マイ パフォーマンス) ページをボタンを使用して拡張し、レポート ユーザーが表示する視覚化の種類を選択できるようにします。 デザインが完了すると、ページは次のようになります。

構築する拡張された [My Performance](マイ パフォーマンス) ページのスクリーンショット。

タスク 1: ブックマークを追加する

このタスクでは、2 つのブックマークを追加します。1 つは、毎月の売上と目標の各視覚化を表示するためのものです。

  1. [My Performance](マイ パフォーマンス) ページに移動します。

  2. [表示] リボン タブの [ペインを表示する] グループ内の [ブックマーク] を選択します。

    [ブックマーク] が強調表示されている [表示] リボン タブのスクリーンショット。

  3. [表示] リボン タブの [ペインを表示する] グループ内の [Selection](選択範囲) を選択します。

    [Selection](選択範囲) が強調表示されている [表示] リボン タブのスクリーンショット。

  4. [選択] ペインで、[Sales and Target by Month](月別売上高と目標) 項目の横にある視覚化を非表示にするには、目のアイコンを選択します。

    目のアイコンが表示された [選択] ペインのスクリーンショット。

  5. [ブックマーク] ペインで、[追加] を選択します。

    [追加] ボタンが強調表示されている [ブックマーク] ペインのスクリーンショット。

  6. ブックマークの名前を変更するには、ブックマークをダブルクリックします。

  7. 表示されているグラフが横棒グラフの場合は、ブックマークの名前を「Bar Chart ON」に変更します。それ以外の場合は、ブックマークの名前を「Column Chart ON」に変更します。

  8. ブックマークを編集するには、[ブックマーク] ペインでブックマークにカーソルを合わせて省略記号をクリックしてから [データ] を選択します。

    [ブックマーク] ペインで [Bar Chart ON] の省略記号が選択されて [データ] オプションが強調表示されたスクリーンショット。

    [データ] オプションを無効にすると、ブックマークで現在のフィルターの状態が使用されなくなります。 これが重要である理由は、そのようにしないと、現在 [Year] スライサーによって適用されているフィルターがブックマークによって永久にロックされるからです。

  9. ブックマークを更新するには、省略記号をもう一度クリックして [更新] を選択します。

    次の手順では、2 つ目のブックマークを作成および構成して、2 つ目の視覚化を表示します。

  10. [選択] ペインで、2 つの [Sales and Target by Month](月別売上高と目標) 項目の表示を切り替えます。

    つまり、表示されている視覚化を非表示にし、非表示の視覚化を表示します。

    表示状態のアイコンが強調表示された [Selection](選択範囲) ペインのスクリーンショット。

  11. 2 つ目のブックマークを作成し、適切な名前を付けます (「Column Chart ON」または「Bar Chart ON」)。

    "Bar Chart ON" と "Column Chart ON" が表示された [ブックマーク] ペインのスクリーンショット。

  12. 2 つ目のブックマークを構成してフィルターを無視し ([データ] オプションをオフ)、ブックマークを更新します。

  13. [選択] ペインで、両方の視覚化を表示するには、非表示の視覚化を表示します。

  14. 両方の視覚化のサイズと位置を変更して、マルチカード視覚化の下のページ全体に表示し、互いに完全に重なり合うようにします。

    ヒント

    隠れている視覚化を選択するには、[選択] ペインで選択します。

    ペイン上の 2 つ目の視覚化のサイズと位置の画像のスクリーンショット。

  15. [ブックマーク] ペインで各ブックマークを選択します。1 つの視覚化のみが表示されることに注目してください。

デザインの次の段階は、ページに 2 つのボタンを追加することです。これで、レポート ユーザーはブックマークを選択できるようになります。

タスク 2: ボタンを追加する

このタスクでは、2 つのボタンを追加し、それぞれにブックマーク アクションを割り当てます。

  1. [挿入] リボンの [要素] グループ内の [ボタン] を選択し、[空白] を選択します。

    リボンにある [挿入]、[ボタン]、[空白] の選択肢のスクリーンショット。

  2. ボタンを [年] スライサーのすぐ下に移動します。

  3. ボタンを選択し、[視覚化] ペインで [ボタン テキスト] プロパティを [オン] に変更します。

    [視覚化] ペインで [ボタン テキスト] を [オン] に設定したスクリーンショット。

  4. [ボタン テキスト] セクションを展開し、[ボタン テキスト] ボックスに「Bar Chart」と入力します。

  5. [背景] セクションを展開してから、補完的な色を使用して背景色を設定します。

  6. [アクション] プロパティを [オン] に変更します (リストの一番下近くにあります)。

  7. [アクション] セクションを展開し、[種類] ドロップダウン リストを [ブックマーク] に設定します。

  8. [ブックマーク] ドロップダウン リストで、[Bar Chart ON](横棒グラフ オン) を選択します。

    [アクション] セクションの [種類] と [ブックマーク] が強調表示されたスクリーンショット。

  9. コピーと貼り付けを使用してボタンのコピーを作成し、次のように新しいボタンを構成します。

    ヒント

    コピーと貼り付けのショートカット コマンドは、Ctrl + C キーに続いて Ctrl + V キーです。

    • [ボタン テキスト] プロパティを [縦棒グラフ] に設定します

    • [アクション] セクションで、[ブックマーク] ドロップダウン リストを [Column Chart ON](横棒グラフ オン) に設定します

これで、Sales Analysis レポートのデザインが完成しました。

タスク 3: レポートを発行する

このタスクでは、レポートを発行します。

  1. [概要] ページを選択します。

  2. [年] スライサーで、[FY2020] を選択します。

  3. [地域] スライサーで、[すべて選択] を選択します。

  4. Power BI Desktop ファイルを保存します。

    Power BI サービスに発行する前に必ず、ファイルを保存する必要があります。

  5. [ホーム] リボン タブで、[共有] グループの [発行] をクリックします。

    [Power BI へ発行] ウィンドウで、[マイ ワークスペース] が選択されていることがわかります。

  6. レポートを発行するには、[選択] を選択します。

  7. レポートの置換を求めるメッセージが表示されたら、[置換] を選択します。

  8. 発行が成功したら、[了解] をクリックします。

  9. Power BI Desktop を開いたままにします。

次の演習では、Power BI サービスでレポートを探索します。

演習 5: レポートを探索する

この演習では、Power BI サービスでレポートを探索します。

タスク 1: レポートを探索する

このタスクでは、Power BI サービス内のレポートを探索します。

  1. Microsoft Edge ブラウザー ウィンドウの Power BI サービスの [ナビゲーション] ペインで、Sales Analysis レポートを選択します。

  2. ドリルスルー レポートをテストするには、[概要] ページの [Quantity by Category](カテゴリ別数量) 視覚化で [Clothing](衣類) バーを右クリックし、[ドリルスルー] | [製品の詳細] を選択します。

    [ドリルスルー]、[製品の詳細] の選択肢が表示されたスクリーンショット。

  3. [製品の詳細] ページが [Clothing](衣類) 用であることに注目してください。

  4. ソース ページに戻るには、左上隅にある矢印ボタンを選択します。

  5. [My Performance](マイ パフォーマンス) ページを選択します。

  6. 各ボタンを選択すると、別の視覚化が表示されることに注目してください。

タスク 2: 完了

このタスクでは、ラボを完了します。

  1. ワークスペースに戻るには、階層リンクの軌跡にあるワークスペース名を選択します。

  2. Microsoft Edge ブラウザー ウィンドウを開いたままにします。

  3. Power BI Desktop で [My Performance](マイ パフォーマンス) ページに移動し、[フィルター] ペインで、[Salesperson](営業担当者) フィルター カードを削除します。

    [Salesperson](営業担当者) フィルター カードの削除のスクリーンショット。

  4. [概要] ページを選択します。

  5. Power BI Desktop ファイルを保存してから、レポートをもう一度 Power BI に発行します。

  6. 次のラボを開始する場合は、Power BI Desktop を開いたままにすることを選択できます。

    警告

    ラボを開いたままにしておくと、1 時間から 4 時間後にタイムアウトになります。 "現在" のモジュールのラボでの作業は失われますが、最初のラボの後の各ラボには、前のラボのすべての作業が完了した PBIX ファイルが含まれているので、最初からやり直す必要はありません。

Power BI コンテンツを発行および共有する のラボでレポートを共有すると、レポートでは行レベルのセキュリティが適用されます。

ラボを終了する

このラボを終了するには、この指示ウィンドウの右下隅にある [完了] ボタンを選択します。