演習 – Power BI でデータを視覚化する

完了

ここでは、Microsoft Power BI を使用したデータ モデリングと視覚化について探索します。

Note

この演習を完了するには、Microsoft Windows を実行しているコンピューターが必要です。

Power BI Desktop をインストールする (必要な場合)

Microsoft Power BI Desktop が Windows コンピューターにまだインストールされていない場合は、無料でダウンロードしてインストールできます。

  1. https://aka.ms/power-bi-desktop から Power BI Desktop インストーラーをダウンロードします。
  2. ファイルのダウンロードが完了したら、ファイルを開き、セットアップ ウィザードを使用してコンピューターに Power BI Desktop をインストールします。 これには数分かかることがあります。

データのインポート

  1. Power BI Desktop を開きます。 アプリケーション インターフェイスは次のようになります。

    Power BI Desktop のスタート画面

これで、レポートのデータをインポートする準備ができました。

  1. Power BI Desktop のようこそ画面で、[データの取得] を選択し、データ ソースの一覧で [Web] を選択し、[接続] を選択します。

    Web データ ソースの選択

  2. [Web から] ダイアログ ボックスで、次の URL を入力し、[OK] を選択します。

    https://github.com/MicrosoftLearning/DP-900T00A-Azure-Data-Fundamentals/raw/master/power-bi/customers.csv
    
  3. URL によって、次に示すように顧客データを含むデータセットが開くことを確認します。 次に、[読み込み] を選択して、レポートのデータ モデルにデータを読み込みます。

    顧客データのデータセット

  4. Power BI Desktop のメイン ウィンドウの [データの取得] メニューで、[Web] を選択します。

    [データの取得] メニュー

  5. [Web から] ダイアログ ボックスで、次の URL を入力し、[OK] を選択します。

    https://github.com/MicrosoftLearning/DP-900T00A-Azure-Data-Fundamentals/raw/master/power-bi/products.csv
    
  6. このファイルの製品データをデータ モデルに読み込みます。

  7. 前の 3 つの手順を繰り返して、次の URL から注文データを含む 3 番目のデータセットをインポートします。

    https://github.com/MicrosoftLearning/DP-900T00A-Azure-Data-Fundamentals/raw/master/power-bi/orders.csv
    

データ モデルを探索する

インポートした 3 つのデータ テーブルがデータ モデルに読み込まれたため、今度はこれを探索して検索条件を絞ります。

  1. Power BI Desktop の左側で [モデル] タブを選択し、モデル内のテーブルを表示できるように調整します (右側のペインは、 アイコンを使用して非表示にすることができます)。

    [モデル] タブ

  2. [orders] テーブルで、[Revenue] フィールドを選択し、[プロパティ] ペインで、[Format] (書式) プロパティを [Currency] (通貨) に設定します。

    収益フォーマットを通貨に設定する

    これにより、収益の値がレポートの視覚化で通貨として表示されるようになります。

  3. products テーブルで、[Category] フィールドを右クリックし (または メニューを開いて)、[階層の作成] を選択します。 これにより、[Category 階層] という名前の階層が作成されます (これを表示するには、[products] テーブルの展開またはスクロールが必要になる場合があります。これは [フィールド] ウィンドウに表示することもできます)

    カテゴリ階層の追加

  4. [products] テーブルで、ProductNameフィールドを右クリックし (またはメニューを開いて)、[階層に追加][Category 階層] を選択します。 これにより、前に作成した階層に ProductName フィールドが追加されます。

  5. [フィールド] ウィンドウで、[Category 階層] を右クリックし (または [...] メニューを開いて)、[名前の変更] を選択します。 階層の名前を [Categorized Product] に変更します。

    カテゴリ階層の名前変更

  6. 左端にある [データ] タブを選択し、[フィールド] ウィンドウで [customers] テーブルを選択します。

  7. [City] 列ヘッダーを選択し、[データ カテゴリ] プロパティを [市区町村] に設定します。

    データ カテゴリの設定

    これにより、この列の値が市区町村名として解釈されるようになり、マップの視覚化を含める場合に役立てることができます。

レポートを作成する

これでレポートを作成する準備がほぼ完了しました。 まず、いくつかの設定を確認して、すべての視覚化が有効になっていることを確認する必要があります。

  1. [ファイル] メニューの [オプションと設定] をクリックします。 次に、[オプション] を選択し、[セキュリティ] セクションで、[地図と塗り分け地図の画像を使用する] が有効になっていることを確認し、[OK] を選択します。

    設定オプション

    これにより、マップ視覚化をレポートに含めることができます。

  2. 左端にある [レポート] タブを選択し、レポート デザイン インターフェイスを表示します。

    [レポート] タブ

  3. レポート デザイン画面の上にあるリボンで [テキスト ボックス] を選択し、「Sales Report」というテキストを含むテキスト ボックスをレポートに追加します。 テキストの書式を設定して、フォントサイズを 32 にして太字にします。

    テキスト ボックス

  4. レポート上の空の領域を選択して、テキスト ボックスを選択解除します。 次に、[フィールド] ウィンドウで [products] を展開し、[Categorized Products] フィールドを選択します。 これにより、テーブルがレポートに追加されます。

    レポート内のカテゴリ別製品の表

  5. テーブルを選択したまま、[フィールド] ウィンドウで [orders] を展開し、[Revenue] を選択します。 [Revenue] 列がテーブルに追加されます (表示するには、テーブルのサイズを拡張する必要がある場合があります)。

    収益は、モデルで指定したとおりに通貨として書式設定されます。 ただし、小数点以下の桁数を指定していないので、値には小数部が含まれます。 作成する視覚化にとって重要ではありませんが、[モデル] タブまたは [データ] タブに戻って小数点以下の桁数を変更することもできます。

    レポートに収益が含まれるカテゴリ別製品の表

  6. テーブルを選択したまま、[視覚化] ウィンドウで、[積み上げ縦棒グラフ] の視覚化を選択します。 テーブルが、カテゴリ別の収益を示す縦棒グラフに変更されます。

    レポートに収益が含まれるカテゴリ別製品の積み上げ縦棒グラフ

  7. 選択した縦棒グラフの上にある [↓] アイコンを選択して、ドリルダウンをオンにします。 次に、グラフで 2 番目の列 (Road Bikes) を選択してドリルダウンし、このカテゴリの個々の製品の収益を確認します。 この機能は、カテゴリと製品の階層を定義したため使用でます。

    カテゴリ内の製品を表示するためにドリルダウンされた縦棒グラフ

  8. [↑] アイコンを使用して、カテゴリ レベルにドリルアップして戻ります。 次に、 () アイコンを選択して、ドリルダウン機能をオフにします。

  9. レポートの空白の領域を選択し、[フィールド] ウィンドウで、[orders] テーブルの [Quantity] フィールドと [products] テーブルの [Category] フィールドを選択します。 この結果、製品カテゴリ別の売上数量を示す別の縦棒グラフが表示されます。

  10. 新しい縦棒グラフを選択した状態で、[視覚化] ウィンドウの [円グラフ] を選択し、グラフのサイズを変更して、カテゴリ別の収益の縦棒グラフの横に配置します。

    円グラフにカテゴリ別の販売数量が示されています

  11. レポートの空白の領域を選択し、[フィールド] ウィンドウで、[customers] テーブルの [City] フィールドと [orders] テーブルの [Revenue] フィールドを選択します。 これにより、都市別の売上収益を示すマップが生成されます (必要に応じて、視覚化の並べ替えとサイズの変更を行います)。

    マップに都市ごとの収益が示されています

  12. マップでは、ドラッグ、ダブルクリック、マウスホイールの使用、またはタッチスクリーン上でのピンチやドラッグを行って対話することができます。 次に、特定の都市を選択すると、レポート内の他の視覚化が変更されて、選択された都市のデータが強調表示されるのがわかります。

    マップに都市ごとの収益が示され、選択された都市のデータが強調表示されています

  13. [ファイル] メニューの [保存] をクリックします。 次に、適切な .pbix ファイル名を使用してファイルを保存します。 都合の良いときにこのファイルを開いて、データ モデリングや視覚化をさらに調べることができます。

この演習では、Power BI Desktop を使用してデータを取り込み、データ モデルを作成し、対話型の視覚エフェクトを使用してレポートを作成しました。 Power BI サービスのサブスクリプションをお持ちの場合は、ご自分のアカウントにサインインし、レポートを Power BI ワークスペースに発行できます。