送信ダイレクト ルーティング呼び出しに影響する問題
ダイレクト ルーティングを使用してクライアントからセッション ボーダー コントローラー (SBC) へのMicrosoft Teams発信を行う場合、さまざまな問題が発生する可能性があります。 これらの問題には、次のものが含まれます。
- 呼び出し先に正しくない発信者 ID が表示されます。
- SBC への接続が確立されていません。
- テナント内の一部のユーザーが呼び出しを行えな
- テナント内のユーザーが呼び出しを実行できない。
この記事では、これらの問題の潜在的な原因について説明し、試す解決策を提供します。
受信者に表示される発信者 ID が正しくありません
ダイレクト ルーティングを使用すると、通話受信者に配信される発信者 ID From
P-Asserted-Identity
情報がセッション開始プロトコル (SIP) オプション メッセージのヘッダーに一覧表示されます。
ヘッダー From
には、次の項目が含まれます。
- 通話を開始している発信者に割り当てられている電話番号。 発信者の電話番号を通話受信者から非表示にする必要がある場合は、"匿名" に置き換えられる。
- コマンドレットを使用して呼び出し元に割り当てられるサービス番号
CsCallingLineIdentity
。 - 呼び出しが転送された場合、元の発信者の電話番号。
ヘッダー P-Asserted-Identity
には、通話の請求を受け取るユーザーの電話番号が含まれます。 設定 Privacy:id
されている場合は、ヘッダー内の情報を通話受信者から非表示にする必要があります。
原因
ヘッダーの情報がFrom``P-Asserted-Identity
一致しない場合、および公衆交換電話網 (PSTN) P-Asserted-Identity
From
がヘッダー情報よりもヘッダー情報の優先順位を付ける場合は、正しくない情報が表示されます。
解決方法
呼び出し先に正しい発信者 ID が表示されていることを確認するには、SBC P-Asserted-Identity
を構成して、SIP オプション メッセージからヘッダーを削除するか、その内容を変更します。
SBC への接続が確立されていません
場合によっては、通話は SBC に到達しますが、接続は確立されません。 この状況では、SBC が Teams から SIP オプション メッセージを受信すると、エラー コードが 400 ~ 699 の範囲にあるエラー メッセージを返します。
次の原因により、SBC への接続が妨げる可能性があります。
原因 1
SIP 障害メッセージは、SBC と同じネットワーク上にある別のテレフォニー デバイスによって生成されます。
解決方法 1
他のデバイスをトラブルシューティングして、エラーを修正します。 サポートが必要な場合は、デバイス ベンダーに問い合わせてください。
原因 2
PSTN プロバイダーに何らかの問題が発生し、SIP エラー メッセージが送信されています。 これは、エラー コードが SIP 403 または SIP 404 の場合に最も可能性が高い場合です。
解決方法 2
問題を解決するには、PSTN プロバイダーに問い合わせ、サポートを受け取る必要があります。
原因 3
この問題は、ネットワーク上の別のデバイスや PSTN プロバイダーによって引き起こされません。 ただし、原因は不明です。
解決策 3
問題を解決するには、SBC ベンダーに問い合わせ、サポートを受けることができます。
一部のユーザーが通話を行えな
Teams クライアントと SBC の間の接続が正しく動作しているが、一部のユーザーが呼び出しを行えない場合は、設定が正しくないか、ユーザーのプロビジョニングが正しくない場合に問題が発生する可能性があります。
原因 1
ユーザーは、[通話] タブのダイヤル パッドが表示Teams。
解決方法 1
ユーザーが正しいライセンス (E3 と E5 または 電話システム) と必要なすべての設定を持っている必要があります。 設定を確認するには、PowerShell で Get-CsOnlineUser コマンドレットTeams実行します。
Get-CsOnlineUser -Identity <UserIdParameter> | fl Identity,EnterpriseVoiceEnabled,HostedVoiceMail,OnPremLineURI
「直接ルーティング、音声、ボイスメールのユーザーを有効にする」の説明に従って、必要なすべての値 を指定する必要があります。
原因 2
オンライン 音声ルーティング ポリシー (OVRP) のパターンは、ユーザーがダイヤルした番号と一致しません。
解決方法 2
次の条件が満たされている必要があります。
- OVRP には、ダイヤル番号と一致するパターンがあります。
- 呼び出しの使用状況プロファイルは、特定のユーザーに対して設定された使用状況プロファイルと一致します。
- SBC に対して指定されたゲートウェイが有効です。 無効になっている場合は、有効にするか、有効になっている別のゲートウェイを選択します。
原因 3
ユーザーの OVRP に無効な文字が含まれています。
解決策 3
無効な、非表示の文字は、ユーザーまたは他の WYSIWYG エディターから情報を貼り付Microsoft Word OVRP に挿入できます。 文字は表示されませんが、呼び出しが実行するルートを決定するときに考慮されます。
問題を解決するには、ポリシーを削除し、手動で書き換え、または WYSIWYG 以外のエディター (メモ帳 など) からコピーして、ポリシーを再作成します。
ユーザーが通話を行えない
どのユーザーも呼び出しを行えない場合、通話は SBC に到達していない可能性があります。 次のいずれかの原因を確認します。
原因 1
Teamsゲートウェイが無効になっている場合。
解決方法 1
管理者センター Microsoft Teamsを使用して、管理者が使用するゲートウェイが使用可能Teams確認します。
また、必要に応Teams PowerShell を使用してゲートウェイを確認および更新できます。
ゲートウェイの状態を確認するには、 Get-CsOnlinePSTNGateway コマンドレットを実行 します。 出力では、パラメーターの値がに設定されている Enabled
必要があります True
。 次の例では、ゲートウェイ Enabled
に対してパラメーター True
sbc1.contoso.com
が設定されますが、ゲートウェイには設定 sbc2.contoso.com
されています。
Get-CsOnlinePSTNGateway | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
ゲートウェイがアクセス可能sbc2.contoso.com
Teams、Set-CsOnlinePSTNGateway Enabled
コマンドレットを実行して、パラメーターをに設定しますTrue
。
Set-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" -Enabled $true
ゲートウェイが使用可能かどうかを確認 sbc2.contoso.com
するには、コマンドレットを再度実行 Get-CsOnlinePSTNGateway
します。
Get-CsOnlinePSTNGateway -Identity "sbc2.contoso.com" | fl Identity,Fqdn,SipSignalingPort,MaxConcurrentSessions,Enabled
詳細については、「SBC から直接ルーティングConnectを参照してください。
原因 2
ファイアウォールなどのネットワーク上の一部のデバイスがメッセージをブロックしている場合、ゲートウェイは SIP オプション メッセージに応答しません。
解決方法 2
SBC をインターネットに接続するすべてのネットワーク デバイスで SIP シグナリングIP と FQDN が許可されている必要があります。 許可する必要がある IP アドレスは、 SIP シグナリング: FQDN に一覧表示されます。
詳細
さらにヘルプが必要ですか? Microsoft コミュニティを参照してください。