InfoPath Toolkit で作成したフォーム テンプレートを開くか変換するOpen or Convert a Form Template Created with the InfoPath Toolkit?

InfoPath 2003 Toolkit for Visual Studio に含まれるツールキットを使用して InfoPath 2003 マネージ コード フォーム テンプレートを作成した場合に、InfoPath 2003 との互換性を維持するには、Microsoft InfoPath および Visual Studio 2012 でフォーム テンプレート プロジェクト開きます。これにより、引き続きそのフォーム テンプレート プロジェクトを使用して開発を進めることができます。If you created an InfoPath 2003 managed code form template using one of the InfoPath 2003 Toolkits for Visual Studio and want to maintain compatibility with InfoPath 2003, you can continue to work on and further develop your form template project by opening it in Microsoft InfoPath and Visual Studio 2012.

または、InfoPath 2003 プロジェクトのコードを移行およびアップグレードして、Microsoft.Office.InfoPath 名前空間によって提供される新しい .NET オブジェクト モデルを使用することもできます。その場合は、 Microsoft.Office.InfoPath 名前空間のメンバーを使用するようにすべてのコードを書き直す必要があります。ただし、以前のプロジェクトのコードはすべて、 #if InfoPathManagedObjectModel ステートメントと #endif ステートメント (C# の場合) または #If InfoPathManagedObject Model ステートメントと #End If ステートメント (Visual Basic の場合) で囲まれて、参照用に維持されます。Alternatively, you can migrate and upgrade the code in your InfoPath 2003 project to use the new .NET object model provided by the Microsoft.Office.InfoPath namespace. When doing so, all of your code will need to be re-written to use members of the Microsoft.Office.InfoPath namespace, but all of the code from your previous project is retained and surrounded by #if InfoPathManagedObjectModel and #endif (C#) or #If InfoPathManagedObject Model and #End If (Visual Basic) statements for your reference.

以下の手順では、InfoPath Toolkit を使用して作成したマネージ コード フォーム テンプレートを開いて InfoPath 2003 との互換性を維持する方法と、新しい InfoPath オブジェクト モデルに移行およびアップグレードする方法を説明します。The following procedures describe how to open a managed code form template created by using the InfoPath Toolkit and maintain compatibility with InfoPath 2003 or migrate and upgrade to the new InfoPath object model.

InfoPath Toolkit で作成したマネージ コード フォーム テンプレートを Visual Studio Tools for Applications を使用して開き、InfoPath 2003 との互換性を維持するOpen a managed code form template created with the InfoPath Toolkit and maintain compatibility with InfoPath 2003 using Visual Studio Tools for Applications

  1. InfoPath デザイン モードを開き、[ ファイル] タブの [ 開く] をクリックします。Open the InfoPath Designer, and then click Open on the File tab.

  2. [ デザイン モードで開く] ダイアログ ボックスで、InfoPath Toolkit フォーム テンプレート プロジェクトが保存されているプロジェクト フォルダーに移動します。In the Open in Design Mode dialog box, navigate to the project folder where the InfoPath Toolkit form template project is saved.

    このフォルダーは、既定ではプロジェクトを作成したコンピューター上の C:\Users\ username \Documents\Visual Studio Projects 内にあります。By default, this will be a folder in C:\Users\ username \Documents\Visual Studio Projects on the computer where the project was created. または、このフォルダーを InfoPath が Visual Studio 2012 プロジェクトを格納している場所 (既定では C:\Users\ username \Documents\InfoPath Projects) に移動することもできます。Or, you can move the folder to the location where InfoPath stores Visual Studio 2012 projects, which by default is C:\Users\ username \Documents\InfoPath Projects

  3. manifest.xsf という名前のファイルをクリックし、[ 開く] をクリックします。Click the file that is named manifest.xsf, and then click Open.

  4. [ 開発] タブの [ コード エディター] をクリックします。On the Developer tab, click Code Editor.

  5. "Visual Basic または Visual C# コードを追加する前に、このフォーム テンプレートを保存する必要があります" というメッセージが表示されます。[ OK] をクリックして続行します。The message "This form template must be saved before you can add Visual Basic or C# code to it" is displayed. Click OK to continue.

  6. ファイルを保存する場所に移動し、ファイルの名前を入力して、[ 保存] をクリックします。Navigate to the location where you want to save the file, name the file, and then click Save.

  7. "このコードは InfoPath 2003 Toolkit for Microsoft Visual Studio に含まれるツールキットで作成されたものです。InfoPath では、このツールキット プロジェクトを新しい形式に移行する必要があります" というメッセージが表示されます。[ OK] をクリックして続行します。The message "This code was created with one of the InfoPath 2003 Toolkits for Microsoft Visual Studio. InfoPath needs to migrate the toolkit project to a new format" is displayed. Click OK to continue.

  8. プロジェクトの Visual Studio ソリューション (.sln) ファイルを選択し、[ 開く] をクリックします。Select the Visual Studio Solution (.sln) file for the project, and then click Open.

  9. 移行プロセスが完了すると、"プロジェクトが移行されました" というメッセージが表示されます。[ OK] をクリックして続行します。The message "Your project has been migrated" is displayed when the migration process is complete. Click OK to continue.

  10. "このフォームのコードは、InfoPath 2003 オブジェクト モデルを使用しています" というメッセージが表示され、"Microsoft Office InfoPath オブジェクト モデルを使用するようにコードをアップグレードしますか?" とたずねられます。InfoPath 2003 との互換性を維持し、Microsoft.Office.Interop.InfoPath.SemiTrust 名前空間によって提供されるオブジェクト モデルを引き続き使用するには、[ いいえ] をクリックします。The message "The code in this form uses the InfoPath 2003 object model" is displayed with the prompt "Do you want to upgrade your code to use the Microsoft Office InfoPath object model?" Click No to retain compatibility with InfoPath 2003 and to continue working with the object model provided by the Microsoft.Office.Interop.InfoPath.SemiTrust namespace.

    InfoPath 2003 と互換性のあるマネージ コード フォーム テンプレートの作業方法の詳細については、「InfoPath 2003 オブジェクト モデルを使用してフォーム テンプレートを開発する」を参照してください。For information about how to work with managed code form templates that are compatible with InfoPath 2003, see Developing Form Templates Using the InfoPath 2003 Object Model.

InfoPath Toolkit で作成したマネージ コード フォーム テンプレートを Visual Studio Tools for Applications を使用して開き、新しい InfoPath オブジェクト モデルを使用するようにアップグレードするOpen a managed code form template created with the InfoPath Toolkit and upgrade it to use the new InfoPath object model using Visual Studio Tools for Applications

  1. InfoPath デザイン モードを開き、[ ファイル] タブの [ 開く] をクリックします。Open the InfoPath Designer, and then click Open on the File tab.

  2. [ フォーム テンプレートを開く] で、[ 自分のコンピューター上] をクリックします。Under Open a form template, click On My Computer.

  3. [ デザイン モードで開く] ダイアログ ボックスで、InfoPath Toolkit フォーム テンプレート プロジェクトが保存されているプロジェクト フォルダーに移動します。In the Open in Design Mode dialog box, navigate to the project folder where the InfoPath Toolkit form template project is saved.

    このフォルダーは、既定ではプロジェクトを作成したコンピューター上の C:\Users\ username \Documents\Visual Studio Projects 内にあります。By default this will be a folder in C:\Users\ username \Documents\Visual Studio Projects on the computer where the project was created. または、このフォルダーを InfoPath が Visual Studio 2012 プロジェクトを格納している場所 (既定では C:\Users\ username \Documents\InfoPath Projects) に移動することもできます。Or, you can move the folder to the location where InfoPath stores Visual Studio 2012 projects, which by default is C:\Users\ username \Documents\InfoPath Projects

  4. manifest.xsf という名前のファイルをクリックし、[ 開く] をクリックします。Click the file that is named manifest.xsf, and then click Open.

  5. [ 開発] タブの [ コード エディター] をクリックします。On the Developer tab, click Code Editor.

  6. "Visual Basic または Visual C# コードを追加する前に、このフォーム テンプレートを保存する必要があります" というメッセージが表示されます。[ OK] をクリックして続行します。The message "This form template must be saved before you can add Visual Basic or C# code to it" is displayed. Click OK to continue.

  7. ファイルを保存する場所に移動し、ファイルの名前を入力して、[ 保存] をクリックします。Navigate to the location where you want to save the file, name the file, and then click Save.

  8. "このコードは InfoPath 2003 Toolkit for Microsoft Visual Studio に含まれるツールキットで作成されたものです。InfoPath では、このツールキット プロジェクトを新しい形式に移行する必要があります" というメッセージが表示されます。[ OK] をクリックして続行します。The message "This code was created with one of the InfoPath 2003 Toolkits for Microsoft Visual Studio. InfoPath needs to migrate the toolkit project to a new format" is displayed. Click OK to continue.

  9. プロジェクトの Visual Studio ソリューション (.sln) ファイルを選択し、[ 開く] をクリックします。Select the Visual Studio Solution (.sln) file for the project, and then click Open.

  10. 移行プロセスが完了すると、"プロジェクトが移行されました" というメッセージが表示されます。[ OK] をクリックして続行します。The message "Your project has been migrated" is displayed when the migration process is complete. Click OK to continue.

  11. "このフォームのコードは、InfoPath 2003 オブジェクト モデルを使用しています" というメッセージが表示され、"Microsoft Office InfoPath オブジェクト モデルを使用するようにコードをアップグレードしますか?" とたずねられます。[ はい] をクリックして、Microsoft.Office.InfoPath 名前空間によって提供される新しいマネージ コード オブジェクト モデルを使用するようにフォーム テンプレートをアップグレードします。The message "The code in this form uses the InfoPath 2003 object model" is displayed with the prompt "Do you want to upgrade your code to use the Microsoft Office InfoPath object model?" Click Yes to upgrade the form template to use the new managed code object model provided by the Microsoft.Office.InfoPath namespace.

    フォーム コードが Visual Studio 2012 コード エディターで開きます。以前のプロジェクトのすべてのコードが、 #if InfoPathManagedObjectModel ステートメントと #endif ステートメント (C# の場合) または #If InfoPathManagedObjectModel ステートメントと #End If ステートメント (Visual Basic の場合) で囲まれて、参照用に維持されています。これらすべてのコードを、 Microsoft.Office.InfoPath 名前空間によって提供されるオブジェクト モデルのメンバーを使用するように書き換える必要があります。Your form code is opened in the Visual Studio 2012 code editor with all of the code from your previous project surrounded by #if InfoPathManagedObjectModel and #endif (C#) or #If InfoPathManagedObjectModel and #End If (Visual Basic) statements for your reference. All of this code will have to be re-written to use members of the object model provided by the Microsoft.Office.InfoPath namespace.

    新しい InfoPath マネージ コード オブジェクト モデルを使用するマネージ コード フォーム テンプレートの作業方法の詳細については、「コードを含む InfoPath フォーム テンプレートを開発する」を参照してください。For information about how to work with managed code form templates that use the new InfoPath managed code object model, see Developing InfoPath Form Templates with Code.