ダイアログ API の要件セットDialog API requirement sets

要件セットは、API メンバーの名前付きグループです。Office アドインは、マニフェストで指定されている要件セットを使用するか、ランタイム チェックを使用して、Office ホストがアドインに必要な API をサポートしているかどうかを判別します。詳しくは、「Office のバージョンと要件セット」をご覧ください。Requirement sets are named groups of API members. Office Add-ins use requirement sets specified in the manifest or use a runtime check to determine whether an Office host supports APIs that an add-in needs. For more information, see Office versions and requirement sets.

Office アドインは Office の複数のバージョンで機能します。次の表は、ダイアログ API の要件セット、その要件セットをサポートする Office ホスト アプリケーション、Office アプリケーションのビルド番号またはバージョン番号の一覧です。Office Add-ins run across multiple versions of Office. The following table lists the Dialog API requirement sets, the Office host applications that support that requirement set, and the build or version numbers for the Office application.

要件セットRequirement set Windows 版 Office 2013*Office 2013 on Windows*
(1 回限りの購入)(one-time purchase)
Office 2016 以降 (Windows)*Office 2016 or later on Windows*
(1 回限りの購入)(one-time purchase)
Windows 版 OfficeOffice on Windows
(Office 365 サブスクリプションに接続)(connected to Office 365 subscription)
Office on iPadOffice on iPad
(Office 365 サブスクリプションに接続)(connected to Office 365 subscription)
Mac 版 OfficeOffice on Mac
(Office 365 サブスクリプションに接続)(connected to Office 365 subscription)
Web 上の OfficeOffice on the web Office Online ServerOffice Online Server
DialogApi 1.1DialogApi 1.1 ビルド 15.0.4855.1000 以降Build 15.0.4855.1000 or later ビルド 16.0.4390.1000 以降Build 16.0.4390.1000 or later バージョン 1602 (ビルド 6741.0000) 以降Version 1602 (Build 6741.0000) or later 1.22 以降1.22 or later 15.20 以降15.20 or later 2017 年 1 月January 2017 バージョン 1608 (ビルド 7601.6800) 以降Version 1608 (Build 7601.6800) or later

*ワンタイム購入オフィスのユーザーは、すべての修正プログラムと更新を承諾していない場合があります。* Users of the one-time purchase Office may not have accepted all patches and updates. その場合、Office が UI でそのバージョンを報告するために使用する DLL が、ユーザーのコンピューターにインストールされていない更新された Dll がインストールされていない場合でも、ここにリストされているバージョンよりも大きくなる可能性があります。If so, the DLL that Office uses to report its version in the UI may be greater than the versions listed here even if the updated DLLs needed to support DialogApi have not be installed on the user's computer. 必要な修正プログラムがインストールされていることを確認するには、ユーザーは Office 更新プログラムの一覧 (office 2013 リストまたはoffice 2016 の一覧) に移動し、 osfclientを検索して、一覧に記載されている修正プログラムをインストールする必要があります。To ensure that the needed patch is installed, the user must go to the Office update list (Office 2013 list or Office 2016 list), search for osfclient-x-none, and install the listed patch.

バージョン、ビルド番号、および Office Online Server の詳細については以下を参照してください。To find out more about versions, build numbers, and Office Online Server, see:

Office 共通 API の要件セットOffice Common API requirement sets

共通 API の要件セットの詳細については、「Office 共通 API の要件セット」をご覧ください。For information about Common API requirement sets, see Office Common API requirement sets.

ダイアログ API 1.1Dialog API 1.1

ダイアログ API 1.1 は、API の最初のバージョンです。The Dialog API 1.1 is the first version of the API. API について詳しくは、ダイアログ API リファレンスのトピックをご覧ください。For details about the API, see the Dialog API reference topic.

関連項目See also