Excel JavaScript API 1.3 の新機能What's new in Excel JavaScript API 1.3

ExcelApi 1.3 には、データバインドと基本的なピボットテーブルアクセスのサポートが追加されました。ExcelApi 1.3 added support for data binding and basic PivotTable access.

API リストAPI list

次の表に、Excel JavaScript API 要件セット1.3 の Api を示します。The following table lists the APIs in Excel JavaScript API requirement set 1.3. Excel JavaScript API 要件セット1.3 またはそれ以前でサポートされているすべての Api の API リファレンスドキュメントを表示するには、「要件セット1.3 またはそれ以前の Excel api」を参照してください。To view API reference documentation for all APIs supported by Excel JavaScript API requirement set 1.3 or earlier, see Excel APIs in requirement set 1.3 or earlier.

クラスClass フィールドFields 説明Description
BindingBinding delete()delete() バインドを削除します。Deletes the binding.
BindingCollectionBindingCollection add (range: Range | String, bindingtype: Excel. bindingtype, id: string)add(range: Range | string, bindingType: Excel.BindingType, id: string) 特定の範囲に新しいバインドを追加します。Add a new binding to a particular Range.
addFromNamedItem (name: string, bindingType: Excel. BindingType, id: string)addFromNamedItem(name: string, bindingType: Excel.BindingType, id: string) ブック内の名前付きアイテムに基づいて新しいバインドを追加します。Add a new binding based on a named item in the workbook.
addFromSelection (bindingType: Excel. BindingType, id: string)addFromSelection(bindingType: Excel.BindingType, id: string) 現在の選択範囲に基づいて新しいバインドを追加します。Add a new binding based on the current selection.
PivotTablePivotTable namename ピボットテーブルの名前。Name of the PivotTable.
worksheetworksheet 現在のピボットテーブルを含んでいるワークシート。The worksheet containing the current PivotTable.
refresh()refresh() ピボットテーブルを更新します。Refreshes the PivotTable.
PivotTableCollectionPivotTableCollection getItem(name: string)getItem(name: string) 名前に基づいてピボットテーブルを取得します。Gets a PivotTable by name.
itemsitems このコレクション内に読み込まれた子アイテムを取得します。Gets the loaded child items in this collection.
refreshAll ()refreshAll() コレクション内のすべてのピボットテーブルを更新します。Refreshes all the pivot tables in the collection.
RangeRange getVisibleView ()getVisibleView() 現在の範囲の表示されている行を表します。Represents the visible rows of the current range.
RangeViewRangeView formulasformulas A1 スタイル表記の数式を表します。Represents the formula in A1-style notation.
formulasLocalformulasLocal ユーザーの言語と数値書式ロケールで、A1 スタイル表記の数式を表します。たとえば、英語の数式 "=SUM(A1, 1.5)" は、ドイツ語では "=SUMME(A1; 1,5)" になります。Represents the formula in A1-style notation, in the user's language and number-formatting locale. For example, the English "=SUM(A1, 1.5)" formula would become "=SUMME(A1; 1,5)" in German.
formulasR1C1formulasR1C1 R1C1 スタイル表記の数式を表します。Represents the formula in R1C1-style notation.
getRange()getRange() 現在の RangeView に関連付けられている親の範囲を取得します。Gets the parent range associated with the current RangeView.
numberFormatnumberFormat 指定したセルの Excel の数値書式コードを表します。Represents Excel's number format code for the given cell.
cellAddressescellAddresses RangeView のセル アドレスを表します。Represents the cell addresses of the RangeView. 読み取り専用です。Read-only.
columnCountcolumnCount 表示されている列の数を返します。Returns the number of visible columns. 読み取り専用です。Read-only.
indexindex RangeView のインデックスを表す値を返します。Returns a value that represents the index of the RangeView. 読み取り専用。Read-only.
rowCountrowCount 表示されている行の数を返します。Returns the number of visible rows. 読み取り専用です。Read-only.
rowsrows 範囲に関連付けられている範囲ビューのコレクションを表します。Represents a collection of range views associated with the range. 読み取り専用です。Read-only.
texttext 指定した範囲のテキスト値。テキスト値は、セルの幅には依存しません。Excel UI で発生する # 記号による置換は、この API から返されるテキスト値には影響しません。読み取り専用です。Text values of the specified range. The Text value will not depend on the cell width. The # sign substitution that happens in Excel UI will not affect the text value returned by the API. Read-only.
valueTypesvalueTypes 各セルのデータの種類を表します。Represents the type of data of each cell. 読み取り専用です。Read-only.
valuesvalues 指定した範囲ビューの Raw 値を表します。Represents the raw values of the specified range view. 返されるデータの型は、文字列、数値、ブール値のいずれかになります。The data returned could be of type string, number, or a boolean. エラーが含まれているセルは、エラー文字列を返します。Cells that contain an error will return the error string.
RangeViewCollectionRangeViewCollection getItemAt(index: number)getItemAt(index: number) インデックスを使用して、RangeView 行を取得します。Gets a RangeView Row via its index. 0 を起点とする番号になります。Zero-Indexed.
itemsitems このコレクション内に読み込まれた子アイテムを取得します。Gets the loaded child items in this collection.
TableTable highlightFirstColumnhighlightFirstColumn 最初の列に特別な書式設定が含まれているかどうかを示します。Indicates whether the first column contains special formatting.
highlightLastColumnhighlightLastColumn 最後の列に特別な書式設定が含まれているかどうかを示します。Indicates whether the last column contains special formatting.
showBandedColumnsshowBandedColumns テーブルを見やすくするため、奇数列を偶数列とは異なる方法で強調表示する書式設定にして、列を縞模様で表示するかどうかを示します。Indicates whether the columns show banded formatting in which odd columns are highlighted differently from even ones to make reading the table easier.
showBandedRowsshowBandedRows テーブルを見やすくするため、奇数行を偶数行とは異なる方法で強調表示する書式設定にして、行を縞模様で表示するかどうかを示します。Indicates whether the rows show banded formatting in which odd rows are highlighted differently from even ones to make reading the table easier.
showFilterButtonshowFilterButton フィルター ボタンを各列のヘッダーの上部に表示するかどうかを示します。これは、テーブルにヘッダー行が含まれている場合のみ設定できます。Indicates whether the filter buttons are visible at the top of each column header. Setting this is only allowed if the table contains a header row.
WorkbookWorkbook テーブルpivotTables ブックに関連付けられているピボットテーブルのコレクションを表します。Represents a collection of PivotTables associated with the workbook. 読み取り専用です。Read-only.
WorksheetWorksheet テーブルpivotTables ワークシートの一部になっているピボットテーブルのコレクション。Collection of PivotTables that are part of the worksheet. 読み取り専用です。Read-only.

関連項目See also