Excel for Mac を起動すると、"問題が発生したため、閉じる必要があります。" というエラーが発生します。

注意

Office 365 用リソース は、 エンタープライズ向け Microsoft 365 アプリに名前変更されています。 この変更の詳細については、 このブログの投稿を参照してください。

現象

Microsoft Excel for Mac を起動しようとすると、次のエラーメッセージが表示されます。

問題が発生したため、Excel を閉じる必要があります。ご不便をお待ちしております。

原因

このエラーは、次のいずれかの条件に該当する場合に発生することがあります。 

  • Excel の設定が破損しています。
  • バックグラウンドで実行されているプログラムは、Excel for Mac に干渉しています。
  • アプリケーションファイルが破損しています。
  • ユーザーアカウントのプロファイルが破損しています。

解決方法

この問題を解決するには、問題が解決されるまで、次の方法を順に実行します。

方法 1

手順 1: すべてのプログラムを終了する

続行する前に、すべてのプログラムを終了する必要があります。 アプリケーションを終了するには、ツールバーのアプリケーション (上部) を選択し、[ 終了] を選択します。 アプリケーションを終了できない場合、またはその方法がわからない場合は、Command キーと Option キーを押したままにして、キーボードで Esc キーを押します。 [アプリケーションの強制終了] ウィンドウでアプリケーションを選択し、[ 強制終了] を選択します。 [ 強制終了 ] をクリックして、アプリケーションを終了します。

注意

Finder を終了することはできません。

完了したら、左上隅にある赤のボタンをクリックして、手順2に進みます。

手順 2: Excel の環境設定を削除する

  1. すべての Microsoft Office for Mac アプリケーションを終了します。

  2. [ 移動 ] メニューの [ ホーム] をクリックします。

  3.  ライブラリを開きます。 メモ****ライブラリフォルダーは Mac OS X ライオンでは非表示になります。 このフォルダーを表示するには、OPTION キーを押しながら [ 移動 ] メニューをクリックします。

  4. ユーザー設定] を開きます。

  5.  Comをデスクトップにドラッグします。 ファイルが見つからない場合、Excel は既定の設定を使用します。 手順7に進みます。

  6. Excel を開き、問題がまだ発生しているかどうかを確認します。 問題がまだ発生している場合は、Excel を終了し、ファイルを元の場所に復元して、次の手順に進みます。 問題が解決した場合は、「the the the the the the the the the the the theゴミ 」に移動します。

  7. すべての Office for Mac アプリケーションを終了します。

  8. [ 移動 ] メニューの [ ホーム] をクリックします。

  9.  ライブラリを開きます。

    注意

    ライブラリフォルダーは Mac OS X ライオンでは非表示になります。 このフォルダーを表示するには、OPTION キーを押しながら [ 移動 ] メニューをクリックします。

  10. ユーザー設定] を開きます。

  11.  Microsoftを開き、デスクトップに「 excel 」をドラッグします。 ファイルが見つからない場合、Excel は既定の設定を使用します。 手順13に進みます。

  12. Excel を開き、問題がまだ発生しているかどうかを確認します。 問題がまだ発生している場合は、Excel を終了し、ファイルを元の場所に復元して、 方法 2に進みます。 問題が解決した場合は、「the the the the the the the the the the the the the the the the the the the the the the theゴミ に移動します。

方法 2

[ディスクのアクセス許可を修復する] オプションを使用する

[リペアディスクアクセス権] オプションを使用して、Mac OS X 10.2 以降のバージョンでのアクセス許可の問題のトラブルシューティングを行うことができます。[ リペアディスクアクセス権 ] オプションを使用するには、次の手順を実行します。

  1. [ 移動 ] メニューの [ ユーティリティ] をクリックします。
  2. ディスクユーティリティプログラムを起動します。
  3. コンピューターのプライマリハードディスクドライブをクリックします。
  4. [ 最初の補助 ] タブをクリックします。
  5. [ リペアディスク権限] をクリックします。

注意

ディスクユーティリティプログラムは、Apple によってインストールされたソフトウェアのみを修復します。 このユーティリティは、[アプリケーション] フォルダーなどのフォルダーも修復します。 ただし、このユーティリティでは、ホームフォルダー内のソフトウェアは修復されません。

Excel を起動し、問題が解決されているかどうかを確認します。 含まれていない場合は、方法3に進みます。

方法 3

新しいユーザーアカウントを作成して使用する

新しいユーザーアカウントを作成するには、次の手順を使用します。

注意

新しいアカウントを使用してログオンした場合は、多くの場合、Office を再インストールする必要があります。

  1. アップルアイコンをクリックし、[ システム環境設定] をクリックします。

    アップルアイコンのシステム設定

  2. アカウント] をクリックします。

    システム環境設定の [アカウント] ボタン

  3. 左下隅にあるプラス記号 ("+") をクリックして、[新しいアカウント] ウィンドウを開きます。

    注意

    コンピューターの管理者でない場合は、[ ロック] をクリックして変更を行います。 管理者のユーザー名とパスワードを使用してログオンし、[ OK] をクリックします。

    左下隅にあるプラス記号をクリック

  4. ユーザー名として「 Test   」と入力し、[パスワード] ボックスは空白のままにします。[ アカウントの作成] をクリックします。 警告が表示されたら、[ OK] をクリックします。

    名前を入力してアカウントを作成します。

  5. ユーザーにこのコンピューターの管理を許可する] チェックボックスをオンにします。 (このオプションが使用できない場合は、次の手順に進んでください)。

    [このコンピューターの管理をユーザーに許可する] オプションを選択します。

  6. アップルアイコンをクリックし、[* * Log Out * name * * *] をクリックします。

    アップルアイコンにログインします。

  7. テストアカウントを使用してログオンします。

Excel を起動し、問題が解決されているかどうかを確認します。 新しいユーザーアカウントを使用したときに保存できる場合は、Apple support に連絡して既存のアカウントのトラブルシューティングを依頼してください。 既存のアカウントを保持しない場合は、次の手順で作成する "Test" アカウントの名前を変更して、そのアカウントを引き続き使用することができます。含まれていない場合は、方法4に進みます。

方法 4

Office を削除して再インストールする

Office を削除して再インストールする方法については、次の記事を参照してください。

Office 2011 for Mac を再インストールする前に完全にアンインストールして、問題のトラブルシューティングを行う

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