PowerPoint スライドのエクスポート解像度を変更する方法

注意

Office 365 用リソース は、 エンタープライズ向け Microsoft 365 アプリに名前変更されています。 この変更の詳細については、 このブログの投稿を参照してください。

Microsoft PowerPoint では、画像形式でスライドを保存することによって、エクスポート解像度を変更できます。 このプロセスには、次の 2 つの手順があります。システム レジストリを使用して、エクスポートしたスライドの既定の解像度設定を変更した後、実際に新しい解像度でスライドを画像として保存します。

手順 1: エクスポート解像度の設定を変更する

重要

このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 変更する前に、問題の発生に備えて復元用にレジストリのバックアップを作成してください。

既定では、画像として保存する PowerPoint スライドのエクスポート解像度は、1 インチあたり 96 ドット (dpi) です。 エクスポート解像度を変更するには、次の手順を実行します。

  1. Windows ベースのプログラムをすべて終了します。

  2. [スタート] ボタンを右クリックしてから、[ファイル名を指定して実行] を選択します。 (Windows 7 では、[スタート]、[ファイル名を指定して実行] の順に選択します。)

  3. [名前] ボックスに「regedit」と入力し、[OK] を選択します。

  4. 使用している PowerPoint のバージョンに応じて、次のいずれかのレジストリ サブキーを見つけます。

    PowerPoint 2016、2019、PowerPoint for Office 365

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\PowerPoint\Options

    PowerPoint 2013

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\PowerPoint\Options

    PowerPoint 2010

    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\PowerPoint\Options

    PowerPoint 2007

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\PowerPoint\Options

    PowerPoint 2003

    HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\PowerPoint\Options

  5. [オプション] サブキーをクリックし、[編集] メニューの [新規作成] をポイントして、[DWORD (32 ビット) 値] をクリックします。

  6. 「ExportBitmapResolution」と入力し、Enter キーを押します。

  7. ExportBitmapResolution が選択されていることを確認し、[編集] メニューの [変更] をクリックします。

  8. [DWORD 値の編集] ダイアログボックスで、[10 進] を選択します。

  9. [値データ] ボックスに、必要な解像度の値 (300 など) を入力します。 または、次の表のパラメーターを使用します。

    10 進値 全画面表示ピクセル (水平 × 垂直) ワイドスクリーン ピクセル (水平 × 垂直) 1 インチあたりのドット数 (水平および垂直)
    50 500 × 375 667 × 375 50 dpi
    96 (既定値) 960 × 720 1280 × 720 96 dpi
    100 1000 × 750 1333 × 750 100 dpi
    150 1500 × 1125 2000 × 1125 150 dpi
    200 2000 × 1500 2667 × 1500 200 dpi
    250 2500 × 1875 3333 × 1875 250 dpi
    300 3000 × 2250 4000 × 2250 300 dpi

    注意

    この値を設定する場合の詳細については、制限事項セクションを参照してください。

  10. [OK] を選択します。

  11. [ファイル] メニューの [終了] を選択して、レジストリ エディターを終了します。

手順 2: スライドを画像としてエクスポートする

  1. PowerPoint でスライド プレゼンテーションを開き、エクスポートするスライドを開きます。

  2. [ファイル] メニューの [名前を付けて保存] をクリックします。

  3. [ファイルの種類] ボックスで、次のいずれかの画像形式を選択します。

    • GIF グラフィックス交換形式 (.gif)
    • JPEG ファイル交換形式 (*.jpg)
    • PNG ポータブル ネットワーク グラフィックス形式 (*.png)
    • TIFF タグ画像ファイル形式 (*.tif)
    • デバイスに依存しないビットマップ (*.bmp)
    • Windows メタファイル (*.wmf)
    • 拡張 Windows メタファイル (*.emf)

    注意

    [保存先] ボックスで画像の保存場所を変更することもできます。 [ファイル名] ボックスで、画像の名前を変更することもできます。

  4. [保存] を選択します。 次のダイアログ ボックスに確認画面が表示されます。

    [現在のスライドのみ] を選択します。

    [現在のスライドのみ] を選択します。 スライドは、[保存先] ボックスで指定した場所に新しい形式と解像度で保存されます。

  5. スライドが指定した解像度で保存されたことを確認するには、画像を右クリックし、[プロパティ] を選択します。

制限事項

PowerPoint で ExportBitmapResolution レジストリ値を設定する場合、PowerPoint のバージョンによっては最大 DPI の制限が考慮されます。

最大 DPI は、スライドのサイズによって異なります。 数式は次のとおりです。 maxdpi = (sqrt(100,000,000 / (スライドの幅 * スライドの高さ))。スライドの幅/高さはインチ単位です。

たとえば、標準の 13.3” x 7.5” のスライドの場合、等式は sqrt (100,000,000 / (13.333 * 7.5) ) = 1000 となります。

PowerPoint 2019、2016、2013、および 365

固定 DPI の制限はありません。 スライドのエクスポートは、結果のビットマップのサイズによってのみ制限されます。 PowerPoint では、最大 100,000,000 ピクセル (幅 x 高さ) までのビットマップの作成をサポートできます。 標準ワイドスクリーン スライド (13.3” x 7.5”) の場合は、最大 DPI が 1000 になります。 古いスタイルの 10" x 7.5" のスライドの場合、最大 1155 DPI になりますが、スライドのサイズに応じて DPI を増減できます。

PowerPoint 2010 以前

PowerPoint でエクスポートできる最大解像度は、スライドの最長エッジに基づいて 3072 ピクセルです。 たとえば、標準の 10" × 7.5" スライドの最大有効 DPI 値は 307 です。 3070 ピクセルの結果 (10 × 307 = 3070) は、3072 の制限の範囲内であることを示します。 ただし、標準スライドの 307 より大きい DPI 設定は、3072 の制限に戻ります。

10 進値 ピクセル (水平 × 垂直) 1 インチあたりのドット数 (水平および垂直)
307 3072 × 2304 307 dpi

3072 ピクセルの制限は、プログラムによってスライドを保存する場合にも適用されます。

たとえば、次のコードでは、3072 × 2304 ピクセルのサイズの画像をプログラムで保存します。

ActiveWindow.Selection.SlideRange(1).export
"c:\<filename>.jpg","JPG",4000,3000

詳細

スライドのサイズ変更の詳細については、スライドのサイズを変更するを参照してください。