PowerPoint で破損したプレゼンテーションのトラブルシューティングを行う方法

Summary

Microsoft PowerPoint プレゼンテーションを操作するときに、予期しない動作が発生することがあります。 この現象は、プレゼンテーションが破損しているために発生することがあります。 この記事では、プレゼンテーションの一部または全体を復元するのに役立つ方法について手順を追って説明します。

この記事は、中級のコンピューターユーザーを対象としています。 この記事を最初に印刷する場合は、手順を実行する方が簡単な場合があります。

症状

破損しているプレゼンテーションを開くか変更しようとすると、次の現象が発生することがあります。

  • プレゼンテーションを開こうとすると、次のいずれかのエラーメッセージが表示されます。

    これは PowerPoint プレゼンテーションではありません

    ファイル file_name> .ppt で<表されるファイルの種類を開くことができません

    ファイルの一部が見つかりません。

  • 次の種類のエラーメッセージが表示されます。

    一般的な保護違反

    無効な命令

    ページ違反があります

    システムリソースが不足している

    メモリが不足しています

詳細

破損したプレゼンテーションがあるかどうかを確認する方法

プレゼンテーションが破損しているかどうかを確認するには、いくつかの方法があります。 PowerPoint がインストールされている別のコンピューターでファイルを開いて、他のコンピューターで予期しない動作が発生するかどうかを確認することができます。 PowerPoint で新しいファイルを作成し、その新しいファイルで予期しない動作が発生するかどうかを確認します。 このセクションでは、既存のプレゼンテーションを使用する方法と、PowerPoint で新しいファイルを作成してプレゼンテーションに同じ動作があるかどうかを判断する方法について説明します。

方法 1: 既存のプレゼンテーションを開く

  1. [ファイル] メニューの [開く] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択します。
  2. 別のプレゼンテーションを選択し、[開く] を選択します。

このプレゼンテーションを開き、破損していないように見える場合は、このセクションの方法3に進みます。 それ以外の場合は、方法2に進み、新しいプレゼンテーションを作成します。

方法 2: 新しいプレゼンテーションを作成する

手順 1: プレゼンテーションを作成する
  1. [ファイル] メニューの [新規作成] を選択し、 powerpoint へようこそ(または、 powerpoint 2010 の導入)。
    • PowerPoint 2007 で、[インストールされているテンプレート] を選択し、[ Powerpoint 2007 の導入] を選択します。
  2. [作成] を選択します。 このプロセスでは、テンプレートを基にしてプレゼンテーションを作成します。
  3. [ファイル] メニューの [保存] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[保存] を選択します。
  4. プレゼンテーションの名前を入力し、[保存] をクリックします。
  5. PowerPoint を終了します。
手順 2: 新しいプレゼンテーションを開く
  1. [ファイル] メニューの [開く] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[開く] を選択します。
  2. 新しいプレゼンテーションを選択し、[開く] を選択します。

新しいプレゼンテーションを開いたり保存したりできない場合は、方法3に進みます。

新しいプレゼンテーションを作成できない場合は、PowerPoint が破損している可能性があり、修復を開始する必要があります。 (以下の手順3を参照)。

方法 3: 一般的なトラブルシューティング

Windows 10、Windows 8.1、Windows 8、および Windows 7

パート1

この手順により、スタートアップアドオンなしでコンピューターを再起動することができます。 クリーンな再起動の場合は、次の手順を実行します。

  1. 管理者権限を持つアカウントを使用して、コンピューターにサインインします。

  2. [スタート] を選択し、[検索の開始] ボックスに「msconfig.exe **** 」と入力し、enter キーを押して、システム構成ユーティリティを開始します。

    注意

    管理者パスワードまたは確認のメッセージが表示された場合は、パスワードを入力するか、確認を行います。

  3. [全般] タブで、[スタートアップの選択] オプションを選択し、[スタートアップの項目を読み込む] チェックボックスをオフにします。 [元の Boot.ini を使用する] チェックボックスは使用できません。

  4. [サービス] タブで、[Microsoft のサービスをすべて非表示にする] チェックボックスをオンにし、[すべて無効にする] を選択します。

    注意

    この手順により、Microsoft サービスを引き続き実行できます。 再起動した後、Office のパフォーマンスを確認してから、通常のスタートアップを再開する必要があります。

パート2

この手順により、Office プログラムは問題をチェックして修復します。

  1. [スタート] ボタンを選択して、「コントロールパネル」と入力します。

  2. コントロールパネルを開き、[プログラムのアンインストールまたは変更] (または [プログラムの追加と削除]) に移動します。

  3. プログラムの一覧をスクロールして、使用しているバージョンの Microsoft Office を見つけます。 右クリックして、[変更] を選択します。

    注意

    オンライン修復オプションを使用することをお勧めします。

プレゼンテーションを開くことができない場合に試す方法

方法 1: PowerPoint プログラムファイルアイコンにプレゼンテーションをドラッグする

Windows 10、Windows 8.1、および Windows 8
  1. タスクバーの [Windows] アイコンを右クリックし、[実行] を選択します。

  2. 使用している PowerPoint のバージョンに応じて、次のいずれかを入力します。

    %ProgramFiles%\Microsoft Office
    %ProgramFiles(x86)%\Microsoft Office
    
  3. Enter キーを押します。

  4. Windows エクスプローラーで、Powerpnt.exe アイコンを探します。

  5. 破損したプレゼンテーションのアイコンを、1つのウィンドウから別のウィンドウの Powerpnt.exe アイコンにドラッグします。

PowerPoint はプレゼンテーションを開こうとします。 PowerPoint でプレゼンテーションが開かない場合は、方法2に進みます。

Windows 7
  1. [スタート] を選択し、[ドキュメント] を選択します。 または、[スタート] を選択して、Windows エクスプローラーを検索します。

  2. MSI バージョンの PowerPoint 2013 がインストールされている場合は、「%ProgramFiles%\Microsoft Office\office15 (PowerPoint 2013 64 bit) または% ProgramFiles (x86)% \ Microsoft Office\office15 (PowerPoint 2013 32 bit)」と入力し、enter キーを押します。

    PowerPoint 2013 を実行している場合は、「root\office15 (PowerPoint 2013 64 bit)」または「C:\Program Files (x86) \Microsoft Office 15 \ root\office15 (PowerPoint 2013 32 bit)」と入力し、enter キーを押します。

    MSI バージョンの PowerPoint 2016 がインストールされている場合は、「% ProgramFiles (x86)% \ Microsoft Office\office16」と入力し、Enter キーを押します。

    PowerPoint 2016 の実行時インストールをインストールしている場合は、「%ProgramFiles%\Microsoft Office\root\Office16 (PowerPoint 2016 64 bit) または% ProgramFiles (x86)% \ Microsoft Office\root\Office16 (PowerPoint 2016 32 bit)」と入力し、enter キーを押します。

  3. Windows エクスプローラーで、Powerpnt.exe アイコンを探します。

  4. 破損したプレゼンテーションのアイコンを、1つのウィンドウから別のウィンドウの Powerpnt.exe アイコンにドラッグします。

方法 2: 空のプレゼンテーションにスライドを挿入します。

手順 1: 空のプレゼンテーションを作成する
  1. [ファイル] メニューの [新規作成] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンをクリックし、[新規] をクリックします。
  2. [空白のプレゼンテーション] を選択し、[作成] を選択します。

このプロセスでは、空白のタイトルスライドが作成されます。 このスライドは、プレゼンテーションを再作成した後で削除できます。

手順 2: 破損したプレゼンテーションをスライドとして挿入する
  1. [ホーム] タブで、[スライド] グループの [新規スライド] の横にある矢印を選択し、[スライドの再利用] を選択します。
  2. [スライドの再利用] 作業ウィンドウで、[参照] を選択します。 破損したプレゼンテーションを選択し、[開く] を選択します。
  3. 破損したプレゼンテーション内のスライドごとに [スライドの挿入] を選択します。
  4. [ファイル] メニューの [保存] を選択します。
    • PowerPoint 2007 で、 Microsoft Office ボタンをクリックし、[保存] をクリックします。
  5. プレゼンテーションの新しい名前を入力し、[保存] をクリックします。
手順 3: 破損したプレゼンテーションをテンプレートとして適用する

これらの手順を実行した後、プレゼンテーションが期待どおりに表示されない場合は、破損したプレゼンテーションをテンプレートとして適用します。 これを行うには、次の手順に従います。

  1. [ファイル] メニューの [名前を付けて保存] を選択します。

    • PowerPoint 2007 で、 Microsoft Office ボタンをクリックし、[名前を付けて保存] をクリックします。
  2. プレゼンテーションの新しい名前を入力し、[保存] をクリックします。

    注意

    これにより、破損したプレゼンテーションでこの新しいプレゼンテーションが破損した場合に使用できる、復元したプレゼンテーションのバックアップコピーが作成されます。

  3. [デザイン] タブの [テーマ] グループで [その他] を選択し、[テーマの参照] を選択します。

  4. 破損したプレゼンテーションを選択し、[適用] を選択します。 破損したプレゼンテーションのスライドマスターが新しいスライドマスターに置き換えられます。

注意

これらの手順を実行した後に予期しない動作が発生し始めた場合は、テンプレートがプレゼンテーションを破損している可能性があります。 この場合は、バックアップコピーを使用してマスタースライドを再作成します。

新しいプレゼンテーションのバックアップコピーで元のプレゼンテーションと同じ破損や奇妙な現象が発生している場合は、方法3に進みます。

方法 3: プレゼンテーションの一時ファイルバージョンを開こうとしている

PowerPoint では、プレゼンテーションを編集するときに、ファイルの一時コピーが作成されます。 この一時ファイルは、PPT # # # # .tmp という名前です。

注意

プレースホルダー # # # # は、ランダムな4桁の数値を表します。

この一時ファイルは、プレゼンテーションが保存される場所と同じフォルダーに配置できます。 または、一時ファイルフォルダーに配置されている場合もあります。

ファイルの名前を変更して、PowerPoint でファイルを開く
  1. ファイルを右クリックし、[名前の変更] を選択します。

  2. 古いファイル名拡張子を .tmp から .pptx に変更して、ファイル名が次のファイル名のようになるようにします。

    PPT # # # # .pptx

  3. PowerPoint を起動します。

  4. [ファイル] メニューの [開く] を選択します。

  5. 名前を変更したファイルが格納されているフォルダーを参照します。

  6. PowerPoint でファイルを開いてみてください。

注意

プレゼンテーションを最後に保存したときに作成された一時ファイルには、複数のファイルが対応している場合があります。 この場合、各ファイルを開いて、プレゼンテーションの一時コピーがあるかどうかを確認する必要があります。

一時ファイルが存在しない場合や、一時ファイルに同じ種類の破損または異常な動作が表示される場合は、方法4に進みます。

方法 4: 破損したプレゼンテーションのコピーを作成する

  1. プレゼンテーションを右クリックし、[コピー] を選択します。
  2. エクスプローラーウィンドウで、空白の領域を右クリックし、[貼り付け] を選択します。

ファイルをコピーできない場合は、ファイルが破損しているか、ファイルが破損したコンピューターのハードディスク上に存在する可能性があります。 この場合は、方法5に進みます。

ファイルをコピーできる場合は、PowerPoint で破損したプレゼンテーションのコピーを開くようにしてください。 破損したプレゼンテーションのコピーを開くことができない場合は、破損したプレゼンテーションのコピーを使用して、以下の「プレゼンテーションを開くことができない場合に試す方法」セクションの方法1からメソッド5を繰り返します。

方法 5: ハードディスクドライブでエラーチェックを実行する

Windows 10、Windows 8.1、および Windows 8
  1. 開いているすべてのプログラムを終了します。
  2. [スタート] メニューを右クリックし、[エクスプローラー] を選択します。
  3. 破損したプレゼンテーションが含まれるハードディスクドライブを右クリックします。
  4. [プロパティ] を選択し、[ツール] タブを選択します。
  5. [エラーチェック] で、[今すぐ確認] を選択します。
  6. [ファイルシステムのエラーを自動的に修正する] チェックボックスをオンにします。
  7. [不良セクターをスキャンし、回復を試みる] チェックボックスをオンにします。
  8. [開始] を選択します。
Windows 7
  1. 開いているすべてのプログラムを終了します。
  2. [スタート] を選択し、[コンピューター] を選択します。
  3. 破損したプレゼンテーションが含まれるハードディスクドライブを右クリックします。
  4. [プロパティ] を選択し、[ツール] タブを選択します。
  5. [エラーチェック] で、[今すぐ確認] を選択します。
  6. [ファイルシステムエラーを自動的に修復する] チェックボックスをオンにします。
  7. [不良セクターをスキャンし、回復を試みる] チェックボックスをオンにします。
  8. [開始] を選択します。

注意

エラーチェックは、プレゼンテーションがクロスリンクされているかどうかを確認し、プレゼンテーションの修復を試みます。 ただし、これは PowerPoint がプレゼンテーションを読み取ることができるかを保証するものではありません。

破損したプレゼンテーションを開くことができる場合に試す方法

方法 1: 破損したプレゼンテーションをテンプレートとして適用する

手順 1: 空のプレゼンテーションを作成する
  1. [ファイル] メニューの [新規作成] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[新規作成] を選択します。
  2. [空白のプレゼンテーション] を選択し、[作成] を選択します。 このプロセスでは、空白のタイトルスライドが作成されます。 (このスライドは、プレゼンテーションの再作成後に削除できます。)
手順 2: 破損したプレゼンテーションを新しいプレゼンテーションに挿入する
  1. [ホーム] タブで、[スライド] グループの [新規スライド] の横にある矢印を選択し、[スライドの再利用] を選択します。
  2. [スライドの再利用] 作業ウィンドウで、[参照] を選択します。
  3. 破損したプレゼンテーションを選択し、[開く] を選択します。
  4. 破損したプレゼンテーション内のスライドごとに [スライドの挿入] を選択します。
  5. Microsoft Officeボタンを選択し、[保存] を選択します。
  6. プレゼンテーションの新しい名前を入力し、[保存] をクリックします。
手順 3: 破損したプレゼンテーションをテンプレートとして適用する

これらの手順を実行した後、プレゼンテーションが期待どおりに表示されない場合は、破損したプレゼンテーションをテンプレートとして適用します。 これを行うには、次の手順に従います。

  1. [ファイル] メニューの [名前を付けて保存] を選択します。
  • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[名前を付けて保存] を選択します。
  1. プレゼンテーションの新しい名前を入力し、[保存] をクリックします。

    注意

    これにより、破損したプレゼンテーションでこの新しいプレゼンテーションが破損した場合に使用できる、復元したプレゼンテーションのバックアップコピーが作成されます。

  2. [デザイン] タブの [テーマ] グループで [その他] を選択し、[テーマの参照] を選択します。

  3. 破損したプレゼンテーションを選択し、[適用] を選択します。 破損したプレゼンテーションのスライドマスターが新しいスライドマスターに置き換えられます。

注意

これらの手順を実行した後に予期しない動作が発生し始めた場合は、テンプレートがプレゼンテーションを破損している可能性があります。 この場合は、バックアップコピーを使用してマスタースライドを再作成します。

新しいプレゼンテーションのバックアップコピーに破損または異常な現象が表示される場合は、方法2に進みます。

方法 2: 破損したプレゼンテーションのスライドを新しいプレゼンテーションに転送する

手順 1: 空のプレゼンテーションを作成する
  1. PowerPoint の [ファイル] メニューで、[開く] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[開く] を選択します。
  2. 破損したプレゼンテーションを見つけ、[開く] を選択します。
  3. PowerPoint の [ファイル] メニューで、[新規] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[新規作成] を選択します。
  4. [空白のプレゼンテーション] を選択し、[作成] を選択します。 このプロセスでは、空白のタイトルスライドが作成されます。
手順 2: 破損したプレゼンテーションのスライドを新しいプレゼンテーションにコピーする
  1. [表示] タブで、[スライド一覧] を選択します。 ビューを切り替えるときにエラーメッセージが表示される場合は、アウトライン表示を使用してみてください。

  2. コピーするスライドを選択します。 [ホーム] タブで、[コピー] を選択します。

    注意

    一度に複数のスライドをコピーする場合は、Shift キーを押しながらコピーする各スライドを選択します。

  3. 新しいプレゼンテーションに切り替えます。 これを行うには、[ウィンドウ] タブの [表示] グループで [ウィンドウの切り替え] を選択し、手順1で作成した新しいプレゼンテーションを選択します。

  4. [表示] タブで、[スライド一覧] を選択します。

  5. [ホーム] タブで、[貼り付け] を選択します。

  6. プレゼンテーション全体が転送されるまで、手順2a から2f を繰り返します。

注意

場合によっては、1つのスライドが破損していると、プレゼンテーション全体に問題が発生することがあります。 スライドをプレゼンテーションにコピーした後に、新しいプレゼンテーションで予期しない動作が発生する場合は、そのスライドが破損している可能性があります。 スライドを再作成するか、スライドのセクションを新しいスライドにコピーします。

新しいプレゼンテーションに破損または奇妙な現象が表示される場合は、方法3に進みます。

方法 3: リッチテキスト形式 (RTF) ファイルとしてプレゼンテーションを保存する

プレゼンテーション全体が破損している場合は、プレゼンテーションを回復する唯一の方法は、リッチテキスト形式 (RTF) ファイルとしてプレゼンテーションを保存することです。 このメソッドが成功すると、アウトライン表示で表示されるテキストのみが復元されます。

手順 1: プレゼンテーションを RTF ファイル形式で保存する
  1. プレゼンテーションを開きます。
  2. [ファイル] メニューの [名前を付けて保存] を選択し、ファイルを保存する場所を選択して、[その他のオプション] を選択します。
    • PowerPoint 2007 で、[ Microsoft Office] ボタンを選択し、[名前を付けて保存] を選択して、[その他の形式] を選択します。
  3. [ファイルの種類] ボックスの一覧で、[*アウトライン/リッチテキスト形式 ( .rtf)**] を選択します。
  4. [ファイル名] ボックスに使用する名前を入力し、プレゼンテーションを保存する場所を選択して、[保存] を選択します。
  5. プレゼンテーションを閉じます。

注意

元のプレゼンテーションのグラフィックス、表、またはその他のテキストは、.rtf ファイルには保存されません。

手順 2: PowerPoint で .rtf ファイルを開く
  1. [ファイル] メニューの [開く] を選択します。
  2. [ファイルの種類] ボックスの一覧で、[すべてのアウトライン] または [すべてのファイル] を選択します。
  3. 手順1d で保存した .rtf ファイルを選択し、[開く] を選択します。

この手順では、元のプレゼンテーションのアウトライン表示を基にしてプレゼンテーションを再作成します。