Office 365 からドメインを削除しようとすると "このドメインを削除できません" が表示される

問題

Windows PowerShell を使用して Microsoft Office 365 からドメインを削除しようとすると、次のエラーメッセージが表示されます。

Remove-MsolDomain : Unable to remove this domain. Use Get-MsolUser -DomainName<domain name> to retrieve a list of objects that are blocking removal.
At line:1 char:18
+ Remove-MsolDomain <<<< -DomainName <DomainName>
+ CategoryInfo : OperationStopped: (:) [Remove-MsolDomain], MicrosoftOnlineException
+ FullyQualifiedErrorId : Microsoft.Online.Administration.Automation.DomainNotEmptyException,Microsoft.Online.Administration.Automation.RemoveDomain

原因

この問題は、次の条件の1つ以上に該当する場合に発生します。

  • ユーザーアカウントまたはグループは、ドメインに関連付けられています。
  • すべてのメールがライセンスされたユーザーのドメインに対応するプロキシは、すべてのメールが有効なグループに対しては削除されません。 Office 365 は、ドメインに対応するプロキシが削除されるまで、ドメインの削除をブロックします。
  • Skype for Business Online (旧称 Lync Online) セッション開始プロトコル (SIP) アドレスは、ドメインによって使用されます。

解決方法

Microsoft 365 管理センターを使用して、ドメインを削除します。 Office 365 のドメインマネージャーを使用すると、管理者は、Windows PowerShell を使用しなくてもドメインの削除をブロックする依存関係を削除できます。 

Microsoft 365 管理センターでドメインを削除する方法の詳細については、「ドメインを削除する」を参照してください。

Windows PowerShell を使用してドメイン削除のトラブルシューティングを行う

注意

次の手順では、管理者が Windows PowerShell を使用する必要があります。

手順 1: ユーザー名にドメイン名が含まれているかどうかを確認する

注意

また、ユーザー表示を作成し、削除しようとしているドメインにドメインを設定することもできます。 このビューを使用してユーザー名を確認し、問題のドメインがユーザー名に含まれないようにユーザー名を変更します。

ユーザー名にドメイン名が含まれているかどうかを確認するには、次の手順を実行します。

  1. Windows PowerShell の Azure Active Directory モジュールを使用して、Microsoft Azure Active Directory に接続します。 これを行うには、Windows PowerShell の Azure Active Directory モジュールを開き、次のコマンドレットを入力して enter キーを押します。
    Connect-MsolService
    
    確認メッセージが表示されたら、管理者の資格情報を入力します。
  2. 次のコマンドレットを実行します。
    Get-MsolUser -DomainName [Domain] | fl UserPrincipalName  
    
    たとえば、次のように実行します。ここで、contoso.com プレースホルダーは、対象のドメインを表します。
    Get-MsolUser -DomainName contoso.com | fl UserPrincipalName
    
  3. 結果を調べ、ドメインが使用されないようにユーザープリンシパル名 (UPN) を変更します。 UPN は、ユーザー名とユーザー ID のプロパティと同じです。 UPN を変更するには、Office 365 ポータルまたは Windows PowerShell を使用できます。 目標には、結果が返されないようにします。

手順 2: 電子メールアドレスを確認する

注意

  • この手順は、Exchange Online を含むサブスクリプションがある場合にのみ適用されます。
  • Azure Active Directory 同期ツールを実行している場合は、オンプレミス環境から電子メールアドレスを更新することができます。

電子メールアドレスを確認するには、次の手順を実行します。

  1. リモート PowerShell を使用して Exchange Online に接続します。 これを行う方法の詳細については、「 Connect To Exchange Online Using Remote PowerShell」を参照してください。

  2. 削除しようとしているドメインを使用しているすべてのユーザーとグループを検索します。 これを行うには、次のコマンドレットを実行します。 (このコマンドレットでは、contoso.com は、対象のドメインを表します)。

    get-recipient | where {$_.EmailAddresses -match "contoso.com"} | fl Name, RecipientType, EmailAddresses
    
  3. 出力に、EmailAddresses プロパティと受信者 Typeproperty の値をメモします。 たとえば、次のような出力が表示されることがあります。  

    Name : John Smith RecipientType : UserMailbox EmailAddresses : {SIP:john@contoso.com, SMTP:john@contoso.com,   smtp:john@contoso.onmicrosoft.com}
    
  4. 状況に応じて、次のいずれかの操作を行います。

    • 受信者の種類が UserMailbox に設定されている場合は、Mailboxcmdlet と EmailAddresses パラメーターを併用すると、smtp、SMTP、および SIP アドレスを変更できます。 このコマンドレットの詳細については、「メールボックスの設定」を参照してください。

      または、ユーザーまたはライセンスを削除することもできます。 ただし、この方法はお勧めしません。

      注意

      これが最後の管理者ユーザーである場合は、新しい全体管理者を作成し、サインインして、問題のユーザーを削除します。

    • [受信者の種類] が MailUniversalDistributionGroupor MailUniversalSecurityGroup に設定されている場合は、EmailAddresses パラメーターと共に指定したコマンドレットを使用して smtp アドレスと SMTP アドレスを変更できます。 このコマンドレットの詳細については、「 Set-Distribution Group」を参照してください。

      または、グループを削除することができます。 ただし、この方法はお勧めしません。 グループを削除できない場合は、 「Office 365 で配布グループを削除または変更しようとすると、"十分な権限がありません" というエラーが表示される手順に従います。

    • [受信者の種類] が [Dynamic] グループに設定されている場合は、smtp および SMTP アドレスを変更するために、引数 EmailAddresses を指定して、DynamicDistributionGroup コマンドレットを使用できます。 このコマンドレットの詳細については、「 -Dynamicのグループの設定」を参照してください。

      または、グループを削除することができます。 ただし、この方法はお勧めしません。 グループを削除できない場合は、 「Office 365 で配布グループを削除または変更しようとすると、"十分な権限がありません" というエラーが表示される手順に従います。

詳細情報

詳細については、「 Office 365 からドメインを削除しようとするとエラーメッセージが表示される」を参照してください。

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