Power BI Desktop の概要Getting started with Power BI Desktop

Power BI Desktop 概要ガイド」へようこそ。Welcome to the Power BI Desktop Getting Started Guide. この短いツアーでは、Power BI Desktop の機能を説明し、その動作の実例を示します。これにより、強力なデータ モデルと優れたレポートをより迅速に作成できるようになり、ビジネス インテリジェンスの作業を拡張できます。This short tour of Power BI Desktop gets you acquainted with how it works, demonstrates what it can do, and accelerates your ability to build robust data models — along with amazing reports — that amplify your business intelligence efforts.

読むよりも見ることをご希望ですか。Prefer to watch instead of read? 概要を示すビデオをどうぞご覧くださいFeel free to take a look at our getting started video. ビデオを閲覧しながら対応するサンプル データも参照する場合は、このサンプルの Excel ブックをダウンロードします。And if you want to follow along with the video with matching sample data, you can download this sample Excel workbook.

Power BI Desktop によって、他のユーザーと簡単に共有できるクエリ、データ接続、およびレポートのコレクションを作成することができます。Power BI Desktop lets you create a collection of queries, data connections, and reports that can easily be shared with others. Power BI Desktop は、実績のある Microsoft テクノロジ (強力なクエリ エンジン、データ モデリング、視覚エフェクト) を統合して、オンラインのPower BI サービスとシームレスに連携します。Power BI Desktop integrates proven Microsoft technologies – the powerful Query engine, data modeling, and visualizations – and works seamlessly with the online Power BI service.

Power BI Desktop により、アナリストなどが強力なデータ接続、モデル、レポートを作成できます。また、Power BI サービスにより、Power BI Desktop のレポートを共有して、ユーザーがそれらを表示したり操作したりできます。これら 2 つを組み合わせると、データの世界から新しい見識をモデル化、構築、共有、拡張することが容易になります。With the combination of Power BI Desktop (where analysts and others can create powerful data connections, models and reports) and the Power BI service (where Power BI Desktop reports can be shared so users can view and interact with them), new insights from the world of data are easier to model, build, share, and extend.

データの世界に接続してこれを整形し、堅牢なモデルを構築して、適切に構成されたレポートを作成する上で、Power BI Desktop が強力で柔軟性の高い、アクセスの容易なツールであることをデータ アナリストは実感できます。Data analysts will find Power BI Desktop a powerful, flexible, and a highly accessible tool to connect with and shape the world of data, build robust models, and craft well-structured reports.

このガイドの使用方法How to use this guide

このガイドは、簡単な概要を知るために素早く参照したり、Power BI Desktop の動作のしくみについて深く理解するために各セクションを読み通すなど、いくつかの方法で使用できます。You can use this guide in a couple of ways – scan it for a quick overview, or read through each section for a strong understanding of how Power BI Desktop works.

時間が限られている場合には、数分でさっと参照することにより、Power BI Desktop の動作のしくみと使用方法を適切に理解できます。If you’re in a hurry you can do a visual sweep of this guide in just a couple minutes, and come away with a good sense of how Power BI Desktop operates, and how to use it. このガイドの大部分は、Power BI Desktop の機能を視覚的に示す画面で構成されています。Most of this guide consists of screens that visually show how Power BI Desktop works.

より詳しく理解するために、各セクションを読み通して、その手順を実行し、独自の Power BI Desktop ファイルを出力することもできます。そのファイルを Power BI サービスに投稿して他のユーザーと共有することができます。For a more thorough understanding you can read through each section, perform the steps, and walk away with your own Power BI Desktop file that’s ready to post onto the Power BI service, and share with others.

注意

Power BI Report Server という Power BI の別の特殊なバージョンもあります。これは、データやレポートをオンプレミスで保持する必要がある顧客向けです。There is also a separate and specialized version of Power BI called Power BI Report Server, which is for customers who need their data and reporting to remain on-premises. この特殊なバージョンと使用できる、Power BI Report Server 向け Power BI Desktop という Power BI Desktop の別の特殊なバージョンもあります。これは、Report Server バージョンの Power BI でのみ動作します。For use with that specialized version, there's also a separate and specialized version of Power BI Desktop called Power BI Desktop for Power BI Report Server, which works only with the Report Server version of Power BI. この記事では、標準の Power BI Desktop について説明します。This article describes the standard Power BI Desktop.

Power BI Desktop の動作のしくみHow Power BI Desktop works

Power BI Desktop によって、 データに接続 し (通常は複数のデータ ソース)、 そのデータを整形 し (洞察と説得力があるデータ モデルを作成するためのクエリを使用)、そのモデルを使用して レポートを作成 します (他のユーザーによる活用、基盤としての使用、共有が可能)。With Power BI Desktop, you connect to data (usually multiple data sources), shape that data (with queries that build insightful, compelling data models), and use that model to create reports (which others can leverage, build upon, and share).

接続、整形、レポートの各手順が満足のいく仕方で完了したら、その作業を .pbix の拡張子が付いた Power BI Desktop 形式のファイルに保存できます。When the steps are completed to your satisfaction – connect, shape, and report – you can save that work in Power BI Desktop file format, which is the .pbix extension. Power BI Desktop ファイルは、他のすべてのファイルと同じ方法で共有できます。しかし Power BI Desktop ファイルを共有する最も優れた方法は、Power BI サービスにファイルをアップロードする (共有する) ことです。Power BI Desktop files can be shared like any other file, but the most compelling way to share Power BI Desktop files is to upload them (share them) on the Power BI service.

Power BI Desktop により、ビジネス インテリジェンスのリポジトリとレポートの設計と作成は、ばらばらに切り離された困難なプロセスではなく、一元化された、シンプルで効率的なプロセスになります。Power BI Desktop centralizes, simplifies, and streamlines what can otherwise be a scattered, disconnected, and arduous process of designing and creating business intelligence repositories and reports.

では、実際に試してみます。Ready to give it a try? 開始しましょう。Let’s get started.

Power BI Desktop のインストールと実行Install and run Power BI Desktop

歯車 の形のアイコンを選択してから [Power BI Desktop] を選択することにより、Power BI サービスから Power BI Desktopをダウンロードすることができます。You can download Power BI Desktop from the Power BI service, by selecting the gear icon, then select Power BI Desktop.

Power BI Desktop がアプリケーションとしてインストールされて、デスクトップで実行します。Power BI Desktop is installed as an application, and runs on your desktop.

Power BI Desktop を実行すると、 [ようこそ] 画面が表示されます。When you run Power BI Desktop, a Welcome screen is displayed.

[ようこそ] 画面で (左ウィンドウのリンクから)、直接データを取得したり、最近使用したソースを表示したり、他の****レポートを開いたりすることができます。You can Get Data, see Recent Sources, or Open Other Reports directly from the Welcome screen (from the links in the left pane). 画面を閉じた場合 (右上隅の [x] を選択)、Power BI Desktop の レポート ビューが表示されます。If you close the screen (select the x in the top right corner), the Report view of Power BI Desktop is displayed.

Power BI Desktop には、レポート ビュー、データ ビュー、リレーションシップ ビューという 3 つのビューがあります。There are three views in Power BI Desktop: Report view, Data view, and Relationships view. Power BI Desktop には、クエリ エディターも含まれています。クエリ エディターは別のウィンドウで開きます。Power BI Desktop also includes Query Editor, which opens in a separate window. クエリ エディターでは、クエリを作成してデータを変換し、その調整されたデータ モデルを Power BI Desktop に読み込み、レポートを作成することができます。In Query Editor, you can build queries and transform data, then load that refined data model into Power BI Desktop, and create reports.

次の画面では、Power BI Desktop の左側に沿って 3 つのビューのアイコン ( レポートデータ、および リレーションシップ) が上から下に表示されています。The following screen shows the three view icons along the left of Power BI Desktop: Report, Data, and Relationships, from top to bottom. 現在表示されているビューは、左側の黄色のバーで示されています。The currently displayed view is indicated by the yellow bar along the left. このケースでは、 レポート ビューが現在表示されています。In this case, Report view is currently displayed. ビューを変更するには、これら 3 つのアイコンのいずれかを選択します。You can change views by selecting any of those three icons.

Power BI Desktop をインストールすると、データへの接続、データの整形、およびレポートの作成を (通常はこの順序で) 行う準備が整います。With Power BI Desktop installed you’re ready to connect to data, shape data, and build reports (usually in that order). 次のいくつかのセクションで、それぞれのツアーを順番に行います。In the next few sections, we take a tour through each in turn.

データへの接続Connect to data

Power BI Desktop をインストールすると、拡大を続けるデータの世界につながる準備が整います。With Power BI Desktop installed, you’re ready to connect to the ever expanding world of data. クエリ ウィンドウでは、 あらゆる種類 のデータ ソースを使用できます。There are all sorts of data sources available in the Query window. 次の図は、[ホーム] リボンで [データの取得] > [詳細] を選んで行う、データへの接続方法を示しています。The following image shows how to connect to data, by selecting the Home ribbon, then Get Data > More.

このクイック ツアーでは、いくつかの異なる Web データ ソースに接続します。For this quick tour, we'll connect to a couple different Web data sources.

退職を間近に控えて、陽当たりが良く、税額が有利で、医療が充実した場所への移転を考えているとします。または、データ アナリストとして、顧客のためにそのような情報を探しているとします。Imagine you’re retiring – you want to live where there’s lots of sunshine, preferable taxes, and good health care – or perhaps you’re a data analyst, and you want that information to help your customers. たとえば、サングラスの小売業者に対して、日照時間の最も長い地域を営業のターゲットとするように支援する場合があります。For example, perhaps you want to help your sunglasses retailer target sales where the sun shines most frequently.

いずれの場合も、次の Web リソースには、これらのトピックやその他のトピックに関する興味深いデータが含まれています。Either way, the following Web resource has interesting data about those topics, and more:

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

[データの取得] > [Web] を選んで、アドレスを貼り付けます。Select Get Data > Web and paste the address.

[OK] をクリックすると、Power BI Desktop の クエリ 機能が動作します。When you select OK, the Query functionality of Power BI Desktop goes to work. クエリは Web リソースにアクセスし、 [ナビゲーター] ウィンドウは、その Web ページでの検出内容を返します。Query contacts the Web resource, and the Navigator window returns what it found on that Web page. このケースでは、テーブル (Table 0) と Web ドキュメント全体が見つかりました。In this case, it found a table (Table 0) and the overall Web Document. テーブルに興味があるので、一覧からテーブルを選択します。We’re interested in the table, so we select it from the list. [ナビゲーター] ウィンドウにプレビューが表示されます。The Navigator window displays a preview.

この時点で、ウィンドウの下部にある [編集] をクリックしてテーブルを読み込む前にクエリを編集するか、テーブルを読み込みます。At this point we can edit the query before loading the table, by selecting Edit from the bottom of the window, or we can load the table.

[編集] を選択すると、クエリ エディターが起動し、テーブルを表すビューが表示されます。When we select Edit, Query Editor launches and a representative view of the table is presented. [クエリの設定] ウィンドウが表示されます (表示されない場合は、リボンにある [表示] をクリックしてから、[表示] > [クエリの設定] の順にクリックすると [クエリの設定] ウィンドウが表示されます)。The Query Settings pane is displayed (if it’s not, you can select View from the ribbon, then Show > Query Settings to display the Query Settings pane). 表示は次のようになります。Here’s what that looks like.

データへの接続について詳しくは、「Power BI Desktop におけるデータへの接続」をご覧ください。For more information about connecting to data, see Connect to Data in Power BI Desktop.

次のセクションでは、ニーズを満たすようにデータを調整します。In the next section, we adjust the data so it meets our needs. 接続されているデータを調整するプロセスは、データの 整形 と呼ばれます。The process of adjusting connected data is called shaping data.

データの整形と結合Shape and combine data

これで、データ ソースに接続したので、ニーズに合わせてデータを調整する必要があります。Now that we’ve connected to a data source, we need to adjust the data to meet our needs. 調整とは、列またはテーブルの名前の変更、テキストから数値への変更、行の削除、先頭の行をヘッダーに設定するなどのデータの 変換 を意味することもあります。Sometimes adjusting means transforming the data – such as renaming columns or tables, changing text to numbers, removing rows, setting the first row as headers, and so on.

Power BI Desktop のクエリ エディターでは、リボンで使用可能なタスクを実行できることに加えて、右クリック メニューも広範囲に使用します。The Query editor in Power BI Desktop makes ample use of right-click menus, in addition to having tasks available on the ribbon. [変換] リボンで選択できるほとんどの項目は、(列などの) 項目を右クリックし、表示されるメニューからクリックして使用することもできます。Most of what you can select in the Transform ribbon is also available by right-clicking an item (such as a column) and choosing from the menu that appears.

データの整形Shape data

クエリ エディターでデータを整形する際は、(クエリ エディターが行う) 手順ごとの指示を与えて、クエリ エディターが読み込んで表示するデータを調整します。When you shape data in the Query Editor, you’re providing step-by-step instructions (that Query Editor carries out for you) to adjust the data as Query Editor loads and presents it. 元のデータ ソースに影響は及びません。この特定のデータ表示のみが調整または整形されます。The original data source is not affected; only this particular view of the data is adjusted, or shaped.

指定する手順 (テーブル名の変更、データ型の変換、または列の削除など) はクエリ エディターによって記録され、このクエリがデータ ソースに接続するたびにこれらの手順が実行されます。そうすることで、データは常に指定されたとおりに整形されます。The steps you specify (such as rename a table, transform a data type, or delete columns) are recorded by Query Editor, and each time this query connects to the data source those steps are carried out so that the data is always shaped the way you specify. ユーザーが Power BI Desktop でクエリを使用するたびに、あるいは任意のユーザーが Power BI サービスなどで共有クエリを使用する場合に、このプロセスが実行されます。This process occurs whenever you use the query in Power BI Desktop, or for anyone who uses your shared query, such as in the Power BI service. これらの手順は、[クエリの設定] ウィンドウの [適用される手順] で順番にキャプチャされます。Those steps are captured, sequentially, in the Query Settings pane under Applied Steps.

次の図は、整形されたクエリを表示した [クエリの設定] ウィンドウを示しています。これらの各手順については、以降のいくつかの段落で説明します。The following image shows the Query Settings pane for a query that has been shaped – we’ll go through each of those steps in the next few paragraphs.

Web のデータ ソースに接続して検索した退職者関係のデータについて再び考えます。このデータをニーズに合わせて整形することにします。Let’s get back to our retirement data, which we found by connecting to a Web data source, and shape that data to fit our needs.

まず、多くの評価値は整数としてクエリ エディターに取り込まれますが、すべてがそうではありません (1 つの列にはテキストと数値が含まれているため、自動変換されませんでした)。For starters, most ratings were brought into Query Editor as whole numbers, but not all of them (one column contained text and numbers, so it wasn't automatically converted). データは数値であることが必要です。We need the data to be numbers. 心配ありません。列ヘッダーを右クリックして [型の変更] > [整数] の順に選ぶだけでデータ型を変更できます。No problem – just right-click the column header, and select Change Type > Whole Number to change the data type. 複数の列を選ぶ必要がある場合は、まず 1 つの列を選んでから、Shift キーを押したまま追加の隣接する列を選べます。その後、列ヘッダーを右クリックして選んだ列をすべて変更します。If we needed to choose more than one column, we could first select a column then hold down SHIFT, select additional adjacent columns, and then right-click a column header to change all selected columns. Ctrl キーを使用して、連続していない列を選ぶこともできます。You can also use CTRL to select non-adjacent columns.

さらに、[変換] リボンを使用して、列をテキストからヘッダーに変更または変換することもできます。You can also change, or transform, those columns from text to header by using the Transform ribbon. [変換] リボンを次に示します。矢印は、現在のデータ型を別のデータ型に変換する [データ型] ボタンを指しています。Here’s the Transform ribbon, with an arrow pointing toward the Data Type button, which lets you transform the current data type to another.

[クエリの設定] では、 適用される手順 が、加えられたすべての変更を反映することに注意してください。Note that in Query Settings, the Applied Steps reflect the changes that were made. 整形プロセスからいずれかの手順を削除する場合は、その手順を選択してから、手順の左側にある [X] を選択します。If I want to remove any step from the shaping process, I simply select that step, and then select the X to the left of the step.

クエリを望ましい形にするために、あといくつかの変更を行う必要があります。We need to make a few more changes to get the query where we want it:

  • 最初の列を削除する – この列は不要です。”お住まいの州の退職後の生活ランキングをチェック” という冗長な行が含まれているに過ぎません。これが Web ベースのテーブルであることに伴う結果です。Remove the first column – we don’t need it, it just includes redundant rows that say “Check out how your state ranks for retirement” which is an artifact of this being a Web based table
  • いくつかのエラーを修正する – Web ページで、1 つの列にはテキストと数値が混在しています (あるカテゴリで複数の州が同一ランクになっています)。Fix a few Errors – on the Web page, one column had text mixed in with the numbers (some states tied in one category). これは Web サイトでは適切ですが、データ分析では不適切です。That works well in the website, but not for our data analysis. (このケースでは) 修正は容易であり、これによってクエリ エディターとその適用手順の優れた機能をお見せします。It's easy (in this case) to fix, and shows some cool features and capabilities of Query Editor and its Applied Steps
  • テーブル名を変更するTable 0 は役立つ記述子ではありませんが、それを変更することは簡単です。Change the Table Name – that Table 0 is not a useful descriptor, but changing it simple

これらの各手順は、「Power BI Desktop でのデータの整形と結合」で例示されています。Each of these steps is demonstrated in Shape and Combine Data in Power BI Desktop. そのページを自由に確認することができます。または、現在のドキュメントを読み進めて次に行う手順を参照することもできます。Feel free to check out that page, or keep going in this document to see what you would do next. 次のセクションでは、上記の変更が適用された後について扱います。The next section picks up after the changes above are applied.

データの結合Combine data

さまざまな州に関するこのデータは興味深く、追加の分析作業とクエリの構築に役立ちます。That data about various states is interesting, and will be useful for building additional analysis efforts and queries. ただし、1 つ問題があります。ここにあるほとんどのデータでは、州コードの 2 文字の省略形を使用し、州の完全名を使用していません。But there’s one problem: most data out there uses a two-letter abbreviation for state codes, not the full name of the state. 何らかの方法により、州名をその省略形に関連付ける必要があります。We need some way to associate state names with their abbreviations.

幸運にも、ぴったりな別の公共データ ソースがあります。しかし、この退職者テーブルに接続する前に、いくらかの整形を行う必要があります。We’re in luck: there’s another public data source that does just that, but it needs a fair amount of shaping before we can connect it to our retirement table. 州の省略形の Web リソースを次に示します。Here’s the Web resource for state abbreviations:

http://en.wikipedia.org/wiki/List_of_U.S._state_abbreviations

クエリ エディター[ホーム] リボンで、[データの取得] > [Web] の順に選び、アドレスを入力して [OK] を選びます。その Web ページの内容が [ナビゲーター] ウィンドウに表示されます。From the Home ribbon in Query Editor, we select Get Data > Web and type the address, select OK, and the Navigator window shows what it found on that Web page.

ここでは "Table[edit]" を選びました。このテーブルには必要なデータが含まれているためです。しかし、テーブルのデータの余分なところを省くにはかなりの作業が必要です。We select Table[edit] because it includes the data we want, but it’s going to take quite a bit of shaping to pare that table’s data down. これらの各手順は、「Power BI Desktop でのデータの整形と結合」でも例示されています。Each of these steps is also demonstrated in Shape and Combine Data in Power BI Desktop. これらの手順をまとめると、以下のようになります。To summarize those steps, here's what we do:

[編集] を選びます。次に以下を行います。We select Edit, then:

  • 先頭の 2 行を削除する – これらは Web ページのテーブルを作成した方法のために生じたものであり、不要です。Remove the top two rows – they’re a result of the way that Web page’s table was created, and we don’t need them.
  • 末尾の 26 行を削除する – これらはすべて準州であり、含める必要はありません。Remove the bottom 26 rows – they’re all the territories, which we don’t need to include.
  • ワシントン DC を除外する – 退職者統計テーブルには DC が含まれていません。そこで一覧から除外します。Filter out Washington DC – the retirement stats table doesn't include DC, so we'll exclude it from our list.
  • いくつかの不要な列を削除する – 州と公式の 2 文字の省略形のマッピングのみが必要であるため、その他の列は削除できます。Remove a few unneeded columns – we only need the mapping of state to its official two-letter abbreviation, so we can remove the other columns.
  • 最初の行をヘッダーとして使用する – 先頭の 3 行を削除したため、現在の先頭の行が必要なヘッダーになります。Use the first row as headers – since we removed the top three rows, the current top row is the header we want.

    注意

    ここで、クエリ エディターにおいて適用される手順の順番は重要であり、データの整形方法に影響を与えることを指摘しておきます。This is a good time to point out that the sequence of applied steps in Query Editor is important, and can affect how the data is shaped. また、1 つの手順がこれ以降の別の手順にどのような影響を与える可能性があるかを検討することも重要です。適用される手順から手順を削除すると、クエリの手順の順番による影響のため、これ以降のステップは最初に意図したとおりに動作しない可能性があります。It’s also important to consider how one step may impact another subsequent step; if you remove a step from the Applied Steps, subsequent steps may not behave as originally intended, because of the impact of the query’s sequence of steps.

  • 列とテーブル自体の名前を変更する – 通常どおり、列の名前を変更するにはいくつかの方法があります。必要に応じていずれかを選べます。Rename the columns, and the table itself – as usual, there are a couple ways to rename a column, you can choose whichever you prefer.

StateCodes テーブルを整形したら、これらの 2 つのテーブルまたはクエリを 1 つに結合できます。現在あるテーブルはデータに適用したクエリの結果であるため、"クエリ" と呼ばれることがよくあります。With the StateCodes table shaped, we can combine these two tables, or queries, into one; since the tables we now have are a result of the queries we applied to the data, they’re often referred to as queries.

クエリの結合には、 マージ追加という主な 2 つの方法があります。There are two primary ways of combining queries – merging and appending.

別のクエリに追加する 1 つ以上の列がある場合は、クエリを マージ します。When you have one or more columns that you’d like to add to another query, you merge the queries. 既存のクエリに追加するデータの追加の行がある場合は、クエリを 追加 します。When you have additional rows of data that you’d like to add to an existing query, you append the query.

ここではクエリをマージします。In this case we want to merge queries. 最初に、他のクエリのマージ 先の クエリを選択してから、リボンの [ホーム] タブで [クエリのマージ] を選択します。To get started, we select the query into which we want the other query to merge, then select Merge Queries from the Home tab on the ribbon.

[マージ] ウィンドウが表示されて、選んだテーブルにマージするテーブルを選んでから、マージに使用する一致する列を選ぶよう求めるメッセージが表示されます。The Merge window appears, prompting us to select which table we’d like merged into the selected table, and then, the matching columns to use for the merge. RetirementStats テーブル (クエリ) からを選びます。次に、StateCodes クエリを選びます (この場合は、他のクエリが 1 つのみであるため簡単です。多数のデータ ソースに接続する場合、選択対象のクエリが多数になります)。Select State from the RetirementStats table (query), then select the StateCodes query (easy in this case, since there’s only one other query – when you connect to many data sources, there are many queries to choose from). 一致する列を正しく選ぶと (RetirementStats[州]StateCodes[州名])、[マージ] ウィンドウは次のようになり、[OK] ボタンが有効になります。When we select the correct matching columns – State from RetirementStats, and State Name from StateCodes – the Merge window looks like the following, and the OK button is enabled.

クエリの末尾に NewColumn が作成されます。これは、既存のクエリとマージされたテーブル (クエリ) のコンテンツです。A NewColumn is created at the end of the query, which is the contents of the table (query) that was merged with the existing query. マージされたクエリのすべての列が NewColumn に凝縮されますが、テーブルの [展開] を選ぶと、必要な列をどれでも含めることができます。All columns from the merged query are condensed into the NewColumn, but you can select to Expand the table, and include whichever columns you want. マージされたテーブルを展開して含める列を選択するには、展開アイコンを選択します ()。To expand the merged table, and select which columns to include, select the expand icon (). [展開] ウィンドウが表示されます。The Expand window appears.

このケースでは、[州コード] 列のみが必要であるため、この列のみを選んで [OK] を選びます。In this case, we only want the State Code column, so we select only that column and then select OK. [元の列名をプレフィックスとして使用する] のチェックボックスは、不要なためチェックを外します。選んだままにすると、マージされた列の名前は NewColumn.州コード (元の列名、または NewColumn とドットの後にクエリに含める列の名前を続けたもの) になります。We clear the checkbox from Use original column name as prefix because we don’t need or want that; if we leave that selected, the merged column would be named NewColumn.State Code (the original column name, or NewColumn, then a dot, then the name of the column being brought into the query).

注意

NewColumn テーブルの導入操作を試してみることができます。Want to play around with how to bring in that NewColumn table? 少し実験してみてください。結果に満足できない場合は、[クエリの設定] ウィンドウの [適用される手順] の一覧からその手順を削除してください。クエリは、[展開] の手順を適用する前の状態に戻ります。You can experiment a bit, and if you don’t like the results, just delete that step from the Applied Steps list in the Query Settings pane; your query returns to the state prior to applying that Expand step. これは、展開プロセスが希望どおりになるまで何回でも好きなだけ実行できる無料のやり直しのようなものです。It’s like a free do-over, which you can do as many times as you like until the expand process looks the way you want it.

2 つのデータ ソースを結合した 1 つのクエリ (テーブル) ができました。それぞれがニーズに合わせて整形されています。We now have a single query (table) that combined two data sources, each of which has been shaped to meet our needs. このクエリは、いずれかの州の住宅費の統計、人口統計、または求人情報など、その他の多くの興味深いデータ接続の基礎となっています。This query can serve as a basis for lots of additional, interesting data connections – such as housing cost statistics, demographics, or job opportunities in any state.

データ整形と結合に関するこれらの各手順について詳しくは、「Power BI Desktop でのデータの整形と結合」をご覧ください。For a more complete description of each of these shape and combine data steps, see Shape and Combine Data in Power BI Desktop.

これで、いくつかの興味深いレポートを、すべて Power BI Desktop 内で作成するために十分なデータが揃いました。For now, we have enough data to create a few interesting reports, all within Power BI Desktop. ここはマイルストーンとなる箇所なので、この Power BI Desktop ファイルを保存します。その名前を「Power BI Desktop の概要」とします。Since this is a milestone let’s save this Power BI Desktop file – we’ll call it Getting Started with Power BI Desktop. クエリ エディターで変更内容を適用し、Power BI Desktop に読み込むには、[ホーム] リボンの [閉じて適用する] を選びます。To apply the changes in Query Editor and load them into Power BI Desktop, select Close & Apply from the Home ribbon.

レポートの作成Build reports

テーブルが読み込まれた後に追加の変更を行うことができます。また、行われたすべての変更を適用するには、モデルを再読み込みします。Additional changes can be made after the table is loaded, and you can reload a model to apply any changes you make. 今回は、このまま進めることができます。But for now this will do. Power BI Desktop のレポート ビューでレポートの作成を開始します。In Power BI Desktop Report view, you can begin to build reports.

レポート ビューには、次の 5 つの主な領域があります。The Report view has five main areas:

  1. リボン。これにはレポートと視覚エフェクトに関連する一般的なタスクが表示されます。The ribbon, which displays common tasks associated with reports and visualizations

  2. レポート ビューまたはキャンバス。ここに視覚エフェクトが作成されて配置されます。The Report view, or canvas, where visualizations are created and arranged

  3. [ページ] タブ領域 (下部にあります)。レポートのページを選択または追加できます。The Pages tab area along the bottom, which lets you select or add a report page

  4. [視覚エフェクト] ウィンドウ。視覚エフェクトの変更、色や軸のカスタマイズ、フィルターの適用、フィールドのドラッグなどを行えます。The Visualizations pane, where you can change visualizations, customize colors or axes, apply filters, drag fields, and more

  5. [フィールド] ウィンドウ。ここではクエリの要素とフィルターをレポート ビューにドラッグしたり、[視覚エフェクト] ウィンドウのフィルター領域にドラッグしたりできます。The Fields pane, where query elements and filters can be dragged onto the Report view, or dragged to the Filters area of the Visualizations pane

[視覚エフェクト] ウィンドウと [フィールド] ウィンドウは、端の小さな矢印を選んで折りたたむことができます。これにより、レポート ビューの領域が増えて、優れた視覚エフェクトを作成できます。The Visualizations and Fields pane can be collapsed by selecting the small arrow along the edge, providing more space in the Report view to build cool visualizations. さらに、視覚エフェクトを変更する際、上下の矢印が表示されます。これは、状況に応じてそのセクションの展開や折りたたみができることを意味します。When modifying visualizations, you'll also see these arrows pointing up or down, which means you can expand or collapse that section, accordingly.

[フィールド] リストから レポート ビューにフィールドをドラッグするだけで、視覚エフェクトを作成できます。To create a visualization, just drag a field from the Fields list onto the Report view. このケースでは、 [州] フィールドを [RetirementStats] からドラッグして、その結果を観察します。In this case, let’s drag the State field from RetirementStats, and see what happens.

ご覧ください。Power BI Desktop により、地図ベースの視覚エフェクトが自動的に作成されました。これは、[州] フィールドに地理的位置情報データが含まれていることが認識されたためです。Look at that... Power BI Desktop automatically created a map-based visualization, because it recognized that the State field contained geolocation data.

[視覚エフェクト] ウィンドウでは、さまざまな種類の視覚エフェクトを選べることにご注意ください。また、これらのアイコンの下の領域では、凡例を適用するためにフィールドをさまざまな領域にドラッグするか、他の方法で視覚エフェクトを変更できます。Notice that in the Visualizations pane, I can select different types of visualizations, and in the area below those icons, I can drag fields to different areas to apply a Legend, or otherwise modify the visualization.

少し話を早く進めて、いくつかの視覚エフェクトを追加した後の レポート ビューと新しいレポート ページがどのようになるかを見てみます。Let’s fast-forward a bit, and see what the Report view looks like after a handful of visualizations have been added, as well as a few new Report pages. レポートについて詳しくは、「Power BI Desktop のレポート ビュー」をご覧ください。For more information about reports, see Report View in Power BI Desktop.

最初のレポート ページには、 全体的なランク付けに基づくデータのパースペクティブが示されています。The first Report page provides a perspective of the data based on Overall rank. 視覚エフェクトのいずれかを選択すると、 [フィールドとフィルター] ウィンドウには、どのフィールドが選択されたか、および視覚エフェクトの構造 (どのフィールドが [共有の軸][列の値]、および [行の値] に適用されるか) が表示されます。When we select one of the visualizations, the Fields and Filters pane shows which fields are selected, and the structure of the visualization (which fields are applied to the Shared Axis, Column Values, and Line Values).

このレポートには 6 つの ページ があり、それぞれにデータの特定の要素が視覚化されています。There are six Pages in this Report, each visualizing certain elements of our data.

  1. 上に示す最初のページには、 全体的なランク付けに基づき、すべての州が示されます。The first page, shown above, shows all states based on Overall rank.
  2. 2 番目のページでは、 全体的なランク付けに基づく上位 10 の州に注意を向けています。The second page focuses on the top ten states based on Overall rank.
  3. 3 番目のページでは、上位 10 の州の生活費 (および関連データ) が視覚化されています。For the third page, the best 10 states for cost of living (and associated data) are visualized.
  4. 4 番目のページでは、天候に注目して、日照時間の長い上位 15 の州が選ばれています。Weather is the focus of the fourth page, filtered to the 15 sunniest states.
  5. 5 番目のページでは、地域社会の福祉が上位の 15 の州についてグラフで示され、視覚化されています。On the fifth page, Community well-being is charted and visualized for the top 15 states.
  6. 最後に、犯罪統計が視覚化されて、最良 (事件件数が下位) の 10 の州が示されています。Lastly, crime statistics are visualized, showing the best (and well, the last) ten states.

生活費に注目したレポート ページの例をここに示します。Here’s what the cost of living-focused Report page looks like.

あらゆる種類の興味深いレポートや視覚エフェクトを作成することができます。There are all sorts of interesting reports and visualizations you can create.

作業の共有Share your work

Power BI Desktop レポートがある程度完成したので、それを Power BI サービスで他のユーザーと共有できます。Now that we have a Power BI Desktop report that’s reasonably complete, we can share it with others on the Power BI service. Power BI Desktop で作業を共有する方法はいくつかあります。There are a few ways to share your work in Power BI Desktop. Power BI サービスに発行できます。Power BI サービスから直接 .pbix ファイルをアップロードしたり、.pbix ファイルを保存し、他のすべてのファイルと同様に送信したりできます。You can publish to the Power BI service, you can upload the .pbix file directly from the Power BI service, or you can save the .pbix file and send it like any other file.

まず、Power BI Desktop から直接 Power BI サービスに発行する様子を見てみましょう。First, let's look at publishing to the Power BI service directly from Power BI Desktop. [ホーム] リボンで、 [発行] をクリックします。On the Home ribbon, select Publish.

Power BI にサインインするように求めるメッセージが表示されます。You may be prompted to sign in to Power BI.

サインインして、発行プロセスが完了すると、次のダイアログ ボックスが表示されます。When you've signed in and the publish process is complete, you see the following dialog.

Power BI にサインインすると、サービスの ダッシュボードレポート、および データセット の各セクションに、読み込んだ Power BI Desktop ファイルが表示されていることが分かります。When you sign in to Power BI, you'll see Power BI Desktop file you just loaded in the Dashboards, Reports, and Datasets sections of the service.

作業を共有するもう 1 つの方法は、 Power BI サービス内から Power BI Desktop ファイルを読み込むことです。Another way to share your work is to load it from within the Power BI service. 次のリンクにより、ブラウザーに Power BI サービスが表示されます。The following link brings up the Power BI service in a browser:

https://app.powerbi.com

[データの取得] を選択して、Power BI Desktop レポートを読み込むプロセスを開始します。Select Get Data to start the process of loading your Power BI Desktop report.

[データの取得] ページが表示されます。ここでデータの取得元を選べます。The Get Data page appears, from which you can select where to get your data from. このケースでは、[ファイル] ボックスから [取得] を選びます。In this case, we select Get from the Files box.

ファイル ビューが表示されます。The Files view appears. このケースでは、 [ローカル ファイル] を選択します。In this case, we select Local File.

ファイルを選択すると、Power BI はファイルをアップロードします。When you select the file, Power BI uploads the file.

ファイルがアップロードされたら、Power BI サービスの左ウィンドウで [レポート] からファイルを選択できます。Once the file is uploaded, you can select the file from the Reports in the left pane of the Power BI service.

Power BI サービスに、レポートの最初のページが表示されます。The Power BI service displays the first page of the report. ページの下部で、タブを選択し、レポートのそのページを表示できます。Along the bottom of the page, you can select any tab to display that page of the report.

レポート キャンバスの上部で [レポートの編集] をクリックすると、 Power BI サービスでレポートに変更を加えることができます。You can make changes to a report in the Power BI service by selecting Edit Report from the top of the report canvas.

レポートを保存するには、サービスから [ファイル] > [名前を付けて保存] の順に選びます。To save your report, select File > Save As from the service. レポートから、あらゆる種類の興味深いビジュアルを Power BI サービスに作成し、それを ダッシュボードに固定することができます。There are all sorts of interesting visuals you can create in the Power BI service from your report, which you can pin to a dashboard. Power BI サービスのダッシュボードについて詳しくは、「優れたダッシュボードのデザインに関するヒント」をご覧ください。To learn about dashboards in the Power BI service, see Tips for designing a great dashboard.

保存したら、メイン ページで [共有] アイコンを選択します。Once saved, select the Share icon on the main page.

ダッシュボードを共有したい同僚に対して、ここから電子メールを送信できます。From here, you can send an email to colleagues with whom you’d like to share the dashboard.

ダッシュボードの作成、共有、変更について詳しくは、「ダッシュボードの共有」をご覧ください。For more information about creating, sharing, and modifying dashboards, see Share a dashboard.

Power BI Desktop と Power BI サービスにより、データに関連したあらゆる種類の説得力のあるマッシュ アップや視覚化を行うことができます。There are all sorts of compelling data-related mash-ups and visualizations you can do with Power BI Desktop, and with the Power BI service. 詳細については、次のセクションを参照してください。Check out the next section for more information.

診断Diagnostics

Power BI Desktop は、診断ポートへの接続をサポートします。Power BI desktop supports connecting to a diagnostics port. 診断ポートは、その他のツールの接続と、診断目的のトレースの実行を可能にします。The diagnostic port allows for other tools to connect to and perform traces for diagnostic purposes. モデルに対する変更はサポートされていません。モデルに変更を加えると、破損とデータ損失が発生する可能性があります。Making any changes to the model is not supported! Changes to the model may lead to corruption and data loss.

次の手順Next steps

Power BI Desktop を使用すると、さまざまなことを行えます。There are all sorts of things you can do with Power BI Desktop. そのような機能について詳しくは、次のリソースをご覧ください。For more information on its capabilities, check out the following resources: