Power BI Desktop でのクエリの概要Query overview in Power BI Desktop

Power BI Desktop を使用すると、データの世界への接続、説得力のある基本的なレポートの作成、他のユーザーとの成果の共有を行えます。他のユーザーは、その成果を足場としてビジネス インテリジェンスの成果を拡大することができます。With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop には 3 つのビューがあります。Power BI Desktop has three views:

  • [レポート] ビュー – ここでは、作成したクエリを使用して説得力のある視覚化を作成し、これを思いどおりに複数のページに配置したり、他のユーザーと共有したりすることができます。Report view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • [データ] ビュー – データ モデル形式のレポートにデータを表示します。ここでは、メジャーの追加、新しい列の作成、リレーションシップの管理ができます。Data view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • [リレーションシップ] ビュー – データ モデルに確立されたリレーションシップをグラフィカルに表現し、必要に応じて管理または変更できます。Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

これらのビューは、Power BI Desktop の左側にある 3 つのアイコンのいずれかを選んでアクセスします。These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. 次の図では、[レポート] ビューが選択されていることが、アイコンの横の黄色の帯によって示されています。In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop には クエリ エディターも付属しており、1 つまたは多数のデータ ソースに接続し、要件を満たすようにデータの整形と変換を行い、そのモデルを Power BI Desktop に読み込むことができます。Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

このドキュメントでは、 クエリ エディターを使用したデータ操作の概要を説明します。This document provides an overview of the work with data in the Query Editor. もちろん、学習するべきことはほかにもあるため、このドキュメントの末尾には、サポートされているデータ型、データへの接続、データの整形、リレーションシップの作成、作業の開始方法に関する詳しいガイダンスへのリンクが用意されています。There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

まずは、 クエリ エディターに親しむことから始めましょう。But first, let’s see get acquainted with Query Editor.

クエリ エディターThe Query Editor

クエリ エディターにアクセスするには、Power BI Desktop の [ホーム] タブから [Edit Queries] (クエリの編集) を選びます。To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

データ接続がない場合、クエリ エディターは空のウィンドウとして、データの準備ができている状態で開きます。With no data connections, Query Editor appears as a blank pane, ready for data.

クエリが読み込まれると、クエリ エディター ビューはさらに興味深いものになります。Once a query is loaded, Query Editor view becomes more interesting. 次の Web データ ソースに接続すると、クエリ エディターは、整形を開始するデータに関する情報を読み込みます。If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

http://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspxhttp://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

データ接続が確立された後のクエリ エディターの外観を次に示します。Here’s how Query Editor appears once a data connection is established:

  1. リボンでは、多くのボタンがアクティブになり、クエリ内のデータを操作できます。In the ribbon, many buttons are now active to interact with the data in the query
  2. 左側のウィンドウでは、クエリが一覧表示され、選択、表示、および整形に使用できます。In the left pane, queries are listed and available for selection, viewing, and shaping
  3. 中央のウィンドウでは、選択したクエリのデータが表示され、整形に使用できます。In the center pane, data from the selected query is displayed and available for shaping
  4. [クエリの設定] ウィンドウが表示され、クエリのプロパティと適用される手順が一覧表示されます。The Query Settings window appears, listing the query’s properties and applied steps

この後のセクションでは、4 つの領域 (リボン、[クエリ] ウィンドウ、[データ] ビュー、および [クエリの設定] ウィンドウ) のそれぞれについて見ていきます。We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

[クエリ] リボンThe query ribbon

クエリ エディターのリボンは 4 つのタブ ([ホーム][変換][列の追加][表示]) で構成されています。The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

[ホーム] タブには、データの取得のような、クエリの最初の手順を含む一般的なクエリのタスクが含まれています。The Home tab contains the common query tasks, including the first step in any query, which is Get Data. 次の図は、[ホーム] リボンを示しています。The following image shows the Home ribbon.

データに接続してクエリの作成プロセスを開始するには、 [データの取得] ボタンを選びます。To connect to data and begin the query building process, select the Get Data button. 最も一般的なデータ ソースが用意されたメニューが表示されます。A menu appears, providing the most common data sources.

使用できるデータ ソースについて詳しくは、「 データ ソース」をご覧ください。For more information about available data sources, see Data Sources. 例と手順を含む、データへの接続に関する情報については、「 データへの接続」をご覧ください。For information about connecting to data, including examples and steps, see Connect to Data.

[変換] タブでは、列の追加や削除、データ型の変更、列の分割、その他のデータドリブン タスクなどの一般的なデータ変換タスクにアクセスできます。The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. 次の図は、 [変換] タブを示しています。The following image shows the Transform tab.

例を含む、データの変換について詳しくは、「 データの結合と整形」をご覧ください。For more information about transforming data, including examples, see Combine and Shape Data.

[列の追加] タブでは、列の追加、列のデータの書式設定、カスタムの列の追加に関連するその他のタスクが用意されています。The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. 次の図は、 [列の追加] タブを示しています。The following image shows the Add Column tab.

リボンの [表示] タブは、特定のペインまたはウィンドウに表示を切り替えるために使用します。The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. また、詳細設定エディターの表示にも使用します。It’s also used to display the Advanced Editor. 次の図は、 [表示] タブを示しています。The following image shows the View tab.

リボンから使用可能なタスクの多くは、中央のウィンドウで列またはその他のデータを右クリックしても使用できることを知っておくと便利です。It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

左側のウィンドウThe left pane

左側のウィンドウには、アクティブなクエリの数だけでなく、クエリの名前も表示されます。The left pane displays the number of active queries, as well as the name of the query. 左側のペインからクエリを選択すると、データが中央のウィンドウに表示されます。ここではニーズに合わせてデータを整形および変換できます。When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. 次の図は、複数のクエリを含む左側のウィンドウを示しています。The following image shows the left pane with multiple queries.

中央の [データ] ウィンドウThe center (data) pane

中央のウィンドウ、つまり [データ] ウィンドウに、選んだクエリの日付が表示されます。In the center pane, or Data pane, date from the selected query is displayed. ここで、[クエリ] ビューの作業の多くが実行されます。This is where much of the work of the Query view is accomplished.

次の図では、前に確立された Web データの接続が表示されています。[総得点] 列が選ばれ、そのヘッダーが右クリックされて使用可能なメニュー項目が表示されています。In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. なお、右クリックで表示されるこれらのメニューの多くは、[リボン] タブのボタンと同じです。Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

右クリックして表示されるメニュー項目 (またはリボンのボタン) を選ぶと、クエリがデータに手順を適用し、クエリ自体の一部として保存します。When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. 次のセクションで説明するように、手順は [クエリの設定] ウィンドウに順番に記録されます。The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

[クエリの設定] ウィンドウThe query settings pane

[クエリの設定] ウィンドウには、クエリに関連付けられているすべての手順が表示されます。The Query Settings pane is where all steps associated with a query are displayed. たとえば、次の図では、 [クエリの設定] ウィンドウの [適用される手順] セクションで、 [総得点] 列の型を変更したことが反映されています。For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

その他の整形手順がクエリに適用される際、これらの手順は [適用される手順] セクションにキャプチャされます。As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

基になるデータは変更されないことを知っておくことが重要です。むしろ、クエリ エディターはデータの表示だけでなく、クエリ エディターによって整形および変更されたそのデータに基づいて発生する、基になるデータとの相互作用を調整および整形しているのです。It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

[クエリの設定] ウィンドウで、手順の名前の変更、手順の削除、または手順の順序の変更を適宜行うことができます。In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. これを行うには、 [手順の適用] セクションで手順を右クリックし、表示されるメニューから選びます。To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. クエリの手順はすべて、[手順の適用] ウィンドウの表示順に実行されます。All query steps are carried out in the order they appear in the Applied Steps pane.

詳細設定エディターThe Advanced Editor

クエリ エディターが各手順で作成しているコードを表示する場合や、独自の整形コードを作成する場合は、 詳細設定エディターを使用できます。If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. 詳細設定エディターを起動するには、リボンから [表示] をクリックした後、 [詳細設定エディター]をクリックします。To launch the advanced editor, select View from the ribbon, then select Advanced Editor. 既存のクエリのコードを示すウィンドウが表示されます。A window appears, showing the existing query code.

[詳細設定エディター] ウィンドウでは直接コードを編集できます。You can directly edit the code in the Advanced Editor window. ウィンドウを閉じるには、 [完了] ボタンまたは [キャンセル] ボタンを選びます。To close the window, select the Done or Cancel button.

作業を保存するSaving your work

クエリが目的にかなう状態になったなら、クエリ エディターでデータ モデルへの変更を Power BI Desktop に適用し、クエリ エディターを閉じることができます。When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. そのためには、クエリ エディターの [ファイル] メニューから [閉じて適用] を選びます。To do that, select Close & Apply from Query Editor's File menu.

処理が進む間、Power BI Desktop には、その状態を表示するダイアログが開きます。As progress is made, Power BI Desktop provides a dialog to display its status.

希望する場所にクエリを作成したら、または作業内容を確実に保存したい場合、Power BI Desktop では .pbix ファイル形式で作業内容を保存できます。Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

作業内容を保存するには、次の図に示すように、[ファイル] > [保存]> (または [ファイル] > [名前を付けて保存]) の順に選びます>To save your work, select File > Save (or File > Save As), as shown in the following image.

次の手順Next steps

Power BI Desktop を使用すると、さまざまなことを行えます。There are all sorts of things you can do with Power BI Desktop. そのような機能について詳しくは、次のリソースをご覧ください。For more information on its capabilities, check out the following resources: